- Add LICENSE_FILE
- Switch to options helpers - Silence patching - Regenerate patches with `make makepatch`
This commit is contained in:
parent
a78d99ff9d
commit
99076f7c8a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=411685
@ -12,27 +12,28 @@ MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Daemon to monitor vital motherboard parameters
|
||||
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --exec-prefix=${PREFIX}
|
||||
INSTALL_TARGET= install-all
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
OPTIONS_DEFINE= IPV6 FULL_CONFIG DOCS
|
||||
|
||||
FULL_CONFIG_DESC= Remotely reading the full config
|
||||
|
||||
IPV6_CONFIGURE_ENABLE= ipv6
|
||||
FULL_CONFIG_CONFIGURE_ENABLE= full-config
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--exec-prefix=${PREFIX}
|
||||
INSTALL_TARGET= install-all
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's| @exec_prefix@| $$(DESTDIR)@exec_prefix@|' \
|
||||
@${REINPLACE_CMD} -e 's| @exec_prefix@| $$(DESTDIR)@exec_prefix@|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/PROTOCOL ${STAGEDIR}${DOCSDIR}
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- getMB-smb.c.orig 2004-08-17 03:32:39.000000000 +0200
|
||||
+++ getMB-smb.c 2015-05-01 22:56:04.200695000 +0200
|
||||
--- getMB-smb.c.orig 2004-08-17 01:32:39 UTC
|
||||
+++ getMB-smb.c
|
||||
@@ -31,6 +31,7 @@
|
||||
#endif
|
||||
|
||||
@ -8,7 +8,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/ioctl.h>
|
||||
@@ -90,7 +91,9 @@
|
||||
@@ -90,7 +91,9 @@ OpenIO(void) {
|
||||
}
|
||||
|
||||
cmd.cmd = 0x47;
|
||||
@ -18,7 +18,7 @@
|
||||
for (i = 0; i < sizeof(addrs); i++) {
|
||||
cmd.slave = addrs[i];
|
||||
if (ioctl(iosmb, SMB_READB, (caddr_t)&cmd) != -1) {
|
||||
@@ -115,7 +118,11 @@
|
||||
@@ -115,7 +118,11 @@ WriteByte(int addr,int value) {
|
||||
count = 0;
|
||||
cmd.slave = smb_addr;
|
||||
cmd.cmd = addr;
|
||||
@ -30,7 +30,7 @@
|
||||
while (ioctl(iosmb, SMB_WRITEB, &cmd) == -1) {
|
||||
if (++count < 3) {
|
||||
sleep(1);
|
||||
@@ -136,7 +143,12 @@
|
||||
@@ -136,7 +143,12 @@ ReadByte(int addr) {
|
||||
|
||||
cmd.slave = smb_addr;
|
||||
cmd.cmd = addr;
|
Loading…
Reference in New Issue
Block a user