Update to 2.3.

PR:		ports/47604
Submitted by:	Joseph Scott <joseph@randomnetworks.com> (maintainer)
This commit is contained in:
Norikatsu Shigemura 2003-01-28 21:34:17 +00:00
parent 94844bbca9
commit 98cee0048d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74170
12 changed files with 52 additions and 230 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= sendip
PORTVERSION= 2.1
PORTVERSION= 2.3
CATEGORIES= net
MASTER_SITES= http://www.earth.li/projectpurple/files/
@ -15,11 +15,8 @@ MAINTAINER= joseph@randomnetworks.com
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
MAN1= sendip.1
pre-install:
${REINPLACE_CMD} -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
${REINPLACE_CMD} -e "s:/share/man/man1:/man/man1:g" ${WRKSRC}/Makefile;
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (sendip-2.1.tar.gz) = 76b36e63f1b1139e86c7092ed7c010cc
MD5 (sendip-2.3.tar.gz) = d7f238f6f8582676013fe3eaf4401272

View File

@ -1,23 +1,33 @@
--- Makefile.orig Sun Feb 24 04:37:47 2002
+++ Makefile Wed Sep 4 19:40:15 2002
@@ -8,15 +8,16 @@
--- Makefile.orig Tue Jan 28 13:03:48 2003
+++ Makefile Tue Jan 28 13:04:35 2003
@@ -1,23 +1,23 @@
#configureable stuff
-PREFIX ?= /usr/local
-BINDIR ?= $(PREFIX)/bin
-MANDIR ?= $(PREFIX)/share/man/man1
-LIBDIR ?= $(PREFIX)/lib/sendip
+#PREFIX ?= /usr/local
+BINDIR=${PREFIX}/bin
+MANDIR=${PREFIX}/man/man1
+LIBDIR=${PREFIX}/lib/sendip
#For most systems, this works
-INSTALL ?= install
+INSTALL?=install
#For Solaris, you may need
#INSTALL=/usr/ucb/install
-CFLAGS= -fPIC -pipe -Wall -Wpointer-arith -Wwrite-strings \
+CFLAGS+= -fPIC -fsigned-char -Wall -Wpointer-arith -Wwrite-strings \
-Wstrict-prototypes -Wnested-externs -Winline -Werror -g \
CFLAGS= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
-Wstrict-prototypes -Wnested-externs -Winline -Werror -g -Wcast-align \
- -DSENDIP_LIBS=\"$(LIBDIR)\"
+ -DSENDIP_LIBS=\"$(LIBDIR)\" -DHAVE_STRING_H=1
+ -DSENDIP_LIBS=\"${LIBDIR}\"
#-Wcast-align causes problems on solaris, but not serious ones
LDFLAGS= -g -rdynamic -lm
-LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
+#LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
+LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm -ldl
#LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm -ldl
LDFLAGS_LINUX= -g -rdynamic -ldl -lm
LIBCFLAGS= -shared
-CC= gcc
+CC?= cc
+#CC= gcc
PROGS= sendip
PROTOS= ipv4.so ipv6.so icmp.so tcp.so udp.so rip.so bgp.so ntp.so #dns.so
BASEPROTOS= ipv4.so ipv6.so

View File

@ -1,18 +0,0 @@
--- icmp.h Fri Nov 23 17:50:51 2001
+++ icmp.h Tue Mar 5 22:16:25 2002
@@ -3,13 +3,8 @@
#ifndef _SENDIP_ICMP_H
#define _SENDIP_ICMP_H
-/* FreeBSD needs these. It shouldn't, but it does. GRR */
-#include <netinet/in_systm.h>
-#include <netinet/ip.h>
-
-/* For message types */
-#include <netinet/ip_icmp.h>
-#include <netinet/icmp6.h>
+#define ICMP6_ECHO_REQUEST 128
+#define ICMP_ECHO 8
/* ICMP HEADER
* Copied from glibc 2.2, reproduced here without code specific stuff

View File

@ -1,79 +0,0 @@
--- types.h Sat Feb 23 17:28:00 2002
+++ types.h Tue Mar 26 18:19:00 2002
@@ -1,6 +1,8 @@
/* types.h - tpyes needed in sendip and not defined everywhere
* Author: Mike Ricketts <mike@earth.li>
* ChangeLog since 2.1 release:
+ * 03/02/2002 Added more defines/protos for non-IPv6 systems.
+ * 26/03/2002 FreeBSD style BYTE_ORDER fixes
*/
#ifndef _SENDIP_TYPES_H
#define _SENDIP_TYPES_H
@@ -25,8 +27,13 @@
/* for things that *really* don't know about ipv6, ... */
#ifndef AF_INET6
-#define PF_INET6 10
-#define AF_INET6 PF_INET6
+#define AF_INET6 10
+#define IPPROTO_ICMPV6 58
+#define IPPROTO_NONE 59
+#define IPPROTO_DSTOPTS 60
+#endif /* !AF_INET6 */
+
+#ifndef s6_addr
struct in6_addr {
union {
u_int8_t u6_addr8[16];
@@ -37,6 +44,8 @@
#define s6_add16 in6_u.u6_addr16
#define s6_add32 in6_u.u6_addr32
};
+extern const struct in6_addr in6addr_any; /* :: */
+extern const struct in6_addr in6addr_loopback; /* ::1 */
struct sockaddr_in6 {
u_int16_t sin6_family;
@@ -45,8 +54,9 @@
struct in6_addr sin6_addr;
u_int32_t sin6_scope_id;
};
+extern int inet_pton (int af, const char *cp, void *buf);
-#endif /* !AF_INET 6 */
+#endif /* !s6_addr */
/* Convert _BIG_ENDIAN/_LITTLE_ENDIAN to __BYTE_ORDER */
#ifndef __LITTLE_ENDIAN
@@ -58,15 +68,30 @@
#endif
#ifndef __BYTE_ORDER
+
+/* Not linux-style, maybe FreeBSD-style */
+#ifdef BYTE_ORDER
+#undef __LITTLE_ENDIAN
+#undef __BIG_ENDIAN
+#define __LITTLE_ENDIAN LITTLE_ENDIAN
+#define __BIG_ENDIAN BIG_ENDIAN
+#define __BYTE_ORDER BYTE_ORDER
+#else
+
+/* Not FreeBSD-style, try solaris style */
#ifdef _BIG_ENDIAN
#define __BYTE_ORDER __BIG_ENDIAN
#else /* not _BIG_ENDIAN */
#ifdef _LITTLE_ENDIAN
#define __BYTE_ORDER __LITTLE_ENDIAN
#else /* not _LITTLE_ENDIAN */
+
+/* Not solaris style. Give up. */
#error Could not guess your byte order
+
#endif /* not _LITTLE_ENDIAN */
#endif /* not _BIG_ENDIAN */
-#endif /* _BYTE_ORDER */
+#endif /* not BYTE_ORDER */
+#endif /* not __BYTE_ORDER */
#endif /* _SENDIP_TYPES_H */

View File

@ -5,6 +5,7 @@ lib/sendip/icmp.so
lib/sendip/tcp.so
lib/sendip/udp.so
lib/sendip/rip.so
lib/sendip/ripng.so
lib/sendip/bgp.so
lib/sendip/ntp.so
@dirrm lib/sendip

View File

@ -6,7 +6,7 @@
#
PORTNAME= sendip
PORTVERSION= 2.1
PORTVERSION= 2.3
CATEGORIES= net
MASTER_SITES= http://www.earth.li/projectpurple/files/
@ -15,11 +15,8 @@ MAINTAINER= joseph@randomnetworks.com
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
MAN1= sendip.1
pre-install:
${REINPLACE_CMD} -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
${REINPLACE_CMD} -e "s:/share/man/man1:/man/man1:g" ${WRKSRC}/Makefile;
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (sendip-2.1.tar.gz) = 76b36e63f1b1139e86c7092ed7c010cc
MD5 (sendip-2.3.tar.gz) = d7f238f6f8582676013fe3eaf4401272

View File

@ -1,23 +1,33 @@
--- Makefile.orig Sun Feb 24 04:37:47 2002
+++ Makefile Wed Sep 4 19:40:15 2002
@@ -8,15 +8,16 @@
--- Makefile.orig Tue Jan 28 13:03:48 2003
+++ Makefile Tue Jan 28 13:04:35 2003
@@ -1,23 +1,23 @@
#configureable stuff
-PREFIX ?= /usr/local
-BINDIR ?= $(PREFIX)/bin
-MANDIR ?= $(PREFIX)/share/man/man1
-LIBDIR ?= $(PREFIX)/lib/sendip
+#PREFIX ?= /usr/local
+BINDIR=${PREFIX}/bin
+MANDIR=${PREFIX}/man/man1
+LIBDIR=${PREFIX}/lib/sendip
#For most systems, this works
-INSTALL ?= install
+INSTALL?=install
#For Solaris, you may need
#INSTALL=/usr/ucb/install
-CFLAGS= -fPIC -pipe -Wall -Wpointer-arith -Wwrite-strings \
+CFLAGS+= -fPIC -fsigned-char -Wall -Wpointer-arith -Wwrite-strings \
-Wstrict-prototypes -Wnested-externs -Winline -Werror -g \
CFLAGS= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
-Wstrict-prototypes -Wnested-externs -Winline -Werror -g -Wcast-align \
- -DSENDIP_LIBS=\"$(LIBDIR)\"
+ -DSENDIP_LIBS=\"$(LIBDIR)\" -DHAVE_STRING_H=1
+ -DSENDIP_LIBS=\"${LIBDIR}\"
#-Wcast-align causes problems on solaris, but not serious ones
LDFLAGS= -g -rdynamic -lm
-LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
+#LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
+LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm -ldl
#LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm -ldl
LDFLAGS_LINUX= -g -rdynamic -ldl -lm
LIBCFLAGS= -shared
-CC= gcc
+CC?= cc
+#CC= gcc
PROGS= sendip
PROTOS= ipv4.so ipv6.so icmp.so tcp.so udp.so rip.so bgp.so ntp.so #dns.so
BASEPROTOS= ipv4.so ipv6.so

View File

@ -1,18 +0,0 @@
--- icmp.h Fri Nov 23 17:50:51 2001
+++ icmp.h Tue Mar 5 22:16:25 2002
@@ -3,13 +3,8 @@
#ifndef _SENDIP_ICMP_H
#define _SENDIP_ICMP_H
-/* FreeBSD needs these. It shouldn't, but it does. GRR */
-#include <netinet/in_systm.h>
-#include <netinet/ip.h>
-
-/* For message types */
-#include <netinet/ip_icmp.h>
-#include <netinet/icmp6.h>
+#define ICMP6_ECHO_REQUEST 128
+#define ICMP_ECHO 8
/* ICMP HEADER
* Copied from glibc 2.2, reproduced here without code specific stuff

View File

@ -1,79 +0,0 @@
--- types.h Sat Feb 23 17:28:00 2002
+++ types.h Tue Mar 26 18:19:00 2002
@@ -1,6 +1,8 @@
/* types.h - tpyes needed in sendip and not defined everywhere
* Author: Mike Ricketts <mike@earth.li>
* ChangeLog since 2.1 release:
+ * 03/02/2002 Added more defines/protos for non-IPv6 systems.
+ * 26/03/2002 FreeBSD style BYTE_ORDER fixes
*/
#ifndef _SENDIP_TYPES_H
#define _SENDIP_TYPES_H
@@ -25,8 +27,13 @@
/* for things that *really* don't know about ipv6, ... */
#ifndef AF_INET6
-#define PF_INET6 10
-#define AF_INET6 PF_INET6
+#define AF_INET6 10
+#define IPPROTO_ICMPV6 58
+#define IPPROTO_NONE 59
+#define IPPROTO_DSTOPTS 60
+#endif /* !AF_INET6 */
+
+#ifndef s6_addr
struct in6_addr {
union {
u_int8_t u6_addr8[16];
@@ -37,6 +44,8 @@
#define s6_add16 in6_u.u6_addr16
#define s6_add32 in6_u.u6_addr32
};
+extern const struct in6_addr in6addr_any; /* :: */
+extern const struct in6_addr in6addr_loopback; /* ::1 */
struct sockaddr_in6 {
u_int16_t sin6_family;
@@ -45,8 +54,9 @@
struct in6_addr sin6_addr;
u_int32_t sin6_scope_id;
};
+extern int inet_pton (int af, const char *cp, void *buf);
-#endif /* !AF_INET 6 */
+#endif /* !s6_addr */
/* Convert _BIG_ENDIAN/_LITTLE_ENDIAN to __BYTE_ORDER */
#ifndef __LITTLE_ENDIAN
@@ -58,15 +68,30 @@
#endif
#ifndef __BYTE_ORDER
+
+/* Not linux-style, maybe FreeBSD-style */
+#ifdef BYTE_ORDER
+#undef __LITTLE_ENDIAN
+#undef __BIG_ENDIAN
+#define __LITTLE_ENDIAN LITTLE_ENDIAN
+#define __BIG_ENDIAN BIG_ENDIAN
+#define __BYTE_ORDER BYTE_ORDER
+#else
+
+/* Not FreeBSD-style, try solaris style */
#ifdef _BIG_ENDIAN
#define __BYTE_ORDER __BIG_ENDIAN
#else /* not _BIG_ENDIAN */
#ifdef _LITTLE_ENDIAN
#define __BYTE_ORDER __LITTLE_ENDIAN
#else /* not _LITTLE_ENDIAN */
+
+/* Not solaris style. Give up. */
#error Could not guess your byte order
+
#endif /* not _LITTLE_ENDIAN */
#endif /* not _BIG_ENDIAN */
-#endif /* _BYTE_ORDER */
+#endif /* not BYTE_ORDER */
+#endif /* not __BYTE_ORDER */
#endif /* _SENDIP_TYPES_H */

View File

@ -5,6 +5,7 @@ lib/sendip/icmp.so
lib/sendip/tcp.so
lib/sendip/udp.so
lib/sendip/rip.so
lib/sendip/ripng.so
lib/sendip/bgp.so
lib/sendip/ntp.so
@dirrm lib/sendip