math/givaro: Fix build on CURRENT.

PR:		247537
Approved by:	pi (maintainer)
This commit is contained in:
Gleb Popov 2020-06-25 14:59:56 +00:00
parent 2b1ca4156a
commit 98c99cbe65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=540397
4 changed files with 27 additions and 2 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= givaro
PORTVERSION= 4.1.1
DISTVERSIONPREFIX=v
PORTREVISION= 1
CATEGORIES= math
MAINTAINER= pi@FreeBSD.org

View File

@ -1,6 +1,6 @@
--- configure.ac.orig 2017-11-23 13:32:58 UTC
--- configure.ac.orig 2019-06-07 13:23:45 UTC
+++ configure.ac
@@ -52,11 +52,7 @@ AC_COMPILER_NAME
@@ -49,11 +49,7 @@ AC_COMPILER_NAME
# We need a C++11 compiler now - AB 2014-12-12
# clang-3.8 does not support __float128 without explicitly passing it -std=c++11

View File

@ -0,0 +1,10 @@
--- src/kernel/gmp++/gmp++_int.h.orig 2019-06-07 13:23:45 UTC
+++ src/kernel/gmp++/gmp++_int.h
@@ -234,6 +234,7 @@ namespace Givaro {
*/
///@{
giv_all_inlined Integer& operator = (const Integer& n);
+ giv_all_inlined Integer& operator = (const Integer& n) const;
giv_all_inlined Integer& logcpy(const Integer& n);
giv_all_inlined Integer& copy(const Integer& n);
///@}

View File

@ -0,0 +1,14 @@
--- src/kernel/gmp++/gmp++_int_cstor.C.orig 2019-06-07 13:23:45 UTC
+++ src/kernel/gmp++/gmp++_int_cstor.C
@@ -105,6 +105,11 @@ namespace Givaro {
return logcpy(n) ;
}
+ Integer& Integer::operator = (const Integer &n) const
+ {
+ return const_cast<Integer*>(this)->logcpy(n) ;
+ }
+
Integer& Integer::copy(const Integer &n)
{