graphics/gmic: Update 2.9.0 -> 2.9.1
Reported by: portscout
This commit is contained in:
parent
b4bec81fce
commit
98c81e3273
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=538856
@ -1,8 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gmic
|
||||
DISTVERSION= 2.9.0
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 2.9.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= https://gmic.eu/files/source/
|
||||
DISTNAME= ${PORTNAME}_${DISTVERSION}
|
||||
@ -28,7 +27,7 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
|
||||
|
||||
PORTSCOUT= limit:[0-9]\..* # not v.220 and similar
|
||||
|
||||
USES= cmake compiler:c++11-lang jpeg pkgconfig xorg
|
||||
USES= cmake compiler:c++11-lang jpeg localbase:ldflags pkgconfig xorg
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CMAKE_OFF= BUILD_LIB_STATIC
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1585512818
|
||||
SHA256 (gmic_2.9.0.tar.gz) = 6233695f9b27999dcc7cc3aa7480b0f192bd44de85209091a3b4b8a65ae8c4b5
|
||||
SIZE (gmic_2.9.0.tar.gz) = 6195597
|
||||
TIMESTAMP = 1592199576
|
||||
SHA256 (gmic_2.9.1.tar.gz) = 50c9dd418b8d0e80c703c2e2b179b6049343567483d37d9ff6c642c6ede95d8d
|
||||
SIZE (gmic_2.9.1.tar.gz) = 6212626
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt.orig 2020-01-23 17:04:38 UTC
|
||||
--- CMakeLists.txt.orig 2020-06-15 06:22:09 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -108,7 +108,7 @@ set(COMPILE_FLAGS "-Dgmic_build -Dcimg_use_vt100 -Dgmi
|
||||
@@ -100,7 +100,7 @@ set(COMPILE_FLAGS "-Dgmic_build -Dcimg_use_vt100 -Dgmi
|
||||
if(APPLE)
|
||||
set(COMPILE_FLAGS "${COMPILE_FLAGS} -mmacosx-version-min=10.8 -stdlib=libc++ -Wno-error=c++11-narrowing -Wc++11-extensions -fpermissive")
|
||||
else()
|
||||
@ -9,15 +9,3 @@
|
||||
endif()
|
||||
|
||||
if(NOT "${PRERELEASE_TAG}" STREQUAL "")
|
||||
@@ -247,8 +247,9 @@ endif()
|
||||
|
||||
# CImg.h header
|
||||
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/src/CImg.h)
|
||||
- file(DOWNLOAD https://github.com/dtschump/CImg/raw/master/CImg.h ${CMAKE_SOURCE_DIR}/src/CImg.h)
|
||||
- execute_process(COMMAND ${CMAKE_COMMAND} -E touch ${CMAKE_SOURCE_DIR}/src/CImg.h)
|
||||
+ #file(DOWNLOAD https://github.com/dtschump/CImg/raw/master/CImg.h ${CMAKE_SOURCE_DIR}/src/CImg.h)
|
||||
+ #execute_process(COMMAND ${CMAKE_COMMAND} -E touch ${CMAKE_SOURCE_DIR}/src/CImg.h)
|
||||
+ execute_process(COMMAND ln -s ${CMAKE_INSTALL_PREFIX}/include/CImg.h ${CMAKE_SOURCE_DIR}/src/CImg.h)
|
||||
endif()
|
||||
|
||||
# gmic_stdlib.h header
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/gmic.cpp.orig 2018-12-03 08:57:03 UTC
|
||||
--- src/gmic.cpp.orig 2020-06-10 13:43:16 UTC
|
||||
+++ src/gmic.cpp
|
||||
@@ -2029,7 +2029,7 @@ double gmic::mp_ext(char *const str, voi
|
||||
@@ -2320,7 +2320,7 @@ double gmic::mp_setname(const unsigned int ind, const
|
||||
// Manage correspondence between abort pointers and thread ids.
|
||||
CImgList<void*> gmic::list_p_is_abort = CImgList<void*>();
|
||||
bool *gmic::abort_ptr(bool *const p_is_abort) {
|
||||
@ -9,9 +9,9 @@
|
||||
void* tid = (void*)(cimg_ulong)getpid();
|
||||
#elif cimg_OS==1
|
||||
void* tid = (void*)(cimg_ulong)syscall(SYS_gettid);
|
||||
@@ -2362,7 +2362,7 @@ gmic::~gmic() {
|
||||
#endif // #if cimg_display!=0
|
||||
|
||||
@@ -2660,7 +2660,7 @@ gmic::~gmic() {
|
||||
cimg::exception_mode(cimg_exception_mode);
|
||||
cimg_forX(display_windows,l) delete &display_window(l);
|
||||
cimg::mutex(21);
|
||||
-#if defined(__MACOSX__) || defined(__APPLE__)
|
||||
+#if defined(__MACOSX__) || defined(__APPLE__) || defined(__FreeBSD__)
|
||||
|
@ -6,3 +6,4 @@ lib/cmake/gmic/GmicTargets.cmake
|
||||
lib/libgmic.so
|
||||
lib/libgmic.so.1
|
||||
man/man1/gmic.1.gz
|
||||
share/bash-completion/completions/gmic
|
||||
|
Loading…
Reference in New Issue
Block a user