Upgrade to 0.11.3

Approved by:	dima
This commit is contained in:
Munechika SUMIKAWA 2002-09-17 02:11:58 +00:00
parent 9ee062c366
commit 98c24fc5d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=66464
26 changed files with 110 additions and 290 deletions

View File

@ -6,11 +6,9 @@
#
PORTNAME= pilot-link
PORTVERSION= 0.9.5
PORTREVISION= 4
PORTVERSION= 0.11.3
CATEGORIES= palm comms tk83
MASTER_SITES= http://www.pilot-link.org/source/
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= dima@FreeBSD.org
@ -27,8 +25,9 @@ MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
pilot-addresses.1 pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
CFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3
CONFIGURE_ARGS= --with-perl5=${PERL5} --with-libiconv=${LOCALBASE}
MAKE_ARGS= LIBTOOL=libtool
post-patch:
# Remove the FORCE tag, which forced recompiling/relinking

View File

@ -1 +1 @@
MD5 (pilot-link.0.9.5.tar.bz2) = f5f4eb673fe277b2738c889bb355b269
MD5 (pilot-link-0.11.3.tar.bz2) = ff8bf656fa74fe9705c427c2aa8f69a0

View File

@ -1,16 +1,13 @@
--- Makefile.in Tue Oct 7 07:55:21 1997
+++ Makefile.in Mon Nov 24 00:13:27 1997
@@ -15,11 +15,11 @@
PURIFY =
# Libraries needed to link with Tcl & (optionally) Tk
-TCLTK_LIBS = @TCLTKLIBS@
+TCLTK_LIBS = -L/usr/lib @TCLTKLIBS@
# Include directives needed to compile with Tcl & Tk, and
# -DTCL if Tcl is available, and
# -DTK if Tk is available.
-TCLTK_FLAGS = @TCLTKFLAGS@
+TCLTK_FLAGS = @TCLTKFLAGS@ -I/usr/X11R6/include
# Libraries needed to link with GNU readline
RLLIBS = @RLLIBS@
--- Makefile.in.orig Thu Mar 21 07:31:21 2002
+++ Makefile.in Wed Mar 27 12:33:16 2002
@@ -100,8 +100,8 @@
TCLLIBS = @TCLLIBS@
TCLTKFLAGS = @TCLTKFLAGS@
TCLTKLIBS = @TCLTKLIBS@
-TCLTK_FLAGS = @TCLTK_FLAGS@
-TCLTK_LIBS = @TCLTK_LIBS@
+TCLTK_FLAGS = @TCLTK_FLAGS@ -I/usr/X11R6/include
+TCLTK_LIBS = -L/usr/lib @TCLTK_LIBS@
TCL_BIN = @TCL_BIN@
TCL_INC = @TCL_INC@
TCL_LIBS = @TCL_LIBS@

View File

@ -1,19 +1,11 @@
*** pilot-mail.c.orig Sun Oct 10 23:57:07 1999
--- pilot-mail.c Sun Oct 10 23:57:34 1999
***************
*** 15,21 ****
#define POPUSER ""
#define POPPASS ""
#define PILOTFROM ""
! #define SENDMAIL "/usr/lib/sendmail -t -i"
#define POPKEEP "keep"
#define DISPOSE "keep"
#define TOPILOT_MHDIR ""
--- 15,21 ----
#define POPUSER ""
#define POPPASS ""
#define PILOTFROM ""
! #define SENDMAIL "/usr/sbin/sendmail -t -i"
#define POPKEEP "keep"
#define DISPOSE "keep"
#define TOPILOT_MHDIR ""
--- src/pilot-mail.c.orig Fri Mar 1 23:13:57 2002
+++ src/pilot-mail.c Wed Mar 27 12:34:36 2002
@@ -252,7 +252,7 @@
*pop_host = getvars("POPHOST", ""),
*pop_user = getvars("POPUSER", ""),
*pop_pass = getvars("POPPASS", ""),
- *sendmail = getvars("SENDMAIL", "/usr/lib/sendmail -t -i"),
+ *sendmail = getvars("SENDMAIL", "/usr/sbin/sendmail -t -i"),
*pop_keep = getvars("POPKEEP", "keep"),
*pilot_dispose = getvars("PILOTDISPOSE", "keep"),
*topilot_mhdir = getvars("TOPILOT_MHDIR", "");

View File

@ -1,11 +0,0 @@
--- ./include/pi-address.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-address.hxx Mon Jun 17 16:35:08 2002
@@ -33,7 +33,7 @@
char *_entry[19];
- friend addressList_t;
+ friend class addressList_t;
address_t *_next;

View File

@ -1,11 +0,0 @@
--- ./include/pi-datebook.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-datebook.hxx Mon Jun 17 16:35:16 2002
@@ -34,7 +34,7 @@
};
private:
- friend appointmentList_t;
+ friend class appointmentList_t;
tm _begin; // When the appointment begins
tm _end; // When the appointment ends

View File

@ -1,11 +0,0 @@
--- ./include/pi-iambicExpense.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-iambicExpense.hxx Mon Jun 17 16:35:27 2002
@@ -27,7 +27,7 @@
class iambicExpense_t : public baseApp_t
{
- friend iambicExpenseList_t;
+ friend class iambicExpenseList_t;
short _flags;
char *_type;

View File

@ -1,11 +0,0 @@
--- ./include/pi-memo.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-memo.hxx Mon Jun 17 16:35:35 2002
@@ -19,7 +19,7 @@
class memo_t : public baseApp_t
{
- friend memoList_t;
+ friend class memoList_t;
char *_text;
int _size;

View File

@ -1,12 +0,0 @@
--- ./include/pi-todo.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-todo.hxx Mon Jun 17 16:35:43 2002
@@ -23,7 +23,7 @@
class todo_t : public baseApp_t
{
- friend todoList_t;
+ friend class todoList_t;
struct tm *_due; // Non-NULL if there is a due date
int _priority; // A priority in the range 1-5

View File

@ -1,14 +0,0 @@
Don' link include this useless getopt reimplementations into every
executable. When/if pilot-link starts to use the longopt/getopt_long, it
should check if the libc or the libgnugetopt has them first.
+++ Makefile.in Fri Aug 24 10:17:57 2001
@@ -102,1 +102,1 @@ PERLEXECS = pilot-undelete ietf2datebook
-GETOPT = getopt.o getopt1.o
+GETOPT =
--- pilot-xfer.c Tue May 22 08:20:05 2001
+++ pilot-xfer.c Mon Aug 27 14:44:52 2001
@@ -33,3 +33,2 @@
#endif
-#include "getopt.h"
#include <sys/stat.h>

View File

@ -1,7 +0,0 @@
If we use iconv -- link pisock with it, so others don't have to:
--- libsock/Makefile.in Tue Jun 19 12:25:26 2001
+++ libsock/Makefile.in Fri Aug 24 10:09:20 2001
@@ -57,1 +57,1 @@
- -o libpisock.la $(OBJS)
+ -o libpisock.la $(OBJS) @ICONV_LIBS@

View File

@ -3,6 +3,4 @@ organizer. There are programs in here to transfer data, debug the pilot,
synchronize with calendars, and a set of include files and libraries with which
you may build your own applications in C, C++, Perl5, Tcl, Java, and Python.
It does NOT (yet) support USB linked PDAa.
WWW: http://www.gnu-designs.com/pilot-link/

View File

@ -2,10 +2,7 @@ bin/addresses
bin/ccexample
bin/debugsh
bin/dlpsh
bin/getrom
bin/hinotes
bin/iambicexample
bin/ietf2datebook
bin/install-datebook
bin/install-hinote
bin/install-memo
@ -16,73 +13,77 @@ bin/money2qif
bin/pi-csd
bin/pi-getram
bin/pi-getrom
bin/pi-getromtoken
bin/pi-nredir
bin/pi-port
bin/pilot-addresses
bin/pilot-clip
bin/pilot-debug
bin/pilot-datebook
bin/pilot-dedupe
bin/pilot-file
bin/pilot-mail
bin/pilot-prc
bin/pilot-schlep
bin/pilot-undelete
bin/pilot-xfer
bin/read-expenses
bin/read-ical
bin/read-notepad
bin/read-palmpix
bin/read-todos
bin/reminders
bin/sync-plan
include/pi-address.h
include/pi-address.hxx
include/pi-appinfo.h
include/pi-appinfo.hxx
include/pi-args.h
include/pi-cmp.h
include/pi-config-win32.h
include/pi-config.h
include/pi-datebook.h
include/pi-datebook.hxx
include/pi-debug.h
include/pi-dlp.h
include/pi-dlp.hxx
include/pi-expense.h
include/pi-file.h
include/pi-header.h
include/pi-hinote.h
include/pi-iambicExpense.h
include/pi-iambicExpense.hxx
include/pi-inet.h
include/pi-inetserial.h
include/pi-macros.h
include/pi-mail.h
include/pi-md5.h
include/pi-memo.h
include/pi-memo.hxx
include/pi-money.h
include/pi-net.h
include/pi-notepad.h
include/pi-padp.h
include/pi-palmpix.h
include/pi-serial.h
include/pi-slp.h
include/pi-sockaddr-win32.h
include/pi-sockaddr.h
include/pi-socket.h
include/pi-source.h
include/pi-sync.h
include/pi-sys.h
include/pi-syspkt.h
include/pi-todo.h
include/pi-todo.hxx
include/pi-usb.h
include/pi-util.h
include/pi-version.h
lib/libpicc.a
lib/libpisock.a
lib/libpisock.la
lib/libpisock.so
lib/libpisock.so.4.0
lib/pix/b1.gif
lib/pix/b2.gif
lib/pix/b3.gif
lib/pix/b4.gif
lib/pix/b5.gif
lib/pix/b6.gif
lib/pix/b7.gif
lib/pix/case.gif
lib/pix/case.xbm
lib/pix/casemask.xbm
@dirrm lib/pix
lib/libpisock.so.8
share/pilot-link/getrom.prc
share/pilot-link/getrom2.prc
share/pilot-link/pix/b1.gif
share/pilot-link/pix/b2.gif
share/pilot-link/pix/b3.gif
share/pilot-link/pix/b4.gif
share/pilot-link/pix/b5.gif
share/pilot-link/pix/b6.gif
share/pilot-link/pix/b7.gif
share/pilot-link/pix/case.gif
share/pilot-link/pix/casemask.xbm
share/pilot-link/pix/case.xbm
@dirrm share/pilot-link/pix
@dirrm share/pilot-link

View File

@ -6,11 +6,9 @@
#
PORTNAME= pilot-link
PORTVERSION= 0.9.5
PORTREVISION= 4
PORTVERSION= 0.11.3
CATEGORIES= palm comms tk83
MASTER_SITES= http://www.pilot-link.org/source/
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= dima@FreeBSD.org
@ -27,8 +25,9 @@ MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
pilot-addresses.1 pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
CFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/tcl8.3
CONFIGURE_ARGS= --with-perl5=${PERL5} --with-libiconv=${LOCALBASE}
MAKE_ARGS= LIBTOOL=libtool
post-patch:
# Remove the FORCE tag, which forced recompiling/relinking

View File

@ -1 +1 @@
MD5 (pilot-link.0.9.5.tar.bz2) = f5f4eb673fe277b2738c889bb355b269
MD5 (pilot-link-0.11.3.tar.bz2) = ff8bf656fa74fe9705c427c2aa8f69a0

View File

@ -1,16 +1,13 @@
--- Makefile.in Tue Oct 7 07:55:21 1997
+++ Makefile.in Mon Nov 24 00:13:27 1997
@@ -15,11 +15,11 @@
PURIFY =
# Libraries needed to link with Tcl & (optionally) Tk
-TCLTK_LIBS = @TCLTKLIBS@
+TCLTK_LIBS = -L/usr/lib @TCLTKLIBS@
# Include directives needed to compile with Tcl & Tk, and
# -DTCL if Tcl is available, and
# -DTK if Tk is available.
-TCLTK_FLAGS = @TCLTKFLAGS@
+TCLTK_FLAGS = @TCLTKFLAGS@ -I/usr/X11R6/include
# Libraries needed to link with GNU readline
RLLIBS = @RLLIBS@
--- Makefile.in.orig Thu Mar 21 07:31:21 2002
+++ Makefile.in Wed Mar 27 12:33:16 2002
@@ -100,8 +100,8 @@
TCLLIBS = @TCLLIBS@
TCLTKFLAGS = @TCLTKFLAGS@
TCLTKLIBS = @TCLTKLIBS@
-TCLTK_FLAGS = @TCLTK_FLAGS@
-TCLTK_LIBS = @TCLTK_LIBS@
+TCLTK_FLAGS = @TCLTK_FLAGS@ -I/usr/X11R6/include
+TCLTK_LIBS = -L/usr/lib @TCLTK_LIBS@
TCL_BIN = @TCL_BIN@
TCL_INC = @TCL_INC@
TCL_LIBS = @TCL_LIBS@

View File

@ -1,19 +1,11 @@
*** pilot-mail.c.orig Sun Oct 10 23:57:07 1999
--- pilot-mail.c Sun Oct 10 23:57:34 1999
***************
*** 15,21 ****
#define POPUSER ""
#define POPPASS ""
#define PILOTFROM ""
! #define SENDMAIL "/usr/lib/sendmail -t -i"
#define POPKEEP "keep"
#define DISPOSE "keep"
#define TOPILOT_MHDIR ""
--- 15,21 ----
#define POPUSER ""
#define POPPASS ""
#define PILOTFROM ""
! #define SENDMAIL "/usr/sbin/sendmail -t -i"
#define POPKEEP "keep"
#define DISPOSE "keep"
#define TOPILOT_MHDIR ""
--- src/pilot-mail.c.orig Fri Mar 1 23:13:57 2002
+++ src/pilot-mail.c Wed Mar 27 12:34:36 2002
@@ -252,7 +252,7 @@
*pop_host = getvars("POPHOST", ""),
*pop_user = getvars("POPUSER", ""),
*pop_pass = getvars("POPPASS", ""),
- *sendmail = getvars("SENDMAIL", "/usr/lib/sendmail -t -i"),
+ *sendmail = getvars("SENDMAIL", "/usr/sbin/sendmail -t -i"),
*pop_keep = getvars("POPKEEP", "keep"),
*pilot_dispose = getvars("PILOTDISPOSE", "keep"),
*topilot_mhdir = getvars("TOPILOT_MHDIR", "");

View File

@ -1,11 +0,0 @@
--- ./include/pi-address.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-address.hxx Mon Jun 17 16:35:08 2002
@@ -33,7 +33,7 @@
char *_entry[19];
- friend addressList_t;
+ friend class addressList_t;
address_t *_next;

View File

@ -1,11 +0,0 @@
--- ./include/pi-datebook.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-datebook.hxx Mon Jun 17 16:35:16 2002
@@ -34,7 +34,7 @@
};
private:
- friend appointmentList_t;
+ friend class appointmentList_t;
tm _begin; // When the appointment begins
tm _end; // When the appointment ends

View File

@ -1,11 +0,0 @@
--- ./include/pi-iambicExpense.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-iambicExpense.hxx Mon Jun 17 16:35:27 2002
@@ -27,7 +27,7 @@
class iambicExpense_t : public baseApp_t
{
- friend iambicExpenseList_t;
+ friend class iambicExpenseList_t;
short _flags;
char *_type;

View File

@ -1,11 +0,0 @@
--- ./include/pi-memo.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-memo.hxx Mon Jun 17 16:35:35 2002
@@ -19,7 +19,7 @@
class memo_t : public baseApp_t
{
- friend memoList_t;
+ friend class memoList_t;
char *_text;
int _size;

View File

@ -1,12 +0,0 @@
--- ./include/pi-todo.hxx.kan Mon Jun 17 16:34:24 2002
+++ ./include/pi-todo.hxx Mon Jun 17 16:35:43 2002
@@ -23,7 +23,7 @@
class todo_t : public baseApp_t
{
- friend todoList_t;
+ friend class todoList_t;
struct tm *_due; // Non-NULL if there is a due date
int _priority; // A priority in the range 1-5

View File

@ -1,14 +0,0 @@
Don' link include this useless getopt reimplementations into every
executable. When/if pilot-link starts to use the longopt/getopt_long, it
should check if the libc or the libgnugetopt has them first.
+++ Makefile.in Fri Aug 24 10:17:57 2001
@@ -102,1 +102,1 @@ PERLEXECS = pilot-undelete ietf2datebook
-GETOPT = getopt.o getopt1.o
+GETOPT =
--- pilot-xfer.c Tue May 22 08:20:05 2001
+++ pilot-xfer.c Mon Aug 27 14:44:52 2001
@@ -33,3 +33,2 @@
#endif
-#include "getopt.h"
#include <sys/stat.h>

View File

@ -1,7 +0,0 @@
If we use iconv -- link pisock with it, so others don't have to:
--- libsock/Makefile.in Tue Jun 19 12:25:26 2001
+++ libsock/Makefile.in Fri Aug 24 10:09:20 2001
@@ -57,1 +57,1 @@
- -o libpisock.la $(OBJS)
+ -o libpisock.la $(OBJS) @ICONV_LIBS@

View File

@ -3,6 +3,4 @@ organizer. There are programs in here to transfer data, debug the pilot,
synchronize with calendars, and a set of include files and libraries with which
you may build your own applications in C, C++, Perl5, Tcl, Java, and Python.
It does NOT (yet) support USB linked PDAa.
WWW: http://www.gnu-designs.com/pilot-link/

View File

@ -2,10 +2,7 @@ bin/addresses
bin/ccexample
bin/debugsh
bin/dlpsh
bin/getrom
bin/hinotes
bin/iambicexample
bin/ietf2datebook
bin/install-datebook
bin/install-hinote
bin/install-memo
@ -16,73 +13,77 @@ bin/money2qif
bin/pi-csd
bin/pi-getram
bin/pi-getrom
bin/pi-getromtoken
bin/pi-nredir
bin/pi-port
bin/pilot-addresses
bin/pilot-clip
bin/pilot-debug
bin/pilot-datebook
bin/pilot-dedupe
bin/pilot-file
bin/pilot-mail
bin/pilot-prc
bin/pilot-schlep
bin/pilot-undelete
bin/pilot-xfer
bin/read-expenses
bin/read-ical
bin/read-notepad
bin/read-palmpix
bin/read-todos
bin/reminders
bin/sync-plan
include/pi-address.h
include/pi-address.hxx
include/pi-appinfo.h
include/pi-appinfo.hxx
include/pi-args.h
include/pi-cmp.h
include/pi-config-win32.h
include/pi-config.h
include/pi-datebook.h
include/pi-datebook.hxx
include/pi-debug.h
include/pi-dlp.h
include/pi-dlp.hxx
include/pi-expense.h
include/pi-file.h
include/pi-header.h
include/pi-hinote.h
include/pi-iambicExpense.h
include/pi-iambicExpense.hxx
include/pi-inet.h
include/pi-inetserial.h
include/pi-macros.h
include/pi-mail.h
include/pi-md5.h
include/pi-memo.h
include/pi-memo.hxx
include/pi-money.h
include/pi-net.h
include/pi-notepad.h
include/pi-padp.h
include/pi-palmpix.h
include/pi-serial.h
include/pi-slp.h
include/pi-sockaddr-win32.h
include/pi-sockaddr.h
include/pi-socket.h
include/pi-source.h
include/pi-sync.h
include/pi-sys.h
include/pi-syspkt.h
include/pi-todo.h
include/pi-todo.hxx
include/pi-usb.h
include/pi-util.h
include/pi-version.h
lib/libpicc.a
lib/libpisock.a
lib/libpisock.la
lib/libpisock.so
lib/libpisock.so.4.0
lib/pix/b1.gif
lib/pix/b2.gif
lib/pix/b3.gif
lib/pix/b4.gif
lib/pix/b5.gif
lib/pix/b6.gif
lib/pix/b7.gif
lib/pix/case.gif
lib/pix/case.xbm
lib/pix/casemask.xbm
@dirrm lib/pix
lib/libpisock.so.8
share/pilot-link/getrom.prc
share/pilot-link/getrom2.prc
share/pilot-link/pix/b1.gif
share/pilot-link/pix/b2.gif
share/pilot-link/pix/b3.gif
share/pilot-link/pix/b4.gif
share/pilot-link/pix/b5.gif
share/pilot-link/pix/b6.gif
share/pilot-link/pix/b7.gif
share/pilot-link/pix/case.gif
share/pilot-link/pix/casemask.xbm
share/pilot-link/pix/case.xbm
@dirrm share/pilot-link/pix
@dirrm share/pilot-link