The Solidity Contract-Oriented Programming Language
WWW: https://github.com/ethereum/solidity
This commit is contained in:
parent
97dc2e37b8
commit
989bcb5fb6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=459751
@ -329,6 +329,7 @@
|
||||
SUBDIR += smalltalk
|
||||
SUBDIR += smlnj
|
||||
SUBDIR += snobol4
|
||||
SUBDIR += solidity
|
||||
SUBDIR += spidermonkey17
|
||||
SUBDIR += spidermonkey170
|
||||
SUBDIR += spidermonkey185
|
||||
|
34
lang/solidity/Makefile
Normal file
34
lang/solidity/Makefile
Normal file
@ -0,0 +1,34 @@
|
||||
# Created by: Alex Dupre <ale@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= solidity
|
||||
PORTVERSION= 0.4.19
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= https://github.com/ethereum/solidity/releases/download/v${PORTVERSION}/
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= ale@FreeBSD.org
|
||||
COMMENT= Solidity Contract-Oriented Programming Language
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
|
||||
LIB_DEPENDS= libjsoncpp.so:devel/jsoncpp
|
||||
|
||||
OPTIONS_DEFINE= SMT
|
||||
SMT_DESC= SMT Checker
|
||||
SMT_LIB_DEPENDS=libz3.so:math/z3
|
||||
|
||||
USES= cmake
|
||||
|
||||
CMAKE_ARGS+= -DUSE_LD_GOLD=OFF -DTESTS=OFF \
|
||||
-DJSONCPP_INCLUDE_DIR:STRING="${LOCALBASE}/include/jsoncpp" \
|
||||
-DJSONCPP_LIB_DIR:STRING="${LOCALBASE}/lib"
|
||||
|
||||
PLIST_FILES= bin/solc
|
||||
|
||||
pre-patch:
|
||||
@${CP} ${FILESDIR}/jsoncpp.cmake ${WRKSRC}/cmake/
|
||||
@${REINPLACE_CMD} '/EthCcache/d' ${WRKSRC}/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
3
lang/solidity/distinfo
Normal file
3
lang/solidity/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1516355316
|
||||
SHA256 (solidity_0.4.19.tar.gz) = 6525f2cfe498785b3d752b616cb9b5e81222654ec594a27708f45e688bfa56e9
|
||||
SIZE (solidity_0.4.19.tar.gz) = 1027296
|
2
lang/solidity/files/jsoncpp.cmake
Normal file
2
lang/solidity/files/jsoncpp.cmake
Normal file
@ -0,0 +1,2 @@
|
||||
include_directories(${JSONCPP_INCLUDE_DIR})
|
||||
link_directories(${JSONCPP_LIB_DIR})
|
11
lang/solidity/files/patch-libevmasm_Instruction.h
Normal file
11
lang/solidity/files/patch-libevmasm_Instruction.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- libevmasm/Instruction.h.orig 2018-01-23 11:51:18 UTC
|
||||
+++ libevmasm/Instruction.h
|
||||
@@ -26,6 +26,8 @@
|
||||
#include <libdevcore/Assertions.h>
|
||||
#include "Exceptions.h"
|
||||
|
||||
+#undef MSIZE // remove MSIZE definition from <sys/params.h>, included by boost 1.66.0
|
||||
+
|
||||
namespace dev
|
||||
{
|
||||
namespace solidity
|
3
lang/solidity/pkg-descr
Normal file
3
lang/solidity/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
The Solidity Contract-Oriented Programming Language
|
||||
|
||||
WWW: https://github.com/ethereum/solidity
|
Loading…
Reference in New Issue
Block a user