emulators/open-vm-tools: Update to 10.1.0

PR:		212471
This commit is contained in:
Steve Wills 2017-03-22 14:52:00 +00:00
parent 7d34a16114
commit 988c348b42
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=436703
36 changed files with 91 additions and 2143 deletions

View File

@ -5,7 +5,4 @@ MASTERDIR= ${.CURDIR}/../open-vm-tools
PKGNAMESUFFIX= -nox11
OPTIONS_EXCLUDE= X11 LIBNOTIFY
BROKEN_mips64= Does not configure: error: Unknown architecture
BROKEN_powerpc64= Does not build
.include "${MASTERDIR}/Makefile"

View File

@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= open-vm-tools
PORTVERSION= ${BUILD_VER}
PORTREVISION= 17
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/stable-9.4.x
PORTVERSION= ${RELEASE_VER}
PORTEPOCH= 2
MASTER_SITES= https://github.com/vmware/open-vm-tools/files/590760/
DISTNAME= open-vm-tools-${RELEASE_VER}-${BUILD_VER}
CATEGORIES= emulators
MAINTAINER= swills@FreeBSD.org
COMMENT?= Open VMware tools for FreeBSD VMware guests
@ -15,8 +14,8 @@ COMMENT?= Open VMware tools for FreeBSD VMware guests
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
RELEASE_VER= 9.4.0
BUILD_VER= 1280544
RELEASE_VER= 10.1.0
BUILD_VER= 4449150
OPTIONS_DEFINE= X11 LIBNOTIFY UNITY FUSE DNET ICU
OPTIONS_DEFAULT= X11 LIBNOTIFY FUSE DNET ICU
@ -26,11 +25,13 @@ DNET_DESC= libdnet support
LIBNOTIFY_DESC= Desktop notification support
UNITY_DESC= liburiparser support
# TODO add USE_GITHUB=yes after switching to USES=autoreconf
X11_CONFIGURE_WITH= x gtk2 gtkmm
X11_LDFLAGS= -L${LOCALBASE}/lib
X11_USE= xorg=x11,ice,sm,xext,xineramaproto,xinerama,xrandr,xrender,xtst \
gnome=gtk20,gtkmm24
X11_USES= fuse
X11_USE= xorg=x11,ice,sm,xext,xineramaproto,xinerama,xrandr,xrender,xtst,xi \
gnome=gtk20,gtkmm24,gdkpixbuf2
X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
LIBNOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
UNITY_CONFIGURE_ENV= CUSTOM_URIPARSER_CPPFLAGS="-I${LOCALBASE}/include/uriparser"
UNITY_LIB_DEPENDS= liburiparser.so:net/uriparser
@ -40,19 +41,27 @@ DNET_LIB_DEPENDS= libdnet.so:net/libdnet
ICU_CONFIGURE_WITH= icu
ICU_LIB_DEPENDS= libicuuc.so:devel/icu
WRKSRC= ${WRKDIR}/open-vm-tools-${RELEASE_VER}-${BUILD_VER}
WRKSRC= ${WRKDIR}/open-vm-tools-${RELEASE_VER}-${BUILD_VER}/open-vm-tools
GNU_CONFIGURE= yes
USES= pathfix pkgconfig kmod libtool
USE_GNOME= glib20
# TODO add autoreconf when included files are compatible
USES= fuse gettext-runtime kmod libtool pathfix pkgconfig
LIB_DEPENDS= libmspack.so:archivers/libmspack \
libxerces-c.so.3:textproc/xerces-c3 \
libxml-security-c.so:security/apache-xml-security-c
USE_LDCONFIG= yes
CPPFLAGS+= -Wno-deprecated-declarations
LDFLAGS= -L${LOCALBASE}/lib
SSP_UNSAFE= kernel module does not support ssp
CONFIGURE_ARGS+= --without-procps --sysconfdir=${LOCALBASE}/etc
CONFIGURE_ARGS+= --disable-grabbitmqproxy --disable-deploypkg \
--disable-vgauth --without-procps \
--sysconfdir=${LOCALBASE}/etc
CONFLICTS+= vmware-guestd[0-9]* vmware-tools[0-9]*
SUB_FILES= pkg-message
USE_RC_SUBR= vmware-guestd vmware-kmod
@ -64,10 +73,9 @@ CONFLICTS= open-vm-tools-nox11-[0-9]*
CONFLICTS= open-vm-tools-[0-9]*
.endif
BROKEN_aarch64= Fails to configure: error: Unknown architecture
ONLY_FOR_ARCHS= i386 amd64
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this architecture
CONFIGURE_ENV+= SYSDIR=${SRC_BASE}/sys
.include <bsd.port.pre.mk>
@ -77,12 +85,16 @@ post-build:
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers
${MKDIR} ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/input
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmblock.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmblock.ko
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmmemctl.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmmemctl.ko
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmxnet.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmxnet.ko
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmhgfs.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmhgfs.ko
${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmblock.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmblock.ko
${MKDIR} ${STAGEDIR}${PREFIX}/share/open-vm-tools/scripts/vmware/
${MKDIR} ${STAGEDIR}${PREFIX}/share/open-vm-tools/scripts/
${MKDIR} ${STAGEDIR}${PREFIX}/share/open-vm-tools/tests/
${MKDIR} ${STAGEDIR}${PREFIX}/etc/rc.conf.d
${ECHO} 'vmware_guest_vmblock_enable="yes"' > ${STAGEDIR}${PREFIX}/etc/rc.conf.d/vmware_guest_vmblock
${ECHO} 'vmware_guest_vmmemctl_enable="yes"' > ${STAGEDIR}${PREFIX}/etc/rc.conf.d/vmware_guest_vmmemctl
${ECHO} 'vmware_guest_vmxnet_enable="yes"' > ${STAGEDIR}${PREFIX}/etc/rc.conf.d/vmware_guest_vmxnet
${ECHO} 'vmware_guestd_enable="yes"' > ${STAGEDIR}${PREFIX}/etc/rc.conf.d/vmware_guestd
.include <bsd.port.post.mk>

View File

@ -1,2 +1,3 @@
SHA256 (open-vm-tools-9.4.0-1280544.tar.gz) = 5d30652eb0f6dc5e930781029c184837e700be5543b6a7116db4c62a6f3ca399
SIZE (open-vm-tools-9.4.0-1280544.tar.gz) = 3659504
TIMESTAMP = 1484345963
SHA256 (open-vm-tools-10.1.0-4449150.tar.gz) = d579474c9495b504a544dfc2635d291c27488e7e9303ec4fe6b393836dc3b017
SIZE (open-vm-tools-10.1.0-4449150.tar.gz) = 5025787

File diff suppressed because it is too large Load Diff

View File

@ -1,40 +1,11 @@
--- ./configure.orig 2013-09-23 15:51:43.000000000 +0000
+++ ./configure 2014-04-23 15:36:44.174844399 +0000
@@ -2823,6 +2823,9 @@
x86_64)
userSpaceBitness="64"
;;
+ amd64)
+ userSpaceBitness="64"
+ ;;
*)
as_fn_error $? "Unknown architecture." "$LINENO" 5
;;
@@ -21733,18 +21736,6 @@
done
-for ac_header in unwind.h
-do :
- ac_fn_c_check_header_mongrel "$LINENO" "unwind.h" "ac_cv_header_unwind_h" "$ac_includes_default"
-if test "x$ac_cv_header_unwind_h" = xyes; then :
- cat >>confdefs.h <<_ACEOF
-#define HAVE_UNWIND_H 1
-_ACEOF
-
-fi
-
-done
-
ac_fn_c_check_header_mongrel "$LINENO" "wchar.h" "ac_cv_header_wchar_h" "$ac_includes_default"
if test "x$ac_cv_header_wchar_h" = xyes; then :
@@ -22238,7 +22229,7 @@
### General flags / actions
CFLAGS="$CFLAGS -Wall"
-CFLAGS="$CFLAGS -Werror"
+CFLAGS="$CFLAGS -Werror -Wno-unused-function"
# -Wno-unknown-pragmas is due to gcc not understanding '#pragma ident' in Xlib.h on OpenSolaris.
--- configure.orig 2017-01-11 20:40:42.694207000 +0000
+++ configure 2017-01-11 20:41:03.256056000 +0000
@@ -34117,7 +34117,7 @@ CFLAGS="$CFLAGS -Werror"
# warnings for now (-Wno-deprecated-declarations).
for TEST_CFLAG in -Wno-pointer-sign -Wno-unused-value -fno-strict-aliasing \
-Wno-unknown-pragmas -Wno-uninitialized -Wno-deprecated-declarations \
- -Wno-unused-const-variable; do
+ -Wno-unused-const-variable -Wno-address-of-packed-member; do
{ echo "$as_me:$LINENO: checking for GCC flag $TEST_CFLAG" >&5
echo $ECHO_N "checking for GCC flag $TEST_CFLAG... $ECHO_C" >&6; }
ORIGINAL_CFLAGS="$CFLAGS"

View File

@ -1,170 +0,0 @@
--- modules/freebsd/vmhgfs/vnops.c.orig 2009-02-18 17:02:35.000000000 +0900
+++ modules/freebsd/vmhgfs/vnops.c 2009-03-01 17:47:10.000000000 +0900
@@ -325,7 +325,11 @@
*/
{
struct vnode *vp = ap->a_vp;
+#if __FreeBSD_version >= 800001
+ int mode = ap->a_accmode;
+#else
int mode = ap->a_mode;
+#endif
HgfsAccessMode accessMode = 0;
Bool isDir = vp->v_type == VDIR;
if (mode & VREAD) {
--- modules/freebsd/vmblock/vfsops.c.orig 2009-03-18 03:03:21.000000000 -0400
+++ modules/freebsd/vmblock/vfsops.c 2009-05-23 02:25:50.892549675 -0400
@@ -126,6 +126,11 @@
char *target;
int len, error = 0;
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
+
VMBLOCKDEBUG("VMBlockVFSMount(mp = %p)\n", (void *)mp);
/*
@@ -273,6 +278,11 @@
int error;
int flags = 0, removed = 0;
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
+
VMBLOCKDEBUG("VMBlockVFSUnmount: mp = %p\n", (void *)mp);
xmp = MNTTOVMBLOCKMNT(mp);
@@ -448,10 +458,15 @@
VMBlockVFSSync(struct mount *mp, // Ignored
int waitfor) // Ignored
#else
+#if __FreeBSD_version >= 800087
+VMBlockVFSSync(struct mount *mp,
+ int waitfor)
+#else
VMBlockVFSSync(struct mount *mp, // Ignored
int waitfor, // Ignored
struct thread *td) // Ignored
#endif
+#endif
{
return 0;
}
--- modules/freebsd/vmhgfs/vfsops.c.orig 2009-03-18 03:03:26.000000000 -0400
+++ modules/freebsd/vmhgfs/vfsops.c 2009-05-23 02:56:39.608109670 -0400
@@ -109,8 +109,12 @@
*/
static int
+#if __FreeBSD_version >= 800087
+HgfsVfsMount(struct mount *mp)
+#else
HgfsVfsMount(struct mount *mp, // IN: structure representing the file system
struct thread *td) // IN: thread which is mounting the file system
+#endif
{
HgfsSuperInfo *sip;
struct vnode *vp;
@@ -122,6 +126,10 @@
int *uid = NULL;
Bool *gidSet = NULL;
int *gid = NULL;
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
/*
* - Examine/validate mount flags from userland.
@@ -145,7 +153,11 @@
* Since Hgfs requires the caller to be root, only allow mount attempts made
* by the superuser.
*/
+#if __FreeBSD_version >= 800001
+ if ((ret = priv_check(td, PRIV_VFS_MOUNT)) != 0) {
+#else
if ((ret = suser(td)) != 0) {
+#endif
return ret;
}
@@ -277,11 +289,19 @@
*/
static int
+#if __FreeBSD_version >= 800087
+HgfsVfsUnmount(struct mount *mp, int mntflags)
+#else
HgfsVfsUnmount(struct mount *mp, int mntflags, struct thread *td)
+#endif
{
HgfsSuperInfo *sip;
int ret = 0;
int flags = 0;
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
sip = (HgfsSuperInfo *)mp->mnt_data;
@@ -348,10 +368,18 @@
*/
static int
+#if __FreeBSD_version >= 800087
+HgfsVfsStatfs(struct mount *mp, struct statfs *sbp)
+#else
HgfsVfsStatfs(struct mount *mp, struct statfs *sbp, struct thread *td)
+#endif
{
int ret = 0;
struct vnode *vp;
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
/* We always want HGFS_BLOCKSIZE to be a power of two */
ASSERT_ON_COMPILE(HGFS_IS_POWER_OF_TWO(HGFS_BLOCKSIZE));
@@ -361,8 +389,11 @@
* we got from a call to vfs_getnewfsid() in HgfsVfsMount()
*/
bcopy(&mp->mnt_stat, sbp, sizeof mp->mnt_stat);
-
+#if __FreeBSD_version >= 800087
+ ret = HgfsVfsRoot(mp, LK_SHARED, &vp);
+#else
ret = HgfsVfsRoot(mp, LK_SHARED, &vp, td);
+#endif
if (ret) {
DEBUG(VM_DEBUG_FAIL, "HgfsVfsRoot failed\n");
return ret;
@@ -397,13 +428,23 @@
*/
static int
+#if __FreeBSD_version >= 800087
+HgfsVfsRoot(struct mount *mp,
+ int flags,
+ struct vnode **vpp)
+#else
HgfsVfsRoot(struct mount *mp, // IN: Filesystem structure
int flags, // IN: Flags to vget
struct vnode **vpp, // OUT: Address of root vnode
struct thread *td) // IN: Thread structure
+#endif
{
HgfsSuperInfo *sip = (HgfsSuperInfo *)mp->mnt_data;
int ret = 0;
+#if __FreeBSD_version >= 800087
+ struct thread *td;
+ td = curthread;
+#endif
*vpp = NULL;

View File

@ -1,40 +0,0 @@
--- lib/auth/authPosix.c 2008-03-19 08:49:49.000000000 +0100
+++ lib/auth/authPosix.c 2008-03-27 11:20:20.000000000 +0100
@@ -264,7 +264,11 @@
#endif
/* If this point is reached, the user has been authenticated. */
setpwent();
+#if defined(__FreeBSD__)
+ pwd = getpwnam(user);
+#else
pwd = Posix_Getpwnam(user);
+#endif
endpwent();
#else /* !USE_PAM */
@@ -274,7 +278,11 @@
corresponding #endif below. */
setpwent(); //XXX can kill?
+#if defined(__FreeBSD__)
+ pwd = getpwnam(user);
+#else
pwd = Posix_Getpwnam(user);
+#endif
endpwent(); //XXX can kill?
if (!pwd) {
--- lib/impersonate/impersonatePosix.c 2008-03-19 08:49:50.000000000 +0100
+++ lib/impersonate/impersonatePosix.c 2008-03-27 11:21:38.000000000 +0100
@@ -432,7 +432,11 @@
struct passwd *ppw = &pw;
int error;
+#if defined(__FreeBSD__)
+ if ((error = getpwnam_r(user, &pw, buffer, BUFSIZ, &ppw)) != 0 || !ppw) {
+#else
if ((error = Posix_Getpwnam_r(user, &pw, buffer, BUFSIZ, &ppw)) != 0 || !ppw) {
+#endif
if (error == 0) {
error = ENOENT;
}

View File

@ -1,22 +0,0 @@
--- lib/include/hgfsProto.h.orig
+++ lib/include/hgfsProto.h
@@ -148,6 +148,9 @@
HGFS_OP_SET_EAS_V4, /* Add or modify extended attributes. */
HGFS_OP_MAX, /* Dummy op, must be last in enum */
+
+/* If a V4 packet is being processed as a legacy packet it will have this opcode. */
+ HGFS_V4_LEGACY_OPCODE = 0xff,
} HgfsOp;
@@ -155,9 +158,6 @@
#define HGFS_VERSION_OLD (1 << 0)
#define HGFS_VERSION_3 (1 << 1)
-/* If a V4 packet is being processed as a legacy packet it will have this opcode. */
-#define HGFS_V4_LEGACY_OPCODE 0xff
-
/* XXX: Needs change when VMCI is supported. */
#define HGFS_REQ_PAYLOAD_SIZE_V3(hgfsReq) (sizeof *hgfsReq + sizeof(HgfsRequest))
#define HGFS_REP_PAYLOAD_SIZE_V3(hgfsRep) (sizeof *hgfsRep + sizeof(HgfsReply))

View File

@ -1,22 +0,0 @@
--- hgfsmounter/Makefile.in.orig 2011-09-21 18:25:50.000000000 +0000
+++ hgfsmounter/Makefile.in 2011-09-25 04:03:22.000000000 +0000
@@ -606,14 +606,14 @@
@FREEBSD_TRUE@ mv $(DESTDIR)$(sbindir)/mount.vmhgfs \
@FREEBSD_TRUE@ $(DESTDIR)$(sbindir)/mount_vmhgfs
@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
-@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
-@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
+#@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
+#@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
@FREEBSD_TRUE@uninstall-hook:
@FREEBSD_TRUE@ rm -f $(DESTDIR)$(sbindir)/mount_vmhgfs
@FREEBSD_FALSE@install-exec-hook:
-@FREEBSD_FALSE@ -$(MKDIR_P) $(DESTDIR)/sbin
-@FREEBSD_FALSE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
-@FREEBSD_FALSE@ $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
+#@FREEBSD_FALSE@ -$(MKDIR_P) $(DESTDIR)/sbin
+#@FREEBSD_FALSE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
+#@FREEBSD_FALSE@ $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
@FREEBSD_FALSE@uninstall-hook:
@FREEBSD_FALSE@ rm -f $(DESTDIR)/sbin/mount.vmhgfs

View File

@ -1,12 +0,0 @@
--- lib/include/vm_assert.h.orig 2013-09-23 17:51:10.000000000 +0200
+++ lib/include/vm_assert.h 2015-02-04 15:55:56.011187000 +0100
@@ -363,7 +363,8 @@
#define ASSERT_ON_COMPILE(e) \
do { \
enum { AssertOnCompileMisused = ((e) ? 1 : -1) }; \
- typedef char AssertOnCompileFailed[AssertOnCompileMisused]; \
+ typedef char AssertOnCompileFailed[AssertOnCompileMisused] \
+ __attribute__((__unused__)); \
} while (0)

View File

@ -1,12 +0,0 @@
--- lib/include/vm_atomic.h.orig 2013-09-23 17:51:10.000000000 +0200
+++ lib/include/vm_atomic.h 2015-02-04 16:28:59.372337000 +0100
@@ -2460,7 +2460,8 @@
&& 8 * sizeof (out) == size \
&& 8 * sizeof (cast) == size \
? 1 : -1 }; \
- typedef char AssertOnCompileFailed[AssertOnCompileMisused]; \
+ typedef char AssertOnCompileFailed[AssertOnCompileMisused] \
+ __attribute__((__unused__)); \
} \
\
\

View File

@ -1,5 +1,5 @@
--- ./lib/vmCheck/vmcheck.c.orig 2013-09-23 15:51:10.000000000 +0000
+++ ./lib/vmCheck/vmcheck.c 2014-04-23 15:36:44.323843725 +0000
--- ./lib/vmCheck/vmcheck.c.orig 2013-09-23 15:51:10.000000000 +0000
+++ ./lib/vmCheck/vmcheck.c 2014-04-23 15:36:44.323843725 +0000
@@ -134,6 +134,7 @@
#else
do {

View File

@ -1,13 +0,0 @@
--- lib/include/vmware/tools/log.h.orig 2014-11-07 12:41:57.111095753 +0100
+++ lib/include/vmware/tools/log.h 2014-11-07 12:42:24.867212316 +0100
@@ -134,8 +134,9 @@
*******************************************************************************
*/
+#ifndef g_info
#define g_info(fmt, ...) g_log(G_LOG_DOMAIN, G_LOG_LEVEL_INFO, fmt, ## __VA_ARGS__)
-
+#endif
/*
*******************************************************************************

View File

@ -1,18 +0,0 @@
--- libvmtools/i18n.c.orig 2014-04-17 19:02:44.102203216 +0000
+++ libvmtools/i18n.c 2014-04-17 19:08:48.881598972 +0000
@@ -88,6 +88,7 @@
}
+#ifdef BUG_ON
/*
******************************************************************************
* MsgHasMsgID -- */ /**
@@ -112,6 +113,7 @@
*(s += MSG_MAGIC_LEN) == '(' &&
strchr(s + 1, ')') != NULL;
}
+#endif
/*

View File

@ -1,6 +1,6 @@
--- modules/Makefile.in.orig 2009-04-06 18:44:58.000000000 -0400
+++ modules/Makefile.in 2009-04-06 18:45:57.000000000 -0400
@@ -528,11 +528,11 @@
--- modules/Makefile.in.orig 2017-01-11 21:40:55.849672000 -0500
+++ modules/Makefile.in 2017-01-11 21:41:10.446157000 -0500
@@ -543,11 +543,6 @@
@SOLARIS_TRUE@ $(MAKE) VM_UNAME=$(KERNEL_RELEASE) MV=mv RM=rm \
@SOLARIS_TRUE@ -C "$(modulesrc)/$(MODULES_OS)/$$MOD" install || exit 1; \
@SOLARIS_TRUE@ done
@ -9,11 +9,6 @@
-@FREEBSD_TRUE@ $(INSTALL) -m644 $(modulesrc)/$(MODULES_OS)/$$MOD.ko \
-@FREEBSD_TRUE@ $(DESTDIR)$(MODULES_DIR); \
-@FREEBSD_TRUE@ done
+#@FREEBSD_TRUE@ for MOD in $(MODULES); do \
+#@FREEBSD_TRUE@ $(INSTALL) -d $(DESTDIR)$(MODULES_DIR); \
+#@FREEBSD_TRUE@ $(INSTALL) -m644 $(modulesrc)/$(MODULES_OS)/$$MOD.ko \
+#@FREEBSD_TRUE@ $(DESTDIR)$(MODULES_DIR); \
+#@FREEBSD_TRUE@ done
@LINUX_TRUE@ for MOD in $(MODULES); do \
@LINUX_TRUE@ $(INSTALL) -d $(DESTDIR)`eval echo '$$'$${MOD}dir`; \
@LINUX_TRUE@ $(INSTALL) -m644 $(modulesrc)/$(MODULES_OS)/$$MOD/$$MOD.ko \

View File

@ -1,11 +0,0 @@
--- modules/freebsd/vmhgfs/channel.h.orig 2014-04-23 15:36:34.432844311 +0000
+++ modules/freebsd/vmhgfs/channel.h 2014-04-23 15:36:44.389843756 +0000
@@ -21,7 +21,7 @@
*/
#ifndef _HGFS_CHANNEL_H_
-#define _HGFS_CHANNEL__H_
+#define _HGFS_CHANNEL_H_
#include "hgfs_kernel.h"
#include "requestInt.h"

View File

@ -1,17 +0,0 @@
--- modules/freebsd/vmxnet/net_compat.h.orig 2011-09-21 14:25:15.000000000 -0400
+++ modules/freebsd/vmxnet/net_compat.h 2012-06-28 17:05:44.638526644 -0400
@@ -170,9 +170,12 @@
#if __FreeBSD_version < 505000
# define VXN_IF_ADDR_LOCK(_ifp)
# define VXN_IF_ADDR_UNLOCK(_ifp)
+#elif __FreeBSD_version < 1000000
+# define VXN_IF_ADDR_LOCK(_ifp) IF_ADDR_LOCK((_ifp))
+# define VXN_IF_ADDR_UNLOCK(_ifp) IF_ADDR_UNLOCK((_ifp))
#else
-# define VXN_IF_ADDR_LOCK(_ifp) IF_ADDR_LOCK((_ifp))
-# define VXN_IF_ADDR_UNLOCK(_ifp) IF_ADDR_UNLOCK((_ifp))
+# define VXN_IF_ADDR_LOCK(_ifp) IF_ADDR_WLOCK((_ifp))
+# define VXN_IF_ADDR_UNLOCK(_ifp) IF_ADDR_WUNLOCK((_ifp))
#endif
#endif /* _VXN_NET_COMPAT_H_ */

View File

@ -1,11 +1,11 @@
--- scripts/Makefile.in.orig 2010-05-22 04:41:58.000000000 +0200
+++ scripts/Makefile.in 2010-05-22 04:43:57.000000000 +0200
@@ -236,7 +236,7 @@
--- scripts/Makefile.in.orig 2017-01-11 20:52:28.004220000 -0500
+++ scripts/Makefile.in 2017-01-11 20:52:42.153725000 -0500
@@ -256,7 +256,7 @@
top_srcdir = @top_srcdir@
defaultscripts = poweron-vm-default poweroff-vm-default \
suspend-vm-default resume-vm-default
-confdir = /etc/vmware-tools
+confdir = ${prefix}/share/vmware-tools
conf_SCRIPTS = ./common/vm-support ./common/statechange.subr \
$(defaultscripts)
$(am__append_1) $(defaultscripts)
vmwsrcdir = $(confdir)/scripts/vmware

View File

@ -2,9 +2,11 @@
+++ scripts/linux/pam.d/vmtoolsd
@@ -1,7 +1,3 @@
#%PAM-1.0
-auth sufficient pam_unix2.so nullok
auth sufficient pam_unix.so shadow nullok
-auth required pam_unix_auth.so shadow nullok
-account sufficient pam_unix2.so
account sufficient pam_unix.so
-auth required pam_shells.so
-auth sufficient pam_unix.so shadow
-auth required pam_unix_auth.so shadow
-account required pam_shells.so
-account sufficient pam_unix.so
-account required pam_unix_acct.so
+auth include system
+account include system

View File

@ -1,11 +0,0 @@
--- toolbox/toolboxcmd-shrink.c.orig 2013-09-23 17:51:10.000000000 +0200
+++ toolbox/toolboxcmd-shrink.c 2014-11-25 17:57:44.000000000 +0100
@@ -391,7 +391,7 @@ ShrinkDoWipeAndShrink(char *mountPoint,
* Verify that wiping/shrinking are permitted before going through with the
* wiping operation.
*/
- if (!ShrinkGetWiperState() == WIPER_ENABLED && !Wiper_IsWipeSupported(part)) {
+ if (ShrinkGetWiperState() != WIPER_ENABLED && !Wiper_IsWipeSupported(part)) {
g_debug("%s cannot be wiped / shrunk\n", mountPoint);
ToolsCmd_PrintErr("%s",
SU_(disk.shrink.disabled, SHRINK_DISABLED_ERR));

View File

@ -1,6 +1,6 @@
--- lib/misc/util_misc.c.orig 2009-04-14 02:38:09.000000000 +0200
+++ lib/misc/util_misc.c 2009-04-14 02:39:00.000000000 +0200
@@ -292,7 +292,7 @@
--- lib/misc/util_misc.c.orig 2017-01-12 00:14:04.989252000 -0500
+++ lib/misc/util_misc.c 2017-01-12 00:14:12.099031000 -0500
@@ -307,7 +307,7 @@ Util_CanonicalPathsIdentical(const char
return (strcmp(path1, path2) == 0);
#elif defined(_WIN32)
return (_stricmp(path1, path2) == 0);
@ -9,12 +9,3 @@
return (strcasecmp(path1, path2) == 0);
#else
NOT_IMPLEMENTED();
@@ -319,7 +319,7 @@
Bool
Util_IsAbsolutePath(const char *path) // IN: path to check
{
-#if defined(__linux__) || defined(__APPLE__)
+#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__)
// path[0] is valid even for the empty string.
return path && path[0] == DIRSEPC;
#elif defined(_WIN32)

View File

@ -1,11 +0,0 @@
--- lib/include/vm_basic_asm.h.orig 2013-11-13 03:22:29.000000000 +0000
+++ lib/include/vm_basic_asm.h 2013-11-13 03:24:26.000000000 +0000
@@ -208,7 +208,7 @@
GetCallerEFlags(void)
{
unsigned long flags;
- asm volatile("pushf; pop %0" : "=r"(flags));
+ __asm__ volatile("pushf; pop %0" : "=r"(flags));
return flags;
}

View File

@ -1,10 +0,0 @@
--- ./lib/include/vm_basic_types.h.orig 2010-10-20 05:19:54.000000000 +0900
+++ ./lib/include/vm_basic_types.h 2010-10-29 20:11:03.000000000 +0900
@@ -333,6 +333,7 @@
#define FMTPD ""
#endif
#elif defined(__linux__) \
+ || (defined(__clang__)) \
|| (defined(_POSIX_C_SOURCE) && _POSIX_C_SOURCE >= 200112L) \
|| (defined(_POSIX_VERSION) && _POSIX_VERSION >= 200112L) \
|| (defined(_POSIX2_VERSION) && _POSIX2_VERSION >= 200112L)

View File

@ -1,11 +0,0 @@
--- modules/freebsd/vmblock/vfsops.c.orig
+++ modules/freebsd/vmblock/vfsops.c
@@ -236,7 +236,7 @@
*/
MNT_ILOCK(mp);
mp->mnt_flag |= lowerrootvp->v_mount->mnt_flag & MNT_LOCAL;
-#if __FreeBSD_version >= 600000
+#if __FreeBSD_version >= 600000 && __FreeBSD_version < 1000021
mp->mnt_kern_flag |= lowerrootvp->v_mount->mnt_kern_flag & MNTK_MPSAFE;
#endif
MNT_IUNLOCK(mp);

View File

@ -1,24 +0,0 @@
--- modules/freebsd/vmblock/vnops.c.orig 2011-09-21 14:25:15.000000000 -0400
+++ modules/freebsd/vmblock/vnops.c 2012-06-28 20:51:22.897344202 -0400
@@ -1362,7 +1362,9 @@
*/
{
struct vnode *vp = ap->a_vp;
+#if __FreeBSD_version < 1000000
struct thread *td = ap->a_td;
+#endif
vp->v_object = NULL;
@@ -1370,7 +1372,11 @@
* If this is the last reference, then free up the vnode so as not to
* tie up the lower vnode.
*/
+#if __FreeBSD_version < 1000000
vrecycle(vp, td);
+#else
+ vrecycle(vp);
+#endif
return 0;
}

View File

@ -1,6 +1,6 @@
--- vmblockmounter/Makefile.in.orig 2013-12-27 17:42:57.000000000 +0000
+++ vmblockmounter/Makefile.in 2013-12-27 17:44:31.000000000 +0000
@@ -644,9 +644,6 @@
--- vmblockmounter/Makefile.in.orig 2017-01-11 20:47:51.559298000 -0500
+++ vmblockmounter/Makefile.in 2017-01-11 20:48:04.188633000 -0500
@@ -578,9 +578,6 @@
@FREEBSD_TRUE@install-exec-hook:
@FREEBSD_TRUE@ mv $(DESTDIR)$(sbindir)/mount.vmblock \
@FREEBSD_TRUE@ $(DESTDIR)$(sbindir)/mount_vmblock

View File

@ -1,21 +0,0 @@
--- modules/freebsd/vmhgfs/Makefile.orig 2013-04-17 22:12:22.000000000 +0000
+++ modules/freebsd/vmhgfs/Makefile 2013-11-16 03:21:39.890032940 +0000
@@ -47,7 +47,7 @@
.endif
COMMON_HGFS_SRCS := debug.c
-COMMON_HGFS_SRCS := bdhandler.c
+COMMON_HGFS_SRCS += bdhandler.c
COMMON_HGFS_SRCS += request.c
COMMON_HGFS_SRCS += worker.c
COMMON_HGFS_SRCS += fsutil.c
@@ -108,7 +108,9 @@
CWARNFLAGS += -Wpointer-arith
CWARNFLAGS += -Winline
CWARNFLAGS += -Wcast-qual
+CWARNFLAGS += ${NO_WUNNEEDED_INTERNAL_DECL}
EXPORT_SYMS = NO
+.include <bsd.own.mk>
.include <bsd.kmod.mk>

View File

@ -1,11 +0,0 @@
--- modules/freebsd/vmhgfs/kernelStubs.h.orig 2010-10-20 05:19:54.000000000 +0900
+++ modules/freebsd/vmhgfs/kernelStubs.h 2010-11-16 13:26:24.000000000 +0900
@@ -132,7 +132,7 @@
* Stub functions we provide.
*/
-void Panic(const char *fmt, ...);
+/* void Panic(const char *fmt, ...); -> vm_assert.h */
char *Str_Strcpy(char *buf, const char *src, size_t maxSize);
int Str_Vsnprintf(char *str, size_t size, const char *format,

View File

@ -1,11 +0,0 @@
--- modules/freebsd/vmhgfs/os.c.orig
+++ modules/freebsd/vmhgfs/os.c
@@ -647,7 +647,7 @@
OS_THREAD_T *newThread) // OUT
{
return compat_kthread_create(function, parameter,
- newThread, 0, 0, threadName);
+ newThread, 0, 0, "%s", threadName);
}

View File

@ -1,12 +0,0 @@
--- modules/freebsd/vmhgfs/vfsops.c.orig
+++ modules/freebsd/vmhgfs/vfsops.c
@@ -201,7 +201,9 @@
* structures, not oplocks/leases with the VM's host.)
*/
+#if __FreeBSD_version < 1000021
MNT_ILOCK(mp);
mp->mnt_kern_flag |= MNTK_MPSAFE;
MNT_IUNLOCK(mp);
+#endif
/* Get a new unique filesystem ID */

View File

@ -1,11 +0,0 @@
--- modules/freebsd/vmhgfs/vnopscommon.c.orig 2010-10-20 05:19:54.000000000 +0900
+++ modules/freebsd/vmhgfs/vnopscommon.c 2010-11-16 13:26:55.000000000 +0900
@@ -50,7 +50,7 @@
static int HgfsDoGetattrInt(const char *path, const HgfsHandle handle, HgfsSuperInfo *sip,
HgfsAttrV2 *hgfsAttrV2);
static int HgfsDoGetattrByName(const char *path, HgfsSuperInfo *sip, HgfsAttrV2 *hgfsAttrV2);
-int HgfsReadlinkInt(struct vnode *vp, struct uio *uiop);
+/* int HgfsReadlinkInt(struct vnode *vp, struct uio *uiop); -> vnopscommon.h */
static int HgfsQueryAttrInt(const char *path, HgfsHandle handle, HgfsSuperInfo *sip,
HgfsKReqHandle req);
static int HgfsRefreshHandle(struct vnode *vp, HgfsSuperInfo *sip, HgfsHandle *handle);

View File

@ -1,5 +1,5 @@
--- modules/freebsd/vmmemctl/os.c.orig 2013-09-23 08:51:10.000000000 -0700
+++ modules/freebsd/vmmemctl/os.c 2017-02-20 21:19:02.000000000 -0800
--- modules/freebsd/vmmemctl/os.c.orig 2016-09-29 06:07:23.000000000 -0400
+++ modules/freebsd/vmmemctl/os.c 2017-02-22 12:15:23.708060000 -0500
@@ -37,9 +37,11 @@
#include <sys/param.h>
#include <sys/systm.h>
@ -12,7 +12,7 @@
#include <sys/sysctl.h>
#include <vm/vm.h>
@@ -223,7 +225,11 @@
@@ -223,7 +225,11 @@ static __inline__ unsigned long os_ffz(u
unsigned long
OS_ReservedPageGetLimit(void)
{
@ -24,33 +24,7 @@
}
@@ -295,7 +301,13 @@
Mapping
OS_MapPageHandle(PageHandle handle) // IN
{
+
+#if __FreeBSD_version >= 1000042
+ vm_offset_t res = kva_alloc(PAGE_SIZE);
+#else
vm_offset_t res = kmem_alloc_nofault(kernel_map, PAGE_SIZE);
+#endif
+
vm_page_t page = (vm_page_t)handle;
if (!res) {
@@ -352,7 +364,11 @@
OS_UnmapPage(Mapping mapping) // IN
{
pmap_qremove((vm_offset_t)mapping, 1);
+#if __FreeBSD_version >= 1000042
+ kva_free((vm_offset_t)mapping, PAGE_SIZE);
+#else
kmem_free(kernel_map, (vm_offset_t)mapping, PAGE_SIZE);
+#endif
}
@@ -360,7 +376,11 @@
@@ -369,7 +375,11 @@ static void
os_pmap_alloc(os_pmap *p) // IN
{
/* number of pages (div. 8) */
@ -61,32 +35,8 @@
+#endif
/*
* expand to nearest word boundary
@@ -369,14 +389,23 @@
p->size = (p->size + sizeof(unsigned long) - 1) &
~(sizeof(unsigned long) - 1);
+#if __FreeBSD_version >= 1000042
+ p->bitmap = (unsigned long *)kmem_malloc(kernel_arena, p->size,
+ M_WAITOK | M_ZERO);
+#else
p->bitmap = (unsigned long *)kmem_alloc(kernel_map, p->size);
+#endif
}
static void
os_pmap_free(os_pmap *p) // IN
{
+#if __FreeBSD_version >= 1000042
+ kva_free((vm_offset_t)p->bitmap, p->size);
+#else
kmem_free(kernel_map, (vm_offset_t)p->bitmap, p->size);
+#endif
p->size = 0;
p->bitmap = NULL;
}
@@ -449,12 +478,31 @@
* expand to nearest word boundary
@@ -466,12 +476,31 @@ os_kmem_free(vm_page_t page) // IN
os_state *state = &global_state;
os_pmap *pmap = &state->pmap;
@ -123,7 +73,7 @@
}
@@ -466,8 +514,19 @@
@@ -483,8 +512,19 @@ os_kmem_alloc(int alloc_normal_failed) /
os_state *state = &global_state;
os_pmap *pmap = &state->pmap;
@ -143,7 +93,7 @@
return NULL;
}
@@ -488,6 +547,11 @@
@@ -505,6 +545,11 @@ os_kmem_alloc(int alloc_normal_failed) /
if (!page) {
os_pmap_putindex(pmap, pindex);
}
@ -155,7 +105,7 @@
return page;
}
@@ -824,7 +888,7 @@
@@ -847,7 +892,7 @@ vmmemctl_sysctl(SYSCTL_HANDLER_ARGS)
static void
vmmemctl_init_sysctl(void)
{

View File

@ -1,7 +1,7 @@
--- services/vmtoolsd/Makefile.in.orig 2009-04-06 18:40:27.000000000 -0400
+++ services/vmtoolsd/Makefile.in 2009-04-06 18:41:16.000000000 -0400
@@ -722,7 +722,7 @@
$@ || (rm -f $@ && exit 1)
--- services/vmtoolsd/Makefile.in.orig 2017-01-11 21:00:01.938705000 -0500
+++ services/vmtoolsd/Makefile.in 2017-01-11 21:00:22.495767000 -0500
@@ -761,7 +761,7 @@
@INSTVMSG@ vmtoolsd $(srcdir)/l10n $(DESTDIR)$(datadir)
install-exec-hook:
- $(INSTALL) -d $(DESTDIR)/etc/vmware-tools

View File

@ -1,11 +0,0 @@
*******************************************************************
To run the Open Virtual Machine tools at startup, add the following
settings to your /etc/rc.conf
vmware_guest_vmblock_enable="YES"
vmware_guest_vmhgfs_enable="YES"
vmware_guest_vmmemctl_enable="YES"
vmware_guest_vmxnet_enable="YES"
vmware_guestd_enable="YES"
*******************************************************************

View File

@ -84,18 +84,3 @@ stop_cmd=":"
load_rc_config $name
[ -z "$vmware_guest_vmblock_enable" ] && vmware_guest_vmblock_enable="NO"
run_rc_command "$1"
# VMware kernel module: vmhgfs
kernel_mod="vmhgfs"
name="vmware_guest_${kernel_mod}"
rcvar=vmware_guest_${kernel_mod}_enable
extra_commands="status"
status_cmd="vmware_mod_status ${kernel_mod}"
start_precmd="${checkvm_cmd}"
start_cmd="vmware_mod_load ${kernel_mod}"
stop_precmd="${checkvm_cmd}"
stop_cmd=":"
load_rc_config $name
[ -z "$vmware_guest_vmhgfs_enable" ] && vmware_guest_vmhgfs_enable="NO"
run_rc_command "$1"

View File

@ -1,9 +1,11 @@
bin/vmhgfs-fuse
bin/vmtoolsd
bin/vmware-checkvm
bin/vmware-hgfsclient
bin/vmware-namespace-cmd
bin/vmware-rpctool
bin/vmware-xferlogs
bin/vmtoolsd
bin/vmware-toolbox-cmd
bin/vmware-xferlogs
%%X11%%%%FUSE%%bin/vmware-vmblock-fuse
lib/open-vm-tools/plugins/vmsvc/libguestInfo.so
lib/open-vm-tools/plugins/vmsvc/libpowerOps.so
@ -29,7 +31,6 @@ lib/libguestlib.so.0
lib/libguestlib.so.0.0.0
libdata/pkgconfig/vmguestlib.pc
lib/vmware-tools/modules/drivers/vmblock.ko
lib/vmware-tools/modules/drivers/vmhgfs.ko
lib/vmware-tools/modules/drivers/vmmemctl.ko
lib/vmware-tools/modules/drivers/vmxnet.ko
include/vmGuestLib/includeCheck.h
@ -37,16 +38,15 @@ include/vmGuestLib/vmGuestLib.h
include/vmGuestLib/vmSessionId.h
include/vmGuestLib/vm_basic_types.h
@dir lib/vmware-tools/modules/input
sbin/mount_vmhgfs
sbin/mount_vmblock
%%X11%%bin/vmware-user-suid-wrapper
share/vmware-tools/poweroff-vm-default
share/vmware-tools/poweron-vm-default
share/vmware-tools/resume-vm-default
share/vmware-tools/scripts/vmware/network
share/vmware-tools/statechange.subr
share/vmware-tools/suspend-vm-default
share/vmware-tools/vm-support
share/vmware-tools/statechange.subr
share/vmware-tools/scripts/vmware/network
%%DATADIR%%/messages/de/toolboxcmd.vmsg
%%DATADIR%%/messages/de/vmtoolsd.vmsg
%%DATADIR%%/messages/ja/toolboxcmd.vmsg
@ -57,5 +57,10 @@ share/vmware-tools/scripts/vmware/network
@rmtry share/vmware-tools/tools.conf
@rmtry etc/vmware-tools/plugins
etc/pam.d/vmtoolsd
etc/rc.conf.d/vmware_guest_vmblock
etc/rc.conf.d/vmware_guest_vmmemctl
etc/rc.conf.d/vmware_guest_vmxnet
etc/rc.conf.d/vmware_guestd
@dir %%DATADIR%%/scripts/vmware
@dir %%DATADIR%%/tests
@preunexec %%PREFIX%%/bin/vmware-rpctool 'tools.set.version 0' ; service vmware-guestd stop ; true