- Allow staging as a regular user
- Shebangfix
This commit is contained in:
parent
9083803efa
commit
988b15524a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=365583
@ -3,12 +3,16 @@
|
||||
|
||||
PORTNAME= abck
|
||||
PORTVERSION= 2.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.tundraware.com/Software/abck/
|
||||
|
||||
MAINTAINER= tundra@tundraware.com
|
||||
COMMENT= Manage intrusion attempts recorded in the system log
|
||||
|
||||
USE_PYTHON= yes
|
||||
USES= python shebangfix
|
||||
SHEBANG_FILES= abck
|
||||
python_OLD_CMD= /usr/local/bin/python
|
||||
python_CMD= ${PYTHON_CMD}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.orig 2014-06-26 22:31:16.566637227 +0800
|
||||
+++ Makefile 2014-06-26 22:31:40.165642393 +0800
|
||||
--- Makefile.orig 2002-09-04 21:55:45 UTC
|
||||
+++ Makefile
|
||||
@@ -4,7 +4,7 @@
|
||||
all: # Do nothing - this is a python script that needs no build
|
||||
|
||||
@ -8,7 +8,7 @@
|
||||
- mkdir ${PREFIX}/share/doc/abck
|
||||
- install -c -o root -g wheel -m 644 ./abck.1.gz ${PREFIX}/man/man1
|
||||
- install -c -o root -g wheel -m 644 ./abck-License.txt ${PREFIX}/share/doc/abck
|
||||
+ install -c -o root -g wheel -m 700 ./abck $(DESTDIR)${PREFIX}/bin
|
||||
+ mkdir $(DESTDIR)${PREFIX}/share/doc/abck
|
||||
+ install -c -o root -g wheel -m 644 ./abck.1.gz $(DESTDIR)${PREFIX}/man/man1
|
||||
+ install -c -o root -g wheel -m 644 ./abck-License.txt $(DESTDIR)${PREFIX}/share/doc/abck
|
||||
+ ${BSD_INSTALL_SCRIPT} ./abck ${DESTDIR}${PREFIX}/bin
|
||||
+ mkdir ${DESTDIR}${PREFIX}/share/doc/abck
|
||||
+ ${BSD_INSTALL_MAN} ./abck.1.gz ${DESTDIR}${PREFIX}/man/man1
|
||||
+ ${BSD_INSTALL_DATA} ./abck-License.txt ${DESTDIR}${PREFIX}/share/doc/abck
|
||||
|
Loading…
Reference in New Issue
Block a user