Update tcl81 to beta 1

This commit is contained in:
Eric J.Chet 1999-01-17 14:07:13 +00:00
parent 2c50a7e851
commit 985464b23d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16100
15 changed files with 174 additions and 162 deletions

View File

@ -3,11 +3,11 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.12 1998/12/01 03:06:29 asami Exp $
# $Id: Makefile,v 1.13 1998/12/13 08:49:06 asami Exp $
#
DISTNAME= tcl8.1a2
PKGNAME= tcl-8.1.a2
DISTNAME= tcl8.1b1
PKGNAME= tcl-8.1.b1
CATEGORIES= lang tcl81
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_1/
@ -23,6 +23,7 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
PKGINSTALL= ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
MAN1= tclsh.1
MAN3= AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 Async.3 \
BackgdErr.3 Backslash.3 BoolObj.3 ByteArrObj.3 CallDel.3 CmdCmplt.3 \
Concat.3 CrtChannel.3 CrtChnlHdlr.3 CrtCloseHdlr.3 CrtCommand.3 \
@ -31,23 +32,25 @@ MAN3= AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 Async.3 \
DoWhenIdle.3 DoubleObj.3 Encoding.3 Eval.3 Exit.3 ExprLong.3 \
ExprLongObj.3 FindExec.3 GetIndex.3 GetInt.3 GetOpnFl.3 GetStdChan.3 \
Hash.3 IntObj.3 Interp.3 LinkVar.3 ListObj.3 Notifier.3 Object.3 \
ObjectType.3 OpenFileChnl.3 OpenTcp.3 ParseCmd.3 PkgRequire.3 \
ObjectType.3 OpenFileChnl.3 OpenTcp.3 ParseCmd.3 PkgRequire.3 \
Preserve.3 PrintDbl.3 RecEvalObj.3 RecordEval.3 RegExp.3 SaveResult.3 \
SetErrno.3 SetRecLmt.3 SetResult.3 SetVar.3 Sleep.3 SplitList.3 \
SplitPath.3 StaticPkg.3 StrMatch.3 StringObj.3 Tcl_Main.3 Thread.3 \
ToUpper.3 TraceVar.3 Translate.3 UpVar.3 Utf.3 WrongNumArgs.3
ToUpper.3 TraceVar.3 Translate.3 UpVar.3 Utf.3 WrongNumArgs.3
MANN= Tcl.n after.n append.n array.n bgerror.n binary.n break.n case.n \
catch.n cd.n clock.n close.n concat.n continue.n eof.n error.n eval.n \
exec.n exit.n expr.n fblocked.n fconfigure.n fcopy.n file.n \
fileevent.n filename.n flush.n for.n foreach.n format.n gets.n glob.n \
global.n history.n http.n if.n incr.n info.n interp.n join.n \
catch.n cd.n clock.n close.n concat.n continue.n encoding.n eof.n \
error.n eval.n exec.n exit.n expr.n fblocked.n fconfigure.n fcopy.n \
file.n fileevent.n filename.n flush.n for.n foreach.n format.n gets.n \
glob.n global.n history.n http.n if.n incr.n info.n interp.n join.n \
lappend.n library.n lindex.n linsert.n list.n llength.n load.n \
lrange.n lreplace.n lsearch.n lsort.n namespace.n open.n package.n \
pid.n pkgMkIndex.n proc.n puts.n pwd.n read.n regexp.n registry.n \
regsub.n rename.n resource.n return.n safe.n scan.n seek.n set.n \
socket.n source.n split.n string.n subst.n switch.n tclvars.n tell.n \
time.n trace.n unknown.n unset.n update.n uplevel.n upvar.n \
variable.n vwait.n while.n
lrange.n lreplace.n lsearch.n lsort.n msgcat.n namespace.n open.n \
package.n pid.n pkgMkIndex.n proc.n puts.n pwd.n read.n regexp.n \
registry.n regsub.n rename.n resource.n return.n safe.n scan.n seek.n \
set.n socket.n source.n split.n string.n subst.n switch.n tclvars.n \
tell.n time.n trace.n unknown.n unset.n update.n uplevel.n upvar.n \
variable.n vwait.n while.n
MANCOMPRESSED= yes
.include <bsd.port.pre.mk>

View File

@ -1 +1 @@
MD5 (tcl8.1a2.tar.gz) = 4360381e0c64ed55be8dd8e85fa2cbe1
MD5 (tcl8.1b1.tar.gz) = 608c36993dfa52f06499f5c2004c7633

View File

@ -1,5 +1,5 @@
--- Makefile.in.orig Mon Feb 23 20:02:50 1998
+++ Makefile.in Sat Oct 3 15:49:29 1998
--- Makefile.in.orig Fri Dec 11 18:36:13 1998
+++ Makefile.in Sat Jan 2 14:47:02 1999
@@ -55,7 +55,9 @@
BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
@ -11,16 +11,16 @@
# Top-level directory in which to install manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -73,7 +75,7 @@
@@ -86,7 +88,7 @@
#CFLAGS = $(CFLAGS_DEBUG)
#CFLAGS = $(CFLAGS_OPTIMIZE)
#CFLAGS = $(CFLAGS_DEBUG) $(CFLAGS_OPTIMIZE)
-CFLAGS = @CFLAGS@
+CFLAGS? = @CFLAGS@
# To change the compiler switches, for example to change from -O
# to -g, change the following line:
-CFLAGS = -O
+CFLAGS?= -O
# To disable ANSI-C procedure prototypes reverse the comment characters
# on the following lines:
@@ -138,7 +140,7 @@
@@ -152,7 +154,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -29,7 +29,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -334,15 +336,21 @@
@@ -357,15 +359,21 @@
SRCS = $(GENERIC_SRCS) $(UNIX_SRCS)
@ -52,7 +52,7 @@
# Make target which outputs the list of the .o contained in the Tcl lib
# usefull to build a single big shared library containing Tcl and other
# extensions. used for the Tcl Plugin. -- dl
@@ -434,7 +442,7 @@
@@ -459,7 +467,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -61,7 +61,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -446,20 +454,26 @@
@@ -471,16 +479,22 @@
done;
@echo "Installing $(TCL_LIB_FILE)"
@$(INSTALL_DATA) $(TCL_LIB_FILE) $(LIB_INSTALL_DIR)/$(TCL_LIB_FILE)
@ -87,12 +87,7 @@
do \
if [ ! -d $$i ] ; then \
echo "Making directory $$i"; \
- mkdir $$i; \
+ mkdir -p $$i; \
chmod 755 $$i; \
else true; \
fi; \
@@ -473,8 +487,15 @@
@@ -498,8 +512,15 @@
else true; \
fi; \
done;
@ -110,7 +105,7 @@
@for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex $(UNIX_DIR)/tclAppInit.c $(UNIX_DIR)/ldAix; \
do \
echo "Installing $$i"; \
@@ -506,30 +527,37 @@
@@ -531,30 +552,37 @@
@cd $(TOP_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,6 +1,6 @@
--- configure.orig Mon Feb 23 20:02:51 1998
+++ configure Sat Oct 3 15:46:42 1998
@@ -4528,14 +4528,19 @@
--- configure.orig Fri Dec 11 18:36:14 1998
+++ configure Sat Jan 2 15:04:24 1999
@@ -4330,14 +4330,19 @@
echo "$ac_t""yes" 1>&6
SHLIB_CFLAGS="-fpic"
@ -11,13 +11,14 @@
DL_LIBS=""
LD_FLAGS=""
LD_SEARCH_FLAGS=""
+ if eval "test \"`echo ${PORTOBJFORMAT}`\" = elf"; then
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1'
+ SHLIB_LD="ld -shared -x -soname \$@"
+ else
TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ SHLIB_LD="ld -Bshareable -x"
+ fi
- TCL_SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.so.1.0'
+ if eval "test \"`echo ${PORTOBJFORMAT}`\" = elf"; then
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1'
+ SHLIB_LD="ld -shared -x -soname \$@"
+ else
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ SHLIB_LD="ld -Bshareable -x"
+ fi
else
echo "$ac_t""no" 1>&6

View File

@ -1,6 +1,8 @@
bin/tclsh8.1
include/tcl8.1/generic/chr.h
include/tcl8.1/generic/guts.h
include/tcl8.1/generic/regcustom.h
include/tcl8.1/generic/regerrs.h
include/tcl8.1/generic/regex.h
include/tcl8.1/generic/regguts.h
include/tcl8.1/generic/tcl.h
include/tcl8.1/generic/tclCompile.h
include/tcl8.1/generic/tclInitScript.h
@ -8,10 +10,8 @@ include/tcl8.1/generic/tclInt.h
include/tcl8.1/generic/tclMath.h
include/tcl8.1/generic/tclPort.h
include/tcl8.1/generic/tclRegexp.h
include/tcl8.1/tcl.h
include/tcl8.1/unix/tclUnixPort.h
lib/libtcl81.a
lib/libtcl81.so
lib/libtcl81.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@ -49,6 +49,7 @@ lib/tcl8.1/encoding/cp949.enc
lib/tcl8.1/encoding/cp950.enc
lib/tcl8.1/encoding/dingbats.enc
lib/tcl8.1/encoding/euc-jp.enc
lib/tcl8.1/encoding/euc-kr.enc
lib/tcl8.1/encoding/gb12345.enc
lib/tcl8.1/encoding/gb1988.enc
lib/tcl8.1/encoding/gb2312.enc
@ -67,6 +68,7 @@ lib/tcl8.1/encoding/iso8859-9.enc
lib/tcl8.1/encoding/jis0201.enc
lib/tcl8.1/encoding/jis0208.enc
lib/tcl8.1/encoding/jis0212.enc
lib/tcl8.1/encoding/ksc5601.enc
lib/tcl8.1/encoding/macCentEuro.enc
lib/tcl8.1/encoding/macCroatian.enc
lib/tcl8.1/encoding/macCyrillic.enc
@ -89,6 +91,8 @@ lib/tcl8.1/http2.0/pkgIndex.tcl
lib/tcl8.1/init.tcl
lib/tcl8.1/ldAix
lib/tcl8.1/ldAout.tcl
lib/tcl8.1/msgcat1.0/msgcat.tcl
lib/tcl8.1/msgcat1.0/pkgIndex.tcl
lib/tcl8.1/opt0.4/optparse.tcl
lib/tcl8.1/opt0.4/pkgIndex.tcl
lib/tcl8.1/package.tcl
@ -98,11 +102,12 @@ lib/tcl8.1/tclAppInit.c
lib/tcl8.1/tclConfig.sh
lib/tcl8.1/tclIndex
lib/tcl8.1/word.tcl
@dirrm include/tcl8.1/generic
@dirrm include/tcl8.1/unix
@dirrm include/tcl8.1
@dirrm lib/tcl8.1/encoding
@dirrm lib/tcl8.1/opt0.4
@dirrm lib/tcl8.1/msgcat1.0
@dirrm lib/tcl8.1/http2.0
@dirrm lib/tcl8.1/http1.0
@dirrm lib/tcl8.1/opt0.4
@dirrm lib/tcl8.1/encoding
@dirrm lib/tcl8.1
@dirrm include/tcl8.1/unix
@dirrm include/tcl8.1/generic
@dirrm include/tcl8.1

View File

@ -3,11 +3,11 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.12 1998/12/01 03:06:29 asami Exp $
# $Id: Makefile,v 1.13 1998/12/13 08:49:06 asami Exp $
#
DISTNAME= tcl8.1a2
PKGNAME= tcl-8.1.a2
DISTNAME= tcl8.1b1
PKGNAME= tcl-8.1.b1
CATEGORIES= lang tcl81
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_1/
@ -23,6 +23,7 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
PKGINSTALL= ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
MAN1= tclsh.1
MAN3= AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 Async.3 \
BackgdErr.3 Backslash.3 BoolObj.3 ByteArrObj.3 CallDel.3 CmdCmplt.3 \
Concat.3 CrtChannel.3 CrtChnlHdlr.3 CrtCloseHdlr.3 CrtCommand.3 \
@ -31,23 +32,25 @@ MAN3= AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 Async.3 \
DoWhenIdle.3 DoubleObj.3 Encoding.3 Eval.3 Exit.3 ExprLong.3 \
ExprLongObj.3 FindExec.3 GetIndex.3 GetInt.3 GetOpnFl.3 GetStdChan.3 \
Hash.3 IntObj.3 Interp.3 LinkVar.3 ListObj.3 Notifier.3 Object.3 \
ObjectType.3 OpenFileChnl.3 OpenTcp.3 ParseCmd.3 PkgRequire.3 \
ObjectType.3 OpenFileChnl.3 OpenTcp.3 ParseCmd.3 PkgRequire.3 \
Preserve.3 PrintDbl.3 RecEvalObj.3 RecordEval.3 RegExp.3 SaveResult.3 \
SetErrno.3 SetRecLmt.3 SetResult.3 SetVar.3 Sleep.3 SplitList.3 \
SplitPath.3 StaticPkg.3 StrMatch.3 StringObj.3 Tcl_Main.3 Thread.3 \
ToUpper.3 TraceVar.3 Translate.3 UpVar.3 Utf.3 WrongNumArgs.3
ToUpper.3 TraceVar.3 Translate.3 UpVar.3 Utf.3 WrongNumArgs.3
MANN= Tcl.n after.n append.n array.n bgerror.n binary.n break.n case.n \
catch.n cd.n clock.n close.n concat.n continue.n eof.n error.n eval.n \
exec.n exit.n expr.n fblocked.n fconfigure.n fcopy.n file.n \
fileevent.n filename.n flush.n for.n foreach.n format.n gets.n glob.n \
global.n history.n http.n if.n incr.n info.n interp.n join.n \
catch.n cd.n clock.n close.n concat.n continue.n encoding.n eof.n \
error.n eval.n exec.n exit.n expr.n fblocked.n fconfigure.n fcopy.n \
file.n fileevent.n filename.n flush.n for.n foreach.n format.n gets.n \
glob.n global.n history.n http.n if.n incr.n info.n interp.n join.n \
lappend.n library.n lindex.n linsert.n list.n llength.n load.n \
lrange.n lreplace.n lsearch.n lsort.n namespace.n open.n package.n \
pid.n pkgMkIndex.n proc.n puts.n pwd.n read.n regexp.n registry.n \
regsub.n rename.n resource.n return.n safe.n scan.n seek.n set.n \
socket.n source.n split.n string.n subst.n switch.n tclvars.n tell.n \
time.n trace.n unknown.n unset.n update.n uplevel.n upvar.n \
variable.n vwait.n while.n
lrange.n lreplace.n lsearch.n lsort.n msgcat.n namespace.n open.n \
package.n pid.n pkgMkIndex.n proc.n puts.n pwd.n read.n regexp.n \
registry.n regsub.n rename.n resource.n return.n safe.n scan.n seek.n \
set.n socket.n source.n split.n string.n subst.n switch.n tclvars.n \
tell.n time.n trace.n unknown.n unset.n update.n uplevel.n upvar.n \
variable.n vwait.n while.n
MANCOMPRESSED= yes
.include <bsd.port.pre.mk>

View File

@ -1 +1 @@
MD5 (tcl8.1a2.tar.gz) = 4360381e0c64ed55be8dd8e85fa2cbe1
MD5 (tcl8.1b1.tar.gz) = 608c36993dfa52f06499f5c2004c7633

View File

@ -1,5 +1,5 @@
--- Makefile.in.orig Mon Feb 23 20:02:50 1998
+++ Makefile.in Sat Oct 3 15:49:29 1998
--- Makefile.in.orig Fri Dec 11 18:36:13 1998
+++ Makefile.in Sat Jan 2 14:47:02 1999
@@ -55,7 +55,9 @@
BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
@ -11,16 +11,16 @@
# Top-level directory in which to install manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -73,7 +75,7 @@
@@ -86,7 +88,7 @@
#CFLAGS = $(CFLAGS_DEBUG)
#CFLAGS = $(CFLAGS_OPTIMIZE)
#CFLAGS = $(CFLAGS_DEBUG) $(CFLAGS_OPTIMIZE)
-CFLAGS = @CFLAGS@
+CFLAGS? = @CFLAGS@
# To change the compiler switches, for example to change from -O
# to -g, change the following line:
-CFLAGS = -O
+CFLAGS?= -O
# To disable ANSI-C procedure prototypes reverse the comment characters
# on the following lines:
@@ -138,7 +140,7 @@
@@ -152,7 +154,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -29,7 +29,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -334,15 +336,21 @@
@@ -357,15 +359,21 @@
SRCS = $(GENERIC_SRCS) $(UNIX_SRCS)
@ -52,7 +52,7 @@
# Make target which outputs the list of the .o contained in the Tcl lib
# usefull to build a single big shared library containing Tcl and other
# extensions. used for the Tcl Plugin. -- dl
@@ -434,7 +442,7 @@
@@ -459,7 +467,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -61,7 +61,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -446,20 +454,26 @@
@@ -471,16 +479,22 @@
done;
@echo "Installing $(TCL_LIB_FILE)"
@$(INSTALL_DATA) $(TCL_LIB_FILE) $(LIB_INSTALL_DIR)/$(TCL_LIB_FILE)
@ -87,12 +87,7 @@
do \
if [ ! -d $$i ] ; then \
echo "Making directory $$i"; \
- mkdir $$i; \
+ mkdir -p $$i; \
chmod 755 $$i; \
else true; \
fi; \
@@ -473,8 +487,15 @@
@@ -498,8 +512,15 @@
else true; \
fi; \
done;
@ -110,7 +105,7 @@
@for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex $(UNIX_DIR)/tclAppInit.c $(UNIX_DIR)/ldAix; \
do \
echo "Installing $$i"; \
@@ -506,30 +527,37 @@
@@ -531,30 +552,37 @@
@cd $(TOP_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,6 +1,6 @@
--- configure.orig Mon Feb 23 20:02:51 1998
+++ configure Sat Oct 3 15:46:42 1998
@@ -4528,14 +4528,19 @@
--- configure.orig Fri Dec 11 18:36:14 1998
+++ configure Sat Jan 2 15:04:24 1999
@@ -4330,14 +4330,19 @@
echo "$ac_t""yes" 1>&6
SHLIB_CFLAGS="-fpic"
@ -11,13 +11,14 @@
DL_LIBS=""
LD_FLAGS=""
LD_SEARCH_FLAGS=""
+ if eval "test \"`echo ${PORTOBJFORMAT}`\" = elf"; then
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1'
+ SHLIB_LD="ld -shared -x -soname \$@"
+ else
TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ SHLIB_LD="ld -Bshareable -x"
+ fi
- TCL_SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.so.1.0'
+ if eval "test \"`echo ${PORTOBJFORMAT}`\" = elf"; then
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1'
+ SHLIB_LD="ld -shared -x -soname \$@"
+ else
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ SHLIB_LD="ld -Bshareable -x"
+ fi
else
echo "$ac_t""no" 1>&6

View File

@ -1,6 +1,8 @@
bin/tclsh8.1
include/tcl8.1/generic/chr.h
include/tcl8.1/generic/guts.h
include/tcl8.1/generic/regcustom.h
include/tcl8.1/generic/regerrs.h
include/tcl8.1/generic/regex.h
include/tcl8.1/generic/regguts.h
include/tcl8.1/generic/tcl.h
include/tcl8.1/generic/tclCompile.h
include/tcl8.1/generic/tclInitScript.h
@ -8,10 +10,8 @@ include/tcl8.1/generic/tclInt.h
include/tcl8.1/generic/tclMath.h
include/tcl8.1/generic/tclPort.h
include/tcl8.1/generic/tclRegexp.h
include/tcl8.1/tcl.h
include/tcl8.1/unix/tclUnixPort.h
lib/libtcl81.a
lib/libtcl81.so
lib/libtcl81.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@ -49,6 +49,7 @@ lib/tcl8.1/encoding/cp949.enc
lib/tcl8.1/encoding/cp950.enc
lib/tcl8.1/encoding/dingbats.enc
lib/tcl8.1/encoding/euc-jp.enc
lib/tcl8.1/encoding/euc-kr.enc
lib/tcl8.1/encoding/gb12345.enc
lib/tcl8.1/encoding/gb1988.enc
lib/tcl8.1/encoding/gb2312.enc
@ -67,6 +68,7 @@ lib/tcl8.1/encoding/iso8859-9.enc
lib/tcl8.1/encoding/jis0201.enc
lib/tcl8.1/encoding/jis0208.enc
lib/tcl8.1/encoding/jis0212.enc
lib/tcl8.1/encoding/ksc5601.enc
lib/tcl8.1/encoding/macCentEuro.enc
lib/tcl8.1/encoding/macCroatian.enc
lib/tcl8.1/encoding/macCyrillic.enc
@ -89,6 +91,8 @@ lib/tcl8.1/http2.0/pkgIndex.tcl
lib/tcl8.1/init.tcl
lib/tcl8.1/ldAix
lib/tcl8.1/ldAout.tcl
lib/tcl8.1/msgcat1.0/msgcat.tcl
lib/tcl8.1/msgcat1.0/pkgIndex.tcl
lib/tcl8.1/opt0.4/optparse.tcl
lib/tcl8.1/opt0.4/pkgIndex.tcl
lib/tcl8.1/package.tcl
@ -98,11 +102,12 @@ lib/tcl8.1/tclAppInit.c
lib/tcl8.1/tclConfig.sh
lib/tcl8.1/tclIndex
lib/tcl8.1/word.tcl
@dirrm include/tcl8.1/generic
@dirrm include/tcl8.1/unix
@dirrm include/tcl8.1
@dirrm lib/tcl8.1/encoding
@dirrm lib/tcl8.1/opt0.4
@dirrm lib/tcl8.1/msgcat1.0
@dirrm lib/tcl8.1/http2.0
@dirrm lib/tcl8.1/http1.0
@dirrm lib/tcl8.1/opt0.4
@dirrm lib/tcl8.1/encoding
@dirrm lib/tcl8.1
@dirrm include/tcl8.1/unix
@dirrm include/tcl8.1/generic
@dirrm include/tcl8.1

View File

@ -3,11 +3,11 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.12 1998/12/01 03:06:29 asami Exp $
# $Id: Makefile,v 1.13 1998/12/13 08:49:06 asami Exp $
#
DISTNAME= tcl8.1a2
PKGNAME= tcl-8.1.a2
DISTNAME= tcl8.1b1
PKGNAME= tcl-8.1.b1
CATEGORIES= lang tcl81
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_1/
@ -23,6 +23,7 @@ CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
PKGINSTALL= ${PORTSDIR}/lang/tcl80/pkg/INSTALL.tclsh
MAN1= tclsh.1
MAN3= AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 Async.3 \
BackgdErr.3 Backslash.3 BoolObj.3 ByteArrObj.3 CallDel.3 CmdCmplt.3 \
Concat.3 CrtChannel.3 CrtChnlHdlr.3 CrtCloseHdlr.3 CrtCommand.3 \
@ -31,23 +32,25 @@ MAN3= AddErrInfo.3 Alloc.3 AllowExc.3 AppInit.3 AssocData.3 Async.3 \
DoWhenIdle.3 DoubleObj.3 Encoding.3 Eval.3 Exit.3 ExprLong.3 \
ExprLongObj.3 FindExec.3 GetIndex.3 GetInt.3 GetOpnFl.3 GetStdChan.3 \
Hash.3 IntObj.3 Interp.3 LinkVar.3 ListObj.3 Notifier.3 Object.3 \
ObjectType.3 OpenFileChnl.3 OpenTcp.3 ParseCmd.3 PkgRequire.3 \
ObjectType.3 OpenFileChnl.3 OpenTcp.3 ParseCmd.3 PkgRequire.3 \
Preserve.3 PrintDbl.3 RecEvalObj.3 RecordEval.3 RegExp.3 SaveResult.3 \
SetErrno.3 SetRecLmt.3 SetResult.3 SetVar.3 Sleep.3 SplitList.3 \
SplitPath.3 StaticPkg.3 StrMatch.3 StringObj.3 Tcl_Main.3 Thread.3 \
ToUpper.3 TraceVar.3 Translate.3 UpVar.3 Utf.3 WrongNumArgs.3
ToUpper.3 TraceVar.3 Translate.3 UpVar.3 Utf.3 WrongNumArgs.3
MANN= Tcl.n after.n append.n array.n bgerror.n binary.n break.n case.n \
catch.n cd.n clock.n close.n concat.n continue.n eof.n error.n eval.n \
exec.n exit.n expr.n fblocked.n fconfigure.n fcopy.n file.n \
fileevent.n filename.n flush.n for.n foreach.n format.n gets.n glob.n \
global.n history.n http.n if.n incr.n info.n interp.n join.n \
catch.n cd.n clock.n close.n concat.n continue.n encoding.n eof.n \
error.n eval.n exec.n exit.n expr.n fblocked.n fconfigure.n fcopy.n \
file.n fileevent.n filename.n flush.n for.n foreach.n format.n gets.n \
glob.n global.n history.n http.n if.n incr.n info.n interp.n join.n \
lappend.n library.n lindex.n linsert.n list.n llength.n load.n \
lrange.n lreplace.n lsearch.n lsort.n namespace.n open.n package.n \
pid.n pkgMkIndex.n proc.n puts.n pwd.n read.n regexp.n registry.n \
regsub.n rename.n resource.n return.n safe.n scan.n seek.n set.n \
socket.n source.n split.n string.n subst.n switch.n tclvars.n tell.n \
time.n trace.n unknown.n unset.n update.n uplevel.n upvar.n \
variable.n vwait.n while.n
lrange.n lreplace.n lsearch.n lsort.n msgcat.n namespace.n open.n \
package.n pid.n pkgMkIndex.n proc.n puts.n pwd.n read.n regexp.n \
registry.n regsub.n rename.n resource.n return.n safe.n scan.n seek.n \
set.n socket.n source.n split.n string.n subst.n switch.n tclvars.n \
tell.n time.n trace.n unknown.n unset.n update.n uplevel.n upvar.n \
variable.n vwait.n while.n
MANCOMPRESSED= yes
.include <bsd.port.pre.mk>

View File

@ -1 +1 @@
MD5 (tcl8.1a2.tar.gz) = 4360381e0c64ed55be8dd8e85fa2cbe1
MD5 (tcl8.1b1.tar.gz) = 608c36993dfa52f06499f5c2004c7633

View File

@ -1,5 +1,5 @@
--- Makefile.in.orig Mon Feb 23 20:02:50 1998
+++ Makefile.in Sat Oct 3 15:49:29 1998
--- Makefile.in.orig Fri Dec 11 18:36:13 1998
+++ Makefile.in Sat Jan 2 14:47:02 1999
@@ -55,7 +55,9 @@
BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
@ -11,16 +11,16 @@
# Top-level directory in which to install manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -73,7 +75,7 @@
@@ -86,7 +88,7 @@
#CFLAGS = $(CFLAGS_DEBUG)
#CFLAGS = $(CFLAGS_OPTIMIZE)
#CFLAGS = $(CFLAGS_DEBUG) $(CFLAGS_OPTIMIZE)
-CFLAGS = @CFLAGS@
+CFLAGS? = @CFLAGS@
# To change the compiler switches, for example to change from -O
# to -g, change the following line:
-CFLAGS = -O
+CFLAGS?= -O
# To disable ANSI-C procedure prototypes reverse the comment characters
# on the following lines:
@@ -138,7 +140,7 @@
@@ -152,7 +154,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -29,7 +29,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -334,15 +336,21 @@
@@ -357,15 +359,21 @@
SRCS = $(GENERIC_SRCS) $(UNIX_SRCS)
@ -52,7 +52,7 @@
# Make target which outputs the list of the .o contained in the Tcl lib
# usefull to build a single big shared library containing Tcl and other
# extensions. used for the Tcl Plugin. -- dl
@@ -434,7 +442,7 @@
@@ -459,7 +467,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -61,7 +61,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -446,20 +454,26 @@
@@ -471,16 +479,22 @@
done;
@echo "Installing $(TCL_LIB_FILE)"
@$(INSTALL_DATA) $(TCL_LIB_FILE) $(LIB_INSTALL_DIR)/$(TCL_LIB_FILE)
@ -87,12 +87,7 @@
do \
if [ ! -d $$i ] ; then \
echo "Making directory $$i"; \
- mkdir $$i; \
+ mkdir -p $$i; \
chmod 755 $$i; \
else true; \
fi; \
@@ -473,8 +487,15 @@
@@ -498,8 +512,15 @@
else true; \
fi; \
done;
@ -110,7 +105,7 @@
@for i in $(TOP_DIR)/library/*.tcl $(TOP_DIR)/library/tclIndex $(UNIX_DIR)/tclAppInit.c $(UNIX_DIR)/ldAix; \
do \
echo "Installing $$i"; \
@@ -506,30 +527,37 @@
@@ -531,30 +552,37 @@
@cd $(TOP_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,6 +1,6 @@
--- configure.orig Mon Feb 23 20:02:51 1998
+++ configure Sat Oct 3 15:46:42 1998
@@ -4528,14 +4528,19 @@
--- configure.orig Fri Dec 11 18:36:14 1998
+++ configure Sat Jan 2 15:04:24 1999
@@ -4330,14 +4330,19 @@
echo "$ac_t""yes" 1>&6
SHLIB_CFLAGS="-fpic"
@ -11,13 +11,14 @@
DL_LIBS=""
LD_FLAGS=""
LD_SEARCH_FLAGS=""
+ if eval "test \"`echo ${PORTOBJFORMAT}`\" = elf"; then
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1'
+ SHLIB_LD="ld -shared -x -soname \$@"
+ else
TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ SHLIB_LD="ld -Bshareable -x"
+ fi
- TCL_SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}\$\{DBGX\}.so.1.0'
+ if eval "test \"`echo ${PORTOBJFORMAT}`\" = elf"; then
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1'
+ SHLIB_LD="ld -shared -x -soname \$@"
+ else
+ TCL_SHARED_LIB_SUFFIX='`echo ${VERSION} | tr -d .`.so.1.0'
+ SHLIB_LD="ld -Bshareable -x"
+ fi
else
echo "$ac_t""no" 1>&6

View File

@ -1,6 +1,8 @@
bin/tclsh8.1
include/tcl8.1/generic/chr.h
include/tcl8.1/generic/guts.h
include/tcl8.1/generic/regcustom.h
include/tcl8.1/generic/regerrs.h
include/tcl8.1/generic/regex.h
include/tcl8.1/generic/regguts.h
include/tcl8.1/generic/tcl.h
include/tcl8.1/generic/tclCompile.h
include/tcl8.1/generic/tclInitScript.h
@ -8,10 +10,8 @@ include/tcl8.1/generic/tclInt.h
include/tcl8.1/generic/tclMath.h
include/tcl8.1/generic/tclPort.h
include/tcl8.1/generic/tclRegexp.h
include/tcl8.1/tcl.h
include/tcl8.1/unix/tclUnixPort.h
lib/libtcl81.a
lib/libtcl81.so
lib/libtcl81.so.1
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@ -49,6 +49,7 @@ lib/tcl8.1/encoding/cp949.enc
lib/tcl8.1/encoding/cp950.enc
lib/tcl8.1/encoding/dingbats.enc
lib/tcl8.1/encoding/euc-jp.enc
lib/tcl8.1/encoding/euc-kr.enc
lib/tcl8.1/encoding/gb12345.enc
lib/tcl8.1/encoding/gb1988.enc
lib/tcl8.1/encoding/gb2312.enc
@ -67,6 +68,7 @@ lib/tcl8.1/encoding/iso8859-9.enc
lib/tcl8.1/encoding/jis0201.enc
lib/tcl8.1/encoding/jis0208.enc
lib/tcl8.1/encoding/jis0212.enc
lib/tcl8.1/encoding/ksc5601.enc
lib/tcl8.1/encoding/macCentEuro.enc
lib/tcl8.1/encoding/macCroatian.enc
lib/tcl8.1/encoding/macCyrillic.enc
@ -89,6 +91,8 @@ lib/tcl8.1/http2.0/pkgIndex.tcl
lib/tcl8.1/init.tcl
lib/tcl8.1/ldAix
lib/tcl8.1/ldAout.tcl
lib/tcl8.1/msgcat1.0/msgcat.tcl
lib/tcl8.1/msgcat1.0/pkgIndex.tcl
lib/tcl8.1/opt0.4/optparse.tcl
lib/tcl8.1/opt0.4/pkgIndex.tcl
lib/tcl8.1/package.tcl
@ -98,11 +102,12 @@ lib/tcl8.1/tclAppInit.c
lib/tcl8.1/tclConfig.sh
lib/tcl8.1/tclIndex
lib/tcl8.1/word.tcl
@dirrm include/tcl8.1/generic
@dirrm include/tcl8.1/unix
@dirrm include/tcl8.1
@dirrm lib/tcl8.1/encoding
@dirrm lib/tcl8.1/opt0.4
@dirrm lib/tcl8.1/msgcat1.0
@dirrm lib/tcl8.1/http2.0
@dirrm lib/tcl8.1/http1.0
@dirrm lib/tcl8.1/opt0.4
@dirrm lib/tcl8.1/encoding
@dirrm lib/tcl8.1
@dirrm include/tcl8.1/unix
@dirrm include/tcl8.1/generic
@dirrm include/tcl8.1