Merge print/html2ps-{a4,letter} to print/html2ps.

This commit is contained in:
Hiroki Sato 2013-04-28 15:11:37 +00:00
parent d60158d113
commit 9846ed10cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=316729
11 changed files with 93 additions and 32 deletions

2
MOVED
View File

@ -4234,3 +4234,5 @@ graphics/jpeg2ps-letter|graphics/jpeg2ps|2013-04-27|Merged into graphics/jpeg2ps
graphics/jpeg2ps-a4|graphics/jpeg2ps|2013-04-27|Merged into graphics/jpeg2ps
print/a2ps-letter|print/a2ps|2013-04-27|Merged into print/a2ps
print/a2ps-a4|print/a2ps|2013-04-27|Merged into print/a2ps
print/html2ps-letter|print/html2ps|2013-04-28|Merged into print/html2ps
print/html2ps-a4|print/html2ps|2013-04-28|Merged into print/html2ps

View File

@ -7,7 +7,7 @@
PORTNAME= kmymoney2
PORTVERSION= 1.0.5
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= finance
MASTER_SITES= SF/${PORTNAME}/KMyMoney/${PORTVERSION}
@ -52,7 +52,7 @@ CONFIGURE_ARGS= --enable-ofxplugin --enable-ofxbanking --enable-pdf-docs
# Add more build-time dependencies to generate the PDF docs
BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
pdfjadetex:${PORTSDIR}/print/jadetex \
html2ps:${PORTSDIR}/print/html2ps-letter \
html2ps:${PORTSDIR}/print/html2ps \
dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular \
cppunit-config:${PORTSDIR}/devel/cppunit \
recode:${PORTSDIR}/converters/recode

View File

@ -106,8 +106,7 @@
SUBDIR += hplip
SUBDIR += hs-hscolour
SUBDIR += html2latex
SUBDIR += html2ps-a4
SUBDIR += html2ps-letter
SUBDIR += html2ps
SUBDIR += hyperlatex
SUBDIR += ifxetex
SUBDIR += it-acroread8

View File

@ -108,7 +108,7 @@ _DEPENDS_DVIPS= dvips:${PORTSDIR}/print/dvipsk-tetex
_DEPENDS_FIG2DEV= \
fig2dev:${PORTSDIR}/print/transfig
_DEPENDS_HTML2PS= \
html2ps:${PORTSDIR}/print/html2ps${PSUFX}
html2ps:${PORTSDIR}/print/html2ps
_DEPENDS_ATALK= pap:${PORTSDIR}/net/netatalk
_DEPENDS_SAMBA= smbclient:${PORTSDIR}/net/samba36
_DEPENDS_MP3= mpg321:${PORTSDIR}/audio/mpg321

View File

@ -1,11 +0,0 @@
# New ports collection makefile for: html2ps-a4
# Date created: Sat Nov 22 12:54:50 CET 1997
# Whom: andreas
#
# $FreeBSD$
#
PAPERSIZE= A4
MASTERDIR= ${.CURDIR}/../html2ps-letter
.include "${MASTERDIR}/Makefile"

View File

@ -1,19 +1,15 @@
# New ports collection makefile for: html2ps-letter
# Date created: Sat Nov 22 12:54:50 CET 1997
# Whom: andreas
#
# Created by: Andreas Klemm <andreas@FreeBSD.org>
# $FreeBSD$
#
PORTNAME= html2ps
DISTVERSION= 1.0b7
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= print www perl5
MASTER_SITES= http://user.it.uu.se/~jan/ \
http://fossies.org/unix/www/
PKGNAMESUFFIX= -${PAPERSIZE}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= hrs@FreeBSD.org
COMMENT= HTML to PostScript converter
LICENSE= GPLv2
@ -21,36 +17,37 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= mogrify:${PORTSDIR}/graphics/ImageMagick \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
weblint:${PORTSDIR}/www/weblint
weblint++:${PORTSDIR}/www/weblint++ \
paperconf:${PORTSDIR}/print/libpaper
NO_BUILD= yes
USE_PERL5= yes
USE_GHOSTSCRIPT_RUN= yes
SUB_FILES= html2psrc
SUB_LIST= PAPERSIZE="${PAPERSIZE}"
MAN1= html2ps.1
MAN5= html2psrc.5
PLIST_FILES= bin/html2ps \
etc/html2psrc \
%%DATADIR%%/html2ps.html \
%%DATADIR%%/html2psrc \
%%DATADIR%%/hyphen.tex
PLIST_DIRS= %%DATADIR%%
PAPERSIZE?= letter
post-patch:
@${REINPLACE_CMD} -e \
's|exec perl|exec ${PERL}| ; \
s|/it/sw/share/www/lib/html2ps|${DATADIR}|' ${WRKSRC}/html2ps
s|%%LOCALBASE%%|${LOCALBASE}| ; \
s|%%PREFIX%%|${PREFIX}| ; \
s|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/html2ps
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/html2ps ${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/html2psrc ${PREFIX}/etc
${INSTALL_MAN} ${WRKSRC}/html2ps.1 ${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/html2psrc.5 ${MAN5PREFIX}/man/man5
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKDIR}/html2psrc ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/html2ps.html ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/hyphen.tex ${DATADIR}

View File

@ -8,12 +8,12 @@
TeX: 1;
dvips: 1;
Ghostscript: 1;
check: weblint;
check: weblint++;
libwww-perl: 1;
path: "%%LOCALBASE%%/bin";
}
paper {
type: %%PAPERSIZE%%;
type: libpaper;
}
hyphenation {
en {

View File

@ -0,0 +1,63 @@
--- html2ps.orig 2010-05-07 20:22:12.000000000 +0900
+++ html2ps 2013-04-29 00:07:16.000000000 +0900
@@ -26,8 +26,9 @@
# Set the name of the global configuration file. See the installation notes
# and manual page for more details on configuration files.
-$globrc='/it/sw/share/www/lib/html2ps/html2psrc';
-$ug='/it/sw/share/www/lib/html2ps/html2ps.html';
+$LIBPAPER=1;
+$globrc='%%PREFIX%%/etc/html2psrc';
+$ug='%%DATADIR%%/html2ps.html';
$conf=<<'EOR';
@html2ps {
@@ -46,7 +47,7 @@
path: "";
}
paper {
- type: A4;
+ type: libpaper;
height: "";
width: "";
}
@@ -613,6 +614,23 @@
$height{"b$_"}=int($temp*2**(1/2)*1000+.5)/10;
}
if(!$pagew || !$pageh) {
+ if ($LIBPAPER) {
+ my $env_com;
+ if ("\L$paper{'type'}" ne 'libpaper') {
+ $env_com = "/usr/bin/env PAPERSIZE=\"$paper{'type'}\"";
+ }
+ my $_w = `$env_com /usr/local/bin/paperconf -wc`;
+ my $_h = `$env_com /usr/local/bin/paperconf -hc`;
+ my $_n = `$env_com /usr/local/bin/paperconf -n`;
+ if ($_w ne '' and $_h ne '') {
+ $paper{'width'} = $_w;
+ $paper{'height'} = $_h;
+ $paper{'type'} = $_n;
+ ($pagew,$pageh)=($paper{'width'},$paper{'height'});
+ } else {
+ &dbg("Unknown paper type: $paper{'type'}\n");
+ }
+ } else { # !LIBPAPER
if($width{"\L$paper{'type'}"}) {
$paper{'width'}=$width{"\L$paper{'type'}"} if(!defined $paper{'width'});
$paper{'height'}=$height{"\L$paper{'type'}"} if(!defined $paper{'height'});
@@ -620,6 +638,7 @@
} elsif($paper{'type'}) {
&dbg("Unknown paper type: $paper{'type'}\n");
}
+ } # LIBPAPER
}
if($opt_L) {
$wl=$pageh-$mll-$mrl;
@@ -3405,7 +3424,6 @@
local($optlist)=@_;
local(@args,$_,$opt,$opts,$rest,$olist,$plist,$found,@popts);
local($errs)=0;
- local($[)=0;
@args=split( /\|/, $optlist );
for $opt (@args) {
if(substr($opt,-1,1) ne ':') {$olist.=$opt}

View File

@ -0,0 +1,11 @@
--- html2ps.1.orig 2013-04-28 23:11:32.000000000 +0900
+++ html2ps.1 2013-04-28 23:11:39.000000000 +0900
@@ -357,7 +357,7 @@
$HOME/.html2psrc
User configuration file, see html2psrc(5).
.SH SEE ALSO
-html2psrc(5), perl(1), setlocale(3), strftime(3), weblint(1)
+html2psrc(5), perl(1), setlocale(3), strftime(3), weblint++(1)
.SH VERSION
This manpage describes html2ps version 1.0 beta7.
.SH AVAILABILITY