- Update to 2.0.19

PR:		162861
Submitted by:	Alex Deiter <alex.deiter@gmail.com> (maintaner)
Feature safe:	yes
This commit is contained in:
Martin Wilke 2011-11-27 09:34:37 +00:00
parent 549f83280c
commit 9826257cef
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286482
4 changed files with 19 additions and 16 deletions

View File

@ -6,10 +6,9 @@
#
PORTNAME= openipmi
PORTVERSION= 2.0.18
PORTREVISION= 5
PORTVERSION= 2.0.19
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library/${PORTVERSION}
MASTER_SITES= SF/${PORTNAME}/OpenIPMI%202.0%20Library
DISTNAME= OpenIPMI-${PORTVERSION}
MAINTAINER= alex.deiter@gmail.com
@ -39,6 +38,7 @@ OPTIONS= SSL "IPMI 2.0 RMCP+ encryption and authentication" On \
PYTHON "Python interface for OpenIPMI library" Off \
TCL "TCL interface for OpenIPMI library" Off \
TKINTER "GUI for OpenIPMI, written in Python" Off \
TRACE "Enable backtrace inspecting" Off \
GDBM "Local SDR caching on startup" Off \
GLIB12 "Simply OS handler for glib 1.2" Off \
GLIB20 "Simply OS handler for glib 2.0" Off
@ -116,6 +116,10 @@ CONFIGURE_ARGS+= --with-tcl=no
PLIST_SUB+= TCL="@comment "
.endif
.if defined(WITH_TRACE)
LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
.endif
.if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
.endif

View File

@ -1,2 +1,2 @@
SHA256 (OpenIPMI-2.0.18.tar.gz) = 6c1679a1c16aade48dd929e5124d2640ff12224ac0de1bb3777e9f1030d62e01
SIZE (OpenIPMI-2.0.18.tar.gz) = 2895686
SHA256 (OpenIPMI-2.0.19.tar.gz) = 5b0de4741f07e350bf53b7d31bb20dd1109c2dc005dfb13969d8a9ff290f3a4e
SIZE (OpenIPMI-2.0.19.tar.gz) = 2971041

View File

@ -0,0 +1,10 @@
--- configure.in.orig 2011-11-25 01:40:43.243119438 +0400
+++ configure.in 2011-11-25 01:42:18.859147897 +0400
@@ -274,6 +274,7 @@
AC_CHECK_FUNCS(getaddrinfo)
AC_CHECK_HEADERS(execinfo.h)
+AC_SEARCH_LIBS(backtrace_symbols, [execinfo])
AC_SUBST(OPENIPMI_VERSION_MAJOR)
AC_SUBST(OPENIPMI_VERSION_MINOR)

View File

@ -1,11 +0,0 @@
--- lib/sensor.c.orig 2010-05-28 18:51:20.949496519 +0400
+++ lib/sensor.c 2010-05-28 18:51:37.079705617 +0400
@@ -1438,7 +1438,7 @@
s[p]->id_type = IPMI_ASCII_STR;
}
- if (share_count) {
+ if (share_count > 1) {
/* Duplicate the sensor records for each instance. Go
backwards to avoid destroying the first one until we
finish the others. */