Add xcalendar 4.0,

a calendar with a notebook for X11
(internationarized version).

PR:		ports/25739
Submitted by:	MITA Yoshio <mita@iis.u-tokyo.ac.jp>
This commit is contained in:
Jun Kuriyama 2001-03-16 02:37:16 +00:00
parent 0818373b56
commit 98116ff0ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39907
15 changed files with 1323 additions and 0 deletions

View File

@ -27,6 +27,7 @@
SUBDIR += sliderule
SUBDIR += teapot
SUBDIR += wmpinboard
SUBDIR += xcalendar
SUBDIR += xinvest
SUBDIR += xmaddressbook
SUBDIR += xmdiary

View File

@ -0,0 +1,25 @@
# New ports collection makefile for: xcalendar-4.0
# Date created: 25 June 1996
# Whom: MITA Yoshio <mita@iis.u-tokyo.ac.jp>
#
# $FreeBSD$
#
PORTNAME= xcalendar
PORTVERSION= 4.0
CATEGORIES= deskutils
MASTER_SITES= ftp://daemon.jp.FreeBSD.org/pub/FreeBSD-jp/ports-jp/LOCAL_PORTS/
DISTNAME= ${PORTNAME}-${PORTVERSION}+i18n
MAINTAINER= mistral@imasy.or.jp
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_IMAKE= yes
USE_GMAKE= yes
MAKE_ENV= FILESDIR=${FILESDIR}
ALL_TARGET= all XCal-uj.ad xcalendar-uj.hlp xcalendar-uj.man
MAN1= xcalendar.1
MANLANG= "" ja
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (xcalendar-4.0+i18n.tar.gz) = 88a642ccb00d419068b43c1f6f1949c8

View File

@ -0,0 +1,41 @@
--- xcalendar.c.dist Tue Jul 4 06:59:01 1995
+++ xcalendar.c Mon Mar 12 20:53:10 2001
@@ -1091,10 +1091,10 @@
struct tm *
gettime()
{
- struct timeval t;
+ time_t now;
- gettimeofday(&t, NULL);
- today = localtime(&t.tv_sec);
+ (void) time(&now);
+ today = localtime(&now);
return today;
}
@@ -1827,8 +1827,8 @@
*sb++ = '1', *sb++ = '9';
/* fall thru */
case 'y':
- *sb++ = tm.tm_year / 10 + '0';
- *sb++ = tm.tm_year % 10 + '0';
+ *sb++ = (tm.tm_year%100) / 10 + '0';
+ *sb++ = (tm.tm_year%100) % 10 + '0';
break;
case '%':
*sb++ = *p;
@@ -1869,6 +1869,13 @@
if (len == -1)
return;
}
+
+ /* terminate `buf' with NULL */
+ if (sizeof(buf) == len) {
+ buf = XtRealloc(buf, len + 1);
+ }
+ buf[len] = NULL;
+
start = buf;
while (len > 0) {

View File

@ -0,0 +1,20 @@
--- dayeditor.c.orig Sun Oct 1 13:54:55 1995
+++ dayeditor.c Mon Mar 12 20:55:07 2001
@@ -236,7 +236,7 @@
{
char *getenv();
DIR *dirp;
-#if defined (SYSV) || defined(__osf__) || defined(SVR4)
+#if defined (SYSV) || defined(__osf__) || defined(SVR4) || defined(HAVE_DIRENT_H)
struct dirent *dp;
#else
struct direct *dp;
@@ -1068,7 +1068,7 @@
XawTextSetSource(editor->holiday,
#ifdef XI18N
(XtIsSubclass(old, multiSrcObjectClass) ?
- XtCreateWidget("holSource", asciiSrcObjectClass,
+ XtCreateWidget("holSource", multiSrcObjectClass,
editor->holiday, args, n) :
XtCreateWidget("holSource", asciiSrcObjectClass,
editor->holiday, args, n) ),

View File

@ -0,0 +1,154 @@
--- XCal-uj.sed.orig Sun Oct 1 14:31:06 1995
+++ XCal-uj.sed Sun Mar 11 12:52:22 2001
@@ -3,7 +3,9 @@
*showGrip: False
*calendar*internalBorderWidth: 0
*input: True
-*resize: False
+*controls*resize: False
+*bcontrols*resize: False
+*daybuttons*resize: False
*resizable: True
*title: XCalendar v.4.0
*dayEditor.title: Day Editor
@@ -21,8 +23,8 @@
*succ*Label: 来月
*prevday*Label: 昨日
*succday*Label: 明日
-*helpButton*label: 助け
-*quitButton*label: 終り
+*helpButton*Label: 助け
+*quitButton*Label: 終り
*daynames.SUN.label: \ 日
*daynames.MON.label: \ 月
@@ -32,20 +34,12 @@
*daynames.FRI.label: \ 金
*daynames.SAT.label: \ 土
-*prev*labelString: 先月
-*succ*labelString: 来月
-*prevday*labelString: 昨日
-*succday*labelString: 明日
-*helpButton*labelString: 助け
-*quitButton*labelString: 終り
-
-*daynames.SUN.labelString: \ 日
-*daynames.MON.labelString: \ 月
-*daynames.TUE.labelString: \ 火
-*daynames.WED.labelString: \ 水
-*daynames.THU.labelString: \ 木
-*daynames.FRI.labelString: \ 金
-*daynames.SAT.labelString: \ 土
+*monthnames: 1/2/3/4/5/6/7/8/9/10/11/12
+*monthnms: 1/2/3/4/5/6/7/8/9/10/11/12
+*daynames: 日曜日/月曜日/火曜日/水曜日/木曜日/金曜日/土曜日
+*daynms: 日/月/火/水/木/金/土
+*date: %M月%d日(%W)
+
#ifdef COLOR
! colors
@@ -70,11 +64,12 @@
*editorControls*Background: lightgray
*editorControls*Command.Background: slategray
*editorControls*Command.Foreground: White
+*editorControls*XmPushButton.Background: slategray
+*editorControls*XmPushButton.Foreground: White
#endif
*setMarkBackground: True
*markOnStartup: True
-!
*markCurrent: True
*currentForeground: Blue
*markHoliday: True
@@ -88,57 +83,38 @@
*prev*vertDistance: 0
*succ*vertDistance: 0
-*controls*date*fontSet: 8x13bold
+*controls*date*fontSet: 8x13bold, -*--14-*
*daynames*fontSet: -*--14-*
-*dayEditor*editorTitle*fontSet: 8x13bold
-*helpWindow*editorTitle*fontSet: 8x13bold
+*dayEditor*editorTitle*fontSet: 8x13bold, -*--14-*
+*helpWindow*editorTitle*fontSet: 8x13bold, -*--14-*
*helpButton*vertDistance: 5
*quitButton*vertDistance: 5
*editorTitle*vertDistance: 5
-*cdate*vertDistance: 0
+*cdate*vertDistance: 5
*editorControls*doneButton*label: 終り
*editorControls*saveButton*label: 保存
*editorControls*clearEntry*label: 消えてなくなれ
-*editorControls*doneButton*labelString: 終り
-*editorControls*saveButton*labelString: 保存
-*editorControls*clearEntry*labelString: 消えてなくなれ
+*doneButton*labelString: 終り
+*saveButton*labelString: 保存
+*clearEntry*labelString: 消えてなくなれ
*dayEditor*geometry: 300x150
*helpWindow*geometry: 600x350
-*doneButton*Label: done
-*editorTitle*Label: Help
-*saveButton*Label: save
-
-*bcontrols*borderWidth: 0
-*prev*highlightThickness: 0
-*succ*highlightThickness: 0
-
-*prevday*highlightThickness: 0
-*succday*highlightThickness: 0
-*daybuttons*borderWidth: 0
-
-*Scrollbar.borderWidth: 1
-*editor.scrollVertical: whenNeeded
-! *scrollHorizontal: False
-! *helpWindow*scrollHorizontal: True
-*holiday*cursorPositionVisible: False
-*holiday*displayCaret: False
-*helpWindow*cursorPositionVisible: False
-*helpWindow*displayCaret: False
-
-
*dayEditor*fontSet: -*--14-*
*controls*fontSet: -*--14-*
*bcontrols*fontSet: -*--14-*
*editorControls*fontSet: -*--14-*
*fontSet: -*--14-*
+
!*preeditType: Root
!*preeditType: OffTheSpot
*preeditType: OverTheSpot
+*helpWindow*editorTitle*label: ヘルプ
+*helpWindow*editorTitle*labelString: ヘルプ
*helpWindow*rows: 15
*helpWindow*columns: 80
*rows:7
@@ -149,11 +125,18 @@
*helpWindow*Paned*editor.width: 600
*helpWindow*Paned*editor.height: 350
+*bcontrols*borderWidth: 0
+*prev*highlightThickness: 0
+*succ*highlightThickness: 0
+
+*prevday*highlightThickness: 0
+*succday*highlightThickness: 0
+*daybuttons*borderWidth: 0
*Scrollbar.borderWidth: 1
*Text*scrollVertical: whenNeeded
-*scrollHorizontal: False
-*helpWindow*scrollHorizontal: True
+*scrollHorizontal: Never
+*helpWindow*scrollHorizontal: Always
*holiday*cursorPositionVisible: False
*holiday*displayCaret: False
*helpWindow*cursorPositionVisible: False

View File

@ -0,0 +1,46 @@
--- Imakefile.orig Sun Oct 1 12:19:17 1995
+++ Imakefile Mon Mar 12 20:54:39 2001
@@ -1,4 +1,5 @@
XCALENDAR_LIBDIR = $(LIBDIR)/xcalendar
+XCALENDAR_JP_LIBDIR = $(LIBDIR)/ja_JP.EUC/xcalendar
LIBFILES = larrow.xbm qmark.xbm quit.xbm rarrow.xbm xcalendar.hlp
# Comment out the following two lines for the Motif version
LOCAL_LIBRARIES = $(XAWLIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
@@ -12,7 +13,7 @@
#
# for Internationalization
#
-EXTRA_DEFINES = -DXI18N -DATHENA
+EXTRA_DEFINES = -DXI18N -DATHENA -DHAVE_DIRENT_H
##if !SharedLibXwchar
# _UseCat($(USRLIBDIR),$(CONTRIBSRC)/lib/Xwchar,/libXwchar.a)
# XWCHARLIB = LoaderLibPrefix _Use(-lXwchar,$(DEPXWCHARLIB))
@@ -40,12 +41,26 @@
# for Internationalization
#
XCal-uj.ad: XCal-uj.sed
- sed 's;%%XCALENDAR_LIBDIR%%;$(XCALENDAR_LIBDIR);'\
+ sed 's;%%XCALENDAR_LIBDIR%%;$(XCALENDAR_JP_LIBDIR);'\
+ < $? \
+ > $@
+xcalendar-uj.hlp: $(FILESDIR)/xcalendar-uj.hlp.sed
+ sed 's;%%XCALENDAR_LIBDIR%%;$(XCALENDAR_JP_LIBDIR);'\
+ < $? \
+ > $@
+xcalendar-uj.man: $(FILESDIR)/xcalendar-uj.man.sed
+ sed 's;%%XCALENDAR_LIBDIR%%;$(XCALENDAR_JP_LIBDIR);'\
< $? \
> $@
-install:: XCal-uj.ad
+install::
MakeDir($(LIBDIR)/ja_JP.EUC/app-defaults)
$(INSTALL) -c $(INSTAPPFLAGS) XCal-uj.ad $(LIBDIR)/ja_JP.EUC/app-defaults/XCalendar
+ MakeDir($(XCALENDAR_JP_LIBDIR))
+ $(INSTALL) -c $(INSTAPPFLAGS) $(FILESDIR)/xcalendar.hol $(XCALENDAR_JP_LIBDIR)
+ $(INSTALL) -c $(INSTAPPFLAGS) xcalendar-uj.hlp $(XCALENDAR_JP_LIBDIR)/xcalendar.hlp
+ $(INSTALL) -c $(INSTMANFLAGS) xcalendar-uj.man \
+ $(MANPATH)/ja/man1/xcalendar.1
+ $(COMPRESSMANCMD) $(MANPATH)/ja/man1/xcalendar.1
# MakeDir($(LIBDIR)/ja_JP.ujis/app-defaults)
# $(INSTALL) -c $(INSTAPPFLAGS) XCal-uj.ad $(LIBDIR)/ja_JP.ujis/app-defaults/XCalendar

View File

@ -0,0 +1,24 @@
--- XCalendar.sed.orig Tue Jul 4 06:59:01 1995
+++ XCalendar.sed Sun Mar 11 11:39:52 2001
@@ -2,7 +2,9 @@
*showGrip: False
*calendar*internalBorderWidth: 0
*input: True
-*resize: False
+*controls*resize: False
+*bcontrols*resize: False
+*daybuttons*resize: False
*resizable: True
*title: XCalendar v.4.0
*dayEditor.title: Day Editor
@@ -120,8 +122,8 @@
*Scrollbar.borderWidth: 1
*Text*scrollVertical: whenNeeded
-*scrollHorizontal: False
-*helpWindow*scrollHorizontal: True
+*scrollHorizontal: Never
+*helpWindow*scrollHorizontal: Always
*holiday*cursorPositionVisible: False
*holiday*displayCaret: False
*helpWindow*cursorPositionVisible: False

View File

@ -0,0 +1,11 @@
--- xcalendar.h.orig Sun Oct 1 12:21:42 1995
+++ xcalendar.h Mon Mar 12 20:54:02 2001
@@ -75,7 +75,7 @@
#include <X11/Xaw/Xawi18n.h>
#endif
-#if defined(SYSV) || defined(__osf__) || defined(SVR4)
+#if defined(SYSV) || defined(__osf__) || defined(SVR4) || defined(HAVE_DIRENT_H)
#include <dirent.h>
#else
#include <sys/dir.h>

View File

@ -0,0 +1,497 @@
xcalendar(1) xcalendar(1)
xcalendar - X11 用のカレンダーとメモ
xcalendar [month [year]]
xcalendar はメモ機能を持ったシンプルな対話型カレンダープロ
X Toolkit と Athena ま た は
Motif ウィジェット (コンパイル時のオプションで指定) で作ら
month と year が指定されなかった場合に は
calendarDir リソースで指定されたディレク ト
( ~/Calendar) に保存されます。エディタか
ShowEntries 関数を実行すると、その月にある全ての予定をハイ
(
)
( holidayfile 参照)
mm/dd/yyyy
使
便
(
)
xcalendar+ という perl スクリプトがありま
xcalendar はこの機能を内蔵 す る で
使
XCalendar - アプリケーションクラス
xcalendar - トップレベルペイン
controls - コントロールパネル
quitButton - 終了ボタン
helpButton - ヘルプボタン
date - 日付ラベル
calendar - カレンダーぺイン
daynumbers - 日付フレーム
1-49 -
daynames - 曜日フレーム
MON,TUE,WED,THU,FRI,SAT,SUN - 曜日ボタン
helpWindow - ヘルプウィンドウ
bcontrols - 月ボタンフレーム
prev - 先月ボタン
succ - 来月ボタン
cdate - 今日の日付ウィジェット
dayEditor - エディタポップアップ
editorFrame - エディタフレーム
editorTitle - エディタタイトル
editor - エディタ
holiday - 祝日テキスト
daybuttons - 日付ボタンフレーム
prevday - 前日ボタン
succday - 明日ボタン
editorControls - コントロールパネル
doneButton - 終了ボタン
saveButton - 保存ボタン
clearEntry - 消去ボタン
:
reverseVideoMark - True の場合は予定を反転した強調表示にします。
True で、
Falase です。
setMarkBackground - True かつ reverseVideoMark が False の場合、
調 markBackground に
markBackground - 予定を強調表示する際に使われる背景色。
setMarkForeground - setMarkBackground と同様です。
markForeground - 予定を強調表示する際に使われる前景色。
setMarkBackground と setMarkForeground の組合わせは
january,february,..,december - これらのリソースで月ラベルの月名や
oldStyle (下記参照) 時のファイル名決定方法を
firstDay - 1-7 の整数で週をどの曜日から始めるか指定します。
7 ()
markOnStartup - True の場合起動時から予定をマークします。
: True。
helpFile - xcalendar.hlp ファイルのフルパス名。
: %%XCALENDAR_LIBDIR%%/xcalendar.hlp
textBufferSize - 日付エディタのテキストバッファの最大サイズ。
: 2048。
calendarDir - $HOME/Calendar 以外のディレクトリにカレンダー
holidayFile - 祝日を決めるのに用いるファイルのパス名。
: %%XCALENDAR_LIBDIR%%/xcalendar.hol
oldStyle - ファイルの命名規則として新しいスタイル
(xcyyyymmdd) ではなく version 3.0 およびそれ
(xcDAYmonYEAR) を使用
DAY YEAR は数字で mon は月
3
: True
markCurrent - True の場合、今日の日付をマークします (見ら
便)
: False
updateCurrent - 今日の日付のマーキングを更新する間隔の秒数。
: 60
currentForeground - 今日の日付を強調表示する際の前景色。
markHoliday - True の場合、祝日をマークします (見られる場合、
便)
: False
holidayForeground - 祝日を強調表示する際の前景色
monthnames - cdate において日付をフォーマットする際に用いる
'/'
monthnms - cdate において日付をフォーマットする際に用いる
'/'
daynames - cdate において日付をフォーマットする際に用いる
'/'
daynms - cdate において日付をフォーマットする際に用いる
'/'
date - cdate において日付をフォーマットする文字列。
:
%W 曜日の完全な名称
%w 曜日の略称
%M
%m
%d ()
%Y (4 )
%y 2
: "%W, %M %d";
*international: TRUE
!
*showGrip: False
*calendar*internalBorderWidth: 0
*input: True
*controls*resize: False
*bcontrols*resize: False
*daybuttons*resize: False
*resizable: True
*title: XCalendar v.4.0
*dayEditor.title: Day Editor
*helpWindow.title: XCalendar Help
*Font: 8x13
*FontList: 8x13
*helpFile: %%XCALENDAR_LIBDIR%%/xcalendar.hlp
*holidayFile: %%XCALENDAR_LIBDIR%%/xcalendar.hol
*firstDay: 7
*labelType: XmSTRING
*prev*Label: 先月
*succ*Label: 来月
*prevday*Label: 昨日
*succday*Label: 明日
*helpButton*Label: 助け
*quitButton*Label: 終り
*daynames.SUN.label: \ 日
*daynames.MON.label: \ 月
*daynames.TUE.label: \ 火
*daynames.WED.label: \ 水
*daynames.THU.label: \ 木
*daynames.FRI.label: \ 金
*daynames.SAT.label: \ 土
*monthnames: 1/2/3/4/5/6/7/8/9/10/11/12
*monthnms: 1/2/3/4/5/6/7/8/9/10/11/12
*daynames: 日曜日/月曜日/火曜日/水曜日/木曜日/金曜日/土曜日
*daynms: 日/月/火/水/木/金/土
*date: %M月%d日(%W)
#ifdef COLOR
! colors
*Background: lightgray
*markBackground: Steel Blue
*daynames*Background: lightgray
*daynames.SUN*Foreground: Red
*daynames.SAT*Foreground: Black
*daynumbers*Foreground: Black
*daynumbers.1*Foreground: Red
*daynumbers.8*Foreground: Red
*daynumbers.15*Foreground: Red
*daynumbers.22*Foreground: Red
*daynumbers.29*Foreground: Red
*daynumbers.36*Foreground: Red
*helpButton*Background: slategray
*helpButton*Foreground: White
*quitButton*Background: slategray
*quitButton*Foreground: White
*editorTitle*Background: lightgray
*editorTitle*Foreground: Black
*editorControls*Background: lightgray
*editorControls*Command.Background: slategray
*editorControls*Command.Foreground: White
*editorControls*XmPushButton.Background: slategray
*editorControls*XmPushButton.Foreground: White
#endif
*setMarkBackground: True
*markOnStartup: True
*markCurrent: True
*currentForeground: Blue
*markHoliday: True
*holidayForeground: Red
*BorderWidth: 2
*calendar.borderWidth: 1
*borderWidth: 0
*date*borderWidth: 0
*date*vertDistance: 1
*prev*vertDistance: 0
*succ*vertDistance: 0
*controls*date*fontSet: 8x13bold, -*--14-*
*daynames*fontSet: -*--14-*
*dayEditor*editorTitle*fontSet: 8x13bold, -*--14-*
*helpWindow*editorTitle*fontSet: 8x13bold, -*--14-*
*helpButton*vertDistance: 5
*quitButton*vertDistance: 5
*editorTitle*vertDistance: 5
*cdate*vertDistance: 5
*editorControls*doneButton*label: 終り
*editorControls*saveButton*label: 保存
*editorControls*clearEntry*label: 消えてなくなれ
*doneButton*labelString: 終り
*saveButton*labelString: 保存
*clearEntry*labelString: 消えてなくなれ
*dayEditor*geometry: 300x150
*helpWindow*geometry: 600x350
*dayEditor*fontSet: -*--14-*
*controls*fontSet: -*--14-*
*bcontrols*fontSet: -*--14-*
*editorControls*fontSet: -*--14-*
*fontSet: -*--14-*
!*preeditType: Root
!*preeditType: OffTheSpot
*preeditType: OverTheSpot
*helpWindow*editorTitle*label: ヘルプ
*helpWindow*editorTitle*labelString: ヘルプ
*helpWindow*rows: 15
*helpWindow*columns: 80
*rows:7
*columns: 30
*dayEditor*Paned*editor.width: 300
*dayEditor*Paned*editor.height: 150
*helpWindow*Paned*editor.width: 600
*helpWindow*Paned*editor.height: 350
*bcontrols*borderWidth: 0
*prev*highlightThickness: 0
*succ*highlightThickness: 0
*prevday*highlightThickness: 0
*succday*highlightThickness: 0
*daybuttons*borderWidth: 0
*Scrollbar.borderWidth: 1
*Text*scrollVertical: whenNeeded
*scrollHorizontal: Never
*helpWindow*scrollHorizontal: Always
*holiday*cursorPositionVisible: False
*holiday*displayCaret: False
*helpWindow*cursorPositionVisible: False
*helpWindow*displayCaret: False
! Keyboard accelerators
*editorControls*doneButton*accelerators: #override \n\
Meta<Key>q: set() notify() reset() \n
*editorControls*saveButton*accelerators: #override \n\
Meta<Key>s: set() notify() reset() \n
*editorControls*clearEntry*accelerators: #override \n\
Meta<Key>c: set() notify() reset() \n
*daybuttons*prevday*accelerators: #override \n\
Meta<Key>p: set() notify() reset() \n
*daybuttons*succday*accelerators: #override \n\
Meta<Key>n: set() notify() reset() \n
*prev*accelerators: #override \n\
<Key>p: set() notify() reset() \n
*succ*accelerators: #override \n\
<Key>n: set() notify() reset() \n
*quitButton*accelerators: #override \n\
<Key>q: set() notify() \n
*XmText.translations: #override\n\
Ctrl <Key>b: backward-character()\n\
Alt <Key>b: backward-word()\n\
Meta <Key>b: backward-word()\n\
Shift Alt <Key>b: backward-word(extend)\n\
Shift Meta <Key>b: backward-word(extend)\n\
Alt <Key>[: backward-paragraph()\n\
Meta <Key>[: backward-paragraph()\n\
Shift Alt <Key>[: backward-paragraph(extend)\n\
Shift Meta <Key>[: backward-paragraph(extend)\n\
Alt <Key><: beginning-of-file()\n\
Meta <Key><: beginning-of-file()\n\
Ctrl <Key>a: beginning-of-line()\n\
Shift Ctrl <Key>a: beginning-of-line(extend)\n\
Ctrl <Key>osfInsert: copy-clipboard()\n\
Shift <Key>osfDelete: cut-clipboard()\n\
Shift <Key>osfInsert: paste-clipboard()\n\
Alt <Key>>: end-of-file()\n\
Meta <Key>>: end-of-file()\n\
Ctrl <Key>e: end-of-line()\n\
Shift Ctrl <Key>e: end-of-line(extend)\n\
Ctrl <Key>f: forward-character()\n\
Alt <Key>]: forward-paragraph()\n\
Meta <Key>]: forward-paragraph()\n\
Shift Alt <Key>]: forward-paragraph(extend)\n\
Shift Meta <Key>]: forward-paragraph(extend)\n\
Ctrl Alt <Key>f: forward-word()\n\
Ctrl Meta <Key>f: forward-word()\n\
Ctrl <Key>d: kill-next-character()\n\
Ctrl <Key>h: kill-previous-character()\n\
Alt <Key>BackSpace: kill-previous-word()\n\
Meta <Key>BackSpace: kill-previous-word()\n\
Ctrl <Key>w: key-select() kill-selection()\n\
Ctrl <Key>y: unkill()\n\
Ctrl <Key>k: kill-to-end-of-line()\n\
Alt <Key>Delete: kill-to-start-of-line()\n\
Meta <Key>Delete: kill-to-start-of-line()\n\
Ctrl <Key>o: newline-and-backup()\n\
Ctrl <Key>j: newline-and-indent()\n\
Ctrl <Key>n: next-line()\n\
Ctrl <Key>osfLeft: page-left()\n\
Ctrl <Key>osfRight: page-right()\n\
Ctrl <Key>p: previous-line()\n\
Ctrl <Key>g: process-cancel()\n\
Ctrl <Key>l: redraw-display()\n\
Ctrl <Key>v: next-page()\n\
Meta <Key>v: previous-page()\n\
Ctrl <Key>osfDown: next-page()\n\
Ctrl <Key>osfUp: previous-page()\n\
Ctrl <Key>space: set-anchor()\n
$HOME/Calendar/*, %%XCALENDAR_LIBDIR%%/xcalendar.hlp,
%%XCALENDAR_LIBDIR%%/xcalendar.hol
xrdb(1), xcalendar+(1)
(bingle@cs.pur-
due.edu) に教えてください。
Copyright 1988 by Massachusetts Institute of Technology
Roman J. Budzianowski, MIT Project Athena
Copyright 1990-1994 by Purdue University
Richard Bingle, Department of Computer Sciences
/ :
Beth Chaney
Purdue University, Department of Computer Sciences
Mike Urban
Jet Propulsion Labs, NASA
Joel Neisen
Minnesota Supercomputer Center
Hiroshi Kuribayashi
Omron Corp.
X Version 11 6 June 1994 1

View File

@ -0,0 +1,456 @@
.de EX \"Begin example
.ne 5
.if n .sp 1
.if t .sp .5
.nf
.in +.5i
..
.de EE
.fi
.in -.5i
.if n .sp 1
.if t .sp .5
..
.TH xcalendar 1 "6 June 1994" "X Version 11"
.SH
xcalendar - X11 用のカレンダーとメモ
.SH
.PP
\fBxcalendar \fP[month \fp[year\fp]\fP]
.PP
.SH
.PP
\fIxcalendar\fP はメモ機能を持ったシンプルな対話型カレンダープログラムです。
X Toolkit と Athena または Motif ウィジェット
()
.PP
month と year が指定されなかった場合には
.PP
.SH
.PP
calendarDir リソースで指定されたディレクトリ (デフォルトでは
~/Calendar) に保存されます。エディタからは個々の日付に関連づけられた内容を
.PP
.PP
ShowEntries 関数を実行すると、その月にある全ての予定をハイライト表示できます。
()
.PP
( holidayfile 参照) から読み取られます。
mm/dd/yyyy
使
.SH
.PP
便
()
\fIxcalendar+\fP という perl
\fIxcalendar\fP はこの機能を
.PP
.SH
.PP
使
.PP
.PP
.EX 0
XCalendar - アプリケーションクラス
xcalendar - トップレベルペイン
controls - コントロールパネル
quitButton - 終了ボタン
helpButton - ヘルプボタン
date - 日付ラベル
calendar - カレンダーぺイン
daynumbers - 日付フレーム
1-49 -
daynames - 曜日フレーム
MON,TUE,WED,THU,FRI,SAT,SUN - 曜日ボタン
helpWindow - ヘルプウィンドウ
bcontrols - 月ボタンフレーム
prev - 先月ボタン
succ - 来月ボタン
cdate - 今日の日付ウィジェット
dayEditor - エディタポップアップ
editorFrame - エディタフレーム
editorTitle - エディタタイトル
editor - エディタ
holiday - 祝日テキスト
daybuttons - 日付ボタンフレーム
prevday - 前日ボタン
succday - 明日ボタン
editorControls - コントロールパネル
doneButton - 終了ボタン
saveButton - 保存ボタン
clearEntry - 消去ボタン
.EE
.PP
:
.PP
.EX 0
reverseVideoMark - True の場合は予定を反転した強調表示にします。
True で、
Falase です。
setMarkBackground - True かつ reverseVideoMark が False の場合、
調 markBackground に
markBackground - 予定を強調表示する際に使われる背景色。
setMarkForeground - setMarkBackground と同様です。
markForeground - 予定を強調表示する際に使われる前景色。
\fIsetMarkBackground\fP と \fIsetMarkForeground\fP の組合わせは
january,february,..,december - これらのリソースで月ラベルの月名や
oldStyle (下記参照) 時のファイル名決定方法を
firstDay - 1-7 の整数で週をどの曜日から始めるか指定します。
7 ()
markOnStartup - True の場合起動時から予定をマークします。
: True。
.\" False
helpFile - xcalendar.hlp ファイルのフルパス名。
: %%XCALENDAR_LIBDIR%%/xcalendar.hlp
textBufferSize - 日付エディタのテキストバッファの最大サイズ。
: 2048。
calendarDir - $HOME/Calendar 以外のディレクトリにカレンダー
holidayFile - 祝日を決めるのに用いるファイルのパス名。
: %%XCALENDAR_LIBDIR%%/xcalendar.hol
oldStyle - ファイルの命名規則として新しいスタイル
(xcyyyymmdd) ではなく version 3.0 およびそれ
(xcDAYmonYEAR) を使用
DAY YEAR は数字で mon は月
3
: True
markCurrent - True の場合、今日の日付をマークします (見ら
便)
: False
updateCurrent - 今日の日付のマーキングを更新する間隔の秒数。
: 60
currentForeground - 今日の日付を強調表示する際の前景色。
markHoliday - True の場合、祝日をマークします (見られる場合、
便)
: False
holidayForeground - 祝日を強調表示する際の前景色
monthnames - cdate において日付をフォーマットする際に用いる
'/'
monthnms - cdate において日付をフォーマットする際に用いる
'/'
daynames - cdate において日付をフォーマットする際に用いる
'/'
daynms - cdate において日付をフォーマットする際に用いる
'/'
date - cdate において日付をフォーマットする文字列。
:
.in +9
.nf
%W 曜日の完全な名称
%w 曜日の略称
%M
%m
%d ()
%Y (4 )
%y 2
.fi
.in -9
: "%W, %M %d";
.EE
.SH
.EX 0
*international: TRUE
!
*showGrip: False
*calendar*internalBorderWidth: 0
*input: True
*controls*resize: False
*bcontrols*resize: False
*daybuttons*resize: False
*resizable: True
*title: XCalendar v.4.0
*dayEditor.title: Day Editor
*helpWindow.title: XCalendar Help
*Font: 8x13
*FontList: 8x13
*helpFile: %%XCALENDAR_LIBDIR%%/xcalendar.hlp
*holidayFile: %%XCALENDAR_LIBDIR%%/xcalendar.hol
*firstDay: 7
*labelType: XmSTRING
*prev*Label: 先月
*succ*Label: 来月
*prevday*Label: 昨日
*succday*Label: 明日
*helpButton*Label: 助け
*quitButton*Label: 終り
*daynames.SUN.label: \\ 日
*daynames.MON.label: \\ 月
*daynames.TUE.label: \\ 火
*daynames.WED.label: \\ 水
*daynames.THU.label: \\ 木
*daynames.FRI.label: \\ 金
*daynames.SAT.label: \\ 土
*monthnames: 1/2/3/4/5/6/7/8/9/10/11/12
*monthnms: 1/2/3/4/5/6/7/8/9/10/11/12
*daynames: 日曜日/月曜日/火曜日/水曜日/木曜日/金曜日/土曜日
*daynms: 日/月/火/水/木/金/土
*date: %M月%d日(%W)
#ifdef COLOR
! colors
*Background: lightgray
*markBackground: Steel Blue
*daynames*Background: lightgray
*daynames.SUN*Foreground: Red
*daynames.SAT*Foreground: Black
*daynumbers*Foreground: Black
*daynumbers.1*Foreground: Red
*daynumbers.8*Foreground: Red
*daynumbers.15*Foreground: Red
*daynumbers.22*Foreground: Red
*daynumbers.29*Foreground: Red
*daynumbers.36*Foreground: Red
*helpButton*Background: slategray
*helpButton*Foreground: White
*quitButton*Background: slategray
*quitButton*Foreground: White
*editorTitle*Background: lightgray
*editorTitle*Foreground: Black
*editorControls*Background: lightgray
*editorControls*Command.Background: slategray
*editorControls*Command.Foreground: White
*editorControls*XmPushButton.Background: slategray
*editorControls*XmPushButton.Foreground: White
#endif
*setMarkBackground: True
*markOnStartup: True
*markCurrent: True
*currentForeground: Blue
*markHoliday: True
*holidayForeground: Red
*BorderWidth: 2
*calendar.borderWidth: 1
*borderWidth: 0
*date*borderWidth: 0
*date*vertDistance: 1
*prev*vertDistance: 0
*succ*vertDistance: 0
*controls*date*fontSet: 8x13bold, -*--14-*
*daynames*fontSet: -*--14-*
*dayEditor*editorTitle*fontSet: 8x13bold, -*--14-*
*helpWindow*editorTitle*fontSet: 8x13bold, -*--14-*
*helpButton*vertDistance: 5
*quitButton*vertDistance: 5
*editorTitle*vertDistance: 5
*cdate*vertDistance: 5
*editorControls*doneButton*label: 終り
*editorControls*saveButton*label: 保存
*editorControls*clearEntry*label: 消えてなくなれ
*doneButton*labelString: 終り
*saveButton*labelString: 保存
*clearEntry*labelString: 消えてなくなれ
*dayEditor*geometry: 300x150
*helpWindow*geometry: 600x350
*dayEditor*fontSet: -*--14-*
*controls*fontSet: -*--14-*
*bcontrols*fontSet: -*--14-*
*editorControls*fontSet: -*--14-*
*fontSet: -*--14-*
!*preeditType: Root
!*preeditType: OffTheSpot
*preeditType: OverTheSpot
*helpWindow*editorTitle*label: ヘルプ
*helpWindow*editorTitle*labelString: ヘルプ
*helpWindow*rows: 15
*helpWindow*columns: 80
*rows:7
*columns: 30
*dayEditor*Paned*editor.width: 300
*dayEditor*Paned*editor.height: 150
*helpWindow*Paned*editor.width: 600
*helpWindow*Paned*editor.height: 350
*bcontrols*borderWidth: 0
*prev*highlightThickness: 0
*succ*highlightThickness: 0
*prevday*highlightThickness: 0
*succday*highlightThickness: 0
*daybuttons*borderWidth: 0
*Scrollbar.borderWidth: 1
*Text*scrollVertical: whenNeeded
*scrollHorizontal: Never
*helpWindow*scrollHorizontal: Always
*holiday*cursorPositionVisible: False
*holiday*displayCaret: False
*helpWindow*cursorPositionVisible: False
*helpWindow*displayCaret: False
! Keyboard accelerators
*editorControls*doneButton*accelerators: #override \\n\\
Meta<Key>q: set() notify() reset() \\n
*editorControls*saveButton*accelerators: #override \\n\\
Meta<Key>s: set() notify() reset() \\n
*editorControls*clearEntry*accelerators: #override \\n\\
Meta<Key>c: set() notify() reset() \\n
*daybuttons*prevday*accelerators: #override \\n\\
Meta<Key>p: set() notify() reset() \\n
*daybuttons*succday*accelerators: #override \\n\\
Meta<Key>n: set() notify() reset() \\n
*prev*accelerators: #override \\n\\
<Key>p: set() notify() reset() \\n
*succ*accelerators: #override \\n\\
<Key>n: set() notify() reset() \\n
*quitButton*accelerators: #override \\n\\
<Key>q: set() notify() \\n
*XmText.translations: #override\\n\\
.in +9
.nf
Ctrl <Key>b: backward-character()\\n\\
Alt <Key>b: backward-word()\\n\\
Meta <Key>b: backward-word()\\n\\
Shift Alt <Key>b: backward-word(extend)\\n\\
Shift Meta <Key>b: backward-word(extend)\\n\\
Alt <Key>[: backward-paragraph()\\n\\
Meta <Key>[: backward-paragraph()\\n\\
Shift Alt <Key>[: backward-paragraph(extend)\\n\\
Shift Meta <Key>[: backward-paragraph(extend)\\n\\
Alt <Key><: beginning-of-file()\\n\\
Meta <Key><: beginning-of-file()\\n\\
Ctrl <Key>a: beginning-of-line()\\n\\
Shift Ctrl <Key>a: beginning-of-line(extend)\\n\\
Ctrl <Key>osfInsert: copy-clipboard()\\n\\
Shift <Key>osfDelete: cut-clipboard()\\n\\
Shift <Key>osfInsert: paste-clipboard()\\n\\
Alt <Key>>: end-of-file()\\n\\
Meta <Key>>: end-of-file()\\n\\
Ctrl <Key>e: end-of-line()\\n\\
Shift Ctrl <Key>e: end-of-line(extend)\\n\\
Ctrl <Key>f: forward-character()\\n\\
Alt <Key>]: forward-paragraph()\\n\\
Meta <Key>]: forward-paragraph()\\n\\
Shift Alt <Key>]: forward-paragraph(extend)\\n\\
Shift Meta <Key>]: forward-paragraph(extend)\\n\\
Ctrl Alt <Key>f: forward-word()\\n\\
Ctrl Meta <Key>f: forward-word()\\n\\
Ctrl <Key>d: kill-next-character()\\n\\
Ctrl <Key>h: kill-previous-character()\\n\\
Alt <Key>BackSpace: kill-previous-word()\\n\\
Meta <Key>BackSpace: kill-previous-word()\\n\\
Ctrl <Key>w: key-select() kill-selection()\\n\\
Ctrl <Key>y: unkill()\\n\\
Ctrl <Key>k: kill-to-end-of-line()\\n\\
Alt <Key>Delete: kill-to-start-of-line()\\n\\
Meta <Key>Delete: kill-to-start-of-line()\\n\\
Ctrl <Key>o: newline-and-backup()\\n\\
Ctrl <Key>j: newline-and-indent()\\n\\
Ctrl <Key>n: next-line()\\n\\
Ctrl <Key>osfLeft: page-left()\\n\\
Ctrl <Key>osfRight: page-right()\\n\\
Ctrl <Key>p: previous-line()\\n\\
Ctrl <Key>g: process-cancel()\\n\\
Ctrl <Key>l: redraw-display()\\n\\
Ctrl <Key>v: next-page()\\n\\
Meta <Key>v: previous-page()\\n\\
Ctrl <Key>osfDown: next-page()\\n\\
Ctrl <Key>osfUp: previous-page()\\n\\
Ctrl <Key>space: set-anchor()\\n
.fi
.in -9
.EE
.SH
.PP
$HOME/Calendar/*, %%XCALENDAR_LIBDIR%%/xcalendar.hlp,
%%XCALENDAR_LIBDIR%%/xcalendar.hol
.PP
.SH
xrdb(1), xcalendar+(1)
.PP
.SH
.PP
(bingle@cs.purdue.edu) に教えてください。
.PP
.SH
.PP
Copyright 1988 by Massachusetts Institute of Technology
.br
Roman J. Budzianowski, MIT Project Athena
Copyright 1990-1994 by Purdue University
.br
Richard Bingle, Department of Computer Sciences
/ :
.br
Beth Chaney
.br
Purdue University, Department of Computer Sciences
Mike Urban
.br
Jet Propulsion Labs, NASA
Joel Neisen
.br
Minnesota Supercomputer Center
Hiroshi Kuribayashi
.br
Omron Corp.

View File

@ -0,0 +1,21 @@
01/01/2001 元日
01/08/2001 成人の日
02/11/2001 建国記念の日
02/12/2001 振替休日
03/20/2001 春分の日
04/29/2001 みどりの日
04/30/2001 振替休日
05/03/2001 憲法記念日
05/04/2001 国民の休日
05/05/2001 こどもの日
07/20/2001 海の日
09/15/2001 敬老の日
09/23/2001 秋分の日
09/24/2001 振替休日
10/08/2001 体育の日
11/03/2001 文化の日
11/23/2001 勤労感謝の日
12/23/2001 天皇誕生日
12/24/2001 振替休日
01/01/2002 元日
01/14/2002 成人の日

View File

@ -0,0 +1 @@
A calendar with a notebook for X11 (internationarized version)

View File

@ -0,0 +1,12 @@
The xcalendar is a simple interactive calendar program with a notebook
capability. It is built on the X Toolkit and the Athena Widgets.
Just type `xcalendar [month [year]]' on command line.
If month and year are not provided on the command line they are
assumed to be current.
Note: This program is internationarized but only
app-defaults files for English (C) and Japanese (ja_JP.EUC) are included.
Let's add another locales!
MITA Yoshio <mita@jp.FreeBSD.org>

View File

@ -0,0 +1,13 @@
bin/xcalendar
lib/X11/app-defaults/XCalendar
lib/X11/ja_JP.EUC/app-defaults/XCalendar
lib/X11/ja_JP.EUC/xcalendar/xcalendar.hol
lib/X11/ja_JP.EUC/xcalendar/xcalendar.hlp
lib/X11/xcalendar/larrow.xbm
lib/X11/xcalendar/qmark.xbm
lib/X11/xcalendar/quit.xbm
lib/X11/xcalendar/rarrow.xbm
lib/X11/xcalendar/xcalendar.hlp
@dirrm lib/X11/xcalendar
@dirrm lib/X11/ja_JP.EUC/xcalendar
@unexec rmdir %D/lib/X11/ja_JP.EUC/app-defaults 2>/dev/null || true