add ladspa

Linux Audio Developer's Simple Plugin API

PR:		37965, 38723
Submitted by:	Tilman Linneweh <tilman@arved.de>, David Yeske <dyeske@yahoo.com>
This commit is contained in:
Ying-Chieh Liao 2002-05-30 16:47:22 +00:00
parent d2dda23309
commit 97f54f04dc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60298
8 changed files with 140 additions and 0 deletions

View File

@ -104,6 +104,7 @@
SUBDIR += knapster
SUBDIR += koog
SUBDIR += ksmp3play
SUBDIR += ladspa
SUBDIR += lame
SUBDIR += lame-devel
SUBDIR += liba52

35
audio/ladspa/Makefile Normal file
View File

@ -0,0 +1,35 @@
# New ports collection Makefile for: ladspa
# Date created: 11 May 2002
# Whom: Tilman Linneweh <freebsdports@arved.de
#
# $FreeBSD$
PORTNAME= ladspa
PORTVERSION= 0
CATEGORIES= audio
MASTER_SITES= http://www.ladspa.org/download/
DISTNAME= ladspa_sdk
EXTRACT_SUFX= .tgz
MAINTAINER= freebsdports@arved.de
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAKEFILE= makefile
ALL_TARGET= targets
PROGRAM_FILES= analyseplugin applyplugin listplugins
PLUGIN_FILES= amp.so delay.so filter.so noise.so sine.so
PLUGIN_DIR= ${PREFIX}/lib/ladspa/
do-install:
@${INSTALL_DATA} ${WRKSRC}/ladspa.h ${PREFIX}/include
.for file in ${PROGRAM_FILES}
@${INSTALL_PROGRAM} ${WRKSRC}/../bin/${file} ${PREFIX}/bin
.endfor
@${MKDIR} ${PLUGIN_DIR}
.for file in ${PLUGIN_FILES}
@${INSTALL_DATA} ${WRKSRC}/../plugins/${file} ${PLUGIN_DIR}
.endfor
.include <bsd.port.mk>

1
audio/ladspa/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ladspa_sdk.tgz) = 00b34b8f9a80a1fe141b643e64ac1681

View File

@ -0,0 +1,11 @@
--- applyplugin.c.orig Sat May 11 23:31:00 2002
+++ applyplugin.c Sat May 11 23:31:09 2002
@@ -6,7 +6,7 @@
/*****************************************************************************/
#include <dlfcn.h>
-#include <endian.h>
+#include <machine/endian.h>
#include <errno.h>
#include <math.h>
#include <stdlib.h>

View File

@ -0,0 +1,67 @@
--- makefile.orig Wed Nov 22 21:34:58 2000
+++ makefile Sat May 11 23:29:17 2002
@@ -5,19 +5,18 @@
# Change these if you want to install somewhere else. In particularly
# you may wish to remove the middle "local/" part of each entry.
INSTALL_PLUGINS_DIR = /usr/local/lib/ladspa/
INSTALL_INCLUDE_DIR = /usr/include/
INSTALL_BINARY_DIR = /usr/local/bin/
###############################################################################
#
# GENERAL
#
-INCLUDES = -I.
-LIBRARIES = -ldl -lm
-CFLAGS = $(INCLUDES) -Wall -Werror -O3 -fPIC
-CXXFLAGS = $(CFLAGS)
+CFLAGS += -I.
+CXXFLAGS += -I.
+LDFLAGS += -lm
PLUGINS = ../plugins/amp.so \
../plugins/delay.so \
../plugins/filter.so \
@@ -26,9 +25,6 @@
PROGRAMS = ../bin/analyseplugin \
../bin/applyplugin \
../bin/listplugins
-CC = cc
-CPP = c++
-
###############################################################################
#
# RULES TO BUILD PLUGINS FROM C OR C++ CODE
@@ -39,8 +35,8 @@
$(LD) -o ../plugins/$*.so plugins/$*.o -shared
../plugins/%.so: plugins/%.cpp ladspa.h
- $(CPP) $(CXXFLAGS) -o plugins/$*.o -c plugins/$*.cpp
- $(CPP) -o ../plugins/$*.so plugins/$*.o -shared
+ $(CXX) $(CXXFLAGS) -o plugins/$*.o -c plugins/$*.cpp
+ $(CXX) -o ../plugins/$*.so plugins/$*.o -shared
###############################################################################
#
@@ -90,17 +86,17 @@
#
../bin/applyplugin: applyplugin.o load.o
- $(CC) $(CFLAGS) $(LIBRARIES) \
+ $(CC) $(CFLAGS) $(LDFLAGS) \
-o ../bin/applyplugin \
applyplugin.o load.o
../bin/analyseplugin: analyseplugin.o load.o
- $(CC) $(CFLAGS) $(LIBRARIES) \
+ $(CC) $(CFLAGS) $(LDFLAGS) \
-o ../bin/analyseplugin \
analyseplugin.o load.o
../bin/listplugins: listplugins.o search.o
- $(CC) $(CFLAGS) $(LIBRARIES) \
+ $(CC) $(CFLAGS) $(LDFLAGS) \
-o ../bin/listplugins \
listplugins.o search.o

1
audio/ladspa/pkg-comment Normal file
View File

@ -0,0 +1 @@
Linux Audio Developer's Simple Plugin API

14
audio/ladspa/pkg-descr Normal file
View File

@ -0,0 +1,14 @@
Many audio synthesis and recording packages are in use or in
development. These work in many different ways. LADSPA
provides a standard way for `plugin' audio processors to be used with
a wide range of these packages.
For instance, this allows a developer to make a reverb program and
bundle it into a LADSPA `plugin library.' Ordinary users can then use
this reverb within any LADSPA-friendly audio application.
Author: Richard Furse <richard@muse.demon.co.uk.>
WWW: http://www.ladspa.org
- Tilman Linneweh
freebsdports@arved.de

10
audio/ladspa/pkg-plist Normal file
View File

@ -0,0 +1,10 @@
bin/analyseplugin
bin/applyplugin
bin/listplugins
include/ladspa.h
lib/ladspa/amp.so
lib/ladspa/delay.so
lib/ladspa/filter.so
lib/ladspa/noise.so
lib/ladspa/sine.so
@dirrm lib/ladspa