Add games/triplane, a side-scrolling dogfighting game.
Approved by: ehaupt (mentor) Feature safe: yes
This commit is contained in:
parent
57f67727fe
commit
97e28a8680
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267904
@ -889,6 +889,7 @@
|
||||
SUBDIR += tremulous
|
||||
SUBDIR += trigger
|
||||
SUBDIR += trimines
|
||||
SUBDIR += triplane
|
||||
SUBDIR += trojka
|
||||
SUBDIR += trophy
|
||||
SUBDIR += tsito
|
||||
|
29
games/triplane/Makefile
Normal file
29
games/triplane/Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
# New ports collection makefile for: triplane
|
||||
# Date created: 01 Jan 2011
|
||||
# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= triplane
|
||||
PORTVERSION= 1.04.r20110114
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
|
||||
SF/${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-classic-${PORTVERSION}
|
||||
|
||||
MAINTAINER= martymac@FreeBSD.org
|
||||
COMMENT= Port of the original Triplane Turmoil game
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
USE_SDL= sdl mixer
|
||||
USE_GMAKE= yes
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
||||
CFLAGS+= -DTRIPLANE_DATA=\\\"${DATADIR}\\\"
|
||||
MAKE_ENV= DATADIR="${DATADIR}"
|
||||
|
||||
ALL_TARGET= depend all
|
||||
|
||||
.include <bsd.port.mk>
|
2
games/triplane/distinfo
Normal file
2
games/triplane/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (triplane-classic-1.04.r20110114.tar.gz) = 3d72b528dddaa9c4ef147df3b26db00ff38a9ef561c3b826fc56f46d529f5aa2
|
||||
SIZE (triplane-classic-1.04.r20110114.tar.gz) = 3471686
|
36
games/triplane/files/patch-Makefile
Normal file
36
games/triplane/files/patch-Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
--- Makefile.orig 2011-01-14 15:46:08.000000000 +0000
|
||||
+++ Makefile 2011-01-14 15:49:40.248413763 +0000
|
||||
@@ -1,11 +1,11 @@
|
||||
-PREFIX = /usr/local
|
||||
-DESTDIR = ""
|
||||
-
|
||||
-CXX = g++
|
||||
-OPTIFLAG = -O2 -g
|
||||
-CFLAGS := -Wall -Isrc $(OPTIFLAG) $(CFLAGS_NOSDL) `sdl-config --cflags` -DHAVE_SDL_MIXER "-DTRIPLANE_DATA=\"$(PREFIX)/share/games/triplane-classic\""
|
||||
-LDFLAGS =
|
||||
-LIBS := `sdl-config --libs` -lSDL_mixer -lm
|
||||
+PREFIX ?= /usr/local
|
||||
+DESTDIR ?= ""
|
||||
+SDL_CONFIG ?= sdl-config
|
||||
+
|
||||
+CXX ?= g++
|
||||
+#OPTIFLAG = -O2 -g
|
||||
+CFLAGS += -Wall -Isrc $(OPTIFLAG) $(CFLAGS_NOSDL) `$(SDL_CONFIG) --cflags` -DHAVE_SDL_MIXER
|
||||
+LIBS := `$(SDL_CONFIG) --libs` -lSDL_mixer -lm
|
||||
|
||||
COMMON_OBJS = src/gfx/bitmap.o src/gfx/font.o \
|
||||
src/gfx/gfx.o src/util/wutil.o src/util/random.o \
|
||||
@@ -72,10 +72,9 @@
|
||||
$(CXX) -o tools/dksbuild -g src/tools/dksbuild/dksbuild.cc
|
||||
|
||||
install:
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/games
|
||||
- install triplane-classic $(DESTDIR)$(PREFIX)/games/triplane-classic
|
||||
- mkdir -p $(DESTDIR)$(PREFIX)/share/games/triplane-classic
|
||||
- install -m 644 fokker.dks $(DESTDIR)$(PREFIX)/share/games/triplane-classic/fokker.dks
|
||||
+ $(BSD_INSTALL_PROGRAM) triplane-classic $(DESTDIR)$(PREFIX)/bin/triplane
|
||||
+ mkdir -p $(DESTDIR)$(DATADIR)
|
||||
+ $(BSD_INSTALL_DATA) fokker.dks $(DESTDIR)$(DATADIR)/fokker.dks
|
||||
test:
|
||||
if [ ! -d triplane-testsuite ]; then echo Please darcs get http://iki.fi/lindi/darcs/triplane-testsuite; false; fi
|
||||
bash tools/run-all-tests tools/run-one-test ./triplane-classic triplane-testsuite
|
7
games/triplane/pkg-descr
Normal file
7
games/triplane/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
Triplane Classic is a side-scrolling dogfighting game featuring solo
|
||||
missions and multiplayer mode with up to four players. It is a port of
|
||||
the original Triplane Turmoil game for DOS and aims to match the
|
||||
original game exactly so that high scores remain comparable to the
|
||||
original.
|
||||
|
||||
WWW: http://triplane.sourceforge.net
|
3
games/triplane/pkg-plist
Normal file
3
games/triplane/pkg-plist
Normal file
@ -0,0 +1,3 @@
|
||||
bin/triplane
|
||||
%%DATADIR%%/fokker.dks
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in New Issue
Block a user