Upgrade to 0.3.5.
This commit is contained in:
parent
d6c1807c0f
commit
9775565a73
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110592
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= SimGear
|
||||
PORTVERSION= 0.3.4
|
||||
PORTVERSION= 0.3.5
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= ftp://ftp.simgear.org/pub/simgear/Source/ \
|
||||
ftp://ftp.de.flightgear.org/pub/simgear/Source/
|
||||
@ -22,12 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libmk4.so:${PORTSDIR}/databases/metakit \
|
||||
${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_MESA= yes
|
||||
USE_GL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
# Force configure to look in /usr/local/{include,lib}
|
||||
CONFIGURE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}" \
|
||||
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (SimGear-0.3.4.tar.gz) = 5eab33a6504b9cb164acdfa679914cd8
|
||||
SIZE (SimGear-0.3.4.tar.gz) = 892220
|
||||
MD5 (SimGear-0.3.5.tar.gz) = 24e87739c63c125a7c2c55836a27b121
|
||||
SIZE (SimGear-0.3.5.tar.gz) = 897193
|
||||
|
@ -13,7 +13,7 @@
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lpthread $LIBS"
|
||||
+LIBS="-pthread $LIBS"
|
||||
+LIBS="${PTHREAD_LIBS} $LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
#include "confdefs.h"
|
||||
|
13
devel/simgear/files/patch-simgear::scene::sky::cloud.cxx
Normal file
13
devel/simgear/files/patch-simgear::scene::sky::cloud.cxx
Normal file
@ -0,0 +1,13 @@
|
||||
--- simgear/scene/sky/cloud.cxx.orig Tue Jun 1 10:38:58 2004
|
||||
+++ simgear/scene/sky/cloud.cxx Tue Jun 1 10:39:08 2004
|
||||
@@ -24,8 +24,8 @@
|
||||
// #if defined (__APPLE__)
|
||||
// // any C++ header file undefines isinf and isnan
|
||||
// // so this should be included before <iostream>
|
||||
-// inline int (isinf)(double r) { return isinf(r); }
|
||||
-// inline int (isnan)(double r) { return isnan(r); }
|
||||
+inline int (isinf)(double r) { return isinf(r); }
|
||||
+inline int (isnan)(double r) { return isnan(r); }
|
||||
// #endif
|
||||
|
||||
// #include STL_IOSTREAM
|
@ -3,6 +3,7 @@ include/simgear/compiler.h
|
||||
include/simgear/constants.h
|
||||
include/simgear/debug/debug_types.h
|
||||
include/simgear/debug/logstream.hxx
|
||||
include/simgear/environment/metar.hxx
|
||||
include/simgear/ephemeris/celestialBody.hxx
|
||||
include/simgear/ephemeris/ephemeris.hxx
|
||||
include/simgear/ephemeris/jupiter.hxx
|
||||
@ -34,8 +35,7 @@ include/simgear/math/sg_memory.h
|
||||
include/simgear/math/sg_random.h
|
||||
include/simgear/math/sg_types.hxx
|
||||
include/simgear/math/vector.hxx
|
||||
include/simgear/metar/MetarReport.h
|
||||
include/simgear/metar/MetarStation.h
|
||||
include/simgear/misc/interpolator.hxx
|
||||
include/simgear/misc/sg_path.hxx
|
||||
include/simgear/misc/sgstream.hxx
|
||||
include/simgear/misc/stopwatch.hxx
|
||||
@ -43,6 +43,7 @@ include/simgear/misc/strutils.hxx
|
||||
include/simgear/misc/tabbed_values.hxx
|
||||
include/simgear/misc/texcoord.hxx
|
||||
include/simgear/misc/zfstream.hxx
|
||||
include/simgear/nasal/nasal.h
|
||||
include/simgear/props/condition.hxx
|
||||
include/simgear/props/props.hxx
|
||||
include/simgear/props/props_io.hxx
|
||||
@ -70,6 +71,7 @@ include/simgear/scene/tgdb/leaf.hxx
|
||||
include/simgear/scene/tgdb/obj.hxx
|
||||
include/simgear/scene/tgdb/pt_lights.hxx
|
||||
include/simgear/scene/tgdb/userdata.hxx
|
||||
include/simgear/scene/tgdb/vasi.hxx
|
||||
include/simgear/screen/colors.hxx
|
||||
include/simgear/screen/extensions.hxx
|
||||
include/simgear/screen/screen-dump.hxx
|
||||
@ -99,14 +101,15 @@ include/simgear/xml/easyxml.hxx
|
||||
lib/libsgbucket.a
|
||||
lib/libsgclouds3d.a
|
||||
lib/libsgdebug.a
|
||||
lib/libsgenvironment.a
|
||||
lib/libsgephem.a
|
||||
lib/libsgio.a
|
||||
lib/libsgmagvar.a
|
||||
lib/libsgmaterial.a
|
||||
lib/libsgmath.a
|
||||
lib/libsgmetar.a
|
||||
lib/libsgmisc.a
|
||||
lib/libsgmodel.a
|
||||
lib/libsgnasal.a
|
||||
lib/libsgprops.a
|
||||
lib/libsgroute.a
|
||||
lib/libsgscreen.a
|
||||
@ -135,12 +138,13 @@ lib/libsgxml.a
|
||||
@dirrm include/simgear/scene
|
||||
@dirrm include/simgear/route
|
||||
@dirrm include/simgear/props
|
||||
@dirrm include/simgear/nasal
|
||||
@dirrm include/simgear/misc
|
||||
@dirrm include/simgear/metar
|
||||
@dirrm include/simgear/math
|
||||
@dirrm include/simgear/magvar
|
||||
@dirrm include/simgear/io
|
||||
@dirrm include/simgear/ephemeris
|
||||
@dirrm include/simgear/environment
|
||||
@dirrm include/simgear/debug
|
||||
@dirrm include/simgear/bucket
|
||||
@dirrm include/simgear
|
||||
|
Loading…
Reference in New Issue
Block a user