Add ruby-refe, a Ruby interactive reference in Japanese.

This commit is contained in:
Akinori MUSHA 2002-11-24 08:33:53 +00:00
parent 050e36f275
commit 9773a43a4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70970
7 changed files with 111 additions and 0 deletions

View File

@ -316,6 +316,7 @@
SUBDIR += ruby-gyokuro
SUBDIR += ruby-kakasi
SUBDIR += ruby-man
SUBDIR += ruby-refe
SUBDIR += ruby-romkan
SUBDIR += ruby-slang
SUBDIR += ruby-tcltklib

View File

@ -0,0 +1,66 @@
# New ports collection makefile for: rbbr
# Date created: 24 November 2002
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= refe
PORTVERSION= 0.5.0
CATEGORIESf= japanese lang ruby
MASTER_SITES= http://www.loveruby.net/archive/refe/ \
http://www.ruby-lang.org/~rubikitch/refm/:refm \
http://www.loveruby.net/archive/:extrefm
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
ruby-refm.rd.gz:refm \
extrefm.rd:extrefm
DIST_SUBDIR= ruby
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= knu@FreeBSD.org
IGNOREFILES= ruby-refm.rd.gz \
extrefm.rd
USE_RUBY= yes
USE_RUBY_SETUP= yes
RUBY_SETUP= install.rb
DOCS_EN= ChangeLog \
TODO
DOCS_JA= README.ja
.include <bsd.port.pre.mk>
PKGNAMEPREFIX:= ${PKGNAMEPREFIX}${RUBY_PKGNAMEPREFIX}
.if exists(${RUBY_ARCHLIBDIR}/gdbm.so)
RUN_DEPENDS+= ${RUBY_ARCHLIBDIR}/gdbm.so:${PORTSDIR}/databases/ruby-gdbm
PLIST_SUB+= WITH_GDBM="" WITH_DBM="@comment "
.else
PLIST_SUB+= WITH_DBM="" WITH_GDBM="@comment "
.endif
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/ruby-refm.rd.gz ${WRKSRC}/
${GUNZIP_CMD} ${WRKSRC}/ruby-refm.rd.gz
${CP} ${DISTDIR}/${DIST_SUBDIR}/extrefm.rd ${WRKSRC}/
post-patch:
${RM} -f ${WRKSRC}/lib/refe/*.orig
post-install:
cd ${WRKSRC}; ${PREFIX}/bin/mkrefe -ir ruby-refm.rd
cd ${WRKSRC}; ${PREFIX}/bin/mkrefe -e extrefm.rd
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (ruby/refe-0.5.0.tar.gz) = 0b7c9aef76ae8f15cdbcf4158b06b4d7
MD5 (ruby/ruby-refm.rd.gz) = IGNORE
MD5 (ruby/extrefm.rd) = IGNORE

View File

@ -0,0 +1,11 @@
--- lib/refe/extrefparser.rb.orig Fri Mar 22 20:21:23 2002
+++ lib/refe/extrefparser.rb Sun Nov 24 17:22:24 2002
@@ -39,7 +39,7 @@
f.each do |line|
next if /\A[=\w]/ === line
if /\A: / === line then
- m = /\A: .*?(\w+)\(/.match(line) or
+ m = /\A: .*?(\w+)(\(|$)/.match(line) or
raise "parse failed: #{line.inspect}"
curr = line
table[ m[1] ] = curr

View File

@ -0,0 +1 @@
Ruby interactive reference in Japanese

View File

@ -0,0 +1,4 @@
ReFe is a Ruby interactive reference in Japanese.
Author: Minero Aoki <aamine@loveruby.net>
WWW: http://www.loveruby.net/ja/prog/refe.html

View File

@ -0,0 +1,25 @@
bin/mkrefe
bin/refe
%%RUBY_SITELIBDIR%%/refe/completion.rb
%%RUBY_SITELIBDIR%%/refe/config.rb
%%RUBY_SITELIBDIR%%/refe/database.rb
%%RUBY_SITELIBDIR%%/refe/extrefparser.rb
%%RUBY_SITELIBDIR%%/refe/info.rb
%%RUBY_SITELIBDIR%%/refe/mtable.rb
%%RUBY_SITELIBDIR%%/refe/mtof.rb
%%RUBY_SITELIBDIR%%/refe/mygetopt.rb
%%RUBY_SITELIBDIR%%/refe/rubyrefmparser.rb
%%RUBY_SITELIBDIR%%/refe/rubysrcparser.rb
@dirrm %%RUBY_SITELIBDIR%%/refe
%%WITH_GDBM%%share/refe/fdoc
%%WITH_DBM%%share/refe/fdoc.db
share/refe/ftable
%%WITH_GDBM%%share/refe/mdoc
%%WITH_DBM%%share/refe/mdoc.db
share/refe/mtable
@dirrm share/refe
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TODO
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%