- Unbreak the build on PowerPC by using modern GCC version

- Do not use += to set initial CONFIGURE_ARGS value
- Convert to option helpers and new test framework (TEST_TARGET)
- Remove extra patch that prevented installation of the example files
  (it is not needed in the post-staging era: running `make package
  OPTIONS_UNSET=EXAMPLES -DBATCH' will produce package without the
  exampes by default, requiring no special hacks)
- Wrap one overly long line by optimizing away one of the STRIP_CMD's
This commit is contained in:
Alexey Dokuchaev 2015-11-20 08:02:26 +00:00
parent 0962fbef57
commit 976b3538bd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=401989
2 changed files with 10 additions and 44 deletions

View File

@ -23,10 +23,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
USES= compiler:features gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-ilmbasetest --enable-imfexamples
CONFIGURE_ARGS= --disable-ilmbasetest --enable-imfexamples
USE_LDCONFIG= yes
CPPFLAGS+= -I. -I../IlmImf
TEST_TARGET= check
CPPFLAGS+= -I. -I../IlmImf
# must be linked with -l{thr|pthread} explicitly
LDFLAGS+= -lpthread
@ -49,6 +50,10 @@ LARGE_STACK_CONFIGURE_ENABLE= large-stack
.include <bsd.port.pre.mk>
.if ${ARCH} == powerpc
USE_GCC= yes
.endif
MAJORVER= 2_2
VER= 22
@ -75,17 +80,11 @@ pre-configure:
${ECHO_CMD} "*** same C++ std. library before trying to build OpenEXR. Abort. ***" ; \
exit 1; }
.if ! ${PORT_OPTIONS:MEXAMPLES}
EXTRA_PATCHES+=${FILESDIR}/extra-patch-IlmImfExamples__Makefile.in
.endif
regression-test regression test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${_MAKE_JOBS} check)
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImf-${MAJORVER}.so.${VER}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImfUtil-${MAJORVER}.so.${VER}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImf-${MAJORVER}.so.${VER} \
${STAGEDIR}${PREFIX}/lib/libIlmImfUtil-${MAJORVER}.so.${VER}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}

View File

@ -1,33 +0,0 @@
--- ./IlmImfExamples/Makefile.in.orig 2014-03-24 18:28:37.886449236 +0100
+++ ./IlmImfExamples/Makefile.in 2014-03-24 18:33:52.637113427 +0100
@@ -356,18 +356,18 @@
clean-libtool:
-rm -rf .libs _libs
-install-examplesDATA: $(examples_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(examplesdir)" || $(MKDIR_P) "$(DESTDIR)$(examplesdir)"
- @list='$(examples_DATA)'; test -n "$(examplesdir)" || list=; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \
- done | $(am__base_list) | \
- while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(examplesdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(examplesdir)" || exit $$?; \
- done
+#install-examplesDATA: $(examples_DATA)
+# @$(NORMAL_INSTALL)
+# test -z "$(examplesdir)" || $(MKDIR_P) "$(DESTDIR)$(examplesdir)"
+# @list='$(examples_DATA)'; test -n "$(examplesdir)" || list=; \
+# for p in $$list; do \
+# if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+# echo "$$d$$p"; \
+# done | $(am__base_list) | \
+# while read files; do \
+# echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(examplesdir)'"; \
+# $(INSTALL_DATA) $$files "$(DESTDIR)$(examplesdir)" || exit $$?; \
+# done
uninstall-examplesDATA:
@$(NORMAL_UNINSTALL)