comms/hamlib: Update to 4.5.3

Fairly lengthy changes we were quite out of date...
I did do a quick API check.

Version 4.5.3
	* 2022-12-31
	* Fix serial.c for hardware flow control on Linux and MacOSy
	* Add QRPLabs QCX/QDX rig -- not quite a TS480
	* Fix QRP QRDX firmware bugs in IF message so PTT works now
	* FTDX5000 will now remember startup front/read settings and restore it
	* Fix FTDX5000 write_delay with microham
	* Fix grep error on MingW build

Version 4.5.2
	* 2022-12-23
	* Fix PowerSDR ability to do commands while powered off
	* Fix TX-500 operations
	* Fix FTDX5000 to return to MIC input on closing
	* Fix rig.c calling rig_get_mode when backend does not have get_mode
	* Fix kenwood_ts890_get_level
	* Add Prosistel D elevation CBOX az to fix problem with azimuth control
	* Fix FT736R gpredict usage by adding cached get_freq
	* Fix get_powerstat problem with Log4OM/Flex and others
	* Fix -R option to not need argument
	* Fix -R option to close rig on last rigctld client disconnect
	* Add FTDX1200 to rigs that need to ensure PTT is off before changing frequency
	* Add --disable-parallel configure option for mingw builds on Linux

Version 4.5.1
	* 2022-12-08
	* FT2000, FTDX3000/D, FT891, FT991, FT950, FTDX5000 now set CAT TOT to 100ms
	* Add missing NB2 setting to FT-950, FTDX-1200, FT-2000, FTDX-3000, FTDX-5000, FTDX-9000
	* Add missing meter reading to TS-890S -- thanks to Geore Baltz N3GB
	* Fix FT736 VFOB freq and mode set
	* Added send_raw to rigctl -- see rigctl man page
	* Fix AGC Level dumpcaps on most rigs
	* Fix rig_send_raw to return bytes read, fill buffer, and also work with fixed length response/null terminator
	* Change all Kenwood rigs to 500ms serial timeout
	* Fix dumpcaps filter printout to only show declared filters
	* Fix triggering PTT on XGComms device on Linux
	* Fix level_gran in all rigs
	* Add RIG_FUNC_TUNER to flrig.c
	* Fix FT-991 level_gran (needs to be done for lots of rigs)
	* Fix man page rigctl to show units for LEVEL items
	* Fix Flex6xxx if_len
	* Fix FLRig set_ptt
	* Fix missing KEYSPD to TS890
	* rigctl 'W' command can now use a singled char terminator like ; that allows for variable length responses with no timeout -- e.g.  W FA; ;
	* New RIG_LEVEL_USB_AF to control audio gain from rig to computer -- to allow AGC function in software using RF and USB_AF
	* Add RIG_LEVEL_AGC_TIME to allow AGC/OFF to be set for IC-7300, IC-9700, IC-705
	* Add RIG_FUNC_OVF_STATUS to get overflow status for IC-7300, IC-9700, IC-705, and IC-R8600

Version 4.5
	* 2022-10-30
	* New rotator utility https://www.pianetaradio.it/blog/catrotator/
	* Add FT-710
	* Add Rohde&Schwartz EK89X receiver
	* Add Xeigu X5105
	* Add Gemini DX-1200 HF-1K Amplifiers
	* Kenwood rigs should now support AI command packets
	* Add FT-990UNI for older 990 ROMs 1.2 and earlier
	* Add FT-650
	* Add get_separator and set_separator and -S option for rigctld -- node-red applicability
	* Add GRBLTRK rotor project -- two axis rotor
	* Add SDRPlay SDRUno rig -- can now use Data/Pkt in WSJTX
	* Add ability to use cat_string to FLRig via the "w" and "W" commands
	* Add -B/--mapa2b to rigctlcom
	  Allows rigctlcom to map set_freq on VFOA to VFOB instead
	  This will allow CW Skimmer to work with some rigs (e.g. IC7300) using FM
	  mode on VFOA and CW mode on VFOB and split mode transmit on VFOB.
	  Clicking on CW Skimmer will change VFOB instead of VFOA to allow working
	  dxpeditions where the fox is staying on frequency
	* Add password capability to rigctld via -A switch.
	  rigctld -A will produce a consistent shared key for any specific password that can used in \password and rig_set_password
	  TBD The shared key can also be placed in .hamlib_settings
	* Asynchronous rig data output handling to support transceive and spectrum data. Mikael, OH3BHX
	  Example for the IC-7300 to multicast on port 20001 and provide async rig information
	  rigctld --port=20001 --model=3073 --serial-speed=115200 --rig-file=/dev/serial/... --set-conf=rts_state=OFF --set-conf=dtr_state=OFF --multicast-addr=224.0.0.1 --multicast-port=20001 --set-conf=async=1
	  Also, spectrum data output needs to be enabled with: \set_func SPECTRUM 1
	* See new set_conf option async for some Icom rigs
	* Multicast UDP packet output for asynchronous data. Mikael, OH3BHX
	* Rig state poll routine to serve commonly used data like frequency and mode from cache. Mikael, OH3BHX
	* deprecated hamlib_port_t at front of rig_state structure -- new one at end of structure
	* New rig_send_raw to send/read raw command to rig
	* New RIG_LEVEL_BAND_SELECT for Yaesu rigs
	* New rig_get_conf2 to replace rig_get_conf buffer overflow potential
	* New rot_get_conf2 to reaplce rot_get_conf buffer overflow potential
	* Added Barrett 4050 -- not functional yet
	* Added TCI 1.X -- not functional yet
	* Added TM-V71(A)
	* Added IC-F8101
	* Added JRC JST-145 and JST-245
	* Added Xiegu X108G, G90, and X6100
	* Added CODAN Envoy and NGS
	* Added Lab599 TX-500
	* Added GOMSPACE GS100
	* Deprecated: rigctl commands \set_trn (A) and \get_trn (a) as they never worked as intended
	* Deprecated: field rig_caps.transceive and RIG_TRN_* macros

PR:		ports/267682
Reported by:	takefu@airport.fm
Tested by:	db
This commit is contained in:
Diane Bruce 2023-01-24 13:24:51 -05:00
parent db9cfcf3e8
commit 974c429b89
6 changed files with 13 additions and 58 deletions

View File

@ -1,6 +1,5 @@
PORTNAME= hamlib
PORTVERSION= 4.4
PORTREVISION= 3
PORTVERSION= 4.5.3
CATEGORIES= comms hamradio
MASTER_SITES= SF
@ -27,16 +26,13 @@ CONFIGURE_ARGS= --with-perl-binding \
--with-tcl-binding --with-tcl=${TCL_LIBDIR} \
--with-libusb \
--with-python-binding
CONFIGURE_ENV= LIBUSB_LIBS="-lusb"
CONFIGURE_ENV= LIBUSB_LIBS="-lusb" cf_with_cxx=yes
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
PLIST_SUB= VER=${PORTVERSION} TCL_VER=${TCL_VER}
PLIST_SUB= TCL_VER=${TCL_VER}
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|python3-config|${PYTHON_CMD}-config|g' \
${WRKSRC}/macros/ax_python_devel.m4
post-build:
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' \
${WRKSRC}/bindings/Hamlib-pl.mk

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1641893139
SHA256 (hamlib-4.4.tar.gz) = 8bf0107b071f52f08587f38e2dee8a7848de1343435b326f8f66d95e1f8a2487
SIZE (hamlib-4.4.tar.gz) = 2401399
TIMESTAMP = 1672594651
SHA256 (hamlib-4.5.3.tar.gz) = e1818e9df0e59023d2dff320c41c5c622b02a0afd3e50c3155694e1a9014f260
SIZE (hamlib-4.5.3.tar.gz) = 2590200

View File

@ -1,6 +1,6 @@
--- hamlib.pc.in.orig 2021-12-03 00:09:30 UTC
--- hamlib.pc.in.orig 2022-10-30 00:06:12 UTC
+++ hamlib.pc.in
@@ -7,7 +7,6 @@ Name: @PACKAGE_NAME@
@@ -7,7 +7,6 @@ Version: @PACKAGE_VERSION@
Description: Library to control radio and rotator equipment.
URL: @PACKAGE_URL@
Version: @PACKAGE_VERSION@

View File

@ -1,21 +0,0 @@
--- include/hamlib/rig.h.orig 2021-12-03 00:09:30 UTC
+++ include/hamlib/rig.h
@@ -1124,8 +1124,8 @@ typedef uint64_t setting_t;
#define RIG_FUNC_TRANSCEIVE CONSTANT_64BIT_FLAG (42) /*!< \c TRANSCEIVE -- Send radio state changes automatically ON/OFF */
#define RIG_FUNC_SPECTRUM CONSTANT_64BIT_FLAG (43) /*!< \c SPECTRUM -- Spectrum scope data output ON/OFF */
#define RIG_FUNC_SPECTRUM_HOLD CONSTANT_64BIT_FLAG (44) /*!< \c SPECTRUM_HOLD -- Pause spectrum scope updates ON/OFF */
-#define RIG_FUNC_BIT45 CONSTANT_64BIT_FLAG (45) /*!< \c available for future RIG_FUNC items */
-#define RIG_FUNC_BIT46 CONSTANT_64BIT_FLAG (46) /*!< \c available for future RIG_FUNC items */
+#define RIG_FUNC_SEND_MORSE CONSTANT_64BIT_FLAG (45) /*!< \c SEND_MORSE -- Send specified characters using CW */
+#define RIG_FUNC_SEND_VOICE_MEM CONSTANT_64BIT_FLAG (46) /*!< \c SEND_VOICE_MEM -- Transmit in SSB message stored in memory */
#define RIG_FUNC_BIT47 CONSTANT_64BIT_FLAG (47) /*!< \c available for future RIG_FUNC items */
#define RIG_FUNC_BIT48 CONSTANT_64BIT_FLAG (48) /*!< \c available for future RIG_FUNC items */
#define RIG_FUNC_BIT49 CONSTANT_64BIT_FLAG (49) /*!< \c available for future RIG_FUNC items */
@@ -2063,6 +2063,7 @@ enum rig_function_e {
RIG_FUNCTION_SEND_MORSE,
RIG_FUNCTION_STOP_MORSE,
RIG_FUNCTION_WAIT_MORSE,
+ RIG_FUNCTION_SEND_VOICE_MEM,
RIG_FUNCTION_SET_BANK,
RIG_FUNCTION_SET_MEM,
RIG_FUNCTION_GET_MEM,

View File

@ -1,21 +0,0 @@
--- src/misc.c.orig 2021-12-03 00:09:30 UTC
+++ src/misc.c
@@ -884,6 +884,8 @@ static const struct
{ RIG_LEVEL_SPECTRUM_AVG, "SPECTRUM_AVG" },
{ RIG_LEVEL_SPECTRUM_ATT, "SPECTRUM_ATT" },
{ RIG_LEVEL_TEMP_METER, "TEMP_METER" },
+ { RIG_FUNC_SEND_MORSE, "SEND_MORSE" },
+ { RIG_FUNC_SEND_VOICE_MEM, "SEND_VOICE_MEM" },
{ RIG_LEVEL_NONE, "" },
};
@@ -2254,6 +2256,9 @@ void *HAMLIB_API rig_get_function_ptr(rig_model_t rig_
case RIG_FUNCTION_WAIT_MORSE:
return caps->wait_morse;
+
+ case RIG_FUNCTION_SEND_VOICE_MEM:
+ return caps->send_voice_mem;
case RIG_FUNCTION_SET_BANK:
return caps->set_bank;

View File

@ -11,6 +11,7 @@ bin/rotctld
include/hamlib/ampclass.h
include/hamlib/amplifier.h
include/hamlib/amplist.h
include/hamlib/config.h
include/hamlib/rig.h
include/hamlib/rig_dll.h
include/hamlib/rigclass.h
@ -22,12 +23,12 @@ lib/libhamlib++.a
lib/libhamlib++.la
lib/libhamlib++.so
lib/libhamlib++.so.4
lib/libhamlib++.so.4.0.4
lib/libhamlib++.so.4.0.6
lib/libhamlib.a
lib/libhamlib.la
lib/libhamlib.so
lib/libhamlib.so.4
lib/libhamlib.so.4.0.4
lib/libhamlib.so.4.0.6
%%SITE_ARCH%%/Hamlib.pm
%%SITE_ARCH%%/auto/Hamlib/Hamlib.so
%%SITE_ARCH%%/perltest.pl
@ -37,7 +38,7 @@ lib/libhamlib.so.4.0.4
%%PYTHON_SITELIBDIR%%/_Hamlib.so
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.opt-1.pyc
%%PYTHON_SITELIBDIR%%/__pycache__/Hamlib%%PYTHON_EXT_SUFFIX%%.pyc
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-%%VER%%.so
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl-4.6.so
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.a
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.la
lib/tcl%%TCL_VER%%/Hamlib/hamlibtcl.so
@ -45,8 +46,8 @@ lib/tcl%%TCL_VER%%/Hamlib/pkgIndex.tcl
libdata/pkgconfig/hamlib.pc
man/man1/ampctl.1.gz
man/man1/ampctld.1.gz
man/man1/rigctlcom.1.gz
man/man1/rigctl.1.gz
man/man1/rigctlcom.1.gz
man/man1/rigctld.1.gz
man/man1/rigmem.1.gz
man/man1/rigsmtr.1.gz