Make PREFIX clean and respect CFLAGS.

PR:		21365
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
David E. O'Brien 2000-11-11 06:34:39 +00:00
parent 6049e123ea
commit 972c1774be
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34987
5 changed files with 64 additions and 37 deletions

View File

@ -11,7 +11,7 @@ PORTVERSION= 5.21b
CATEGORIES= comms
MASTER_SITES= ftp://ftp.uu.net/vendor/bitsko/config-mgmt/ \
ftp://unix.hensa.ac.uk/mirrors/uunet/vendor/bitsko/config-mgmt/
DISTNAME= conserver-5.21-Beta
DISTNAME= ${PORTNAME}-5.21-Beta
EXTRACT_SUFX= .shar.gz
MAINTAINER= obrien@FreeBSD.org
@ -30,16 +30,15 @@ MAKE_ENV+= DEFAULTHOST="${DEFAULTHOST}"
# XXX we also have to work around ``new'' uudecode behavior, thanks guys!
post-extract:
${CP} ${FILESDIR}/Makefile ${WRKSRC}
if [ -f ${WRKSRC}/group.c ]; then \
${MV} ${WRKSRC}/group.c ${WRKSRC}/conserver/group.c ; \
fi
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
.if !exists(${WRKSRC}/group.c)
@${MV} ${WRKSRC}/group.c ${WRKSRC}/conserver/group.c
.endif
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/conserver.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/conserver.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/conserver.sh \
${PREFIX}/etc/rc.d/conserver.sh; \
fi
.if !exists(${PREFIX}/etc/rc.d/conserver.sh)
@${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/conserver.sh startup file."
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/conserver.sh ${PREFIX}/etc/rc.d
.endif
.include <bsd.port.mk>

View File

@ -1,33 +1,46 @@
--- conserver/Makefile.orig Sat Nov 22 20:42:18 1997
+++ conserver/Makefile Sat Nov 22 20:43:24 1997
@@ -8,6 +8,6 @@
--- conserver/Makefile.orig Fri Nov 10 22:22:39 2000
+++ conserver/Makefile Fri Nov 10 22:26:14 2000
@@ -7,8 +7,9 @@
# (1) change ETC below to where you would like the console server installed
# I would not change the name, you have to much with the docs then...
PROG= conserver
-ETC= ${DESTDIR}/usr/local/etc
-DOC= ${DESTDIR}/usr/local/man
+ETC= ${PREFIX}/sbin
+DOC= ${PREFIX}/man/man8
+CONFIG= ${PREFIX}/etc/conserver.cf
# if we have to PUCC ptyd daemon we can use it to get ptys, else use fallback.o
@@ -25,5 +25,5 @@
INCLUDE=
DEBUG=-O
-CDEFS= -DSUN5 -DHAVE_PTYD=0 -DDO_VIRTUAL=1
+CDEFS= -DFREEBSD -DHAVE_PTYD=0 -DDO_VIRTUAL=1 -DPORT=782
CFLAGS= ${DEBUG} ${CDEFS} ${INCLUDE}
# and change the CDEFS line below to =0
@@ -23,9 +24,9 @@
P=
@@ -42,5 +42,5 @@
INCLUDE=
-DEBUG=-O
-CDEFS= -DSUN5 -DHAVE_PTYD=0 -DDO_VIRTUAL=1
-CFLAGS= ${DEBUG} ${CDEFS} ${INCLUDE}
+#DEBUG=-O
+CDEFS= -DFREEBSD -DHAVE_PTYD=0 -DDO_VIRTUAL=1 -DPORT=782 -DCONFIG=\"${CONFIG}\"
+CFLAGS+= ${DEBUG} ${CDEFS} ${INCLUDE}
HDR= cons.h \
access.h client.h consent.h group.h main.h master.h \
@@ -41,7 +42,7 @@
all: ${PROG}
${PROG}:$P ${OBJ}
- ${CC} -o $@ ${CFLAGS} ${OBJ} ${PUCCLIB} -lsocket -lnsl
+ ${CC} -o $@ ${CFLAGS} ${OBJ} ${PUCCLIB} -lcrypt
clean: FRC
@@ -60,5 +60,6 @@
rm -f Makefile.bak ${PROG} a.out *.o core errs lint.out tags
@@ -59,7 +60,8 @@
distrib -c ${ETC}/${PROG}
install: all dirs FRC
- install -c -s ${PROG} ${ETC}/${PROG}
+ install -c -s -o bin -g bin -m 555 ${PROG} ${ETC}/${PROG}
+ install -c -o bin -g bin -m 444 ${MAN} ${DOC}/conserver.8
+ ${BSD_INSTALL_PROGRAM} ${PROG} ${ETC}/${PROG}
+ ${BSD_INSTALL_MAN} ${MAN} ${DOC}/conserver.8
lint: ${HDR} ${SRC} FRC
lint -h ${CDEFS} ${INCLUDE} ${SRC}

View File

@ -1,5 +1,5 @@
--- console/Makefile.orig Sat Nov 22 23:02:48 1997
+++ console/Makefile Sat Nov 22 23:03:45 1997
--- console/Makefile.orig Fri Nov 10 22:22:39 2000
+++ console/Makefile Fri Nov 10 22:30:59 2000
@@ -6,8 +6,8 @@
# edit the ETC directory below to change where the console client
# is installed.
@ -11,15 +11,19 @@
I=/usr/include
S=/usr/include/sys
@@ -17,7 +17,7 @@
@@ -16,9 +16,9 @@
P=
INCLUDE= -I$C
DEBUG=-O
-DEBUG=-O
-CDEFS= -DSUN5
-CFLAGS= ${DEBUG} ${CDEFS} ${INCLUDE}
+#DEBUG=-O
+CDEFS= -DFREEBSD -DHOST=\"${DEFAULTHOST}\" -DPORT=782
CFLAGS= ${DEBUG} ${CDEFS} ${INCLUDE}
+CFLAGS+= ${DEBUG} ${CDEFS} ${INCLUDE}
HDR=
ONEC= console.c
@@ -29,7 +29,7 @@
all: ${PROG}
@ -34,8 +38,8 @@
install: all dirs FRC
- install -cs ${PROG} ${ETC}/${PROG}
+ install -c -s -o bin -g bin -m 555 ${PROG} ${ETC}/${PROG}
+ install -c -o bin -g bin -m 444 ${MAN} ${DOC}/console.8
+ ${BSD_INSTALL_PROG} ${PROG} ${ETC}/${PROG}
+ ${BSD_INSTALL_MAN} ${MAN} ${DOC}/console.8
lint: ${HDR} ${ONEC} FRC
lint -h ${CDEFS} ${INCLUDE} ${ONEC}

View File

@ -29,8 +29,8 @@
install: all dirs FRC
- install -c ${PROG} ${LIB}/${PROG}
+ install -c -o bin -g bin -m 444 ${PROG} ${LIB}
+ install -c -o bin -g bin -m 444 ${MAN} ${DOC}/conserver.cf.5
+ ${BSD_INSTALL_PROG} ${PROG} ${LIB}
+ ${BSD_INSTALL_MAN} ${MAN} ${DOC}/conserver.cf.5
lint: FRC

View File

@ -1,6 +1,6 @@
--- autologin/Makefile Sun Apr 19 03:51:53 1998
+++ autologin/Makefile Sun Apr 19 03:54:02 1998
@@ -7,11 +7,11 @@
--- autologin/Makefile.orig Fri Nov 10 22:22:39 2000
+++ autologin/Makefile Fri Nov 10 22:32:54 2000
@@ -7,12 +7,12 @@
#
DESTDIR=
@ -10,8 +10,19 @@
INCLUDE=
-DEBUG= -g
-DEFS= -DPUCC -DSUN5
+DEBUG= -O
-CFLAGS= ${DEBUG} ${DEFS} ${INCLUDE}
+#DEBUG= -O
+DEFS= -DFREEBSD
CFLAGS= ${DEBUG} ${DEFS} ${INCLUDE}
+CFLAGS+= ${DEBUG} ${DEFS} ${INCLUDE}
GENC= main.c
GENH= main.h
@@ -56,7 +56,7 @@
lint -h ${CDEFS} ${INCLUDE} ${GEN} ${SRC}
install: all
- install -c -s -m 755 autologin ${BINDIR}
+ ${BSD_INSTALL_PROGRAM} autologin ${BINDIR}
distrib:
distrib -c ${BINDIR}/autologin