Remove ascend-radius port

PR:		37783
Submitted by:	Jeff Palmer <scorpio@drkshdw.org>
This commit is contained in:
Mark Pulford 2002-09-05 07:59:37 +00:00
parent 6473683779
commit 96e4f27c39
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65668
14 changed files with 0 additions and 415 deletions

View File

@ -23,7 +23,6 @@
SUBDIR += arprelease
SUBDIR += arpwatch
SUBDIR += arts++
SUBDIR += ascend-radius
SUBDIR += asfrecorder
SUBDIR += aslookup
SUBDIR += balance

View File

@ -1,61 +0,0 @@
# New ports collection makefile for: ascend-radius
# Date created: August 28th 96
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ascend-radius
PORTVERSION= 980618
CATEGORIES= net
MASTER_SITES= ftp://ftp.ascend.com/pub/Software-Releases/Radius/Current/ \
ftp://ftp.ascend.com/pub/Software-Releases/Radius/Current/doc/ \
ftp://ftp.ascend.com/pub/Software-Releases/Radius/Archive/ \
ftp://ftp.ascend.com/pub/Software-Releases/Radius/Archive/doc/
DISTFILES= radius-980618.tar.gz \
radius.ps \
radius.pdf \
980618.ps \
980618.pdf
EXTRACT_ONLY= radius-980618.tar.gz
FORBIDDEN= "Remotely exploitable buffer overflow"
MAINTAINER= ports@FreeBSD.org
WRKPREFIX= radius-980618/radius-1.16-ascend
WRKSRC= ${WRKDIR}/${WRKPREFIX}/ascendd
ALL_TARGET= all dbm
MAN1= builddbm.1 users-file-syntax.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/radiusd ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/radiusd.dbm ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/builddbm ${PREFIX}/sbin
${INSTALL_MAN} ${WRKDIR}/${WRKPREFIX}/man1/users-file-syntax.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKDIR}/${WRKPREFIX}/man1/builddbm.1 ${PREFIX}/man/man1
.ifndef NOPORTDOCS
@ ${MKDIR} ${PREFIX}/share/doc/ascend-radius
for file in ascend.doc draft-ietf-radius-accounting-01.txt draft-ietf-radius-radius-03.txt draft-ietf-radius-radius-04.txt; do \
${INSTALL_DATA} ${WRKDIR}/${WRKPREFIX}/doc/$$file ${PREFIX}/share/doc/ascend-radius; \
done
for file in ChangeLog README README.cexample README.dict; do \
${INSTALL_DATA} ${WRKDIR}/${WRKPREFIX}/$$file ${PREFIX}/share/doc/ascend-radius; \
done
${INSTALL_DATA} ${DISTDIR}/radius.ps ${PREFIX}/share/doc/ascend-radius
${INSTALL_DATA} ${DISTDIR}/radius.pdf ${PREFIX}/share/doc/ascend-radius
${INSTALL_DATA} ${DISTDIR}/980618.ps ${PREFIX}/share/doc/ascend-radius
${INSTALL_DATA} ${DISTDIR}/980618.pdf ${PREFIX}/share/doc/ascend-radius
.endif
@ ${MKDIR} ${PREFIX}/etc/raddb
@ ${CHOWN} root:wheel ${PREFIX}/etc/raddb
@ ${CHMOD} 700 ${PREFIX}/etc/raddb
for file in clients.example dictionary users.example; do \
${INSTALL} -c -o root -g wheel -m 0400 ${WRKDIR}/${WRKPREFIX}/raddb/$$file ${PREFIX}/etc/raddb; \
done
@ ${MKDIR} /var/log/radacct
@ ${CHOWN} root:wheel /var/log/radacct
@ ${CHMOD} 700 /var/log/radacct
.include <bsd.port.mk>

View File

@ -1,5 +0,0 @@
MD5 (radius-980618.tar.gz) = 770058923f51ab2392c5b90ad27799bb
MD5 (radius.ps) = ca2a732ba76c912e37affa35e2b725d6
MD5 (radius.pdf) = 3fd800184323d0cd1fb9be2018d676a8
MD5 (980618.ps) = 2ff4fa9d8bedfa6ce3ddbf67fb6e4f2a
MD5 (980618.pdf) = 8ac2d94e92e600347133119eab19a6de

View File

@ -1,50 +0,0 @@
--- Makefile.orig Tue Oct 29 14:44:07 1996
+++ Makefile Fri Jan 24 05:00:19 1997
@@ -111,8 +111,8 @@
# Pick your compiler
#
#CC= gcc -ansi -Wall # set the GCC compiler to ANSI mode and picky
-CC= gcc -ansi # set the GCC compiler to ANSI mode
-#CC= gcc # set the GCC compiler for BSDI and friends
+#CC= gcc -ansi # set the GCC compiler to ANSI mode
+CC= gcc # set the GCC compiler for BSDI and friends
#CC= cc -Xc -v -fd # set the SUN compiler to full-whine ANSI mode
#CC= cc -Xc -v # set the SUN compiler to partial-whine ANSI mode
#CC= cc -Xc # set the SUN compiler to ANSI mode
@@ -132,7 +132,7 @@
# use this for BSDI
#CFLAGS= -O -DNOSHADOW -DBSDI -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
# use this for SunOS
-CFLAGS= -O -DNOSHADOW -DOSUN -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
+#CFLAGS= -O -DNOSHADOW -DOSUN -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
# use this for Solaris 2.1 - 2.4
#CFLAGS= -O -Dsys5 -DSOLARIS -D_SVID_GETTOD -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
# use this for Solaris 2.5
@@ -140,7 +140,7 @@
# use this for Linux
#CFLAGS= -g -Dsys5 -DNOSHADOW -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
# use this for FreeBSD
-#CFLAGS= -O -DNOSHADOW -DFreeBSD -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
+CFLAGS= -O -DNOSHADOW -D_HAVE_PARAM_H -DUSE_NDBM -DFreeBSD -DBINARY_FILTERS -DASCEND_SECRET -DASCEND_LOGOUT $(AUTH_SERVERS)
# Pick any load options and the load libraries. The AUTH_LIBS
# are selected above
@@ -150,14 +150,14 @@
# See above for the things you may need to add here
#
#LIBS= $(AUTH_LIBS) # use this for Linux, BSDI and friends
-LIBS= -lnsl $(AUTH_LIBS) # use this for SunOS
+#LIBS= -lnsl $(AUTH_LIBS) # use this for SunOS
#LIBS= -lnsl -lsocket $(AUTH_LIBS) # use this for Solaris 2.x
-#LIBS= -lcrypt $(AUTH_LIBS) # use this for FreeBSD
+LIBS= -lcrypt $(AUTH_LIBS) # use this for FreeBSD
# use this for SunOs. Linux, BSDI, FreeBSD
-DBMLIBS= -ldbm
+#DBMLIBS= -ldbm
# use this for Solaris
-#DBMLIBS=
+DBMLIBS=
CMN_OBJS=radiusd.o dict.o util.o md5.o attrprint.o filters.o \
usr_read.o cache.o des.o radipa.o strerror.o

View File

@ -1,13 +0,0 @@
--- cache.c.orig Tue Oct 29 14:41:54 1996
+++ cache.c Fri Jan 24 05:02:11 1997
@@ -12,6 +12,10 @@
* FOR A PARTICULAR PURPOSE.
*/
+#if defined(_HAVE_PARAM_H)
+#include <sys/param.h>
+#endif
+
#include <sys/types.h>
#include <ctype.h>
#if defined(BSDI) || defined(FreeBSD)

View File

@ -1,13 +0,0 @@
--- conf.h.orig Tue Oct 29 14:41:54 1996
+++ conf.h Fri Jan 24 05:02:40 1997
@@ -27,6 +27,10 @@
*
*/
+#if defined(_HAVE_PARAM_H)
+#include <sys/param.h>
+#endif
+
#ifndef _conf_h_
#define _conf_h_

View File

@ -1,34 +0,0 @@
--- radiusd.c.orig Thu Sep 19 20:20:38 1996
+++ radiusd.c Mon Sep 23 21:42:03 1996
@@ -40,6 +40,10 @@
static char sccsid[] =
"@(#)radiusd.c 1.17 Copyright 1992 Livingston Enterprises Inc";
+#if defined(_HAVE_PARAM_H)
+#include <sys/param.h>
+#endif
+
#include <sys/types.h>
#include <sys/socket.h>
#include <sys/file.h>
@@ -151,8 +155,10 @@
#if defined(sys5) || defined(BSDI)
extern char *crypt P__((CONST char *, CONST char *));
#else
+#if ! (defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__))
extern char *crypt P__((u_char *, u_char *));
#endif
+#endif
static void insertValuePair P__((VALUE_PAIR** list, VALUE_PAIR* pair));
static VALUE_PAIR *copyValuePair P__((VALUE_PAIR* source));
static AUTH_HDR *prepare_send_buffer P__((AUTH_REQ *authreq, int code));
@@ -1727,7 +1733,8 @@
VALUE_PAIR *checkList;
VALUE_PAIR *replyList;
{
- pairfree(authInfo->cutList);
+ if (authInfo->cutList != authInfo->authreq->request)
+ pairfree(authInfo->cutList);
authInfo->cutList = (VALUE_PAIR *)0;
pairfree( checkList );
pairfree( replyList );

View File

@ -1,11 +0,0 @@
--- radius.h.orig Tue Oct 29 14:41:54 1996
+++ radius.h Fri Jan 24 05:05:08 1997
@@ -224,7 +224,7 @@
/* Default Database File Names */
-#define RADIUS_DIR "/etc/raddb"
+#define RADIUS_DIR "@@PREFIX@@/etc/raddb"
#ifdef FreeBSD
#define RADACCT_DIR "/var/log/radacct"
#else

View File

@ -1,96 +0,0 @@
--- users.c.orig Fri Jun 19 05:27:37 1998
+++ users.c Thu Dec 3 13:27:15 1998
@@ -32,6 +32,10 @@
static char sccsid[] =
"@(#)users.c 1.12 Copyright 1992 Livingston Enterprises Inc";
+#if defined(_HAVE_PARAM_H)
+#include <sys/param.h>
+#endif
+
#include <sys/types.h>
#include <sys/socket.h>
#include <sys/time.h>
@@ -50,18 +54,30 @@
# if defined(SOLARIS)
# include </usr/ucbinclude/dbm.h>
# else
+# if defined(USE_NDBM)
+# include <ndbm.h>
+# else
# include <dbm.h>
+# endif
# endif /* SOLARIS */
#endif /* DBM_MODE */
#include "radius.h"
#include "protos.h"
+#if (defined(BSD) && (BSD>=199306))
+#include <fcntl.h>
+#endif
+
extern char *progname;
extern int debug_flag;
extern char *radius_dir;
extern char *radius_users;
+#if (defined(DBM_MODE) && defined(USE_NDBM))
+DBM *dbp;
+#endif
+
static int parse_record P__((char *name, char *linep,
VALUE_PAIR **check_first, VALUE_PAIR **reply_first));
extern int user_read P__((FILE **userfp_p, char *name, char *content));
@@ -99,7 +115,15 @@
{
#if defined(DBM_MODE)
(void)userfp_p;
+#if defined(USE_NDBM)
+ if(!(dbp=dbm_open(infoname, O_RDONLY, NULL))) {
+ return(-1);
+ } else {
+ return(0);
+ }
+#else
return dbminit(infoname);
+#endif
#else
*userfp_p = fopen(infoname, "r");
return *userfp_p == (FILE *)NULL;
@@ -122,7 +146,11 @@
{
#if defined(DBM_MODE)
(void)userfp;
+#if defined(USE_NDBM)
+ dbm_close(dbp);
+#else
dbmclose();
+#endif
#else
DEBUG("userinfo_close: fclosing fp=%p\n", userfp );
fclose(userfp);
@@ -219,7 +247,11 @@
#ifdef DBM_MODE
named.dptr = name;
named.dsize = strlen(name)+1;
+#if defined(USE_NDBM)
+ contentd = dbm_fetch(dbp,named);
+#else
contentd = fetch(named);
+#endif
if(contentd.dsize != 0) { /* name found */
*user_data = contentd.dptr;
userinfo_close(userfp);
@@ -228,7 +260,11 @@
named.dptr = "DEFAULT";
named.dsize = sizeof("DEFAULT");
+#if defined(USE_NDBM)
+ contentd = dbm_fetch(dbp,named);
+#else
contentd = fetch(named);
+#endif
if(contentd.dsize != 0) { /* DEFAULT found */
*user_data = contentd.dptr;
userinfo_close(userfp);

View File

@ -1,103 +0,0 @@
--- builddbm.c.orig Tue Jun 2 09:32:29 1998
+++ builddbm.c Thu Dec 3 13:18:30 1998
@@ -32,6 +32,10 @@
static char sccsid[] =
"@(#)builddbm.c 1.4 Copyright 1992 Livingston Enterprises Inc";
+#if defined(_HAVE_PARAM_H)
+#include <sys/param.h>
+#endif
+
#if defined(SOLARIS)
# include <sys/uio.h>
# include <unistd.h>
@@ -39,7 +43,11 @@
# include <fcntl.h>
# include </usr/ucbinclude/dbm.h>
#else
+#if defined(USE_NDBM)
+# include <ndbm.h>
+#else
# include <dbm.h>
+#endif
#endif /* SOLARIS */
#include <sys/types.h>
@@ -61,8 +69,13 @@
char *progname;
char *radius_dir;
char *radius_users;
+#if defined(USE_NDBM)
+char dbfile[256];
+DBM *dbp;
+#else
char pagfile[256];
char dirfile[256];
+#endif
char dbmname[256];
FILE *userfp;
FILE *errf;
@@ -126,6 +139,20 @@
}
}
+#if defined(USE_NDBM)
+ sprintf(dbfile, "%s/%s.db", radius_dir, radius_users);
+ if((fd = open(dbfile, O_WRONLY | O_CREAT | O_TRUNC, 0600)) < 0) {
+ fprintf(errf, "%s: Couldn't open %s for writing\n",
+ progname, dbfile);
+ exit(-1);
+ }
+ close(fd);
+ sprintf(dbmname, "%s/%s", radius_dir, radius_users);
+ if(!(dbp=dbm_open(dbmname, O_RDWR | O_CREAT | O_TRUNC, 0600))) {
+ fprintf(errf, "%s: Couldn't dbm_open(%s)\n",
+ progname, dbmname);
+ }
+#else
sprintf(pagfile, "%s/%s.pag", radius_dir, radius_users);
if((fd = open(pagfile, O_WRONLY | O_CREAT | O_TRUNC, 0600)) < 0) {
fprintf(errf, "%s: Couldn't open %s for writing\n",
@@ -145,7 +172,7 @@
fprintf(errf, "%s: Couldn't dbminit(%s)\n", progname, dbmname);
exit(-1);
}
-
+#endif
userfp = (FILE *)NULL;
curParseLine = 0;
while(user_read(&userfp, name, content) == 0) {
@@ -155,7 +182,11 @@
}
named.dptr = name;
named.dsize = strlen(name)+1;
+#if defined(USE_NDBM)
+ contentd = dbm_fetch(dbp,named);
+#else
contentd = fetch(named);
+#endif
if(contentd.dsize != 0) { /* name found */
warn("Skipping duplicate record\n\tfor user '%s'", name);
continue;
@@ -164,13 +195,21 @@
named.dsize = strlen(name)+1;
contentd.dptr = content;
contentd.dsize = strlen(content)+1;
+#if defined(USE_NDBM)
+ if(dbm_store(dbp, named, contentd, DBM_INSERT) < 0) {
+#else
if(store(named, contentd) != 0) {
+#endif
fprintf(errf, "%s: Couldn't store datum for %s\n",
progname, name);
exit(-1);
}
}
+#if defined(USE_NDBM)
+ dbm_close(dbp);
+#else
dbmclose();
+#endif
exit(0);
}

View File

@ -1 +0,0 @@
The Ascend modified Radius Daemon

View File

@ -1 +0,0 @@
The Ascend modified Radius Daemon.

View File

@ -1,20 +0,0 @@
sbin/builddbm
sbin/radiusd
sbin/radiusd.dbm
%%PORTDOCS%%share/doc/ascend-radius/ascend.doc
%%PORTDOCS%%share/doc/ascend-radius/draft-ietf-radius-accounting-01.txt
%%PORTDOCS%%share/doc/ascend-radius/draft-ietf-radius-radius-03.txt
%%PORTDOCS%%share/doc/ascend-radius/draft-ietf-radius-radius-04.txt
%%PORTDOCS%%share/doc/ascend-radius/ChangeLog
%%PORTDOCS%%share/doc/ascend-radius/README
%%PORTDOCS%%share/doc/ascend-radius/README.cexample
%%PORTDOCS%%share/doc/ascend-radius/README.dict
%%PORTDOCS%%share/doc/ascend-radius/radius.ps
%%PORTDOCS%%share/doc/ascend-radius/radius.pdf
%%PORTDOCS%%share/doc/ascend-radius/980618.ps
%%PORTDOCS%%share/doc/ascend-radius/980618.pdf
etc/raddb/clients.example
etc/raddb/dictionary
etc/raddb/users.example
%%PORTDOCS%%@dirrm share/doc/ascend-radius
@dirrm etc/raddb

View File

@ -1,6 +0,0 @@
#!/bin/sh
cd $WRKSRC || exit 1
cp radius.h radius.h.old
sed -e "s:@@PREFIX@@:$PREFIX:g" < radius.h.old > radius.h