- Update to 0.43.1
PR: 166015 Submitted by: Ports Fury Feature safe: yes
This commit is contained in:
parent
8ad83bd55c
commit
96c27b6b37
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=293784
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= pd
|
||||
DISTVERSION= 0.43-0
|
||||
DISTVERSION= 0.43-1
|
||||
DISTVERSIONSUFFIX= .src
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www-crca.ucsd.edu/~msp/Software/
|
||||
@ -16,6 +16,9 @@ COMMENT= MIDI-capable real-time audio processor/synthesizer
|
||||
|
||||
LICENSE= BSD
|
||||
|
||||
OPTIONS= ALSA "Enable ALSA support" off \
|
||||
JACK "Enable JACK support" off
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S;.src;/src;}
|
||||
PATCH_WRKSRC= ${WRKSRC}/..
|
||||
|
||||
@ -29,9 +32,25 @@ MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
MAN1= pd.1 pdreceive.1 pdsend.1
|
||||
|
||||
CPPFLAGS+= -I${TCL_INCLUDEDIR}
|
||||
CPPFLAGS+= -I${TCL_INCLUDEDIR} -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(WITH_ALSA)
|
||||
LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
|
||||
CONFIGURE_ARGS+= --enable-alsa
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-alsa
|
||||
.endif
|
||||
|
||||
.if defined(WITH_JACK)
|
||||
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
|
||||
CONFIGURE_ARGS+= --enable-jack
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-jack
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${PATCH_WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|__FreeBSD_kernel__|__FreeBSD__|g ; \
|
||||
@ -43,6 +62,7 @@ post-patch:
|
||||
s|-ltcl8[0-9]|-ltcl${USE_TCL}|g ; \
|
||||
s|-ltk8[0-9]|-ltk${USE_TK}|g ; \
|
||||
s|s_midi_oss.c ||g ; \
|
||||
/SYSSRC/s|s_midi_alsa.c||g ; \
|
||||
/uname/s|Linux|${OPSYS}|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|$$(WARN_CFLAGS)||g ; \
|
||||
@ -80,8 +100,8 @@ do-install:
|
||||
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
|
||||
@${FIND} ${DOCSDIR} -type d -exec ${CHMOD} 755 {} \;
|
||||
@${FIND} ${DOCSDIR} -type f -exec ${CHMOD} ${SHAREMODE} {} \;
|
||||
.for file in LICENSE.txt README.txt
|
||||
${INSTALL_DATA} ${WRKSRC}/../${file} ${DOCSDIR}
|
||||
.for i in LICENSE.txt README.txt
|
||||
${INSTALL_DATA} ${WRKSRC}/../${i} ${DOCSDIR}
|
||||
.endfor
|
||||
@${LN} -sf ${DOCSDIR} ${PREFIX}/lib/pd/doc
|
||||
.endif
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (pd-0.43-0.src.tar.gz) = e2fbc8f854397368fe428c6dc358a46e00065daf7bd9dc18c85304b9513fd8e1
|
||||
SIZE (pd-0.43-0.src.tar.gz) = 2194131
|
||||
SHA256 (pd-0.43-1.src.tar.gz) = ecbae559926d4120a8c4d9aee4e441c1a2b4c3120460249e5d9634bcec7a3c2b
|
||||
SIZE (pd-0.43-1.src.tar.gz) = 2186998
|
||||
|
17
audio/pd/files/patch-src_s_audio_alsa.c
Normal file
17
audio/pd/files/patch-src_s_audio_alsa.c
Normal file
@ -0,0 +1,17 @@
|
||||
--- src/s_audio_alsa.c.orig 2011-11-07 13:06:38.000000000 +0900
|
||||
+++ src/s_audio_alsa.c 2012-02-26 03:12:50.000000000 +0900
|
||||
@@ -25,7 +25,14 @@
|
||||
#include <sched.h>
|
||||
#include <sys/mman.h>
|
||||
#include "s_audio_alsa.h"
|
||||
+#if defined(__FreeBSD__)
|
||||
+#include <sys/endian.h>
|
||||
+#define LITTLE_ENDIAN _LITTLE_ENDIAN
|
||||
+#define BIG_ENDIAN _BIG_ENDIAN
|
||||
+#define BYTE_ORDER _BYTE_ORDER
|
||||
+#else
|
||||
#include <endian.h>
|
||||
+#endif
|
||||
|
||||
/* Defines */
|
||||
#define DEBUG(x) x
|
@ -109,6 +109,7 @@ lib/pd/tcl/opt_parser.tcl
|
||||
lib/pd/tcl/pd-gui.tcl
|
||||
lib/pd/tcl/pd_bindings.tcl
|
||||
lib/pd/tcl/pd_connect.tcl
|
||||
lib/pd/tcl/pd_guiprefs.tcl
|
||||
lib/pd/tcl/pd_menucommands.tcl
|
||||
lib/pd/tcl/pd_menus.tcl
|
||||
lib/pd/tcl/pdtk_array.tcl
|
||||
|
Loading…
Reference in New Issue
Block a user