Fix build on non-x86 archs by disabling apm.

Approved by:	portmgr (tier-2 blanket)
This commit is contained in:
Mark Linimon 2019-03-08 02:15:50 +00:00
parent 08f7f58e7e
commit 96b29de686
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495008
2 changed files with 16 additions and 0 deletions

View File

@ -123,6 +123,11 @@ XOAP_USE= gnome=libxml2
PLIST_FILES+= lib/conky/libcairo_imlib2_helper.so
.endif
# disable apm on non-x86 archs
.if ${ARCH} != amd64 && ${ARCH} != i386
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src_CMakeLists.txt
.endif
post-patch:
@${REINPLACE_CMD} -e 's/^#\(set(RELEASE true\)/\1/' \
-e 's/-D_POSIX_C_SOURCE=200809L/& -D__BSD_VISIBLE=1 -D_XOPEN_SOURCE=700/' \

View File

@ -0,0 +1,11 @@
--- src/CMakeLists.txt.orig 2019-02-23 02:12:15 UTC
+++ src/CMakeLists.txt
@@ -124,7 +124,7 @@ if(OS_LINUX)
endif(OS_LINUX)
if(OS_FREEBSD)
- set(freebsd freebsd.cc freebsd.h bsdapm.cc bsdapm.h)
+ set(freebsd freebsd.cc freebsd.h)
set(optional_sources ${optional_sources} ${freebsd})
endif(OS_FREEBSD)