Update to version 0.6.2
PR: 22892 Submitted by: Ports Fury
This commit is contained in:
parent
cc2cb0427e
commit
96a0bdf09c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35222
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qhacc
|
||||
PORTVERSION= 0.6.1a
|
||||
PORTVERSION= 0.6.2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ftp://ftp.ostrich-emulators.cx/qhacc/
|
||||
|
||||
@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
|
||||
USE_QT2= yes
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-qt="${X11BASE}"
|
||||
CONFIGURE_ENV= QTDIR="${X11BASE}"
|
||||
|
||||
pre-build:
|
||||
@${RM} -f ${WRKSRC}/src/moc_*.cpp
|
||||
|
@ -1 +1 @@
|
||||
MD5 (qhacc-0.6.1a.tar.gz) = b1fe659ab692d2814fbf0bd75a2ea9b1
|
||||
MD5 (qhacc-0.6.2.tar.gz) = d2693ef38cba992c114c6ace1012de89
|
||||
|
@ -1,16 +1,13 @@
|
||||
--- src/Makefile.in.orig Sun Aug 27 10:24:42 2000
|
||||
+++ src/Makefile.in Wed Sep 13 20:44:43 2000
|
||||
@@ -94,12 +94,12 @@
|
||||
qhaccgrapher.h
|
||||
|
||||
|
||||
-INCLUDES = $(all_includes) -I$(QTDIR)/include
|
||||
+INCLUDES = $(all_includes) -I$(QTDIR)/include/qt2
|
||||
qhacc_LDFLAGS = -L$(QTDIR)/lib
|
||||
--- src/Makefile.in.orig Wed Nov 15 04:44:04 2000
|
||||
+++ src/Makefile.in Wed Nov 15 05:01:56 2000
|
||||
@@ -85,10 +85,10 @@
|
||||
INCLUDES = $(all_includes) -I$(QTINCDIR)
|
||||
LDFLAGS =
|
||||
qhacc_LDFLAGS = -L$(QTLIBDIR) $(LDFLAGS)
|
||||
-qhacc_LDADD = -lqt
|
||||
-MOC = $(QTDIR)/bin/moc
|
||||
-MOC = $(QTMOCDIR)/moc
|
||||
+qhacc_LDADD = -lqt2
|
||||
+MOC = $(QTDIR)/bin/moc2
|
||||
+MOC = $(QTMOCDIR)/moc2
|
||||
|
||||
-CXXFLAGS = -O2 -Wall $(MYFLAGS)
|
||||
+CXXFLAGS = @CXXFLAGS@ $(MYFLAGS)
|
||||
|
@ -1,11 +1,32 @@
|
||||
--- configure.orig Mon Aug 21 05:14:11 2000
|
||||
+++ configure Wed Sep 13 20:51:38 2000
|
||||
@@ -1255,7 +1255,7 @@
|
||||
--- configure.orig Sat Sep 30 10:54:43 2000
|
||||
+++ configure Wed Nov 15 04:56:52 2000
|
||||
@@ -1215,7 +1215,7 @@
|
||||
|
||||
for dir in $with_qt
|
||||
for dir in $with_qt_moc
|
||||
do
|
||||
- if test -f $dir/lib/libqt.so.2
|
||||
- if test -f $dir/bin/moc
|
||||
+ if test -f $dir/bin/moc2
|
||||
then
|
||||
qtmoc=$dir/bin
|
||||
echo "found in $qtmoc"
|
||||
@@ -1252,7 +1252,7 @@
|
||||
|
||||
for dir in $with_qt_libs
|
||||
do
|
||||
- if test -f $dir/lib/libqt.so.2 -o "$dir/lib/libqt.so.2.*" != "$dir/lib/libqt.so.2.\*"
|
||||
+ if test -f $dir/lib/libqt2.so
|
||||
then
|
||||
qthome=$dir
|
||||
echo "found in $dir"
|
||||
qtlibs=$dir/lib
|
||||
echo "found in $qtlibs"
|
||||
@@ -1289,9 +1289,9 @@
|
||||
|
||||
for dir in $with_qt_incs
|
||||
do
|
||||
- if test -f $dir/include/qnamespace.h
|
||||
+ if test -f $dir/include/qt2/qnamespace.h
|
||||
then
|
||||
- qtincs=$dir/include
|
||||
+ qtincs=$dir/include/qt2
|
||||
echo "found in $qtincs"
|
||||
break
|
||||
fi
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qhacc
|
||||
PORTVERSION= 0.6.1a
|
||||
PORTVERSION= 0.6.2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ftp://ftp.ostrich-emulators.cx/qhacc/
|
||||
|
||||
@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
|
||||
USE_QT2= yes
|
||||
USE_X_PREFIX= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-qt="${X11BASE}"
|
||||
CONFIGURE_ENV= QTDIR="${X11BASE}"
|
||||
|
||||
pre-build:
|
||||
@${RM} -f ${WRKSRC}/src/moc_*.cpp
|
||||
|
@ -1 +1 @@
|
||||
MD5 (qhacc-0.6.1a.tar.gz) = b1fe659ab692d2814fbf0bd75a2ea9b1
|
||||
MD5 (qhacc-0.6.2.tar.gz) = d2693ef38cba992c114c6ace1012de89
|
||||
|
@ -1,16 +1,13 @@
|
||||
--- src/Makefile.in.orig Sun Aug 27 10:24:42 2000
|
||||
+++ src/Makefile.in Wed Sep 13 20:44:43 2000
|
||||
@@ -94,12 +94,12 @@
|
||||
qhaccgrapher.h
|
||||
|
||||
|
||||
-INCLUDES = $(all_includes) -I$(QTDIR)/include
|
||||
+INCLUDES = $(all_includes) -I$(QTDIR)/include/qt2
|
||||
qhacc_LDFLAGS = -L$(QTDIR)/lib
|
||||
--- src/Makefile.in.orig Wed Nov 15 04:44:04 2000
|
||||
+++ src/Makefile.in Wed Nov 15 05:01:56 2000
|
||||
@@ -85,10 +85,10 @@
|
||||
INCLUDES = $(all_includes) -I$(QTINCDIR)
|
||||
LDFLAGS =
|
||||
qhacc_LDFLAGS = -L$(QTLIBDIR) $(LDFLAGS)
|
||||
-qhacc_LDADD = -lqt
|
||||
-MOC = $(QTDIR)/bin/moc
|
||||
-MOC = $(QTMOCDIR)/moc
|
||||
+qhacc_LDADD = -lqt2
|
||||
+MOC = $(QTDIR)/bin/moc2
|
||||
+MOC = $(QTMOCDIR)/moc2
|
||||
|
||||
-CXXFLAGS = -O2 -Wall $(MYFLAGS)
|
||||
+CXXFLAGS = @CXXFLAGS@ $(MYFLAGS)
|
||||
|
@ -1,11 +1,32 @@
|
||||
--- configure.orig Mon Aug 21 05:14:11 2000
|
||||
+++ configure Wed Sep 13 20:51:38 2000
|
||||
@@ -1255,7 +1255,7 @@
|
||||
--- configure.orig Sat Sep 30 10:54:43 2000
|
||||
+++ configure Wed Nov 15 04:56:52 2000
|
||||
@@ -1215,7 +1215,7 @@
|
||||
|
||||
for dir in $with_qt
|
||||
for dir in $with_qt_moc
|
||||
do
|
||||
- if test -f $dir/lib/libqt.so.2
|
||||
- if test -f $dir/bin/moc
|
||||
+ if test -f $dir/bin/moc2
|
||||
then
|
||||
qtmoc=$dir/bin
|
||||
echo "found in $qtmoc"
|
||||
@@ -1252,7 +1252,7 @@
|
||||
|
||||
for dir in $with_qt_libs
|
||||
do
|
||||
- if test -f $dir/lib/libqt.so.2 -o "$dir/lib/libqt.so.2.*" != "$dir/lib/libqt.so.2.\*"
|
||||
+ if test -f $dir/lib/libqt2.so
|
||||
then
|
||||
qthome=$dir
|
||||
echo "found in $dir"
|
||||
qtlibs=$dir/lib
|
||||
echo "found in $qtlibs"
|
||||
@@ -1289,9 +1289,9 @@
|
||||
|
||||
for dir in $with_qt_incs
|
||||
do
|
||||
- if test -f $dir/include/qnamespace.h
|
||||
+ if test -f $dir/include/qt2/qnamespace.h
|
||||
then
|
||||
- qtincs=$dir/include
|
||||
+ qtincs=$dir/include/qt2
|
||||
echo "found in $qtincs"
|
||||
break
|
||||
fi
|
||||
|
Loading…
Reference in New Issue
Block a user