- Fix build with GCC 4.x
This commit is contained in:
parent
1d3f1a251f
commit
968ab6cdd1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=201562
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= amanith
|
||||
PORTVERSION= 0.3
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.amanith.org/download/files/ \
|
||||
http://louhi.kempele.fi/~skyostil/projects/pyamanith/dist/
|
||||
@ -21,7 +21,6 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
freetype.9:${PORTSDIR}/print/freetype2
|
||||
|
||||
USE_GCC= 3.4+
|
||||
USE_QT_VER= 3
|
||||
USE_XLIB= yes
|
||||
USE_GL= yes
|
||||
@ -40,10 +39,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Broken with gcc 4.2
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -i "" -e 's|3rdpart||' ${WRKSRC}/amanith.pro
|
||||
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- examples/opengl/vectorizer/drawer.h 2007-10-16 10:03:21.000000000 -0500
|
||||
+++ examples/opengl/vectorizer/drawer.h 2007-10-16 10:04:22.000000000 -0500
|
||||
@@ -71,7 +71,7 @@
|
||||
#endif
|
||||
// destructor
|
||||
~QGLWidgetTest();
|
||||
- void QGLWidgetTest::timerEvent(QTimerEvent *e);
|
||||
+ void timerEvent(QTimerEvent *e);
|
||||
};
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user