- Update plugin directories to automatically pick up.
- Support staging and tidy up plist. - Remove article from comment and add LICENSE.
This commit is contained in:
parent
20a3bacc2e
commit
9649589998
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=333796
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= nspluginwrapper
|
||||
PORTVERSION= 1.4.4
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= www linux emulators
|
||||
MASTER_SITES= http://nspluginwrapper.org/download/ \
|
||||
LOCAL/jkim \
|
||||
@ -11,7 +11,9 @@ MASTER_SITES= http://nspluginwrapper.org/download/ \
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${BINFILE}:binfile
|
||||
|
||||
MAINTAINER= jkim@FreeBSD.org
|
||||
COMMENT= A compatibility plugin for Mozilla NPAPI plugins
|
||||
COMMENT= Compatibility plugin for Mozilla NPAPI plugins
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
|
||||
|
||||
@ -22,36 +24,36 @@ BINFILE= ${PORTNAME}-i386-${PORTVERSION}-${BINBUILD}${EXTRACT_SUFX}
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
USE_GNOME= glib20 gtk20
|
||||
USE_LDCONFIG= yes
|
||||
USE_LINUX= yes
|
||||
USE_LINUX_APPS= gtk2
|
||||
USE_XORG= x11 xext xt
|
||||
USES= pkgconfig
|
||||
USE_GNOME= glib20 gtk20
|
||||
USES= gmake pkgconfig
|
||||
|
||||
CFLAGS+= -std=c99
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USE_GMAKE= yes
|
||||
HAS_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS= --enable-generic --enable-strip --prefix=${PREFIX} \
|
||||
--target-os=linux --target-cpu=i386 \
|
||||
--with-cc=${CC} --with-cxx=${CXX}
|
||||
|
||||
LIBDIR= ${PREFIX}/lib/${PORTNAME}
|
||||
LINUX_BINDIR= usr/lib/nspluginwrapper/i386/linux
|
||||
|
||||
PLIST_SUB= LIBDIR="${LIBDIR:C/^${PREFIX}\///}" HOST_ARCH="${HOST_ARCH}"
|
||||
|
||||
SUB_FILES= npviewer
|
||||
SUB_LIST+= NSPLUGINWRAPPER="${LIBDIR}"
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
HOST_ARCH= x86_64
|
||||
PLIST_SUB+= HOST_AMD64=""
|
||||
.else
|
||||
HOST_ARCH= ${ARCH}
|
||||
PLIST_SUB+= HOST_AMD64="@comment "
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@ -62,11 +64,9 @@ post-patch:
|
||||
${WRKSRC}/src/utils.c
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${LIBDIR}/i386/linux
|
||||
${INSTALL_PROGRAM} ${WRKDIR}/usr/lib/nspluginwrapper/i386/linux/*.bin \
|
||||
${WRKDIR}/usr/lib/nspluginwrapper/i386/linux/*.so \
|
||||
${LIBDIR}/i386/linux/
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/npviewer ${LIBDIR}/i386/linux/
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
${MKDIR} ${STAGEDIR}${LIBDIR}/i386/linux
|
||||
${INSTALL_PROGRAM} ${WRKDIR}/${LINUX_BINDIR}/*.bin \
|
||||
${WRKDIR}/${LINUX_BINDIR}/*.so ${STAGEDIR}${LIBDIR}/i386/linux/
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/npviewer ${STAGEDIR}${LIBDIR}/i386/linux/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/npw-config.c.orig 2011-04-23 14:47:21.000000000 -0400
|
||||
+++ src/npw-config.c 2011-04-25 17:46:44.000000000 -0400
|
||||
@@ -186,8 +186,9 @@
|
||||
--- src/npw-config.c.orig 2011-06-30 23:18:57.000000000 -0400
|
||||
+++ src/npw-config.c 2013-11-14 14:41:13.000000000 -0500
|
||||
@@ -133,8 +133,9 @@
|
||||
#if defined(__FreeBSD__)
|
||||
{
|
||||
static const char *freebsd_dirs[] = {
|
||||
@ -12,7 +12,7 @@
|
||||
};
|
||||
dirs = freebsd_dirs;
|
||||
}
|
||||
@@ -283,11 +284,13 @@
|
||||
@@ -232,11 +233,12 @@
|
||||
"/usr/lib32/nsbrowser/plugins", // XXX how unfortunate
|
||||
"/usr/lib64/nsbrowser/plugins",
|
||||
#if defined(__FreeBSD__)
|
||||
@ -24,10 +24,9 @@
|
||||
+ "%%LOCALBASE%%/lib/browser_plugins",
|
||||
+ "%%LOCALBASE%%/lib/firefox/plugins",
|
||||
+ "%%LOCALBASE%%/lib/seamonkey/plugins",
|
||||
+ "%%LOCALBASE%%/lib/npapi/linux-flashplugin",
|
||||
+ "%%LOCALBASE%%/lib/npapi/linux-f10-flashplugin",
|
||||
+ "%%LOCALBASE%%/Adobe/Acrobat7.0/ENU/Browser/intellinux",
|
||||
+ "%%LOCALBASE%%/lib/browser_plugins/linux-f10-flashplugin",
|
||||
+ "%%LOCALBASE%%/Adobe/Reader8/ENU/Adobe/Reader8/Browser/intellinux",
|
||||
+ "%%LOCALBASE%%/Adobe/Reader9/ENU/Adobe/Reader9/Browser/intellinux",
|
||||
#endif
|
||||
#if defined(__DragonFly__)
|
||||
"/usr/pkg/lib/netscape/plugins",
|
@ -11,5 +11,5 @@ bin/nspluginwrapper
|
||||
@dirrm %%LIBDIR%%/i386/linux
|
||||
@dirrm %%LIBDIR%%/%%HOST_ARCH%%/freebsd
|
||||
@dirrm %%LIBDIR%%/i386
|
||||
@dirrmtry %%LIBDIR%%/%%HOST_ARCH%%
|
||||
%%HOST_AMD64%%@dirrm %%LIBDIR%%/%%HOST_ARCH%%
|
||||
@dirrm %%LIBDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user