- Update to 0.3.0.1

- Add OPTIONS
This commit is contained in:
Gabor Pali 2010-07-30 09:05:08 +00:00
parent 7606d3c46a
commit 962ca592f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=258482
4 changed files with 57 additions and 8 deletions

View File

@ -6,18 +6,41 @@
#
PORTNAME= texmath
PORTVERSION= 0.2.0.3
PORTVERSION= 0.3.0.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Conversion of LaTeX math formulas to MathML for Haskell
CABAL_SETUP= Setup.hs
USE_HACKAGE= cgi json xml
USE_HACKAGE= xml utf8-string
EXECUTABLE= testTeXMathML texmath-cgi
OPTIONS= CGI "Compile CGI executable" off \
TEST "Compile test executable" off
PORTDATA= *
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_CGI)
CONFIGURE_ARGS+= --flags="cgi"
USE_HACKAGE+= cgi json
EXECUTABLE+= texmath-cgi
PLIST_SUB+= MAYBE_CGI=""
.else
CONFIGURE_ARGS+= --flags="-cgi"
PLIST_SUB+= MAYBE_CGI="@comment "
.endif
.if defined(WITH_TEST)
CONFIGURE_ARGS+= --flags="test"
EXECUTABLE+= testTeXMathML
PLIST_SUB+= MAYBE_TEST=""
.else
CONFIGURE_ARGS+= --flags="-test"
PLIST_SUB+= MAYBE_TEST="@comment "
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (texmath-0.2.0.3.tar.gz) = 5f0b9c3433a050703fe1974ecfba159e
SHA256 (texmath-0.2.0.3.tar.gz) = d355a298d28b9f5356926c2d2942f28ed07afa9d944cadfa47d8cdec73725b55
SIZE (texmath-0.2.0.3.tar.gz) = 19630
MD5 (texmath-0.3.0.1.tar.gz) = f2ec771aaae9e678bf9106fe161efb85
SHA256 (texmath-0.3.0.1.tar.gz) = e1f4773b152ad30ab22f2f31fd6227017474504559ba4fe9a919631448c5c288
SIZE (texmath-0.3.0.1.tar.gz) = 25368

View File

@ -0,0 +1,26 @@
--- ./texmath.cabal.orig 2010-07-23 00:04:31.000000000 +0200
+++ ./texmath.cabal 2010-07-29 13:52:06.000000000 +0200
@@ -63,12 +63,12 @@
Build-depends: base >= 3 && < 4
Exposed-modules: Text.TeXMath, Text.TeXMath.Parser, Text.TeXMath.MathMLWriter
- Ghc-Options: -Wall -fno-warn-unused-do-bind
+ Ghc-Options: -Wall
Ghc-Prof-Options: -auto-all
Executable testTeXMathML
Main-is: testTeXMathML.hs
- Ghc-Options: -Wall -fno-warn-unused-do-bind
+ Ghc-Options: -Wall
Ghc-Prof-Options: -auto-all
if flag(test)
Buildable: True
@@ -78,7 +78,7 @@
Executable texmath-cgi
Main-is: cgi/texmath-cgi.hs
Build-depends: utf8-string
- Ghc-Options: -Wall -fno-warn-unused-do-bind
+ Ghc-Options: -Wall
Ghc-Prof-Options: -auto-all
if flag(cgi)
Buildable: True

View File

@ -1,6 +1,6 @@
@comment $FreeBSD$
bin/testTeXMathML
bin/texmath-cgi
%%MAYBE_TEST%%bin/testTeXMathML
%%MAYBE_CGI%%bin/texmath-cgi
%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/TeXMath.hi
%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/TeXMath/MathMLWriter.hi