- Update to version 0.46, stagify, and cleanup the port
- Remove old BROKEN statement; builds fine on PowerPC at least (it was marked broken on sparc64 almost 5 years ago due to stdlib.h vs. malloc.h conflict, which no longer seems to be the issue)
This commit is contained in:
parent
cb0167cf82
commit
961ef5142f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=362535
@ -1,46 +1,36 @@
|
||||
# Created by: Dereckson <dereckson@gmail.com>
|
||||
# Created by: Sébastien Santoro <dereckson@gmail.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= astrometry
|
||||
PORTVERSION= 0.34
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 0.46
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= http://www.astrometry.net/downloads/
|
||||
DISTNAME= astrometry.net-${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Describes an astronomical image
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
|
||||
LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
|
||||
libcfitsio.so:${PORTSDIR}/astro/cfitsio \
|
||||
libjpeg.so:${PORTSDIR}/graphics/jpeg \
|
||||
libpng15.so:${PORTSDIR}/graphics/png \
|
||||
libnetpbm.so:${PORTSDIR}/graphics/netpbm
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
|
||||
RUN_DEPENDS:= ${BUILD_DEPENDS}
|
||||
|
||||
NO_STAGE= yes
|
||||
USES= gmake pkgconfig
|
||||
USES= gmake pkgconfig tar:bzip2
|
||||
USE_PYTHON= yes
|
||||
ALL_TARGET= all extra
|
||||
MAKE_ENV= INSTALL_DIR=${PREFIX}/astrometry
|
||||
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
|
||||
BROKEN= Does not compile on ia64, powerpc, or sparc64
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
|
||||
${WRKSRC}/util/cairoutils.c
|
||||
${REINPLACE_CMD} -e 's|python setup|${PYTHON_CMD} setup|' \
|
||||
${WRKSRC}/util/Makefile \
|
||||
${WRKSRC}/libkd/Makefile \
|
||||
${WRKSRC}/blind/Makefile
|
||||
@${REINPLACE_CMD} -E 's,python (setup|-c),${PYTHON_CMD} \1,' \
|
||||
${WRKSRC}/blind/Makefile ${WRKSRC}/libkd/Makefile \
|
||||
${WRKSRC}/sdss/Makefile ${WRKSRC}/util/Makefile
|
||||
# Outwit detection logic that thinks Clang does not support -shared argument
|
||||
@${REINPLACE_CMD} -e '/CCTEST/s,\\|warning:,,' \
|
||||
${WRKSRC}/util/makefile.common
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (astrometry.net-0.34.tar.gz) = 77d42ea31566f0486cce0ce4cab22e82001a5d7c8d40acc95631505e4f590d72
|
||||
SIZE (astrometry.net-0.34.tar.gz) = 5540368
|
||||
SHA256 (astrometry.net-0.46.tar.bz2) = be7567f0a2d7adf00dad58b611a3e44b37aae5493066eb77cb0d51e41fbc82cd
|
||||
SIZE (astrometry.net-0.46.tar.bz2) = 6220165
|
||||
|
31
astro/astrometry/files/patch-util-permutedsort.c
Normal file
31
astro/astrometry/files/patch-util-permutedsort.c
Normal file
@ -0,0 +1,31 @@
|
||||
--- util/permutedsort.c.orig 2013-10-29 22:08:09 +0800
|
||||
+++ util/permutedsort.c
|
||||
@@ -105,6 +105,12 @@ int* permuted_sort(const void* realarray
|
||||
if (isnan(d2)) return -1; \
|
||||
assert(0); return 0;
|
||||
|
||||
+#define COMPARE_INT(d1, d2, op1, op2) \
|
||||
+ if (d1 op1 d2) return -1; \
|
||||
+ if (d1 op2 d2) return 1; \
|
||||
+ if (d1 == d2) return 0; \
|
||||
+ assert(0); return 0;
|
||||
+
|
||||
//printf("d1=%g, d2=%g\n", d1, d2);
|
||||
|
||||
int compare_doubles_asc(const void* v1, const void* v2) {
|
||||
@@ -135,13 +141,13 @@ int compare_floats_desc(const void* v1,
|
||||
int compare_int64_asc(const void* v1, const void* v2) {
|
||||
int64_t f1 = *(int64_t*)v1;
|
||||
int64_t f2 = *(int64_t*)v2;
|
||||
- COMPARE(f1, f2, <, >);
|
||||
+ COMPARE_INT(f1, f2, <, >);
|
||||
}
|
||||
|
||||
int compare_int64_desc(const void* v1, const void* v2) {
|
||||
int64_t f1 = *(int64_t*)v1;
|
||||
int64_t f2 = *(int64_t*)v2;
|
||||
- COMPARE(f1, f2, >, <);
|
||||
+ COMPARE_INT(f1, f2, >, <);
|
||||
}
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--------------------------------------------------------------------------
|
||||
astronometry was sucessfully installed.
|
||||
Astrometry was successfully installed.
|
||||
|
||||
You'll find this distribution in %%PREFIX%%/astrometry
|
||||
|
||||
|
@ -1,91 +1,53 @@
|
||||
astrometry/bin/2masstofits
|
||||
astrometry/bin/add-healpix-column
|
||||
astrometry/bin/add-text
|
||||
astrometry/bin/agreeable
|
||||
astrometry/bin/an-fitstopnm
|
||||
astrometry/bin/an-pnmtofits
|
||||
astrometry/bin/augment-xylist
|
||||
astrometry/bin/backend
|
||||
astrometry/bin/blind
|
||||
astrometry/bin/build-an-catalog
|
||||
astrometry/bin/build-index
|
||||
astrometry/bin/certifiable
|
||||
astrometry/bin/checktree
|
||||
astrometry/bin/codetree
|
||||
astrometry/bin/column-merge
|
||||
astrometry/bin/control-program
|
||||
astrometry/bin/cut-an
|
||||
astrometry/bin/astrometry-engine
|
||||
astrometry/bin/build-astrometry-index
|
||||
astrometry/bin/downsample-fits
|
||||
astrometry/bin/fits-dedup
|
||||
astrometry/bin/fit-wcs
|
||||
astrometry/bin/fits-column-merge
|
||||
astrometry/bin/fits-flip-endian
|
||||
astrometry/bin/fits-guess-scale
|
||||
astrometry/bin/fits2fits.py
|
||||
astrometry/bin/fitscopy
|
||||
astrometry/bin/fitsgetext
|
||||
astrometry/bin/fitstomatlab
|
||||
astrometry/bin/fix-bb
|
||||
astrometry/bin/get-healpix
|
||||
astrometry/bin/get-wcs
|
||||
astrometry/bin/hpowned
|
||||
astrometry/bin/hpquads
|
||||
astrometry/bin/hpsplit
|
||||
astrometry/bin/image2pnm.py
|
||||
astrometry/bin/image2xy
|
||||
astrometry/bin/imarith
|
||||
astrometry/bin/imcopy
|
||||
astrometry/bin/imstat
|
||||
astrometry/bin/index-info
|
||||
astrometry/bin/index-to-table
|
||||
astrometry/bin/listhead
|
||||
astrometry/bin/liststruc
|
||||
astrometry/bin/local-index
|
||||
astrometry/bin/merge-index
|
||||
astrometry/bin/mergesolved
|
||||
astrometry/bin/modhead
|
||||
astrometry/bin/new-wcs
|
||||
astrometry/bin/nomadtofits
|
||||
astrometry/bin/pad-file
|
||||
astrometry/bin/plot-constellations
|
||||
astrometry/bin/plotcat
|
||||
astrometry/bin/plotann.py
|
||||
astrometry/bin/plotquad
|
||||
astrometry/bin/plotstuff
|
||||
astrometry/bin/plotxy
|
||||
astrometry/bin/printsolved
|
||||
astrometry/bin/query-starkd
|
||||
astrometry/bin/rdlsinfo
|
||||
astrometry/bin/removelines.py
|
||||
astrometry/bin/resort-xylist
|
||||
astrometry/bin/search-index
|
||||
astrometry/bin/setsolved
|
||||
astrometry/bin/smooth-image
|
||||
astrometry/bin/solve-field
|
||||
astrometry/bin/solvedserver
|
||||
astrometry/bin/startree
|
||||
astrometry/bin/startree2
|
||||
astrometry/bin/subtable
|
||||
astrometry/bin/subwcs
|
||||
astrometry/bin/tablist
|
||||
astrometry/bin/tabmerge
|
||||
astrometry/bin/tabsort
|
||||
astrometry/bin/tycho2tofits
|
||||
astrometry/bin/uniformize-catalog
|
||||
astrometry/bin/uniformize.py
|
||||
astrometry/bin/unpermute-quads
|
||||
astrometry/bin/unpermute-stars
|
||||
astrometry/bin/usnobtofits
|
||||
astrometry/bin/wcs-grab
|
||||
astrometry/bin/wcs-rd2xy
|
||||
astrometry/bin/wcs-resample
|
||||
astrometry/bin/wcs-to-tan
|
||||
astrometry/bin/wcs-xy2rd
|
||||
astrometry/bin/wcsinfo
|
||||
astrometry/bin/whynot
|
||||
astrometry/bin/xylist2fits
|
||||
astrometry/bin/xylsinfo
|
||||
astrometry/doc/CREDITS
|
||||
astrometry/doc/GETTING-INDEXES
|
||||
astrometry/doc/LICENSE
|
||||
astrometry/doc/README
|
||||
astrometry/doc/report.txt
|
||||
astrometry/etc/backend.cfg
|
||||
astrometry/etc/astrometry.cfg
|
||||
astrometry/examples/CREDITS
|
||||
astrometry/examples/apod1.jpg
|
||||
astrometry/examples/apod1.xyls
|
||||
@ -97,193 +59,214 @@ astrometry/examples/apod4.jpg
|
||||
astrometry/examples/apod4.xyls
|
||||
astrometry/examples/apod5.jpg
|
||||
astrometry/examples/apod5.xyls
|
||||
astrometry/examples/m44-1910-04-01.jpg
|
||||
astrometry/examples/m44-1975-01-18.jpg
|
||||
astrometry/examples/sdss.jpg
|
||||
astrometry/examples/sdss.xyls
|
||||
astrometry/include/2mass-fits.h
|
||||
astrometry/include/2mass.h
|
||||
astrometry/include/allquads.h
|
||||
astrometry/include/an-bool.h
|
||||
astrometry/include/an-catalog.h
|
||||
astrometry/include/an-endian.h
|
||||
astrometry/include/an-opts.h
|
||||
astrometry/include/an-thread-pthreads.h
|
||||
astrometry/include/an-thread.h
|
||||
astrometry/include/anqfits.h
|
||||
astrometry/include/augment-xylist.h
|
||||
astrometry/include/axyfile.h
|
||||
astrometry/include/backend.h
|
||||
astrometry/include/bl-nl.h
|
||||
astrometry/include/bl-nl.inc
|
||||
astrometry/include/bl-nl.ph
|
||||
astrometry/include/bl.h
|
||||
astrometry/include/bl.inc
|
||||
astrometry/include/bl.ph
|
||||
astrometry/include/blind.h
|
||||
astrometry/include/blind_wcs.h
|
||||
astrometry/include/blindutils.h
|
||||
astrometry/include/brightstars.h
|
||||
astrometry/include/bt.h
|
||||
astrometry/include/build-index.h
|
||||
astrometry/include/cairoutils.h
|
||||
astrometry/include/catalog.h
|
||||
astrometry/include/coadd.h
|
||||
astrometry/include/codefile.h
|
||||
astrometry/include/codekd.h
|
||||
astrometry/include/codetree.h
|
||||
astrometry/include/constellations.h
|
||||
astrometry/include/convolve-image.h
|
||||
astrometry/include/ctmf.h
|
||||
astrometry/include/dimage.h
|
||||
astrometry/include/dualtree.h
|
||||
astrometry/include/dualtree_nearestneighbour.h
|
||||
astrometry/include/dualtree_rangesearch.h
|
||||
astrometry/include/errors.h
|
||||
astrometry/include/fits-guess-scale.h
|
||||
astrometry/include/fitsbin.h
|
||||
astrometry/include/fitsfile.h
|
||||
astrometry/include/fitsioutils.h
|
||||
astrometry/include/fitstable.h
|
||||
astrometry/include/gslutils.h
|
||||
astrometry/include/hd.h
|
||||
astrometry/include/healpix-utils.h
|
||||
astrometry/include/healpix.h
|
||||
astrometry/include/hpquads.h
|
||||
astrometry/include/image2xy-files.h
|
||||
astrometry/include/image2xy.h
|
||||
astrometry/include/index.h
|
||||
astrometry/include/intmap.h
|
||||
astrometry/include/ioutils.h
|
||||
astrometry/include/kdtree.h
|
||||
astrometry/include/kdtree_fits_io.h
|
||||
astrometry/include/keywords.h
|
||||
astrometry/include/log.h
|
||||
astrometry/include/matchfile.h
|
||||
astrometry/include/matchobj.h
|
||||
astrometry/include/mathutil.h
|
||||
astrometry/include/merge-index.h
|
||||
astrometry/include/new-wcs.h
|
||||
astrometry/include/ngc2000.h
|
||||
astrometry/include/ngcic-accurate.h
|
||||
astrometry/include/nomad-fits.h
|
||||
astrometry/include/nomad.h
|
||||
astrometry/include/os-features-config.h
|
||||
astrometry/include/os-features.h
|
||||
astrometry/include/permutedsort.h
|
||||
astrometry/include/plotannotations.h
|
||||
astrometry/include/plotfill.h
|
||||
astrometry/include/plotgrid.h
|
||||
astrometry/include/plotimage.h
|
||||
astrometry/include/plotoutline.h
|
||||
astrometry/include/plotstuff.h
|
||||
astrometry/include/plotxy.h
|
||||
astrometry/include/qfits.h
|
||||
astrometry/include/qfits_cache.h
|
||||
astrometry/include/qfits_convert.h
|
||||
astrometry/include/qfits_error.h
|
||||
astrometry/include/qfits_filename.h
|
||||
astrometry/include/qfits_header.h
|
||||
astrometry/include/qfits_image.h
|
||||
astrometry/include/qfits_keywords.h
|
||||
astrometry/include/qfits_md5.h
|
||||
astrometry/include/qfits_memory.h
|
||||
astrometry/include/qfits_rw.h
|
||||
astrometry/include/qfits_std.h
|
||||
astrometry/include/qfits_table.h
|
||||
astrometry/include/qfits_time.h
|
||||
astrometry/include/qfits_tools.h
|
||||
astrometry/include/qidxfile.h
|
||||
astrometry/include/quad-builder.h
|
||||
astrometry/include/quad-utils.h
|
||||
astrometry/include/quadfile.h
|
||||
astrometry/include/radix.h
|
||||
astrometry/include/rdlist.h
|
||||
astrometry/include/resort-xylist.h
|
||||
astrometry/include/scamp-catalog.h
|
||||
astrometry/include/scamp.h
|
||||
astrometry/include/simplexy-common.h
|
||||
astrometry/include/simplexy.h
|
||||
astrometry/include/sip-utils.h
|
||||
astrometry/include/sip.h
|
||||
astrometry/include/sip_qfits.h
|
||||
astrometry/include/solvedclient.h
|
||||
astrometry/include/solvedfile.h
|
||||
astrometry/include/solver.h
|
||||
astrometry/include/starkd.h
|
||||
astrometry/include/starutil.h
|
||||
astrometry/include/starutil.inc
|
||||
astrometry/include/starxy.h
|
||||
astrometry/include/svn.h
|
||||
astrometry/include/tabsort.h
|
||||
astrometry/include/tic.h
|
||||
astrometry/include/tweak.h
|
||||
astrometry/include/tweak2.h
|
||||
astrometry/include/tycho2-fits.h
|
||||
astrometry/include/tycho2.h
|
||||
astrometry/include/uniformize-catalog.h
|
||||
astrometry/include/unpermute-quads.h
|
||||
astrometry/include/unpermute-stars.h
|
||||
astrometry/include/usnob-fits.h
|
||||
astrometry/include/usnob.h
|
||||
astrometry/include/verify.h
|
||||
astrometry/include/wcs-rd2xy.h
|
||||
astrometry/include/wcs-xy2rd.h
|
||||
astrometry/include/xylist.h
|
||||
astrometry/include/astrometry/2mass-fits.h
|
||||
astrometry/include/astrometry/2mass.h
|
||||
astrometry/include/astrometry/allquads.h
|
||||
astrometry/include/astrometry/an-bool.h
|
||||
astrometry/include/astrometry/an-endian.h
|
||||
astrometry/include/astrometry/an-opts.h
|
||||
astrometry/include/astrometry/an-thread-pthreads.h
|
||||
astrometry/include/astrometry/an-thread.h
|
||||
astrometry/include/astrometry/anqfits.h
|
||||
astrometry/include/astrometry/anwcs.h
|
||||
astrometry/include/astrometry/augment-xylist.h
|
||||
astrometry/include/astrometry/axyfile.h
|
||||
astrometry/include/astrometry/bl-nl.h
|
||||
astrometry/include/astrometry/bl-nl.inc
|
||||
astrometry/include/astrometry/bl-nl.ph
|
||||
astrometry/include/astrometry/bl.h
|
||||
astrometry/include/astrometry/bl.inc
|
||||
astrometry/include/astrometry/bl.ph
|
||||
astrometry/include/astrometry/blind.h
|
||||
astrometry/include/astrometry/blindutils.h
|
||||
astrometry/include/astrometry/brightstars.h
|
||||
astrometry/include/astrometry/bt.h
|
||||
astrometry/include/astrometry/build-index.h
|
||||
astrometry/include/astrometry/cairoutils.h
|
||||
astrometry/include/astrometry/catalog.h
|
||||
astrometry/include/astrometry/coadd.h
|
||||
astrometry/include/astrometry/codefile.h
|
||||
astrometry/include/astrometry/codekd.h
|
||||
astrometry/include/astrometry/codetree.h
|
||||
astrometry/include/astrometry/constellations.h
|
||||
astrometry/include/astrometry/convolve-image.h
|
||||
astrometry/include/astrometry/ctmf.h
|
||||
astrometry/include/astrometry/dimage.h
|
||||
astrometry/include/astrometry/dualtree.h
|
||||
astrometry/include/astrometry/dualtree_nearestneighbour.h
|
||||
astrometry/include/astrometry/dualtree_rangesearch.h
|
||||
astrometry/include/astrometry/engine.h
|
||||
astrometry/include/astrometry/errors.h
|
||||
astrometry/include/astrometry/fit-wcs.h
|
||||
astrometry/include/astrometry/fits-guess-scale.h
|
||||
astrometry/include/astrometry/fitsbin.h
|
||||
astrometry/include/astrometry/fitsfile.h
|
||||
astrometry/include/astrometry/fitsioutils.h
|
||||
astrometry/include/astrometry/fitstable.h
|
||||
astrometry/include/astrometry/gslutils.h
|
||||
astrometry/include/astrometry/hd.h
|
||||
astrometry/include/astrometry/healpix-utils.h
|
||||
astrometry/include/astrometry/healpix.h
|
||||
astrometry/include/astrometry/hpquads.h
|
||||
astrometry/include/astrometry/image2xy-files.h
|
||||
astrometry/include/astrometry/image2xy.h
|
||||
astrometry/include/astrometry/index.h
|
||||
astrometry/include/astrometry/intmap.h
|
||||
astrometry/include/astrometry/ioutils.h
|
||||
astrometry/include/astrometry/kdtree.h
|
||||
astrometry/include/astrometry/kdtree_fits_io.h
|
||||
astrometry/include/astrometry/keywords.h
|
||||
astrometry/include/astrometry/log.h
|
||||
astrometry/include/astrometry/matchfile.h
|
||||
astrometry/include/astrometry/matchobj.h
|
||||
astrometry/include/astrometry/mathutil.h
|
||||
astrometry/include/astrometry/md5.h
|
||||
astrometry/include/astrometry/merge-index.h
|
||||
astrometry/include/astrometry/multiindex.h
|
||||
astrometry/include/astrometry/new-wcs.h
|
||||
astrometry/include/astrometry/ngc2000.h
|
||||
astrometry/include/astrometry/ngcic-accurate.h
|
||||
astrometry/include/astrometry/nomad-fits.h
|
||||
astrometry/include/astrometry/nomad.h
|
||||
astrometry/include/astrometry/os-features-config.h
|
||||
astrometry/include/astrometry/os-features.h
|
||||
astrometry/include/astrometry/permutedsort.h
|
||||
astrometry/include/astrometry/plotannotations.h
|
||||
astrometry/include/astrometry/plotfill.h
|
||||
astrometry/include/astrometry/plotgrid.h
|
||||
astrometry/include/astrometry/plotimage.h
|
||||
astrometry/include/astrometry/plotoutline.h
|
||||
astrometry/include/astrometry/plotstuff.h
|
||||
astrometry/include/astrometry/plotxy.h
|
||||
astrometry/include/astrometry/qfits_byteswap.h
|
||||
astrometry/include/astrometry/qfits_card.h
|
||||
astrometry/include/astrometry/qfits_convert.h
|
||||
astrometry/include/astrometry/qfits_error.h
|
||||
astrometry/include/astrometry/qfits_float.h
|
||||
astrometry/include/astrometry/qfits_header.h
|
||||
astrometry/include/astrometry/qfits_image.h
|
||||
astrometry/include/astrometry/qfits_md5.h
|
||||
astrometry/include/astrometry/qfits_memory.h
|
||||
astrometry/include/astrometry/qfits_rw.h
|
||||
astrometry/include/astrometry/qfits_table.h
|
||||
astrometry/include/astrometry/qfits_time.h
|
||||
astrometry/include/astrometry/qfits_tools.h
|
||||
astrometry/include/astrometry/qidxfile.h
|
||||
astrometry/include/astrometry/quad-builder.h
|
||||
astrometry/include/astrometry/quad-utils.h
|
||||
astrometry/include/astrometry/quadfile.h
|
||||
astrometry/include/astrometry/radix.h
|
||||
astrometry/include/astrometry/rdlist.h
|
||||
astrometry/include/astrometry/resample.h
|
||||
astrometry/include/astrometry/resort-xylist.h
|
||||
astrometry/include/astrometry/scamp-catalog.h
|
||||
astrometry/include/astrometry/scamp.h
|
||||
astrometry/include/astrometry/simplexy-common.h
|
||||
astrometry/include/astrometry/simplexy.h
|
||||
astrometry/include/astrometry/sip-utils.h
|
||||
astrometry/include/astrometry/sip.h
|
||||
astrometry/include/astrometry/sip_qfits.h
|
||||
astrometry/include/astrometry/solvedclient.h
|
||||
astrometry/include/astrometry/solvedfile.h
|
||||
astrometry/include/astrometry/solver.h
|
||||
astrometry/include/astrometry/starkd.h
|
||||
astrometry/include/astrometry/starutil.h
|
||||
astrometry/include/astrometry/starutil.inc
|
||||
astrometry/include/astrometry/starxy.h
|
||||
astrometry/include/astrometry/svn.h
|
||||
astrometry/include/astrometry/tabsort.h
|
||||
astrometry/include/astrometry/tic.h
|
||||
astrometry/include/astrometry/tweak.h
|
||||
astrometry/include/astrometry/tweak2.h
|
||||
astrometry/include/astrometry/tycho2-fits.h
|
||||
astrometry/include/astrometry/tycho2.h
|
||||
astrometry/include/astrometry/uniformize-catalog.h
|
||||
astrometry/include/astrometry/unpermute-quads.h
|
||||
astrometry/include/astrometry/unpermute-stars.h
|
||||
astrometry/include/astrometry/usnob-fits.h
|
||||
astrometry/include/astrometry/usnob.h
|
||||
astrometry/include/astrometry/verify.h
|
||||
astrometry/include/astrometry/wcs-rd2xy.h
|
||||
astrometry/include/astrometry/wcs-xy2rd.h
|
||||
astrometry/include/astrometry/xylist.h
|
||||
astrometry/lib/libanfiles.a
|
||||
astrometry/lib/libanutils.a
|
||||
astrometry/lib/libbackend.a
|
||||
astrometry/lib/libbackend.so
|
||||
astrometry/lib/libastrometry.a
|
||||
astrometry/lib/libastrometry.so
|
||||
astrometry/lib/libcatalogs.a
|
||||
astrometry/lib/libkd.a
|
||||
astrometry/lib/libqfits.a
|
||||
astrometry/python/astrometry/__init__.py
|
||||
astrometry/python/astrometry/libkd/__init__.py
|
||||
astrometry/python/astrometry/libkd/spherematch.py
|
||||
astrometry/python/astrometry/libkd/spherematch_c.so
|
||||
astrometry/python/astrometry/util/__init__.py
|
||||
astrometry/python/astrometry/util/_healpix.so
|
||||
astrometry/python/astrometry/util/_sip.so
|
||||
astrometry/python/astrometry/util/casjobs.py
|
||||
astrometry/python/astrometry/util/file.py
|
||||
astrometry/python/astrometry/util/filetype.py
|
||||
astrometry/python/astrometry/util/find_data_file.py
|
||||
astrometry/python/astrometry/util/fits2fits.py
|
||||
astrometry/python/astrometry/util/fix_sdss_idr.py
|
||||
astrometry/python/astrometry/util/healpix.py
|
||||
astrometry/python/astrometry/util/image2pnm.py
|
||||
astrometry/python/astrometry/util/lsstutils.py
|
||||
astrometry/python/astrometry/util/ngc2000.py
|
||||
astrometry/python/astrometry/util/pyfits_utils.py
|
||||
astrometry/python/astrometry/util/removelines.py
|
||||
astrometry/python/astrometry/util/run_command.py
|
||||
astrometry/python/astrometry/util/sdss_das.py
|
||||
astrometry/python/astrometry/util/sdss_filenames.py
|
||||
astrometry/python/astrometry/util/sdss_get_catalog.py
|
||||
astrometry/python/astrometry/util/sdss_noise.py
|
||||
astrometry/python/astrometry/util/sdss_psf.py
|
||||
astrometry/python/astrometry/util/sdss_psfield.py
|
||||
astrometry/python/astrometry/util/sdss_radec_to_rcf.py
|
||||
astrometry/python/astrometry/util/shell.py
|
||||
astrometry/python/astrometry/util/sip.py
|
||||
astrometry/python/astrometry/util/sqlcl.py
|
||||
astrometry/python/astrometry/util/starutil.py
|
||||
astrometry/python/astrometry/util/starutil_numpy.py
|
||||
astrometry/python/astrometry/util/uniformize.py
|
||||
astrometry/python/astrometry/util/usnob_catalog.py
|
||||
astrometry/python/astrometry/util/usnob_get_image.py
|
||||
astrometry/python/astrometry/util/usnob_get_region.py
|
||||
astrometry/python/astrometry/util/w3c_validator.py
|
||||
astrometry/python/pyfits/NA_pyfits.py
|
||||
astrometry/python/pyfits/NP_pyfits.py
|
||||
astrometry/python/pyfits/__init__.py
|
||||
astrometry/python/pyfits/rec.py
|
||||
astrometry/python/pyfits/svn_version.py
|
||||
astrometry/lib/python/astrometry/__init__.py
|
||||
astrometry/lib/python/astrometry/blind/__init__.py
|
||||
astrometry/lib/python/astrometry/blind/_plotstuff_c.so
|
||||
astrometry/lib/python/astrometry/blind/plotann.py
|
||||
astrometry/lib/python/astrometry/blind/plotstuff.py
|
||||
astrometry/lib/python/astrometry/blind/plotstuff_c.py
|
||||
astrometry/lib/python/astrometry/catalogs/__init__.py
|
||||
astrometry/lib/python/astrometry/catalogs/ngc2000.py
|
||||
astrometry/lib/python/astrometry/libkd/__init__.py
|
||||
astrometry/lib/python/astrometry/libkd/spherematch.py
|
||||
astrometry/lib/python/astrometry/libkd/spherematch_c.so
|
||||
astrometry/lib/python/astrometry/sdss/__init__.py
|
||||
astrometry/lib/python/astrometry/sdss/_cutils.so
|
||||
astrometry/lib/python/astrometry/sdss/common.py
|
||||
astrometry/lib/python/astrometry/sdss/cutils.py
|
||||
astrometry/lib/python/astrometry/sdss/dr7.py
|
||||
astrometry/lib/python/astrometry/sdss/dr8.py
|
||||
astrometry/lib/python/astrometry/sdss/dr9.py
|
||||
astrometry/lib/python/astrometry/sdss/runList-dr8.par
|
||||
astrometry/lib/python/astrometry/sdss/runList-dr9.par
|
||||
astrometry/lib/python/astrometry/util/__init__.py
|
||||
astrometry/lib/python/astrometry/util/addpath.py
|
||||
astrometry/lib/python/astrometry/util/casjobs.py
|
||||
astrometry/lib/python/astrometry/util/file.py
|
||||
astrometry/lib/python/astrometry/util/filetype.py
|
||||
astrometry/lib/python/astrometry/util/find_data_file.py
|
||||
astrometry/lib/python/astrometry/util/fits.py
|
||||
astrometry/lib/python/astrometry/util/fits2fits.py
|
||||
astrometry/lib/python/astrometry/util/fix_sdss_idr.py
|
||||
astrometry/lib/python/astrometry/util/image2pnm.py
|
||||
astrometry/lib/python/astrometry/util/lsstutils.py
|
||||
astrometry/lib/python/astrometry/util/miscutils.py
|
||||
astrometry/lib/python/astrometry/util/multiproc.py
|
||||
astrometry/lib/python/astrometry/util/plotshift.py
|
||||
astrometry/lib/python/astrometry/util/plotutils.py
|
||||
astrometry/lib/python/astrometry/util/removelines.py
|
||||
astrometry/lib/python/astrometry/util/run_command.py
|
||||
astrometry/lib/python/astrometry/util/sdss_das.py
|
||||
astrometry/lib/python/astrometry/util/sdss_filenames.py
|
||||
astrometry/lib/python/astrometry/util/sdss_get_catalog.py
|
||||
astrometry/lib/python/astrometry/util/sdss_noise.py
|
||||
astrometry/lib/python/astrometry/util/sdss_psf.py
|
||||
astrometry/lib/python/astrometry/util/sdss_psfield.py
|
||||
astrometry/lib/python/astrometry/util/sdss_radec_to_rcf.py
|
||||
astrometry/lib/python/astrometry/util/shell.py
|
||||
astrometry/lib/python/astrometry/util/sqlcl.py
|
||||
astrometry/lib/python/astrometry/util/starutil.py
|
||||
astrometry/lib/python/astrometry/util/starutil_numpy.py
|
||||
astrometry/lib/python/astrometry/util/uniformize.py
|
||||
astrometry/lib/python/astrometry/util/usnob_catalog.py
|
||||
astrometry/lib/python/astrometry/util/usnob_get_image.py
|
||||
astrometry/lib/python/astrometry/util/usnob_get_region.py
|
||||
astrometry/lib/python/astrometry/util/util.py
|
||||
astrometry/lib/python/astrometry/util/w3c_validator.py
|
||||
astrometry/lib/python/astrometry/util/yanny.py
|
||||
astrometry/ups/astrometry_net.cfg.template
|
||||
astrometry/ups/astrometry_net.table
|
||||
@dirrm astrometry/ups
|
||||
@dirrm astrometry/python/pyfits
|
||||
@dirrm astrometry/python/astrometry/util
|
||||
@dirrm astrometry/python/astrometry/libkd
|
||||
@dirrm astrometry/python/astrometry
|
||||
@dirrm astrometry/python
|
||||
@dirrm astrometry/lib/python/astrometry/util
|
||||
@dirrm astrometry/lib/python/astrometry/sdss
|
||||
@dirrm astrometry/lib/python/astrometry/libkd
|
||||
@dirrm astrometry/lib/python/astrometry/catalogs
|
||||
@dirrm astrometry/lib/python/astrometry/blind
|
||||
@dirrm astrometry/lib/python/astrometry
|
||||
@dirrm astrometry/lib/python
|
||||
@dirrm astrometry/lib
|
||||
@dirrm astrometry/include/astrometry
|
||||
@dirrm astrometry/include
|
||||
@dirrm astrometry/examples
|
||||
@dirrm astrometry/etc
|
||||
|
Loading…
Reference in New Issue
Block a user