print/epson-inkjet-printer-escpr: Update to 1.6.19
PR: 226839 Submitted by: Tatsuki Makino <tatsuki_makino@hotmail.com> (maintainer)
This commit is contained in:
parent
8e3098e06c
commit
9602c6091c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465300
@ -1,10 +1,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= epson-inkjet-printer-escpr
|
||||
PORTVERSION= 1.6.17
|
||||
PORTVERSION= 1.6.19
|
||||
DISTVERSIONSUFFIX= -1lsb3.2
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= https://download3.ebz.epson.net/dsc/f/03/00/06/66/09/4ac2bf69bb1ddf4a9ad525596615cbb40fe4dad5/
|
||||
MASTER_SITES= https://download3.ebz.epson.net/dsc/f/03/00/07/07/57/91f8069e80d17a5dade2f18eda1ade2d49297840/
|
||||
|
||||
MAINTAINER= tatsuki_makino@hotmail.com
|
||||
COMMENT= Epson Inkjet Printer Driver (ESC/P-R) for Linux
|
||||
@ -24,6 +24,8 @@ PORTDOCS= AUTHORS COPYING NEWS README README.ja
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
PORTSCOUT= ignore # MASTER_SITES is changed in each version
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1508378400
|
||||
SHA256 (epson-inkjet-printer-escpr-1.6.17-1lsb3.2.tar.gz) = 9b2e5cd1b7b232d4404b78a3ec0a0d5aa70dba860c73ef641199f0ad1a0fdb54
|
||||
SIZE (epson-inkjet-printer-escpr-1.6.17-1lsb3.2.tar.gz) = 3866776
|
||||
TIMESTAMP = 1521687600
|
||||
SHA256 (epson-inkjet-printer-escpr-1.6.19-1lsb3.2.tar.gz) = ed99a18cbc5d0c8549996efbfee21db00cc95c1136237e626d2a2ef2144d34b7
|
||||
SIZE (epson-inkjet-printer-escpr-1.6.19-1lsb3.2.tar.gz) = 4010643
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- configure.ac.orig 2015-10-23 06:30:33 UTC
|
||||
--- configure.ac.orig 2018-03-08 02:38:54 UTC
|
||||
+++ configure.ac
|
||||
@@ -58,9 +58,9 @@ AC_ARG_WITH([cupsfilterdir],
|
||||
if test "xno" = "x${with_cupsfilterdir}"; then
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- lib/Makefile.am.orig 2016-06-29 23:57:44 UTC
|
||||
--- lib/Makefile.am.orig 2017-03-24 04:35:04 UTC
|
||||
+++ lib/Makefile.am
|
||||
@@ -44,7 +44,7 @@ DEFINES += -DGCOMSW_ASYNCJOB_SUPPORT
|
||||
DEFINES += -DGCOMSW_RAWFILE_SUPPORT
|
@ -1,4 +1,4 @@
|
||||
--- lib/epson-escpr-api.c.orig 2016-06-29 23:37:45 UTC
|
||||
--- lib/epson-escpr-api.c.orig 2017-03-24 04:35:04 UTC
|
||||
+++ lib/epson-escpr-api.c
|
||||
@@ -62,6 +62,7 @@
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- lib/epson-usb.c.orig 2014-08-19 02:29:44 UTC
|
||||
--- lib/epson-usb.c.orig 2017-03-24 04:35:04 UTC
|
||||
+++ lib/epson-usb.c
|
||||
@@ -2325,7 +2325,7 @@ static EPS_ERR_CODE GetSerialNumber (
|
||||
EPS_RETURN( ret );
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/Makefile.am.orig 2015-08-04 02:35:06 UTC
|
||||
--- src/Makefile.am.orig 2017-03-24 04:35:04 UTC
|
||||
+++ src/Makefile.am
|
||||
@@ -28,7 +28,11 @@ cupsfilter_PROGRAMS =\
|
||||
epson_escpr_wrapper_CFLAGS =\
|
@ -1,4 +1,4 @@
|
||||
--- src/filter.c.orig 2016-02-29 04:28:11 UTC
|
||||
--- src/filter.c.orig 2018-03-08 04:25:24 UTC
|
||||
+++ src/filter.c
|
||||
@@ -33,7 +33,10 @@
|
||||
|
||||
@ -19,7 +19,7 @@
|
||||
|
||||
#define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
|
||||
|
||||
@@ -382,7 +386,7 @@ main (int argc, char *argv[])
|
||||
@@ -381,7 +385,7 @@ main (int argc, char *argv[])
|
||||
}
|
||||
|
||||
printJob.jobStatus = EPS_STATUS_ESTABLISHED;
|
||||
@ -28,7 +28,7 @@
|
||||
///////////////////////////////////////////////////////////////////////////////////////////////////////////
|
||||
|
||||
print_area_x = printJob.printableAreaWidth;
|
||||
@@ -411,7 +415,7 @@ main (int argc, char *argv[])
|
||||
@@ -410,7 +414,7 @@ main (int argc, char *argv[])
|
||||
while ((read_page_no = read (STDIN_FILENO, &page_num, 1)) > 0) // 最初に page番号を読み込み
|
||||
{
|
||||
long x_count, y_count;
|
||||
@ -37,7 +37,7 @@
|
||||
y_count = 0;
|
||||
band_line_count = 0;
|
||||
|
||||
@@ -499,7 +503,11 @@ main (int argc, char *argv[])
|
||||
@@ -498,7 +502,11 @@ main (int argc, char *argv[])
|
||||
pagebuf+= bandBmp.widthBytes;
|
||||
posbuf+=bandBmp.widthBytes;
|
||||
|
||||
@ -49,7 +49,7 @@
|
||||
bandBmp.bits += band_line_count;
|
||||
|
||||
}
|
||||
@@ -510,13 +518,17 @@ main (int argc, char *argv[])
|
||||
@@ -509,13 +517,17 @@ main (int argc, char *argv[])
|
||||
memcpy(pagebuf, bandBmp.bits, bandBmp.widthBytes);
|
||||
pagebuf+= bandBmp.widthBytes;
|
||||
posbuf+= bandBmp.widthBytes;
|
||||
@ -68,7 +68,7 @@
|
||||
for (revert = print_area_y; revert > 0; revert--)
|
||||
{
|
||||
if (3 != byte_par_pixel)
|
||||
@@ -660,7 +672,11 @@ main (int argc, char *argv[])
|
||||
@@ -659,7 +671,11 @@ main (int argc, char *argv[])
|
||||
#endif
|
||||
debug_msg("printHeight = %d\n", printHeight);
|
||||
debug_msg("widthByte = %d\n", bandBmp.widthBytes);
|
||||
@ -80,7 +80,7 @@
|
||||
bandBmp.bits += band_line_count;
|
||||
}
|
||||
|
||||
@@ -682,7 +698,11 @@ main (int argc, char *argv[])
|
||||
@@ -681,7 +697,11 @@ main (int argc, char *argv[])
|
||||
fprintf(fp, "\n");
|
||||
fclose(fp);
|
||||
#endif
|
||||
@ -92,7 +92,7 @@
|
||||
bandBmp.bits += band_line_count;
|
||||
}
|
||||
|
||||
@@ -881,7 +901,7 @@ EPS_INT32 print_spool_fnc(void* hParam,
|
||||
@@ -880,7 +900,7 @@ EPS_INT32 print_spool_fnc(void* hParam,
|
||||
|
||||
// fwrite (pBuf, cbBuf, 1, outfp);
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- src/mem.c.orig 2014-09-08 02:02:44 UTC
|
||||
--- src/mem.c.orig 2017-03-24 04:35:04 UTC
|
||||
+++ src/mem.c
|
||||
@@ -24,6 +24,7 @@
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/wrapper.c.orig 2015-10-23 07:16:10 UTC
|
||||
--- src/wrapper.c.orig 2018-03-08 04:25:02 UTC
|
||||
+++ src/wrapper.c
|
||||
@@ -176,8 +176,8 @@ main (int argc, char *argv[])
|
||||
@@ -177,8 +177,8 @@ main (int argc, char *argv[])
|
||||
|
||||
int total_read = 0;
|
||||
int total_read_cache = 0;
|
||||
|
@ -83,11 +83,14 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-ET-2550_Series-epson-escpr-en.
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-2600_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-2610_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-2650_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-2700_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-2750_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-4500_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-4550_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-7700_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-ET-7750_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EW-M5071FT_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EW-M571T_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EW-M660FT_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-EW-M970A3T_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-K200-epson-escpr-en.ppd
|
||||
@ -101,7 +104,10 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-L375_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L385_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L386_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L395_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L396_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L405_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L4150_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L4160_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L455_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L475_Series-epson-escpr-en.ppd
|
||||
share/cups/model/epson-inkjet-printer-escpr/Epson-L485_Series-epson-escpr-en.ppd
|
||||
|
Loading…
Reference in New Issue
Block a user