PHP 7.2: Remove bad repocopies.
Reported by: adamw
This commit is contained in:
parent
3d401a3f72
commit
96025cafd3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454318
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -intl
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -json
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -pcntl
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -readline
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,38 +0,0 @@
|
||||
--- config.m4.orig 2013-08-20 06:46:43.000000000 +0200
|
||||
+++ config.m4 2013-08-27 16:01:29.000000000 +0200
|
||||
@@ -5,13 +5,8 @@
|
||||
PHP_ARG_WITH(libedit,for libedit readline replacement,
|
||||
[ --with-libedit[=DIR] Include libedit readline replacement (CLI/CGI only)])
|
||||
|
||||
-if test "$PHP_LIBEDIT" = "no"; then
|
||||
PHP_ARG_WITH(readline,for readline support,
|
||||
[ --with-readline[=DIR] Include readline support (CLI/CGI only)])
|
||||
-else
|
||||
- dnl "register" the --with-readline option to preven invalid "unknown configure option" warning
|
||||
- php_with_readline=no
|
||||
-fi
|
||||
|
||||
if test "$PHP_READLINE" && test "$PHP_READLINE" != "no"; then
|
||||
for i in $PHP_READLINE /usr/local /usr; do
|
||||
@@ -67,6 +62,13 @@
|
||||
-L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
|
||||
])
|
||||
|
||||
+ PHP_CHECK_LIBRARY(readline, rl_completion_matches,
|
||||
+ [
|
||||
+ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1, [ ])
|
||||
+ ],[],[
|
||||
+ -L$READLINE_DIR/$PHP_LIBDIR $PHP_READLINE_LIBS
|
||||
+ ])
|
||||
+
|
||||
AC_DEFINE(HAVE_LIBREADLINE, 1, [ ])
|
||||
|
||||
elif test "$PHP_LIBEDIT" != "no"; then
|
||||
@@ -118,7 +120,6 @@
|
||||
fi
|
||||
|
||||
if test "$PHP_READLINE" != "no" || test "$PHP_LIBEDIT" != "no"; then
|
||||
- AC_CHECK_FUNCS([rl_completion_matches])
|
||||
PHP_NEW_EXTENSION(readline, readline.c readline_cli.c, $ext_shared, cli)
|
||||
PHP_SUBST(READLINE_SHARED_LIBADD)
|
||||
fi
|
@ -1,13 +0,0 @@
|
||||
--- readline_cli.c.orig 2012-03-02 16:40:26.000000000 +0100
|
||||
+++ readline_cli.c 2012-03-02 16:40:43.000000000 +0100
|
||||
@@ -19,6 +19,10 @@
|
||||
|
||||
/* $Id: readline_cli.c 321634 2012-01-01 13:15:04Z felipe $ */
|
||||
|
||||
+#ifdef HAVE_CONFIG_H
|
||||
+#include "config.h"
|
||||
+#endif
|
||||
+
|
||||
#include "php.h"
|
||||
|
||||
#ifndef HAVE_RL_COMPLETION_MATCHES
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -shmop
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -sysvmsg
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -sysvsem
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -sysvshm
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= devel
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -tokenizer
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= ftp
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -curl
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,13 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= ftp
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -ftp
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} s/HAVE_OPENSSL_EXT/__FreeBSD__/ \
|
||||
${WRKSRC}/ftp.* ${WRKSRC}/php_ftp.*
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= graphics
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -exif
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= graphics
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -gd
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= mail
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -imap
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,42 +0,0 @@
|
||||
--- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
|
||||
+++ config.m4 2010-03-08 11:56:24.000000000 +0100
|
||||
@@ -103,6 +103,8 @@
|
||||
PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
|
||||
[ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
|
||||
|
||||
+PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
||||
+[ --with-pcre-dir IMAP: pcre install prefix], no, no)
|
||||
|
||||
if test "$PHP_IMAP" != "no"; then
|
||||
PHP_SUBST(IMAP_SHARED_LIBADD)
|
||||
@@ -119,6 +121,30 @@
|
||||
fi
|
||||
done
|
||||
|
||||
+ dnl This is PECL build, check if bundled PCRE library is used
|
||||
+ old_CPPFLAGS=$CPPFLAGS
|
||||
+ CPPFLAGS=$INCLUDES
|
||||
+ AC_EGREP_CPP(yes,[
|
||||
+#include <main/php_config.h>
|
||||
+#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
|
||||
+yes
|
||||
+#endif
|
||||
+ ],[
|
||||
+ PHP_PCRE_REGEX=yes
|
||||
+ ],[
|
||||
+ AC_EGREP_CPP(yes,[
|
||||
+#include <main/php_config.h>
|
||||
+#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
|
||||
+yes
|
||||
+#endif
|
||||
+ ],[
|
||||
+ PHP_PCRE_REGEX=pecl
|
||||
+ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
|
||||
+ ],[
|
||||
+ PHP_PCRE_REGEX=no
|
||||
+ ])
|
||||
+ ])
|
||||
+
|
||||
dnl Check for c-client version 2004
|
||||
AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
|
||||
AC_DEFINE(HAVE_IMAP2004,1,[ ])
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= math
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -bcmath
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= math
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -gmp
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= misc
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -calendar
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= net-mgmt
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -snmp
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= net
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -ldap
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= net
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -soap
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= net
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -sockets
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= net
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -xmlrpc
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,23 +0,0 @@
|
||||
--- config.m4.orig 2014-04-29 08:04:30.000000000 +0000
|
||||
+++ config.m4 2014-05-15 08:04:00.883004682 +0000
|
||||
@@ -61,11 +61,9 @@ if test "$PHP_XMLRPC" != "no"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
- dnl if iconv is shared or missing then we should build iconv ourselves
|
||||
- if test "$PHP_ICONV_SHARED" = "yes" || test "$PHP_ICONV" = "no"; then
|
||||
-
|
||||
if test "$PHP_ICONV_DIR" != "no"; then
|
||||
PHP_ICONV=$PHP_ICONV_DIR
|
||||
+ PHP_ADD_INCLUDE($PHP_ICONV_DIR/include)
|
||||
fi
|
||||
|
||||
if test -z "$PHP_ICONV" || test "$PHP_ICONV" = "no"; then
|
||||
@@ -75,7 +73,6 @@ if test "$PHP_XMLRPC" != "no"; then
|
||||
PHP_SETUP_ICONV(XMLRPC_SHARED_LIBADD, [], [
|
||||
AC_MSG_ERROR([iconv not found, in order to build xmlrpc you need the iconv library])
|
||||
])
|
||||
- fi
|
||||
fi
|
||||
|
||||
if test "$PHP_XMLRPC" = "yes"; then
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= security
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -filter
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,10 +0,0 @@
|
||||
--- config.m4.orig 2009-03-06 08:25:45.000000000 +0100
|
||||
+++ config.m4 2009-03-06 08:28:10.000000000 +0100
|
||||
@@ -32,6 +32,7 @@
|
||||
#endif
|
||||
],[
|
||||
PHP_PCRE_REGEX=pecl
|
||||
+ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
|
||||
],[
|
||||
PHP_PCRE_REGEX=no
|
||||
])
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= security
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -hash
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= security
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -openssl
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -fileinfo
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,21 +0,0 @@
|
||||
--- config.m4.orig 2010-09-07 15:45:30.000000000 +0200
|
||||
+++ config.m4 2010-09-07 15:46:50.000000000 +0200
|
||||
@@ -4,6 +4,9 @@
|
||||
PHP_ARG_ENABLE(fileinfo, for fileinfo support,
|
||||
[ --disable-fileinfo Disable fileinfo support], yes)
|
||||
|
||||
+PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
||||
+[ --with-pcre-dir FILEINFO: pcre install prefix], no, no)
|
||||
+
|
||||
if test "$PHP_FILEINFO" != "no"; then
|
||||
|
||||
libmagic_sources=" \
|
||||
@@ -13,6 +16,8 @@
|
||||
libmagic/is_tar.c libmagic/magic.c libmagic/print.c \
|
||||
libmagic/readcdf.c libmagic/readelf.c libmagic/softmagic.c"
|
||||
|
||||
+ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
|
||||
+
|
||||
PHP_NEW_EXTENSION(fileinfo, fileinfo.c $libmagic_sources, $ext_shared,,-I@ext_srcdir@/libmagic)
|
||||
PHP_ADD_BUILD_DIR($ext_builddir/libmagic)
|
||||
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -posix
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,38 +0,0 @@
|
||||
--- posix.c.orig Fri Feb 23 00:40:39 2007
|
||||
+++ posix.c Sun May 13 17:52:27 2007
|
||||
@@ -838,7 +838,7 @@
|
||||
#if defined(ZTS) && defined(HAVE_GETGRNAM_R) && defined(_SC_GETGR_R_SIZE_MAX)
|
||||
buflen = sysconf(_SC_GETGR_R_SIZE_MAX);
|
||||
if (buflen < 1) {
|
||||
- RETURN_FALSE;
|
||||
+ buflen = 1024;
|
||||
}
|
||||
buf = emalloc(buflen);
|
||||
g = &gbuf;
|
||||
@@ -888,7 +888,7 @@
|
||||
|
||||
grbuflen = sysconf(_SC_GETGR_R_SIZE_MAX);
|
||||
if (grbuflen < 1) {
|
||||
- RETURN_FALSE;
|
||||
+ grbuflen = 1024;
|
||||
}
|
||||
|
||||
grbuf = emalloc(grbuflen);
|
||||
@@ -955,7 +955,7 @@
|
||||
#if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWNAM_R)
|
||||
buflen = sysconf(_SC_GETPW_R_SIZE_MAX);
|
||||
if (buflen < 1) {
|
||||
- RETURN_FALSE;
|
||||
+ buflen = 1024;
|
||||
}
|
||||
buf = emalloc(buflen);
|
||||
pw = &pwbuf;
|
||||
@@ -1004,7 +1004,7 @@
|
||||
#if defined(ZTS) && defined(_SC_GETPW_R_SIZE_MAX) && defined(HAVE_GETPWUID_R)
|
||||
pwbuflen = sysconf(_SC_GETPW_R_SIZE_MAX);
|
||||
if (pwbuflen < 1) {
|
||||
- RETURN_FALSE;
|
||||
+ pwbuflen = 1024;
|
||||
}
|
||||
pwbuf = emalloc(pwbuflen);
|
||||
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= textproc
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -ctype
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= textproc
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -dom
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
@ -1,9 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= textproc
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php71
|
||||
|
||||
PKGNAMESUFFIX= -enchant
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
Loading…
Reference in New Issue
Block a user