multimedia/libgav1: update to 0.16.3
Changes: https://chromium.googlesource.com/codecs/libgav1/+log/v0.16.0..v0.16.3
Reported by: portscout
(cherry picked from commit 5abf6717e3
)
This commit is contained in:
parent
f78eb90120
commit
95bf52b898
@ -1,8 +1,7 @@
|
||||
|
||||
PORTNAME= libgav1
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.16.0
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.16.3
|
||||
CATEGORIES= multimedia
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1594780074
|
||||
SHA256 (jbeich-libgav1-v0.16.0_GH0.tar.gz) = d9563c70f42466ba4a01a230a8dbbddf8f3a470a695c28a51c23dc246f04e51e
|
||||
SIZE (jbeich-libgav1-v0.16.0_GH0.tar.gz) = 713762
|
||||
TIMESTAMP = 1618365301
|
||||
SHA256 (jbeich-libgav1-v0.16.3_GH0.tar.gz) = 30ef78bf79c21d890e049b565ba99a124fd2d27095bd51ac2e63549780ee5a10
|
||||
SIZE (jbeich-libgav1-v0.16.3_GH0.tar.gz) = 921201
|
||||
|
@ -1,7 +1,7 @@
|
||||
- Sync -std= with devel/abseil to match ABI
|
||||
- Avoid leaking abseil dependency to shared library consumers
|
||||
|
||||
--- CMakeLists.txt.orig 2020-07-15 02:27:54 UTC
|
||||
--- CMakeLists.txt.orig 2021-04-14 01:55:01 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -16,8 +16,8 @@
|
||||
cmake_minimum_required(VERSION 3.7.1 FATAL_ERROR)
|
||||
@ -14,15 +14,20 @@
|
||||
|
||||
project(libgav1 CXX)
|
||||
|
||||
@@ -107,8 +107,11 @@ if(NOT "${LIBGAV1_EXE_LINKER_FLAGS}" STREQUAL "")
|
||||
separate_arguments(LIBGAV1_EXE_LINKER_FLAGS)
|
||||
endif()
|
||||
@@ -115,6 +115,8 @@ endif()
|
||||
# Set test-only flags based on LIBGAV1_CXX_FLAGS.
|
||||
libgav1_set_test_flags()
|
||||
|
||||
+find_package(absl)
|
||||
+if (NOT TARGET absl::base)
|
||||
add_subdirectory("${libgav1_root}/third_party/abseil-cpp"
|
||||
"${libgav1_abseil_build}" EXCLUDE_FROM_ALL)
|
||||
+endif()
|
||||
+if(NOT TARGET absl::base)
|
||||
set(libgav1_abseil "${libgav1_root}/third_party/abseil-cpp")
|
||||
if(NOT EXISTS "${libgav1_abseil}")
|
||||
message(
|
||||
@@ -127,6 +129,7 @@ if(NOT EXISTS "${libgav1_abseil}")
|
||||
" https://github.com/abseil/abseil-cpp.git third_party/abseil-cpp")
|
||||
endif()
|
||||
add_subdirectory("${libgav1_abseil}" "${libgav1_abseil_build}" EXCLUDE_FROM_ALL)
|
||||
+endif() # NOT TARGET absl::base
|
||||
|
||||
libgav1_reset_target_lists()
|
||||
libgav1_add_dsp_targets()
|
||||
|
@ -9,5 +9,6 @@ include/gav1/version.h
|
||||
lib/libgav1.a
|
||||
lib/libgav1.so
|
||||
lib/libgav1.so.0
|
||||
lib/libgav1.so.0.0.0
|
||||
libdata/pkgconfig/libgav1.pc
|
||||
share/cmake/libgav1-config.cmake
|
||||
|
Loading…
Reference in New Issue
Block a user