devel/eric6: update to 17.11.1, add FLAVORS
- add FLAVORS for the following combinations [1]: - python: 2.7 and 3.6 - qt: 4 and 5 - simplify Makefiles: - all common macros between eric6 and the language packages are in devel/eric6/bsd.eric6.mk - devel/eric6/Makefile.inc only includes language package specific macros - eric6 specific macros are now moved into devel/eric6/Makefile - spelling error fixed in Makefile.inc - dependency on eric6 (for language packages) removed as the addition of flavors removes the ability to depend on a single port origin - install language files directly, since setup.py fails without eric6 installed Approved by: portmgr (mat) [1] Differential Revision: https://reviews.freebsd.org/D13448
This commit is contained in:
parent
78830c95d9
commit
95a1554a33
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=458671
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051439
|
||||
SHA256 (eric6-i18n-zh_CN-17.10.tar.gz) = 23dc3d8ab877330ca63402edb7d1f051a7d3b1903e7cef3c629e17f35884e1ec
|
||||
SIZE (eric6-i18n-zh_CN-17.10.tar.gz) = 595047
|
||||
TIMESTAMP = 1512941853
|
||||
SHA256 (eric6-i18n-zh_CN-17.11.1.tar.gz) = 50446df66d835331ad8bd5217ce30770872c7228b319aff9b0b787c0a6a5a9a1
|
||||
SIZE (eric6-i18n-zh_CN-17.11.1.tar.gz) = 595829
|
||||
|
@ -3,6 +3,5 @@
|
||||
|
||||
CATEGORIES= devel python
|
||||
I18N_LANG= cs
|
||||
PKGNAMEPREFIX= ${I18N_LANG}-
|
||||
|
||||
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051541
|
||||
SHA256 (eric6-i18n-cs-17.10.tar.gz) = 13e6e3bea8f87b77d093bde57bc6204f18d40becbfb16b8b67dc257e8a0d2c15
|
||||
SIZE (eric6-i18n-cs-17.10.tar.gz) = 605270
|
||||
TIMESTAMP = 1512941911
|
||||
SHA256 (eric6-i18n-cs-17.11.1.tar.gz) = 38a1be9635a0dcb2ad6a22fa2f55c9387db3429608f134d489a7d0d0c91d9e58
|
||||
SIZE (eric6-i18n-cs-17.11.1.tar.gz) = 606237
|
||||
|
@ -1,9 +1,8 @@
|
||||
# Created by: Boris Samorodov <bsam@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTREVISION= 1
|
||||
PKGNAMESUFFIX= -${FLAVOR:U:S/_/-/}
|
||||
CATEGORIES= devel python
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtGui.so:x11-toolkits/py-qt${PYQTVER}-gui@${PY_FLAVOR} \
|
||||
${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/Qsci.so:devel/py-qt${PYQTVER}-qscintilla2@${PY_FLAVOR}
|
||||
@ -15,27 +14,35 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
|
||||
${PYTHON_SITELIBDIR}/PyQt${PYQTVER}/QtHelp.so:devel/py-qt${PYQTVER}-help@${PY_FLAVOR} \
|
||||
${PYTHON_LIBDIR}/lib-dynload/_sqlite3.so:databases/py-sqlite3@${PY_FLAVOR}
|
||||
|
||||
USES= desktop-file-utils
|
||||
CONFLICTS_INSTALL= ${FLAVORS:N${FLAVOR}:C/^/${PKGNAMEPREFIX}${PORTNAME}-/:C/$/-[0-9]*/}
|
||||
|
||||
USES= desktop-file-utils python:${FLAVOR:C/.*_py([0-9])/\1./}
|
||||
INSTALL_CMD= install.py -c -f eric6config.freebsd -i ${STAGEDIR} --pyqt=${PYQTVER}
|
||||
PLIST_FILES=
|
||||
SUB_FILES= eric6.desktop
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
OPTIONS_DEFAULT=PYQT4
|
||||
OPTIONS_SINGLE= PYQT
|
||||
OPTIONS_SINGLE_PYQT= PYQT4 PYQT5
|
||||
PYQT_DESC= PyQt Version
|
||||
PYQT4_DESC= Python bindings for Qt4
|
||||
PYQT4_VARS= PYQTVER=4
|
||||
PYQT5_DESC= Python bindings for Qt5
|
||||
PYQT5_VARS= PYQTVER=5
|
||||
PYQT5_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PyQt5/QtWebKitWidgets.so:www/py-qt5-webkitwidgets@${PY_FLAVOR}
|
||||
EXTRA_PATCHES=
|
||||
MASTERPORT=
|
||||
PYQTVER= ${FLAVOR:C/qt([45])_py[0-9]+/\1/}
|
||||
MASTERPORT= yes
|
||||
|
||||
PORTDATA= *
|
||||
PORTDOCS= *
|
||||
PORTEXAMPLES= *
|
||||
|
||||
.include "${.CURDIR}/bsd.eric6.mk"
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
PY_FLAVORS= py${PYTHON_DEFAULT:S/.//} py${PYTHON2_DEFAULT:S/.//} py${PYTHON3_DEFAULT:S/.//}
|
||||
.for flavor in ${PY_FLAVORS}
|
||||
. if empty(FLAVORS:Mqt4_${flavor})
|
||||
FLAVORS:= ${FLAVORS} qt4_${flavor} qt5_${flavor}
|
||||
. endif
|
||||
.endfor
|
||||
.if empty(FLAVOR)
|
||||
FLAVOR= ${FLAVORS:[1]}
|
||||
.endif
|
||||
|
||||
.if ${PYQTVER} == 5
|
||||
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt5/QtWebKitWidgets.so:www/py-qt5-webkitwidgets@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${RM} ${WRKSRC}/eric/i18n/*.qm ${WRKSRC}/eric/i18n/*.ts
|
||||
|
||||
@ -48,10 +55,14 @@ do-configure:
|
||||
-e 's,EXAMPLESDIR,${EXAMPLESDIR},' \
|
||||
< ${FILESDIR}/config > ${WRKSRC}/eric6config.freebsd
|
||||
|
||||
do-install:
|
||||
@(cd ${WRKSRC}; \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${INSTALL_CMD})
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKDIR}/eric6.desktop ${STAGEDIR}${PREFIX}/share/applications/
|
||||
${LN} -sf ${DATADIR:C|${PREFIX}(/share(/pixmaps)?)?||:C|/[^/]+|../|g}eric6/icons/default/eric.png \
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/eric6.png
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}/i18n
|
||||
|
||||
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,48 +1,22 @@
|
||||
# Created by: Boris Samorodov <bsam@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
#
|
||||
# This is a set of Makefile macros which allow to build the core and
|
||||
# This is a set of Makefile macros which allow to build the
|
||||
# localized language packages for devel/eric6:
|
||||
# french/eric6, german/eric6, russian/eric6
|
||||
# chinese/eric6, french/eric6, german/eric6, portuguese/eric6, russian/eric6
|
||||
# devel/cs-eric6, devel/es-eric6, devel/it-eric6, devel/tr-eric6
|
||||
|
||||
PORTNAME= eric6
|
||||
PORTVERSION= 17.10
|
||||
MASTER_SITES= SF/eric-ide/${PORTNAME}/stable/${PORTVERSION}
|
||||
DISTNAME?= ${PORTNAME}-i18n-${I18N_LANG}-${PORTVERSION}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
.include "${.CURDIR}/../../devel/eric6/bsd.eric6.mk"
|
||||
|
||||
MAINTAINER?= dbn@FreeBSD.org
|
||||
COMMENT= Full featured Python and Ruby editor and IDE based on Qt
|
||||
PKGNAMEPREFIX= ${I18N_LANG}-
|
||||
DISTNAME= ${PORTNAME}-i18n-${I18N_LANG}-${PORTVERSION}
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
RUN_DEPENDS?= ${LOCALBASE}/bin/eric6:devel/eric6
|
||||
|
||||
I18N_LANG?= ru
|
||||
INSTALL_CMD?= install-i18n.py -p ${STAGEDIR}
|
||||
MAKE_ENV+= "HOME=${WRKDIR}"
|
||||
|
||||
USES+= python:2.7
|
||||
NO_BUILD= yes
|
||||
PLIST_FILES?= %%DATADIR%%/i18n/${PORTNAME}_${I18N_LANG}.qm
|
||||
EXTRA_PATCHES?= ${.CURDIR}/../../devel/eric6/files/extra-patch-install-i18n.py
|
||||
|
||||
.if ! defined(MASTERPORT)
|
||||
INSTALL_CMD= install-i18n.py -p ${STAGEDIR}
|
||||
NO_ARCH= yes
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_VER} <= 2.7
|
||||
PLIST_SUB+= PYTHON2=
|
||||
.else
|
||||
PLIST_SUB+= PYTHON2="@comment "
|
||||
.endif
|
||||
PLIST_FILES= ${DATADIR}/i18n/${PORTNAME}_${I18N_LANG}.qm
|
||||
|
||||
do-install:
|
||||
@(cd ${WRKSRC}; \
|
||||
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${INSTALL_CMD})
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}/i18n
|
||||
${INSTALL_DATA} ${WRKSRC}/eric/i18n/${PORTNAME}_${I18N_LANG}.qm ${STAGEDIR}${DATADIR}/i18n/
|
||||
|
||||
DESCR= ${.CURDIR}/../../devel/eric6/pkg-descr
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
22
devel/eric6/bsd.eric6.mk
Normal file
22
devel/eric6/bsd.eric6.mk
Normal file
@ -0,0 +1,22 @@
|
||||
# Created by: Boris Samorodov <bsam@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
#
|
||||
# This is a set of Makefile macros that are common between devel/eric6 and
|
||||
# localized language packages for devel/eric6:
|
||||
# chinese/eric6, french/eric6, german/eric6, portuguese/eric6, russian/eric6
|
||||
# devel/cs-eric6, devel/es-eric6, devel/it-eric6, devel/tr-eric6
|
||||
|
||||
PORTNAME= eric6
|
||||
PORTVERSION= 17.11.1
|
||||
MASTER_SITES= SF/eric-ide/${PORTNAME}/stable/${PORTVERSION}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= dbn@FreeBSD.org
|
||||
COMMENT= Full featured Python and Ruby editor and IDE based on Qt
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
DESCR= ${.CURDIR}/../../devel/eric6/pkg-descr
|
||||
MAKE_ENV+= "HOME=${WRKDIR}"
|
||||
|
||||
NO_BUILD= yes
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509047590
|
||||
SHA256 (eric6-17.10.tar.gz) = 2fdcde6d6a9c2b23b0ce488ef7e80c74b85900d24b4ced1760b761f543af35ce
|
||||
SIZE (eric6-17.10.tar.gz) = 18938811
|
||||
TIMESTAMP = 1512941764
|
||||
SHA256 (eric6-17.11.1.tar.gz) = 2a7eb6392ce5782ac514c96574587d40240b75e2a9fd970d859db842faeaa89c
|
||||
SIZE (eric6-17.11.1.tar.gz) = 18986262
|
||||
|
@ -1,49 +0,0 @@
|
||||
--- install-i18n.py.orig 2013-08-19 13:16:47.862300000 +0400
|
||||
+++ install-i18n.py 2013-10-05 17:55:20.162267518 +0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python3
|
||||
+#!/usr/bin/env python
|
||||
# -*- coding: utf-8 -*-
|
||||
|
||||
# Copyright (c) 2004 - 2015 Detlev Offenbach <detlev@die-offenbachs.de>
|
||||
@@ -45,6 +45,7 @@
|
||||
# Define the globals.
|
||||
progName = None
|
||||
configDir = getConfigDir()
|
||||
+distDir = None
|
||||
privateInstall = False
|
||||
|
||||
def usage(rcode = 2):
|
||||
@@ -71,7 +72,9 @@
|
||||
global privateInstall, configDir
|
||||
|
||||
if privateInstall:
|
||||
- targetDir = configDir
|
||||
+ targetDir = distDir + getConfig('ericTranslationsDir')
|
||||
+ if not os.path.exists(targetDir):
|
||||
+ os.makedirs(targetDir, 493) # 0o755
|
||||
else:
|
||||
targetDir = getConfig('ericTranslationsDir')
|
||||
|
||||
@@ -97,11 +100,12 @@
|
||||
progName = os.path.basename(argv[0])
|
||||
|
||||
try:
|
||||
- optlist, args = getopt.getopt(argv[1:], "hp")
|
||||
+ optlist, args = getopt.getopt(argv[1:], "hp:")
|
||||
except getopt.GetoptError:
|
||||
usage()
|
||||
|
||||
global platBinDir
|
||||
+ global distDir
|
||||
|
||||
depChecks = 1
|
||||
|
||||
@@ -110,6 +114,7 @@
|
||||
usage(0)
|
||||
elif opt == "-p":
|
||||
privateInstall = 1
|
||||
+ distDir = os.path.normpath(arg)
|
||||
|
||||
installTranslations()
|
||||
|
@ -3,6 +3,5 @@
|
||||
|
||||
CATEGORIES= devel python
|
||||
I18N_LANG= es
|
||||
PKGNAMEPREFIX= ${I18N_LANG}-
|
||||
|
||||
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051586
|
||||
SHA256 (eric6-i18n-es-17.10.tar.gz) = b420e35e4d79319a5323dbf0650c083eea970424235fac5fbd32287267b592cd
|
||||
SIZE (eric6-i18n-es-17.10.tar.gz) = 897187
|
||||
TIMESTAMP = 1512941964
|
||||
SHA256 (eric6-i18n-es-17.11.1.tar.gz) = c960618db95ac6be2b9f46972ac925520fa02bdfa523fe9346a773f354dc0c3f
|
||||
SIZE (eric6-i18n-es-17.11.1.tar.gz) = 901638
|
||||
|
@ -3,6 +3,5 @@
|
||||
|
||||
CATEGORIES= devel python
|
||||
I18N_LANG= it
|
||||
PKGNAMEPREFIX= ${I18N_LANG}-
|
||||
|
||||
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051631
|
||||
SHA256 (eric6-i18n-it-17.10.tar.gz) = 9c96dccf586e0d8f1772f8e5d7ab83014b6d9d0ad5c34b09fc5641d3cb9d7069
|
||||
SIZE (eric6-i18n-it-17.10.tar.gz) = 696894
|
||||
TIMESTAMP = 1512942017
|
||||
SHA256 (eric6-i18n-it-17.11.1.tar.gz) = 73ef8c70e4339e74aa55bbdbd1b6a191be3d2b5c043546a99ab5c7376f1abc26
|
||||
SIZE (eric6-i18n-it-17.11.1.tar.gz) = 681546
|
||||
|
@ -3,6 +3,5 @@
|
||||
|
||||
CATEGORIES= devel python
|
||||
I18N_LANG= tr
|
||||
PKGNAMEPREFIX= ${I18N_LANG}-
|
||||
|
||||
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051675
|
||||
SHA256 (eric6-i18n-tr-17.10.tar.gz) = c1b848f935aa69efcb486cdc06b2442743aaf4a3a6dad4d1c33d5198e7529af9
|
||||
SIZE (eric6-i18n-tr-17.10.tar.gz) = 541728
|
||||
TIMESTAMP = 1512942072
|
||||
SHA256 (eric6-i18n-tr-17.11.1.tar.gz) = ab0031d9ff24cd5f5a69b767185c9d2b854246ef3eba659bdad56ef7bf86eae1
|
||||
SIZE (eric6-i18n-tr-17.11.1.tar.gz) = 542590
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051719
|
||||
SHA256 (eric6-i18n-fr-17.10.tar.gz) = b02c117c3847116e4358ceadee71d05d4345adf11635cb8c75c429c993c906c3
|
||||
SIZE (eric6-i18n-fr-17.10.tar.gz) = 549936
|
||||
TIMESTAMP = 1512942125
|
||||
SHA256 (eric6-i18n-fr-17.11.1.tar.gz) = b9b3d42b896ea6bd23e34abdc2245d1fcc9e65a0787b9116e19a04a94f9ec298
|
||||
SIZE (eric6-i18n-fr-17.11.1.tar.gz) = 550428
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051764
|
||||
SHA256 (eric6-i18n-de-17.10.tar.gz) = 9586ca5d968f26ccfcac43abb15c2ca7c665ad5226a1660bb3d3915de6ce961b
|
||||
SIZE (eric6-i18n-de-17.10.tar.gz) = 895479
|
||||
TIMESTAMP = 1512942181
|
||||
SHA256 (eric6-i18n-de-17.11.1.tar.gz) = e5ea6ef07f6b35265670b71c0d014edb1a77847d3c5207a673e74cc411223e14
|
||||
SIZE (eric6-i18n-de-17.11.1.tar.gz) = 898485
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051809
|
||||
SHA256 (eric6-i18n-pt-17.10.tar.gz) = fa2e4a7103f940222e2a51e7e9f015fcdd140ab278968cc79a63e8bafc06f594
|
||||
SIZE (eric6-i18n-pt-17.10.tar.gz) = 621317
|
||||
TIMESTAMP = 1512942234
|
||||
SHA256 (eric6-i18n-pt-17.11.1.tar.gz) = 8eb5cf2e8c1c83540c992fcca225e870222b15a5d400a1dd4beca4f8485777ae
|
||||
SIZE (eric6-i18n-pt-17.11.1.tar.gz) = 622235
|
||||
|
@ -2,5 +2,6 @@
|
||||
# $FreeBSD$
|
||||
|
||||
CATEGORIES= russian devel python
|
||||
I18N_LANG= ru
|
||||
|
||||
.include "${.CURDIR}/../../devel/eric6/Makefile.inc"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1509051853
|
||||
SHA256 (eric6-i18n-ru-17.10.tar.gz) = 1f11fff894aa8f40d1a7ccdef8aaa77fbce52185cfef06b42cbd5833269f4f7e
|
||||
SIZE (eric6-i18n-ru-17.10.tar.gz) = 939464
|
||||
TIMESTAMP = 1512942289
|
||||
SHA256 (eric6-i18n-ru-17.11.1.tar.gz) = 1297aa73b80ff795bcd13898c63af2d71a61348f48816a64bbc88fd8dc4a7799
|
||||
SIZE (eric6-i18n-ru-17.11.1.tar.gz) = 943045
|
||||
|
Loading…
Reference in New Issue
Block a user