Add bmp-extra-plugins, collection of plugins for Beep Media Player:

Input: musepack, mplayer
General: xf86audio, status
Output: crossfade, ogg, arts
Visualization: blursk, minilcd, wmdiscotux

PR:		ports/71979
Submitted by:	Jan Srzednicki <w@wrzask.pl>
This commit is contained in:
Pav Lucistnik 2004-11-21 19:45:29 +00:00
parent a124bba59c
commit 959fdf9a38
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=122085
6 changed files with 84 additions and 0 deletions

View File

@ -9,6 +9,7 @@
SUBDIR += avifile
SUBDIR += avinfo
SUBDIR += beep-media-player
SUBDIR += bmp-extra-plugins
SUBDIR += bsdbktr_tvtune
SUBDIR += camserv
SUBDIR += dirac

View File

@ -0,0 +1,33 @@
# New ports collection makefile for: bmp-extra-plugins
# Date created: Tue Sep 21 17:09:43 CEST 2004
# Whom: Jan Srzednicki <w@wrzask.pl>
#
# $FreeBSD$
#
PORTNAME= bmp-extra-plugins
PORTVERSION= 0.2.2
CATEGORIES= multimedia audio
MASTER_SITES= http://www.t17.ikarnet.pl/~wiget/bmp-extra-plugins/download/
MAINTAINER= w@wrzask.pl
COMMENT= A collection of additional plugins for beep media player
LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
vorbis.3:${PORTSDIR}/audio/libvorbis \
artsc.0:${PORTSDIR}/audio/arts
USE_GNOME= gtk20 libglade2 esound
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_BZIP2= yes
USE_LIBTOOL_VER= 15
CONFIGURE_ARGS+= --with-ogg=${LOCALBASE} \
--with-vorbis=${LOCALBASE}
post-patch:
@${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (bmp-extra-plugins-0.2.2.tar.bz2) = 612ce39533900610fcd9840284a88012
SIZE (bmp-extra-plugins-0.2.2.tar.bz2) = 836123

View File

@ -0,0 +1,13 @@
--- visualization/minilcd/sockets.c.orig Wed Jan 21 13:08:34 2004
+++ visualization/minilcd/sockets.c Sun Nov 21 18:27:07 2004
@@ -2,9 +2,9 @@
#include <stdio.h>
#include <errno.h>
#include <stdlib.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/un.h>
-#include <sys/types.h>
#include <netinet/in.h>
#include <netdb.h>
#include <arpa/inet.h>

View File

@ -0,0 +1,10 @@
bmp-extra-plugins is a package of additional plugins for beep-mediaplayer,
(ports/multimedia/beep-media-player), including:
Input: musepack, mplayer
General: xf86audio, status
Output: crossfade, ogg, arts
Visualization: blursk, minilcd, wmdiscotux
The distribution package is maintained by:
Artur Frysiak <wiget/at/plg-linux.org>

View File

@ -0,0 +1,25 @@
bin/bmp-arts-helper
lib/bmp/General/statusdocklet.so
lib/bmp/General/xf86audio.so
lib/bmp/Input/mplayer.so
lib/bmp/Input/musepack.so
lib/bmp/Output/arts.so
lib/bmp/Output/crossfade.so
lib/bmp/Output/oggre.so
lib/bmp/Visualization/blursk.so
lib/bmp/Visualization/minilcd.so
lib/bmp/Visualization/wmdiscotux.so
share/bmp/status_docklet/joost-idle.xpm
share/bmp/status_docklet/joost-paused-anim.xpm
share/bmp/status_docklet/joost-playing-anim.xpm
share/bmp/status_docklet/rest.xpm
share/bmp/status_docklet/stave-anim.xpm
share/bmp/status_docklet/stave-anim2.xpm
share/bmp/status_docklet/stave-anim3.xpm
share/bmp/status_docklet/stave-anim4.xpm
share/bmp/status_docklet/stave-anim5.xpm
share/bmp/status_docklet/timetre-idle.xpm
share/bmp/status_docklet/timetre-paused-anim.xpm
share/bmp/status_docklet/timetre-playing-anim.xpm
@dirrm share/bmp/status_docklet
@dirrm lib/bmp/General