Add wenju 1.1, collection of writing tools in Chinese.
PR: 58181 Submitted by: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
This commit is contained in:
parent
d81d1b524f
commit
958a7eb309
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93525
@ -105,6 +105,7 @@
|
||||
SUBDIR += ve
|
||||
SUBDIR += vflib
|
||||
SUBDIR += wangttf
|
||||
SUBDIR += wenju
|
||||
SUBDIR += xcin25
|
||||
SUBDIR += xemacs
|
||||
SUBDIR += xemacs21
|
||||
|
28
chinese/wenju/Makefile
Normal file
28
chinese/wenju/Makefile
Normal file
@ -0,0 +1,28 @@
|
||||
# New ports collection makefile for: wenju
|
||||
# Date created: 18 Oct 2003
|
||||
# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wenju
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= chinese
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= wenju
|
||||
|
||||
MAINTAINER= statue@freebsd.sinica.edu.tw
|
||||
COMMENT= Collection of writing tools in Chinese
|
||||
|
||||
USE_GNOME= gtk20
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --prefix=${PREFIX}
|
||||
USE_X_PREFIX= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
post-install:
|
||||
gtk-query-immodules-2.0 > ${PREFIX}/etc/gtk-2.0/gtk.immodules
|
||||
|
||||
.include <bsd.port.mk>
|
1
chinese/wenju/distinfo
Normal file
1
chinese/wenju/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (wenju-1.1.tar.gz) = 9ed56e365d08b598a4465c0844b32856
|
11
chinese/wenju/files/patch-configure
Normal file
11
chinese/wenju/files/patch-configure
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.orig Sat Oct 18 04:38:19 2003
|
||||
+++ configure Sat Oct 18 04:38:42 2003
|
||||
@@ -7889,7 +7889,7 @@
|
||||
|
||||
|
||||
GTK2_CFLAGS="`pkg-config --cflags gtk+-2.0`"
|
||||
-GTK2_LIBS="`pkg-config --libs gtk+-2.0`"
|
||||
+GTK2_LIBS="`pkg-config --libs gtk+-2.0` -lgnugetopt"
|
||||
GTK2_BINARY_VERSION="`pkg-config --variable=gtk_binary_version gtk+-2.0`"
|
||||
|
||||
|
20
chinese/wenju/files/patch-src::tim::timtable.c
Normal file
20
chinese/wenju/files/patch-src::tim::timtable.c
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/tim/timtable.c.orig Sat Oct 18 05:34:57 2003
|
||||
+++ src/tim/timtable.c Sat Oct 18 05:35:14 2003
|
||||
@@ -86,7 +86,7 @@
|
||||
|
||||
line = (char *)malloc(n*sizeof(char));;
|
||||
/* getline() is a GNU externsion */
|
||||
- while ((l = getline(&line, &n, fp)) > 0) {
|
||||
+ while ((l = fgets(line, n, fp)) > 0) {
|
||||
l = preprocess_line(line, l);
|
||||
if (l > 0) {
|
||||
char *p;
|
||||
@@ -189,7 +189,7 @@
|
||||
|
||||
line = (char *)malloc(n*sizeof(char));;
|
||||
/* getline() is a GNU externsion */
|
||||
- while ((l = getline(&line, &n, fp)) > 0) {
|
||||
+ while ((l = fgets(line, n, fp)) > 0) {
|
||||
l = preprocess_line(line, l);
|
||||
if (l > 0) {
|
||||
char *p;
|
11
chinese/wenju/files/patch-src::wrap::wrap.c
Normal file
11
chinese/wenju/files/patch-src::wrap::wrap.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/wrap/wrap.c.orig Sat Oct 18 05:37:16 2003
|
||||
+++ src/wrap/wrap.c Sat Oct 18 05:36:19 2003
|
||||
@@ -293,7 +293,7 @@
|
||||
size = 0;
|
||||
p = NULL;
|
||||
/* Read in an input line. */
|
||||
- while ((length = getline(&p, &size, fp)) > 0) {
|
||||
+ while ((length = fgets(p, size, fp)) > 0) {
|
||||
if (p[0] == '\n') {
|
||||
/* An empty line signals the end of the paragraph. */
|
||||
if (strcmp(text->str, "\n") == 0) {
|
11
chinese/wenju/files/patch-tests::Makefile.in
Normal file
11
chinese/wenju/files/patch-tests::Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- tests/Makefile.in.orig Sat Oct 18 05:18:58 2003
|
||||
+++ tests/Makefile.in Sat Oct 18 05:19:06 2003
|
||||
@@ -116,7 +116,7 @@
|
||||
noinst_PROGRAMS = wenju
|
||||
|
||||
wenju_SOURCES = wenju.c
|
||||
-wenju_LDADD = -lrt
|
||||
+wenju_LDADD = #-lrt
|
||||
subdir = tests
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/config/mkinstalldirs
|
||||
CONFIG_HEADER = $(top_builddir)/config.h
|
12
chinese/wenju/files/patch-tests::wenju.c
Normal file
12
chinese/wenju/files/patch-tests::wenju.c
Normal file
@ -0,0 +1,12 @@
|
||||
--- tests/wenju.c.orig Sat Oct 18 05:17:33 2003
|
||||
+++ tests/wenju.c Sat Oct 18 05:17:44 2003
|
||||
@@ -23,8 +23,8 @@
|
||||
|
||||
int main(int argc, char *argv[])
|
||||
{
|
||||
- setlocale(LC_ALL, "");
|
||||
#ifdef ENABLE_NLS
|
||||
+ setlocale(LC_ALL, "");
|
||||
bindtextdomain(PACKAGE, LOCALEDIR);
|
||||
#ifdef HAVE_BIND_TEXTDOMAIN_CODESET
|
||||
bind_textdomain_codeset(PACKAGE, "UTF-8");
|
4
chinese/wenju/pkg-descr
Normal file
4
chinese/wenju/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
A collection of writing tools (wenju in Chinese pinyin) such as input
|
||||
method, text file formatter, etc. All the tools are based on Unicode.
|
||||
|
||||
WWW: http://sourceforge.net/projects/wenju/
|
16
chinese/wenju/pkg-plist
Normal file
16
chinese/wenju/pkg-plist
Normal file
@ -0,0 +1,16 @@
|
||||
bin/tim-config
|
||||
bin/wrap
|
||||
lib/gtk-2.0/2.2.0/immodules/im-tim.la
|
||||
lib/gtk-2.0/2.2.0/immodules/im-tim.so
|
||||
%%DATADIR%%/cj.tim
|
||||
%%DATADIR%%/erbi.tim
|
||||
%%DATADIR%%/liu.tim
|
||||
%%DATADIR%%/phone.tim
|
||||
%%DATADIR%%/pinyin-p.tim
|
||||
%%DATADIR%%/pinyin.tim
|
||||
%%DATADIR%%/qfrench.tim
|
||||
%%DATADIR%%/wubi.tim
|
||||
%%DATADIR%%/wubihua-n.tim
|
||||
@dirrm %%DATADIR%%
|
||||
@exec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
|
||||
@unexec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
|
Loading…
Reference in New Issue
Block a user