Object-oriented SGML/XML parser toolkit and DSSSL engine: OpenJade
OpenJade is more active developped version of Jade. Repo. copied by: PW
This commit is contained in:
parent
57c727add4
commit
9588d7bd91
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=28572
@ -1,24 +1,16 @@
|
||||
# New ports collection makefile for: jade
|
||||
# Date created: June 19, 1997
|
||||
# Whom: jfieber
|
||||
# New ports collection makefile for: OpenJade
|
||||
# Date created: May 19, 2000
|
||||
# Whom: kuriyama
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= jade
|
||||
PORTVERSION= 1.2.1
|
||||
PORTNAME= openjade
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.jclark.com/pub/jade/
|
||||
MASTER_SITES= http://download.sourceforge.net/openjade/
|
||||
|
||||
PATCH_SITES= http://ftp.debian.org/debian/dists/unstable/main/source/text/
|
||||
PATCHFILES= jade_1.2.1-13.diff.gz
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= jfieber@FreeBSD.org
|
||||
|
||||
.if ${MACHINE_ARCH} == "alpha"
|
||||
BROKEN= nsgmls coredumps in static constructors
|
||||
.endif
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
|
||||
USE_GMAKE= YES
|
||||
USE_LIBTOOL= YES
|
||||
@ -26,27 +18,12 @@ GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CXXFLAGS="${CFLAGS}"
|
||||
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog
|
||||
|
||||
post-extract:
|
||||
@${CHMOD} u+w ${WRKSRC}/configure
|
||||
|
||||
pre-install:
|
||||
@find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
|
||||
|
||||
post-install:
|
||||
.for i in jade nsgmls sgmlnorm spam spent sx
|
||||
strip ${PREFIX}/bin/$i
|
||||
.endfor
|
||||
${MKDIR} ${PREFIX}/include/sp
|
||||
${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include/sp
|
||||
${MKDIR} ${PREFIX}/share/doc/jade
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/*.htm ${PREFIX}/share/doc/jade
|
||||
${MKDIR} ${PREFIX}/share/sgml/jade
|
||||
${INSTALL_DATA} ${WRKSRC}/dsssl/* ${PREFIX}/share/sgml/jade
|
||||
${MKDIR} ${PREFIX}/share/sgml/openjade
|
||||
${INSTALL_DATA} ${WRKSRC}/dsssl/* ${PREFIX}/share/sgml/openjade
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m $(PREFIX)/lib
|
||||
@if [ ! -f ${PREFIX}/share/sgml/catalog ]; then \
|
||||
${ECHO} "CATALOG \"${PREFIX}/share/sgml/jade/catalog\"" > ${PREFIX}/share/sgml/catalog; \
|
||||
else \
|
||||
${SETENV} LANG=C ${PERL} -ni -e 'print if !m|${PREFIX}/share/sgml/jade/catalog|;print "CATALOG \"${PREFIX}/share/sgml/jade/catalog\"\n" if eof;' ${PREFIX}/share/sgml/catalog; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1 @@
|
||||
MD5 (jade-1.2.1.tar.gz) = 4239670ca6b578bff68b8c2e7cd1225f
|
||||
MD5 (jade_1.2.1-13.diff.gz) = dc999cfad59b5e5be3d87cfe54cbf135
|
||||
MD5 (openjade-1.3.tar.gz) = 4cbc2a8c15431b3f08b4487a5702c938
|
||||
|
@ -1,13 +1,16 @@
|
||||
--- Makefile.comm.in.orig Sun Dec 12 21:06:43 1999
|
||||
+++ Makefile.comm.in Sun Dec 12 21:08:59 1999
|
||||
@@ -24,8 +24,8 @@
|
||||
LIBS=@LIBS@
|
||||
DEFS=@DEFS@
|
||||
INCS=-I$(srcdir) -I$(srcdir)/../include $(INCLUDE)
|
||||
-CXXFLAGS=@CXXFLAGS@ $(INCS) $(DEBUG) $(DEFS)
|
||||
-CFLAGS=@CFLAGS@ $(DEBUG) $(DEFS)
|
||||
+CXXFLAGS=-O $(INCS) $(DEBUG) $(DEFS)
|
||||
+CFLAGS=-O $(DEBUG) $(DEFS)
|
||||
LDFLAGS=@LDFLAGS@
|
||||
MSGGENFLAGS=
|
||||
CXXDEPGENFLAGS=-MM
|
||||
--- style/LangObj.cxx~ Fri Jul 2 07:49:58 1999
|
||||
+++ style/LangObj.cxx Tue May 16 12:59:00 2000
|
||||
@@ -12,11 +12,11 @@
|
||||
#include <string.h>
|
||||
#include <ctype.h>
|
||||
#include <string.h>
|
||||
-#include <wchar.h>
|
||||
-#include <wctype.h>
|
||||
|
||||
#ifdef SP_HAVE_LOCALE
|
||||
#include <locale.h>
|
||||
+#include <wchar.h>
|
||||
+#include <wctype.h>
|
||||
#endif
|
||||
|
||||
#ifdef DSSSL_NAMESPACE
|
||||
|
@ -1,19 +0,0 @@
|
||||
*** lib/instmac.m4.orig Sun Jul 6 20:20:04 1997
|
||||
--- lib/instmac.m4 Sun Jul 6 20:20:54 1997
|
||||
***************
|
||||
*** 75,81 ****
|
||||
__undefine(`undefine')__dnl
|
||||
__undefine(`undivert')__dnl
|
||||
__undefine(`unix')__dnl
|
||||
! __dnl __changequote(,)__dnl disable quoting
|
||||
|
||||
#ifdef SP_NAMESPACE
|
||||
}
|
||||
--- 75,81 ----
|
||||
__undefine(`undefine')__dnl
|
||||
__undefine(`undivert')__dnl
|
||||
__undefine(`unix')__dnl
|
||||
! __dnl __changequote(,)__dnl
|
||||
|
||||
#ifdef SP_NAMESPACE
|
||||
}
|
@ -1 +1 @@
|
||||
An object-oriented SGML/XML parser toolkit and DSSSL engine
|
||||
Object-oriented SGML/XML parser toolkit and DSSSL engine
|
||||
|
@ -1,22 +1,7 @@
|
||||
An object-oriented SGML/XML parser toolkit and DSSSL engine.
|
||||
OpenJade is an implementation of the ISO/IEC 10179:1996 standard DSSSL
|
||||
language. It is based on the James Clark implementation of DSSSL named
|
||||
Jade. OpenJade is now developed and maintained by the OpenJade team.
|
||||
|
||||
Features summary:
|
||||
For general information about DSSSL, see the OpenJade home page.
|
||||
|
||||
* Includes nsgmls
|
||||
* Provides access to all information about SGML document
|
||||
* Supports almost all optional SGML features
|
||||
* Sophisticated entity manager
|
||||
* Supports multi-byte character sets
|
||||
* Object-oriented
|
||||
* Written in C++ from scratch
|
||||
* Fast
|
||||
* Portable
|
||||
* Production quality
|
||||
* Free
|
||||
|
||||
Note: This port is a superset of the sp port. If you have sp
|
||||
installed, it is recommended that you remove it before installing
|
||||
jade.
|
||||
|
||||
John Fieber
|
||||
jfieber@FreeBSD.org
|
||||
WWW: http://www.netfolder.com/DSSSL/
|
||||
|
@ -1,189 +1,31 @@
|
||||
bin/jade
|
||||
bin/nsgmls
|
||||
bin/sgmlnorm
|
||||
bin/spam
|
||||
bin/spent
|
||||
bin/sx
|
||||
include/sp/Allocator.h
|
||||
include/sp/ArcEngine.h
|
||||
include/sp/Attribute.h
|
||||
include/sp/Attributed.h
|
||||
include/sp/Big5CodingSystem.h
|
||||
include/sp/Boolean.h
|
||||
include/sp/CharMap.cxx
|
||||
include/sp/CharMap.h
|
||||
include/sp/CharsetDecl.h
|
||||
include/sp/CharsetInfo.h
|
||||
include/sp/CharsetRegistry.h
|
||||
include/sp/CmdLineApp.h
|
||||
include/sp/CodingSystem.h
|
||||
include/sp/CodingSystemKit.h
|
||||
include/sp/ConsoleOutput.h
|
||||
include/sp/ContentState.h
|
||||
include/sp/ContentToken.h
|
||||
include/sp/CopyOwner.cxx
|
||||
include/sp/CopyOwner.h
|
||||
include/sp/DescriptorManager.h
|
||||
include/sp/Dtd.h
|
||||
include/sp/EUCJPCodingSystem.h
|
||||
include/sp/ElementType.h
|
||||
include/sp/Entity.h
|
||||
include/sp/EntityApp.h
|
||||
include/sp/EntityCatalog.h
|
||||
include/sp/EntityDecl.h
|
||||
include/sp/EntityManager.h
|
||||
include/sp/ErrnoMessageArg.h
|
||||
include/sp/ErrorCountEventHandler.h
|
||||
include/sp/Event.h
|
||||
include/sp/EventsWanted.h
|
||||
include/sp/ExtendEntityManager.h
|
||||
include/sp/ExternalId.h
|
||||
include/sp/Fixed2CodingSystem.h
|
||||
include/sp/GenericEventHandler.h
|
||||
include/sp/Hash.h
|
||||
include/sp/HashTable.cxx
|
||||
include/sp/HashTable.h
|
||||
include/sp/HashTableItemBase.cxx
|
||||
include/sp/HashTableItemBase.h
|
||||
include/sp/IList.h
|
||||
include/sp/IListBase.h
|
||||
include/sp/IListIter.h
|
||||
include/sp/IListIterBase.h
|
||||
include/sp/IQueue.cxx
|
||||
include/sp/IQueue.h
|
||||
include/sp/ISet.cxx
|
||||
include/sp/ISet.h
|
||||
include/sp/ISetIter.h
|
||||
include/sp/IdentityCodingSystem.h
|
||||
include/sp/InputSource.h
|
||||
include/sp/InternalInputSource.h
|
||||
include/sp/Link.h
|
||||
include/sp/LinkProcess.h
|
||||
include/sp/List.cxx
|
||||
include/sp/List.h
|
||||
include/sp/ListIter.h
|
||||
include/sp/LiteralStorage.h
|
||||
include/sp/Location.h
|
||||
include/sp/Lpd.h
|
||||
include/sp/Markup.h
|
||||
include/sp/Message.h
|
||||
include/sp/MessageArg.h
|
||||
include/sp/MessageBuilder.h
|
||||
include/sp/MessageEventHandler.h
|
||||
include/sp/MessageFormatter.h
|
||||
include/sp/MessageReporter.h
|
||||
include/sp/MessageTable.h
|
||||
include/sp/Mode.h
|
||||
include/sp/NCVector.h
|
||||
include/sp/NCVector.sed
|
||||
include/sp/Named.h
|
||||
include/sp/NamedResource.h
|
||||
include/sp/NamedResourceTable.h
|
||||
include/sp/NamedTable.h
|
||||
include/sp/Notation.h
|
||||
include/sp/NotationStorage.h
|
||||
include/sp/OpenElement.h
|
||||
include/sp/Options.cxx
|
||||
include/sp/Options.h
|
||||
include/sp/OutputByteStream.h
|
||||
include/sp/OutputCharStream.h
|
||||
include/sp/Owner.cxx
|
||||
include/sp/Owner.h
|
||||
include/sp/OwnerTable.cxx
|
||||
include/sp/OwnerTable.h
|
||||
include/sp/ParserApp.h
|
||||
include/sp/ParserOptions.h
|
||||
include/sp/PointerTable.cxx
|
||||
include/sp/PointerTable.h
|
||||
include/sp/PosixStorage.h
|
||||
include/sp/Ptr.cxx
|
||||
include/sp/Ptr.h
|
||||
include/sp/RangeMap.cxx
|
||||
include/sp/RangeMap.h
|
||||
include/sp/Resource.h
|
||||
include/sp/RewindStorageObject.h
|
||||
include/sp/SJISCodingSystem.h
|
||||
include/sp/SOEntityCatalog.h
|
||||
include/sp/Sd.h
|
||||
include/sp/SdText.h
|
||||
include/sp/SearchResultMessageArg.h
|
||||
include/sp/SgmlParser.h
|
||||
include/sp/ShortReferenceMap.h
|
||||
include/sp/StdioStorage.h
|
||||
include/sp/StorageManager.h
|
||||
include/sp/StringC.h
|
||||
include/sp/StringOf.cxx
|
||||
include/sp/StringOf.h
|
||||
include/sp/StringResource.h
|
||||
include/sp/SubstTable.cxx
|
||||
include/sp/SubstTable.h
|
||||
include/sp/Syntax.h
|
||||
include/sp/Text.h
|
||||
include/sp/TranslateCodingSystem.h
|
||||
include/sp/TypeId.h
|
||||
include/sp/URLStorage.h
|
||||
include/sp/UTF8CodingSystem.h
|
||||
include/sp/UnicodeCodingSystem.h
|
||||
include/sp/UnivCharsetDesc.h
|
||||
include/sp/Vector.cxx
|
||||
include/sp/Vector.h
|
||||
include/sp/Win32CodingSystem.h
|
||||
include/sp/WinApp.h
|
||||
include/sp/WinInetStorage.h
|
||||
include/sp/XMLCodingSystem.h
|
||||
include/sp/XcharMap.cxx
|
||||
include/sp/XcharMap.h
|
||||
include/sp/config.h
|
||||
include/sp/constant.h
|
||||
include/sp/macros.h
|
||||
include/sp/rtti.h
|
||||
include/sp/sptchar.h
|
||||
include/sp/types.h
|
||||
include/sp/xnew.h
|
||||
lib/libgrove.so
|
||||
lib/libgrove.so.1.3
|
||||
lib/libsp.so
|
||||
lib/libsp.so.1.3
|
||||
lib/libspgrove.so
|
||||
lib/libspgrove.so.1.3
|
||||
lib/libstyle.so
|
||||
lib/libstyle.so.1.3
|
||||
share/doc/jade/archform.htm
|
||||
share/doc/jade/build.htm
|
||||
share/doc/jade/catalog.htm
|
||||
share/doc/jade/charset.htm
|
||||
share/doc/jade/features.htm
|
||||
share/doc/jade/generic.htm
|
||||
share/doc/jade/ideas.htm
|
||||
share/doc/jade/index.htm
|
||||
share/doc/jade/new.htm
|
||||
share/doc/jade/nsgmls.htm
|
||||
share/doc/jade/sgmldecl.htm
|
||||
share/doc/jade/sgmlnorm.htm
|
||||
share/doc/jade/sgmlsout.htm
|
||||
share/doc/jade/spam.htm
|
||||
share/doc/jade/spent.htm
|
||||
share/doc/jade/sx.htm
|
||||
share/doc/jade/sysdecl.htm
|
||||
share/doc/jade/sysid.htm
|
||||
share/doc/jade/xml.htm
|
||||
share/sgml/jade/FOT.tex
|
||||
share/sgml/jade/Makefile.jadetex
|
||||
share/sgml/jade/catalog
|
||||
@unexec env LANG=C perl -ni -e 'print if !m|%D/%F|;' %D/share/sgml/catalog
|
||||
@exec if [ ! -f %D/share/sgml/catalog ]; then echo "CATALOG \"%D/%F\"" > %D/share/sgml/catalog; else env LANG=C perl -ni -e 'print if !m|%D/%F|;print "CATALOG \"%D/%F\"\n" if eof;' %D/share/sgml/catalog; fi
|
||||
share/sgml/jade/demo.dsl
|
||||
share/sgml/jade/demo.sgm
|
||||
share/sgml/jade/demoMaster.tex
|
||||
share/sgml/jade/dsssl.dtd
|
||||
share/sgml/jade/fot.dtd
|
||||
share/sgml/jade/jadetex.dtx
|
||||
share/sgml/jade/jadetex.ini
|
||||
share/sgml/jade/jadetex.ins
|
||||
share/sgml/jade/pdfjadetex.ini
|
||||
share/sgml/jade/style-sheet.dtd
|
||||
@dirrm include/sp
|
||||
@dirrm share/doc/jade
|
||||
@dirrm share/sgml/jade
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %D/lib
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
bin/onsgmls
|
||||
bin/openjade
|
||||
bin/osgmlnorm
|
||||
bin/ospam
|
||||
bin/ospent
|
||||
bin/osx
|
||||
lib/libogrove.so
|
||||
lib/libogrove.so.0
|
||||
lib/libosp.so
|
||||
lib/libosp.so.0
|
||||
lib/libospgrove.so
|
||||
lib/libospgrove.so.0
|
||||
lib/libostyle.so
|
||||
lib/libostyle.so.0
|
||||
share/builtins.dsl
|
||||
share/sgml/openjade/ChangeLog
|
||||
share/sgml/openjade/Makefile.jadetex
|
||||
share/sgml/openjade/builtins.dsl
|
||||
share/sgml/openjade/catalog
|
||||
share/sgml/openjade/demo.dsl
|
||||
share/sgml/openjade/demo.sgm
|
||||
share/sgml/openjade/dsssl.dtd
|
||||
share/sgml/openjade/extensions.dsl
|
||||
share/sgml/openjade/fot.dtd
|
||||
share/sgml/openjade/jadetex.dtx
|
||||
share/sgml/openjade/jadetex.ini
|
||||
share/sgml/openjade/jadetex.ins
|
||||
share/sgml/openjade/pdfjadetex.ini
|
||||
share/sgml/openjade/style-sheet.dtd
|
||||
share/sgml/openjade/unicode.sty
|
||||
@dirrm share/sgml/openjade
|
||||
|
Loading…
Reference in New Issue
Block a user