Activate ko-a2ps.

Simple a2ps wrapper for Korean text printing
This commit is contained in:
CHOI Junho 2000-10-01 13:04:04 +00:00
parent ea97a8d93b
commit 9581a76b12
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33285
6 changed files with 72 additions and 0 deletions

38
korean/a2ps/Makefile Normal file
View File

@ -0,0 +1,38 @@
# New ports collection makefile for: ko-a2ps
# Date created: 30 Sep 2000
# Whom: cjh
#
# $FreeBSD$
#
PORTNAME= a2ps
PORTVERSION= 20000314
CATEGORIES= korean print
MASTER_SITES= http://www.kr.FreeBSD.org/~hwang/misc/
DISTNAME= a2ps-h
EXTRACT_SUFX= .py
EXTRACT_ONLY=
MAINTAINER= cjh@FreeBSD.org
# depends on a2ps-a4. a2ps has several variation, so if I should
# choose one, a2ps-a4 is good because A4-sized paper is default in Korea.
RUN_DEPENDS= a2ps:${PORTSDIR}/print/a2ps-a4
USE_PYTHON= YES
NO_WRKSUBDIR= YES
# default Korean PS font
PSFONTKO= Gulim-Medium-KSC-EUC-H
pre-patch:
${CP} ${_DISTDIR}/${DISTFILES} ${WRKDIR}
do-build:
${SED} -e "s;%%PYTHON_CMD%%;${PYTHON_CMD};g" \
-e "s;%%PSFONTKO%%;${PSFONTKO};g" \
${WRKDIR}/a2ps-h.py > ${WRKDIR}/a2ps-h
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/a2ps-h ${PREFIX}/bin
.include <bsd.port.mk>

1
korean/a2ps/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (a2ps-h.py) = 37b8a768924ae82075a49ee99f789cf2

View File

@ -0,0 +1,23 @@
--- a2ps-h.py~ Sat Sep 30 18:04:02 2000
+++ a2ps-h.py Sat Sep 30 18:04:39 2000
@@ -1,4 +1,4 @@
-#! /usr/bin/env python
+#!%%PYTHON_CMD%%
#
# (C) Mizi Research
@@ -16,10 +16,10 @@
import string,sys,os
-hps = '/Gulim-Regular'
-hbps = '/Gulim-Regular'
-hbops = '/Gulim-Regular'
-hops = '/Gulim-Regular'
+hps = '/%%PSFONTKO%%'
+hbps = '/%%PSFONTKO%%'
+hbops = '/%%PSFONTKO%%'
+hops = '/%%PSFONTKO%%'
def trans_file(filename):
if type(filename) == type([]):

1
korean/a2ps/pkg-comment Normal file
View File

@ -0,0 +1 @@
Simple a2ps wrapper for Korean text printing

8
korean/a2ps/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
a2ps-h does filtering a2ps(not a2ps 4.3, a2ps 4.12 is ok) output
for Korean text printing. It converts Korean text in a2ps output
to Korean-printable PS file.
WWW: http://www.kr.FreeBSD.org/~hwang/misc/index.html
--
CHOI Junho <cjh@FreeBSD.org>

1
korean/a2ps/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/a2ps-h