2015-12-31 security/polarssl: Upstream is ending support for 1.2.x

This commit is contained in:
Xin LI 2016-02-07 09:58:59 +00:00
parent fe25743208
commit 9567fc068c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=408358
8 changed files with 1 additions and 194 deletions

1
MOVED
View File

@ -8134,3 +8134,4 @@ x11-toolkits/py32-tkinter||2016-02-02|Has expired: Full EOL reached. Please upda
sysutils/puppet|sysutils/puppet38|2016-02-05|Renamed
devel/etcdctl|devel/etcd|2016-02-06|Has expired: etcdctl is now part of etcd, following the change from the upstream
graphics/py-graphviz|graphics/py-pygraphviz|2016-02-07|Renamed to match upstream (PyPI) name
security/polarssl||2016-02-07|Has expired: Upstream is ending support for 1.2.x

View File

@ -783,7 +783,6 @@
SUBDIR += pks
SUBDIR += pktsuckers
SUBDIR += please
SUBDIR += polarssl
SUBDIR += polarssl13
SUBDIR += poly1305aes
SUBDIR += pond

View File

@ -1,63 +0,0 @@
# $FreeBSD$
PORTNAME= polarssl
PORTVERSION= 1.2.19
DISTVERSIONSUFFIX= -gpl
CATEGORIES= security devel
MASTER_SITES= https://polarssl.org/download/
MAINTAINER= jase@FreeBSD.org
COMMENT= Open Source embedded SSL/TLS cryptographic library
LICENSE= GPLv2
DEPRECATED= Upstream is ending support for 1.2.x
EXPIRATION_DATE=2015-12-31
ALL_TARGET= no_test
USES= cpe gmake tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
# PolarSSL's 1.3 branch introduces API changes that are served at this
# time by a separate polarssl13 port. Therefore, limit Portscout to the
# 1.2 branch for this port.
PORTSCOUT= limit:^1\.2\.
DOCFILES= ChangeLog README
BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
md5sum mpi_demo rsa_genkey rsa_sign rsa_verify selftest \
sha1sum sha2sum ssl_cert_test ssl_client1 ssl_client2 \
ssl_server ssl_test
OPTIONS_DEFINE= DOCS TEST
.include <bsd.port.options.mk>
post-build:
cd ${WRKSRC} && LD_LIBRARY_PATH="`pwd`/library" programs/test/selftest
post-build-TEST-on:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} LD_LIBRARY_PATH="`pwd`/library" ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check
# cmake install is broken, so we do it by hand
do-install:
@cd ${WRKSRC}/include && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/include "! -name *.orig"
${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${STAGEDIR}${PREFIX}/lib/
${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.5
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.5
cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.5 libpolarssl.so
.for i in ${BINFILES}
${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
.endfor
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCFILES}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
TEST_USES= perl5
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (polarssl-1.2.19-gpl.tgz) = 24cb1608a160101ead3c7240f35fc447fe7880cd60f7ed6c9db7a1d773ccd4b8
SIZE (polarssl-1.2.19-gpl.tgz) = 1045813

View File

@ -1,12 +0,0 @@
--- include/polarssl/config.h.orig 2013-09-24 16:37:14.000000000 +0200
+++ include/polarssl/config.h 2013-09-24 16:39:22.000000000 +0200
@@ -627,8 +627,8 @@
* Requires: POLARSSL_TIMING_C
*
* Uncomment to enable the HAVEGE random generator.
-#define POLARSSL_HAVEGE_C
*/
+#define POLARSSL_HAVEGE_C
/**
* \def POLARSSL_MD_C

View File

@ -1,25 +0,0 @@
--- library/Makefile.orig 2014-10-24 09:42:52.000000000 +0100
+++ library/Makefile 2014-10-27 20:13:26.522466123 +0000
@@ -18,9 +18,7 @@
# CFLAGS += -D_BSD_EXTENSION
# To compile as a shared library:
-ifdef SHARED
CFLAGS += -fPIC
-endif
SONAME=libpolarssl.so.5
@@ -53,11 +51,7 @@
.SILENT:
-ifndef SHARED
-all: static
-else
-all: shared
-endif
+all: shared static
static: libpolarssl.a

View File

@ -1,21 +0,0 @@
PolarSSL is a light-weight open source cryptographic and SSL/TLS library
written in C. PolarSSL is written with embedded systems in mind and has
been ported on a number of architectures, including ARM, PowerPC, MIPS
and Motorola 68000.
Features include:
* Small memory footprint
* Clean and simple API for integration
* Loose coupling of cryptographic code.
* Symmetric encryption algorithms: AES, Triple-DES, DES, ARC4, Camellia, XTEA
* Hash algorithms: MD2, MD4, MD5, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512
* HAVEGE random number generator
* RSA with PKCS#1 v1.5 padding
* SSL version 3 and TLS version 1 client support
* X.509 certificate and CRL reading from memory or disk in PEM and DER formats
* Over 900 regression and code coverage tests
* Example applications
LICENSE: GPL2
WWW: http://polarssl.org/

View File

@ -1,70 +0,0 @@
bin/polarssl_aescrypt2
bin/polarssl_benchmark
bin/polarssl_dh_client
bin/polarssl_dh_genprime
bin/polarssl_dh_server
bin/polarssl_hello
bin/polarssl_md5sum
bin/polarssl_mpi_demo
bin/polarssl_rsa_genkey
bin/polarssl_rsa_sign
bin/polarssl_rsa_verify
bin/polarssl_selftest
bin/polarssl_sha1sum
bin/polarssl_sha2sum
bin/polarssl_ssl_cert_test
bin/polarssl_ssl_client1
bin/polarssl_ssl_client2
bin/polarssl_ssl_server
bin/polarssl_ssl_test
include/polarssl/aes.h
include/polarssl/arc4.h
include/polarssl/asn1.h
include/polarssl/asn1write.h
include/polarssl/base64.h
include/polarssl/bignum.h
include/polarssl/blowfish.h
include/polarssl/bn_mul.h
include/polarssl/camellia.h
include/polarssl/certs.h
include/polarssl/cipher.h
include/polarssl/cipher_wrap.h
include/polarssl/config.h
include/polarssl/ctr_drbg.h
include/polarssl/debug.h
include/polarssl/des.h
include/polarssl/dhm.h
include/polarssl/entropy.h
include/polarssl/entropy_poll.h
include/polarssl/error.h
include/polarssl/gcm.h
include/polarssl/havege.h
include/polarssl/md.h
include/polarssl/md2.h
include/polarssl/md4.h
include/polarssl/md5.h
include/polarssl/md_wrap.h
include/polarssl/net.h
include/polarssl/openssl.h
include/polarssl/padlock.h
include/polarssl/pem.h
include/polarssl/pbkdf2.h
include/polarssl/pkcs11.h
include/polarssl/pkcs12.h
include/polarssl/pkcs5.h
include/polarssl/rsa.h
include/polarssl/sha1.h
include/polarssl/sha2.h
include/polarssl/sha4.h
include/polarssl/ssl.h
include/polarssl/ssl_cache.h
include/polarssl/timing.h
include/polarssl/version.h
include/polarssl/x509.h
include/polarssl/x509write.h
include/polarssl/xtea.h
lib/libpolarssl.a
lib/libpolarssl.so
lib/libpolarssl.so.5
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README