MFH: r562572

www/py-django-classy-tags: Prevent installation of test suite at top-level

* Add a workaround to prevent the installation of the test suite into
  Python's site-lib directory at top-level.

* Bump PORTREVISION due changed package contents.

PR:		252974
Approved by:	cs (maintainer)

Approved by:	ports-secteam (implicit, packaging fix blanket)
This commit is contained in:
Kai Knoblich 2021-01-25 15:57:03 +00:00
parent a076ddb4ef
commit 95408651f7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=562573
2 changed files with 17 additions and 0 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= django-classy-tags
PORTVERSION= 2.0.0
PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View File

@ -0,0 +1,16 @@
Avoid the installation of the test suite in the top-level directory
of ${PYTHON_SITELIBDIR}.
See also: https://github.com/django-cms/django-classy-tags/issues/58
--- setup.py.orig 2020-08-26 08:49:51 UTC
+++ setup.py
@@ -41,7 +41,7 @@ setup(
license='BSD',
description='Class based template tags for Django',
long_description=open('README.rst').read(),
- packages=find_packages(),
+ packages=find_packages(exclude=("tests",)),
include_package_data=True,
zip_safe=False,
install_requires=REQUIREMENTS,