Update to 2.0.0.

The port has moved to github and py-yara is no longer a separate tarball
for distribution. It is now bundled with the yara code. At some point I
want to make py-yara not depend directly upon yara. This way you can get
just the python bindings without needing to install yara itself.
This commit is contained in:
Wesley Shields 2013-12-29 05:59:02 +00:00
parent 5916aa48db
commit 95142eca70
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337941
8 changed files with 50 additions and 30 deletions

View File

@ -1,27 +1,31 @@
# $FreeBSD$
PORTNAME= yara
PORTVERSION= 1.7
PORTREVISION= 1
PORTVERSION= 2.0.0
CATEGORIES= security
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= yara-python-${PORTVERSION}
MAINTAINER= wxs@FreeBSD.org
COMMENT= Python bindings for yara
LIB_DEPENDS= yara.0:${PORTSDIR}/security/yara
USE_GITHUB= yes
GH_ACCOUNT= plusvic
GH_TAGNAME= v2.0.0
GH_COMMIT= d5dbefb
LIB_DEPENDS= yara:${PORTSDIR}/security/yara
PROJECTHOST= yara-project
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
PYDISTUTILS_EGGINFO= yara_python-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
PLIST_FILES= %%PYTHON_SITELIBDIR%%/yara.so
BUILD_WRKSRC= ${WRKSRC}/yara-python
INSTALL_WRKSRC= ${WRKSRC}/yara-python
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${BUILD_WRKSRC}/setup.py
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (yara-python-1.7.tar.gz) = eeb136bab40ad8e03c4ebb597922f3bf53a3a8311f8bfc090932197d8e2383a5
SIZE (yara-python-1.7.tar.gz) = 8700
SHA256 (yara-2.0.0.tar.gz) = 9f24f84d0988817d31ea08630defaca6fdd67d0216892b431e5c243721ede980
SIZE (yara-2.0.0.tar.gz) = 580008

View File

@ -1,12 +0,0 @@
--- ./setup.py.orig 2013-07-17 12:52:04.000000000 -0400
+++ ./setup.py 2013-07-17 12:51:52.000000000 -0400
@@ -10,7 +10,8 @@
name='yara',
sources=['yara-python.c'],
libraries=['yara','pcre'],
- include_dirs=['/usr/local/include']
+ include_dirs=['%%LOCALBASE%%/include'],
+ library_dirs=['%%LOCALBASE%%/lib']
)])

View File

@ -0,0 +1,8 @@
--- ./yara-python/setup.py.orig 2013-12-29 00:44:57.000000000 -0500
+++ ./yara-python/setup.py 2013-12-29 00:48:55.000000000 -0500
@@ -9,4 +9,5 @@
sources=['yara-python.c'],
libraries=['yara'],
include_dirs=['../windows/include', '../libyara'],
+ library_dirs=['%%LOCALBASE%%/lib'],
)])

View File

@ -1,24 +1,29 @@
# $FreeBSD$
PORTNAME= yara
PORTVERSION= 1.7
PORTREVISION= 1
PORTVERSION= 2.0.0
CATEGORIES= security
MASTER_SITES= GOOGLE_CODE
MAINTAINER= wxs@FreeBSD.org
COMMENT= A malware identification and classification tool
LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
USE_GITHUB= yes
GH_ACCOUNT= plusvic
GH_TAGNAME= v2.0.0
GH_COMMIT= d5dbefb
PROJECTHOST= yara-project
USE_AUTOTOOLS= libtool aclocal autoheader automake
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
USE_CSTD= gnu89
MAKE_JOBS_UNSAFE= yes
MAN1= yara.1
NO_STAGE= yes
pre-configure:
@cd ${WRKSRC} && ${SH} ./bootstrap.sh
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (yara-1.7.tar.gz) = fcee06a2f43ab65c88597de54d630a3beee925e7e84c890a8303f08a3fc85c91
SIZE (yara-1.7.tar.gz) = 714430
SHA256 (yara-2.0.0.tar.gz) = 9f24f84d0988817d31ea08630defaca6fdd67d0216892b431e5c243721ede980
SIZE (yara-2.0.0.tar.gz) = 580008

View File

@ -0,0 +1,14 @@
--- ./libyara/proc.c.orig 2013-12-26 09:01:02.000000000 -0500
+++ ./libyara/proc.c 2013-12-28 15:26:52.000000000 -0500
@@ -141,10 +141,9 @@
#else
-#define _XOPEN_SOURCE 500
-
#include <fcntl.h>
#include <unistd.h>
+#include <sys/cdefs.h>
#include <sys/types.h>
#include <sys/ptrace.h>
#include <sys/wait.h>

View File

@ -1,4 +1,5 @@
bin/yara
bin/yarac
include/yara.h
lib/libyara.a
lib/libyara.la