net/py-twitter-tools: Update version 1.19.3=>1.19.6

- Add USE_PYTHON=nose

Relnotes:
https://github.com/python-twitter-tools/twitter/releases/tag/twitter-1.19.6
This commit is contained in:
Muhammad Moinur Rahman 2022-11-05 15:10:31 -05:00
parent 4b98249f40
commit 94d055324d
3 changed files with 10 additions and 16 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= twitter
PORTVERSION= 1.19.3
PORTVERSION= 1.19.6
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= net python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,19 +12,13 @@ WWW= https://github.com/sixohsix/twitter
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${PY_FLAVOR}
USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= sixohsix
USE_PYTHON= autoplist concurrent distutils
USE_PYTHON= autoplist concurrent distutils nose
NO_ARCH= yes
# A number of test failures are (still) present in test_util
# https://github.com/sixohsix/twitter/issues/166
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1646762565
SHA256 (sixohsix-twitter-twitter-1.19.3_GH0.tar.gz) = 91261e8e69c469ee4a9ddb4df2eae09a836e4ad358592d1a2e3b9bc82aca4ee3
SIZE (sixohsix-twitter-twitter-1.19.3_GH0.tar.gz) = 49104
TIMESTAMP = 1667662077
SHA256 (sixohsix-twitter-twitter-1.19.6_GH0.tar.gz) = 16465cb441a37bffea1c21016037605c01ea3dfadd13e86dd9b41a87521152a6
SIZE (sixohsix-twitter-twitter-1.19.6_GH0.tar.gz) = 49113

View File

@ -1,12 +1,12 @@
# Fix UnicodeDecodeError: 'ascii' codec can't decode error
--- setup.py.orig 2021-06-18 10:28:47 UTC
--- setup.py.orig 2022-09-14 13:30:41 UTC
+++ setup.py
@@ -3,12 +3,8 @@ with open("README") as f:
with open("README") as f:
long_description = f.read()
+version = '1.19.3'
+version = '1.19.6'
-def local_scheme(version):
- """Skip the local version (eg. +xyz of 0.6.1.dev4+gdf99fe2)
@ -16,12 +16,12 @@
setup(name='twitter',
description="An API and command-line toolset for Twitter (twitter.com)",
long_description=long_description,
@@ -43,8 +39,6 @@ setup(name='twitter',
@@ -45,8 +41,6 @@ setup(name='twitter',
packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data=True,
zip_safe=True,
- use_scm_version={"local_scheme": local_scheme},
- setup_requires=["setuptools_scm"],
install_requires=["certifi"],
entry_points="""
# -*- Entry points: -*-
[console_scripts]