Include the C++ compiler. Certainly of limited use for a
microcontroller, but i got interested to get a complex FFT working. No stdlibc++ support at this time.
This commit is contained in:
parent
58bf95c7e4
commit
94b00b5e27
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46156
@ -11,7 +11,8 @@ CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
PKGNAMEPREFIX= avr-
|
||||
DISTNAME= gcc-core-${PORTVERSION}
|
||||
DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
|
||||
gcc-g++-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= joerg@freebsd.org
|
||||
|
||||
@ -32,7 +33,7 @@ GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS= --target=avr
|
||||
|
||||
MAKE_FLAGS= LANGUAGES="c"
|
||||
MAKE_FLAGS= LANGUAGES="c c++"
|
||||
|
||||
MAN1= cpp.1 avr-gcc.1 gcov.1
|
||||
|
||||
|
@ -1 +1,2 @@
|
||||
MD5 (gcc-core-3.0.tar.gz) = 7c92ef3beeac09fd00ccd56c17ba12c9
|
||||
MD5 (gcc-g++-3.0.tar.gz) = 2403fe480fbbf894b36b53f693b34f77
|
||||
|
12
devel/avr-gcc-3/files/patch-ac
Normal file
12
devel/avr-gcc-3/files/patch-ac
Normal file
@ -0,0 +1,12 @@
|
||||
--- configure.in.orig Sun Aug 12 18:18:37 2001
|
||||
+++ configure.in Sun Aug 12 18:18:13 2001
|
||||
@@ -665,6 +665,9 @@
|
||||
target_configdirs="${target_configdirs} target-bsp target-cygmon"
|
||||
fi
|
||||
;;
|
||||
+ avr-*-*)
|
||||
+ noconfigdirs="$noconfigdirs ${libstdcxx_version} target-libglosstarget-libiberty"
|
||||
+ ;;
|
||||
arm-*-oabi*)
|
||||
noconfigdirs="$noconfigdirs target-libgloss ${libgcj}"
|
||||
;;
|
@ -1,4 +1,7 @@
|
||||
FSF gcc-2.95.2 for Atmel AVR cross-development
|
||||
FSF gcc-3.0 for Atmel AVR cross-development
|
||||
|
||||
This brings the gcc compiler to the Atmel AVR 8-bit RISC family of
|
||||
microcontrollers.
|
||||
|
||||
Now including the basic C++ compiler, although this is only of limited
|
||||
use without a libstdc++, and it is little tested.
|
||||
|
@ -1,12 +1,18 @@
|
||||
avr/bin/gcc
|
||||
avr/bin/g++
|
||||
avr/bin/c++
|
||||
bin/avr-gcc
|
||||
bin/avr-cpp
|
||||
bin/avr-g++
|
||||
bin/avr-c++
|
||||
bin/avr-c++filt
|
||||
bin/gccbug
|
||||
lib/gcc-lib/avr/3.0/cc1
|
||||
lib/gcc-lib/avr/3.0/collect2
|
||||
lib/gcc-lib/avr/3.0/specs
|
||||
lib/gcc-lib/avr/3.0/cpp0
|
||||
lib/gcc-lib/avr/3.0/tradcpp0
|
||||
lib/gcc-lib/avr/3.0/cc1plus
|
||||
lib/gcc-lib/avr/3.0/libgcc.a
|
||||
lib/gcc-lib/avr/3.0/avr3/libgcc.a
|
||||
lib/gcc-lib/avr/3.0/avr4/libgcc.a
|
||||
|
@ -11,7 +11,8 @@ CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
PKGNAMEPREFIX= avr-
|
||||
DISTNAME= gcc-core-${PORTVERSION}
|
||||
DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
|
||||
gcc-g++-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= joerg@freebsd.org
|
||||
|
||||
@ -32,7 +33,7 @@ GNU_CONFIGURE= yes
|
||||
|
||||
CONFIGURE_ARGS= --target=avr
|
||||
|
||||
MAKE_FLAGS= LANGUAGES="c"
|
||||
MAKE_FLAGS= LANGUAGES="c c++"
|
||||
|
||||
MAN1= cpp.1 avr-gcc.1 gcov.1
|
||||
|
||||
|
@ -1 +1,2 @@
|
||||
MD5 (gcc-core-3.0.tar.gz) = 7c92ef3beeac09fd00ccd56c17ba12c9
|
||||
MD5 (gcc-g++-3.0.tar.gz) = 2403fe480fbbf894b36b53f693b34f77
|
||||
|
12
devel/avr-gcc/files/patch-ac
Normal file
12
devel/avr-gcc/files/patch-ac
Normal file
@ -0,0 +1,12 @@
|
||||
--- configure.in.orig Sun Aug 12 18:18:37 2001
|
||||
+++ configure.in Sun Aug 12 18:18:13 2001
|
||||
@@ -665,6 +665,9 @@
|
||||
target_configdirs="${target_configdirs} target-bsp target-cygmon"
|
||||
fi
|
||||
;;
|
||||
+ avr-*-*)
|
||||
+ noconfigdirs="$noconfigdirs ${libstdcxx_version} target-libglosstarget-libiberty"
|
||||
+ ;;
|
||||
arm-*-oabi*)
|
||||
noconfigdirs="$noconfigdirs target-libgloss ${libgcj}"
|
||||
;;
|
@ -1,4 +1,7 @@
|
||||
FSF gcc-2.95.2 for Atmel AVR cross-development
|
||||
FSF gcc-3.0 for Atmel AVR cross-development
|
||||
|
||||
This brings the gcc compiler to the Atmel AVR 8-bit RISC family of
|
||||
microcontrollers.
|
||||
|
||||
Now including the basic C++ compiler, although this is only of limited
|
||||
use without a libstdc++, and it is little tested.
|
||||
|
@ -1,12 +1,18 @@
|
||||
avr/bin/gcc
|
||||
avr/bin/g++
|
||||
avr/bin/c++
|
||||
bin/avr-gcc
|
||||
bin/avr-cpp
|
||||
bin/avr-g++
|
||||
bin/avr-c++
|
||||
bin/avr-c++filt
|
||||
bin/gccbug
|
||||
lib/gcc-lib/avr/3.0/cc1
|
||||
lib/gcc-lib/avr/3.0/collect2
|
||||
lib/gcc-lib/avr/3.0/specs
|
||||
lib/gcc-lib/avr/3.0/cpp0
|
||||
lib/gcc-lib/avr/3.0/tradcpp0
|
||||
lib/gcc-lib/avr/3.0/cc1plus
|
||||
lib/gcc-lib/avr/3.0/libgcc.a
|
||||
lib/gcc-lib/avr/3.0/avr3/libgcc.a
|
||||
lib/gcc-lib/avr/3.0/avr4/libgcc.a
|
||||
|
Loading…
Reference in New Issue
Block a user