- Update to Alpha9 (because, since updating cdrecord,
Alpha8 would not compile) - Enable non-root mode - Update maintainer email Submitted by: maintainer
This commit is contained in:
parent
96bc7435a6
commit
9485690a76
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46259
@ -6,12 +6,12 @@
|
||||
#
|
||||
|
||||
PORTNAME= xcdroast
|
||||
PORTVERSION= 0.98.a.8
|
||||
PORTVERSION= 0.98.a.9
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://www.xcdroast.org/download/
|
||||
DISTNAME= xcdroast-0.98alpha8
|
||||
DISTNAME= ${PORTNAME}-0.98alpha9
|
||||
|
||||
MAINTAINER= Kai_Allard_Liao@gmx.de
|
||||
MAINTAINER= lehmann@ans-netz.de
|
||||
|
||||
RUN_DEPENDS= cdrecord:${PORTSDIR}/sysutils/cdrtools \
|
||||
mkisofs:${PORTSDIR}/sysutils/mkisofs
|
||||
@ -21,10 +21,33 @@ USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
USE_IMLIB= yes
|
||||
|
||||
post-install:
|
||||
${LN} -sf ${PREFIX}/bin/cdrecord ${X11BASE}/lib/xcdroast-0.98/bin/cdrecord
|
||||
${LN} -sf ${PREFIX}/bin/mkisofs ${X11BASE}/lib/xcdroast-0.98/bin/mkisofs
|
||||
${LN} -sf ${PREFIX}/bin/cdda2wav ${X11BASE}/lib/xcdroast-0.98/bin/cdda2wav
|
||||
${LN} -sf ${PREFIX}/bin/readcd ${X11BASE}/lib/xcdroast-0.98/bin/readcd
|
||||
post-patch:
|
||||
for i in xcdroast.h Makefile ; do \
|
||||
${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/$$i ; \
|
||||
done
|
||||
|
||||
post-install:
|
||||
|
||||
${LN} -sf ${LOCALBASE}/bin/cdrecord ${PREFIX}/lib/xcdroast-0.98/bin/cdrecord
|
||||
${LN} -sf ${LOCALBASE}/bin/mkisofs ${PREFIX}/lib/xcdroast-0.98/bin/mkisofs
|
||||
${LN} -sf ${LOCALBASE}/bin/cdda2wav ${PREFIX}/lib/xcdroast-0.98/bin/cdda2wav
|
||||
${LN} -sf ${LOCALBASE}/bin/readcd ${PREFIX}/lib/xcdroast-0.98/bin/readcd
|
||||
|
||||
/usr/sbin/pw groupadd -n cdwrite
|
||||
|
||||
for i in cdrecord cdda2wav mkisofs readcd ; do \
|
||||
${CHOWN} root:cdwrite ${PREFIX}/bin/$i && \
|
||||
${CHMOD} 4710 ${PREFIX}/bin/$i ; \
|
||||
done
|
||||
|
||||
${CHOWN} root:cdwrite ${PREFIX}/lib/xcdroast-0.98/bin/xcdrwrap
|
||||
${CHMOD} 2755 ${PREFIX}/lib/xcdroast-0.98/bin/xcdrwrap
|
||||
|
||||
@${ECHO} ""
|
||||
@${ECHO} "***************************************************************"
|
||||
@${ECHO} " The first time root have to start xcdroast, to create the"
|
||||
@${ECHO} " root-configuration-file ${PREFIX}/etc/xcdroast.conf. Without"
|
||||
@${ECHO} " this file, a normal user will get an error message."
|
||||
@${ECHO} "***************************************************************"
|
||||
@${ECHO} ""
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (xcdroast-0.98alpha8.tar.gz) = b26664d09a530f798e062cfb9f8aac8f
|
||||
MD5 (xcdroast-0.98alpha9.tar.gz) = 543d3237e7109572f5fcb6bdc6cf3e44
|
||||
|
@ -1,26 +1,11 @@
|
||||
--- Makefile.orig Sun Nov 26 15:03:56 2000
|
||||
+++ Makefile Tue Jan 16 18:02:52 2001
|
||||
@@ -5,7 +5,7 @@
|
||||
|
||||
--- Makefile.orig Tue Aug 14 01:01:08 2001
|
||||
+++ Makefile Tue Aug 14 01:01:32 2001
|
||||
@@ -6,7 +6,7 @@
|
||||
# Installation prefix directory:
|
||||
|
||||
-PREFIX=/usr
|
||||
+PREFIX?=/usr/X11R6
|
||||
#PREFIX=/usr/local
|
||||
#PREFIX=/usr
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX=%%PREFIX%%
|
||||
PRE_LIBDIR=$(PREFIX)/lib/xcdroast-0.98
|
||||
|
||||
@@ -13,10 +13,10 @@
|
||||
|
||||
#---
|
||||
|
||||
-CFLAGS=-Wall `gtk-config --cflags` `imlib-config --cflags` -DPRE_PREFIX="\"$(PREFIX)\"" -DPRE_LIBDIR="\"$(PRE_LIBDIR)\""
|
||||
-LIBS=`gtk-config --libs` `imlib-config --libs` -lgdk_imlib
|
||||
-TOOLLIBS=`gtk-config --libs`
|
||||
-CC=gcc
|
||||
+CFLAGS+=-Wall `${GTK_CONFIG} --cflags` `imlib-config --cflags` -DPRE_PREFIX="\"$(PREFIX)\"" -DPRE_LIBDIR="\"$(PRE_LIBDIR)\""
|
||||
+LIBS=`${GTK_CONFIG} --libs` `imlib-config --libs` -lgdk_imlib
|
||||
+TOOLLIBS=`${GTK_CONFIG} --libs`
|
||||
+CC?=gcc
|
||||
|
||||
OBJ = main.o language.o init.o tools.o xtools.o menus.o setup.o io.o duplicate.o wav_frontend.o wav_id.o create.o
|
||||
|
||||
# put here the prefix where you want xcdroast to look for
|
||||
|
@ -1,4 +1,4 @@
|
||||
bin/xcdrgtk
|
||||
bin/xcdroast
|
||||
lib/xcdroast-0.98/icons/burnproof.gif
|
||||
lib/xcdroast-0.98/icons/cddblogo.gif
|
||||
lib/xcdroast-0.98/icons/dialog_default.png
|
||||
@ -19,6 +19,7 @@ lib/xcdroast-0.98/bin/mkisofs
|
||||
lib/xcdroast-0.98/bin/cdrecord
|
||||
lib/xcdroast-0.98/bin/cdda2wav
|
||||
lib/xcdroast-0.98/bin/readcd
|
||||
lib/xcdroast-0.98/bin/xcdrwrap
|
||||
@dirrm lib/xcdroast-0.98/bin
|
||||
@dirrm lib/xcdroast-0.98/icons
|
||||
@dirrm lib/xcdroast-0.98/lang
|
||||
|
Loading…
Reference in New Issue
Block a user