games/meritous: update 1.2 → 1.5
- Switch to new upstream - Note that music files were removed due to licensing restictions
This commit is contained in:
parent
a507658b97
commit
94524de330
@ -1,43 +1,32 @@
|
||||
PORTNAME= meritous
|
||||
PORTVERSION= 1.2
|
||||
PORTREVISION= 11
|
||||
PORTVERSION= 1.5
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.asceai.net/files/ \
|
||||
http://mirror.amdmi3.ru/distfiles/
|
||||
DISTNAME= ${PORTNAME}_v${PORTVERSION:C/\.//}_src
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Action-adventure dungeon crawl game
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= dos2unix gmake sdl tar:bzip2
|
||||
USES= gettext gmake gnome sdl
|
||||
USE_GNOME= intltool
|
||||
USE_GITLAB= yes
|
||||
GL_COMMIT= a754f33ae35f47b98cc1aa7fe8de43ed24662d11
|
||||
USE_SDL= sdl mixer image
|
||||
ALL_TARGET= default
|
||||
DOS2UNIX_FILES= dat/d/helpfile.txt src/boss.c src/levelblit.c
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
LDFLAGS+= ${LOCALBASE}/lib/libintl.so
|
||||
|
||||
PORTDOCS= *
|
||||
PORTDATA= *
|
||||
|
||||
DESKTOP_ENTRIES="Meritous" \
|
||||
"Action-adventure dungeon crawl game" \
|
||||
"${DATADIR}/i/icon.png" \
|
||||
"meritous" \
|
||||
"Game;ActionGame;AdventureGame;" \
|
||||
false
|
||||
OPTIONS_DEFINE= DOCS NLS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
post-install:
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|dat/|${DATADIR}/|' ${WRKSRC}/src/*.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/meritous ${STAGEDIR}${PREFIX}/bin/
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
cd ${WRKSRC}/dat && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (meritous_v12_src.tar.bz2) = 20b2086240c810c04fd0ce4a24f9d9c9dacbac47da61c26758943f1fdef7571d
|
||||
SIZE (meritous_v12_src.tar.bz2) = 2469389
|
||||
TIMESTAMP = 1647442721
|
||||
SHA256 (meritous-meritous-a754f33ae35f47b98cc1aa7fe8de43ed24662d11_GL0.tar.gz) = e1ef73e1b781b05ab3120200217c516f736279b56509fab36888f93b4c5d58ef
|
||||
SIZE (meritous-meritous-a754f33ae35f47b98cc1aa7fe8de43ed24662d11_GL0.tar.gz) = 1069223
|
||||
|
@ -1,26 +1,22 @@
|
||||
--- Makefile.orig 2008-01-15 05:44:55.000000000 +0300
|
||||
+++ Makefile 2008-11-24 02:09:08.000000000 +0300
|
||||
@@ -18,8 +18,8 @@
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with Meritous. If not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lz
|
||||
-CCFLAGS = -O2 -Wall `sdl-config --cflags` -g
|
||||
+LDFLAGS = `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lm
|
||||
+CCFLAGS = ${CFLAGS} -Wall `${SDL_CONFIG} --cflags`
|
||||
#
|
||||
OBJS = src/levelblit.o \
|
||||
src/mapgen.o \
|
||||
@@ -35,10 +35,10 @@
|
||||
default: meritous
|
||||
--- Makefile.orig 2022-03-16 15:01:57 UTC
|
||||
+++ Makefile
|
||||
@@ -31,8 +31,8 @@ localedir=$(datarootdir)/locale
|
||||
|
||||
%.o: %.c
|
||||
- gcc -c -o $@ $? ${CCFLAGS}
|
||||
+ ${CC} -c -o $@ $? ${CCFLAGS}
|
||||
# Tools
|
||||
INSTALL=install
|
||||
-MKDIR_P=$(INSTALL) -d -m 00755
|
||||
-CP_R=cp -r --preserve=timestamps
|
||||
+MKDIR_P=mkdir -p
|
||||
+CP_R=cp -rp
|
||||
|
||||
meritous: ${OBJS}
|
||||
- gcc -o $@ $+ ${LDFLAGS}
|
||||
+ ${CC} -o $@ $+ ${LDFLAGS}
|
||||
# Compilations flags
|
||||
CFLAGS ?= -O2 -g -Wall
|
||||
@@ -59,7 +59,7 @@ DEPS = $(OBJS:.o=.d)
|
||||
-include $(DEPS)
|
||||
|
||||
clean:
|
||||
rm ${OBJS}
|
||||
meritous: $(OBJS)
|
||||
- $(CC) $(CFLAGS) $(LDFLAGS) $+ $(LDLIBS) -o $@
|
||||
+ $(CC) $(LDFLAGS) $+ $(LDLIBS) -o $@
|
||||
|
||||
po/meritous.pot:
|
||||
cd po; intltool-update --pot --gettext-package=meritous
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/boss.c.orig 2008-01-15 05:54:37.000000000 +0300
|
||||
+++ src/boss.c 2008-12-01 02:19:45.000000000 +0300
|
||||
@@ -691,7 +691,7 @@
|
||||
} else {
|
||||
if (dist(tail_x[0], tail_y[0], boss_x, boss_y) >= 24) {
|
||||
if (boss_tail_len < 10) boss_tail_len++;
|
||||
- for (i = 9; i >= 0; i--) {
|
||||
+ for (i = 8; i >= 0; i--) {
|
||||
tail_x[i+1] = tail_x[i];
|
||||
tail_y[i+1] = tail_y[i];
|
||||
}
|
@ -1,31 +0,0 @@
|
||||
--- src/levelblit.c.orig 2008-01-15 03:54:41.000000000 +0100
|
||||
+++ src/levelblit.c 2010-01-30 10:07:22.000000000 +0100
|
||||
@@ -27,7 +27,12 @@
|
||||
#include <SDL.h>
|
||||
#include <SDL_image.h>
|
||||
#include <assert.h>
|
||||
-
|
||||
+
|
||||
+#include <errno.h>
|
||||
+#include <unistd.h>
|
||||
+#include <err.h>
|
||||
+#include <sys/stat.h>
|
||||
+
|
||||
#include "mapgen.h"
|
||||
#include "demon.h"
|
||||
#include "gamemap.h"
|
||||
@@ -378,6 +383,14 @@
|
||||
|
||||
int main(int argc, char **argv)
|
||||
{
|
||||
+ {
|
||||
+ if (chdir(getenv("HOME")) != 0)
|
||||
+ err(1, "cannot cd to $HOME");
|
||||
+ if (mkdir(".meritous", 0755) != 0 && errno != EEXIST)
|
||||
+ err(1, "cannot mkdir $HOME/.meritous");
|
||||
+ if (chdir(".meritous") != 0)
|
||||
+ err(1, "cannot cd to $HOME/.meritous");
|
||||
+ }
|
||||
int on_title = 1;
|
||||
int executable_running = 1;
|
||||
SDL_Surface *title, *title_pr, *asceai;
|
7
games/meritous/pkg-plist
Normal file
7
games/meritous/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
bin/meritous
|
||||
share/applications/net.asceai.meritous.desktop
|
||||
share/icons/hicolor/256x256/apps/meritous.png
|
||||
share/icons/hicolor/scalable/apps/meritous.svg
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/meritous.mo
|
||||
share/man/man6/meritous.6.gz
|
||||
share/metainfo/net.asceai.meritous.appdata.xml
|
Loading…
Reference in New Issue
Block a user