Install all headers into ${PREFIX}/lib/tk8.0/{generic,unix}.

No longer requires the configured tcl80.

OK'd by:	jkh
This commit is contained in:
Thomas Gellekum 1997-10-01 09:20:37 +00:00
parent 6fffb422bb
commit 94445548c6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=8071
16 changed files with 360 additions and 60 deletions

View File

@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.2 1997/08/25 16:40:13 jkh Exp $
# $Id: Makefile,v 1.3 1997/08/27 05:03:11 asami Exp $
#
DISTNAME= tk8.0
@ -14,7 +14,6 @@ MASTER_SITES= ftp://ftp.sunlabs.com/pub/tcl/
MAINTAINER= jkh@Freebsd.ORG
LIB_DEPENDS= tcl80\\.1\\.:${PORTSDIR}/lang/tcl80
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/lang/tcl80:configure
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
GNU_CONFIGURE= yes

View File

@ -1,11 +1,37 @@
--- configure.orig Wed Aug 20 03:40:08 1997
+++ configure Wed Aug 20 03:40:21 1997
@@ -662,7 +662,7 @@
--- configure.orig Fri Aug 15 22:17:52 1997
+++ configure Wed Oct 1 10:50:54 1997
@@ -662,14 +662,14 @@
if test -n "$withval"; then
TCL_BIN_DIR=$withval
else
- TCL_BIN_DIR=`cd ../../tcl8.0/unix; pwd`
+ TCL_BIN_DIR=`cd ../../../../../lang/tcl80/work/tcl8.0/unix; pwd`
+ TCL_BIN_DIR=${prefix}/lib/tcl8.0
fi
if test ! -d $TCL_BIN_DIR; then
{ echo "configure: error: Tcl directory $TCL_BIN_DIR doesn't exist" 1>&2; exit 1; }
fi
-if test ! -f $TCL_BIN_DIR/Makefile; then
- { echo "configure: error: There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
+ { echo "configure: error: There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
fi
#--------------------------------------------------------------------
@@ -688,6 +688,8 @@
DL_LIBS=$TCL_DL_LIBS
LD_FLAGS=$TCL_LD_FLAGS
+TCL_SRC_DIR=${prefix}/include/tcl${TCL_VERSION}
+
LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
# If Tcl and Tk are installed in different places, adjust the library
@@ -2271,6 +2273,7 @@
s%@SHLIB_VERSION@%$SHLIB_VERSION%g
s%@TCL_BIN_DIR@%$TCL_BIN_DIR%g
s%@TCL_BUILD_LIB_SPEC@%$TCL_BUILD_LIB_SPEC%g
+s%@TCL_LIB_SPEC@%$TCL_LIB_SPEC%g
s%@TCL_SRC_DIR@%$TCL_SRC_DIR%g
s%@TCL_VERSION@%$TCL_VERSION%g
s%@TK_BUILD_LIB_SPEC@%$TK_BUILD_LIB_SPEC%g

View File

@ -1,15 +1,17 @@
--- Makefile.in.orig Fri Aug 15 16:17:51 1997
+++ Makefile.in Sun Aug 31 21:36:30 1997
@@ -56,7 +56,7 @@
--- Makefile.in.orig Fri Aug 15 22:17:51 1997
+++ Makefile.in Wed Oct 1 10:07:16 1997
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include/tk$(VERSION)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -94,11 +94,11 @@
@@ -94,11 +96,11 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
@ -23,7 +25,7 @@
# To turn off the security checks that disallow incoming sends when
# the X server appears to be insecure, reverse the comments on the
@@ -134,7 +134,7 @@
@@ -134,7 +136,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -32,7 +34,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -290,6 +290,11 @@
@@ -290,6 +292,11 @@
@MAKE_LIB@
$(RANLIB) @TK_LIB_FILE@
@ -44,7 +46,7 @@
# Make target which outputs the list of the .o contained in the Tk lib
# usefull to build a single big shared library containing Tcl/Tk and other
# extensions. used for the Tcl Plugin. -- dl
@@ -340,7 +345,7 @@
@@ -340,7 +347,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -53,7 +55,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -354,10 +359,15 @@
@@ -354,13 +361,19 @@
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@ -70,7 +72,32 @@
install-libraries:
@for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
@@ -430,28 +440,28 @@
+ $(GENERIC_INCLUDE_INSTALL_DIR) $(UNIX_INCLUDE_INSTALL_DIR) \
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -370,8 +383,18 @@
else true; \
fi; \
done;
- @echo "Installing tk.h"
- @$(INSTALL_DATA) $(GENERIC_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @echo "Installing headers"
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
do \
echo "Installing $$i"; \
@@ -430,28 +453,28 @@
@cd $(SRC_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,5 +1,26 @@
bin/wish8.0
include/tk8.0/tk.h
include/tk8.0/unix/tkUnixDefault.h
include/tk8.0/unix/tkUnixInt.h
include/tk8.0/unix/tkUnixPort.h
include/tk8.0/generic/default.h
include/tk8.0/generic/ks_names.h
include/tk8.0/generic/tk.h
include/tk8.0/generic/tk3d.h
include/tk8.0/generic/tkButton.h
include/tk8.0/generic/tkCanvas.h
include/tk8.0/generic/tkColor.h
include/tk8.0/generic/tkFileFilter.h
include/tk8.0/generic/tkFont.h
include/tk8.0/generic/tkInitScript.h
include/tk8.0/generic/tkInt.h
include/tk8.0/generic/tkMenu.h
include/tk8.0/generic/tkMenubutton.h
include/tk8.0/generic/tkPort.h
include/tk8.0/generic/tkScale.h
include/tk8.0/generic/tkScrollbar.h
include/tk8.0/generic/tkSelect.h
include/tk8.0/generic/tkText.h
man/man1/wish.1.gz
man/man3/FontId.3.gz
man/man3/GetFont.3.gz
@ -228,4 +249,6 @@ lib/libtk80.so.1.0
@dirrm lib/tk8.0/demos
@dirrm lib/tk8.0/images
@dirrm lib/tk8.0
@dirrm include/tk8.0/unix
@dirrm include/tk8.0/generic
@dirrm include/tk8.0

View File

@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.2 1997/08/25 16:40:13 jkh Exp $
# $Id: Makefile,v 1.3 1997/08/27 05:03:11 asami Exp $
#
DISTNAME= tk8.0
@ -14,7 +14,6 @@ MASTER_SITES= ftp://ftp.sunlabs.com/pub/tcl/
MAINTAINER= jkh@Freebsd.ORG
LIB_DEPENDS= tcl80\\.1\\.:${PORTSDIR}/lang/tcl80
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/lang/tcl80:configure
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
GNU_CONFIGURE= yes

View File

@ -1,11 +1,37 @@
--- configure.orig Wed Aug 20 03:40:08 1997
+++ configure Wed Aug 20 03:40:21 1997
@@ -662,7 +662,7 @@
--- configure.orig Fri Aug 15 22:17:52 1997
+++ configure Wed Oct 1 10:50:54 1997
@@ -662,14 +662,14 @@
if test -n "$withval"; then
TCL_BIN_DIR=$withval
else
- TCL_BIN_DIR=`cd ../../tcl8.0/unix; pwd`
+ TCL_BIN_DIR=`cd ../../../../../lang/tcl80/work/tcl8.0/unix; pwd`
+ TCL_BIN_DIR=${prefix}/lib/tcl8.0
fi
if test ! -d $TCL_BIN_DIR; then
{ echo "configure: error: Tcl directory $TCL_BIN_DIR doesn't exist" 1>&2; exit 1; }
fi
-if test ! -f $TCL_BIN_DIR/Makefile; then
- { echo "configure: error: There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
+ { echo "configure: error: There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
fi
#--------------------------------------------------------------------
@@ -688,6 +688,8 @@
DL_LIBS=$TCL_DL_LIBS
LD_FLAGS=$TCL_LD_FLAGS
+TCL_SRC_DIR=${prefix}/include/tcl${TCL_VERSION}
+
LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
# If Tcl and Tk are installed in different places, adjust the library
@@ -2271,6 +2273,7 @@
s%@SHLIB_VERSION@%$SHLIB_VERSION%g
s%@TCL_BIN_DIR@%$TCL_BIN_DIR%g
s%@TCL_BUILD_LIB_SPEC@%$TCL_BUILD_LIB_SPEC%g
+s%@TCL_LIB_SPEC@%$TCL_LIB_SPEC%g
s%@TCL_SRC_DIR@%$TCL_SRC_DIR%g
s%@TCL_VERSION@%$TCL_VERSION%g
s%@TK_BUILD_LIB_SPEC@%$TK_BUILD_LIB_SPEC%g

View File

@ -1,15 +1,17 @@
--- Makefile.in.orig Fri Aug 15 16:17:51 1997
+++ Makefile.in Sun Aug 31 21:36:30 1997
@@ -56,7 +56,7 @@
--- Makefile.in.orig Fri Aug 15 22:17:51 1997
+++ Makefile.in Wed Oct 1 10:07:16 1997
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include/tk$(VERSION)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -94,11 +94,11 @@
@@ -94,11 +96,11 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
@ -23,7 +25,7 @@
# To turn off the security checks that disallow incoming sends when
# the X server appears to be insecure, reverse the comments on the
@@ -134,7 +134,7 @@
@@ -134,7 +136,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -32,7 +34,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -290,6 +290,11 @@
@@ -290,6 +292,11 @@
@MAKE_LIB@
$(RANLIB) @TK_LIB_FILE@
@ -44,7 +46,7 @@
# Make target which outputs the list of the .o contained in the Tk lib
# usefull to build a single big shared library containing Tcl/Tk and other
# extensions. used for the Tcl Plugin. -- dl
@@ -340,7 +345,7 @@
@@ -340,7 +347,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -53,7 +55,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -354,10 +359,15 @@
@@ -354,13 +361,19 @@
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@ -70,7 +72,32 @@
install-libraries:
@for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
@@ -430,28 +440,28 @@
+ $(GENERIC_INCLUDE_INSTALL_DIR) $(UNIX_INCLUDE_INSTALL_DIR) \
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -370,8 +383,18 @@
else true; \
fi; \
done;
- @echo "Installing tk.h"
- @$(INSTALL_DATA) $(GENERIC_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @echo "Installing headers"
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
do \
echo "Installing $$i"; \
@@ -430,28 +453,28 @@
@cd $(SRC_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,5 +1,26 @@
bin/wish8.0
include/tk8.0/tk.h
include/tk8.0/unix/tkUnixDefault.h
include/tk8.0/unix/tkUnixInt.h
include/tk8.0/unix/tkUnixPort.h
include/tk8.0/generic/default.h
include/tk8.0/generic/ks_names.h
include/tk8.0/generic/tk.h
include/tk8.0/generic/tk3d.h
include/tk8.0/generic/tkButton.h
include/tk8.0/generic/tkCanvas.h
include/tk8.0/generic/tkColor.h
include/tk8.0/generic/tkFileFilter.h
include/tk8.0/generic/tkFont.h
include/tk8.0/generic/tkInitScript.h
include/tk8.0/generic/tkInt.h
include/tk8.0/generic/tkMenu.h
include/tk8.0/generic/tkMenubutton.h
include/tk8.0/generic/tkPort.h
include/tk8.0/generic/tkScale.h
include/tk8.0/generic/tkScrollbar.h
include/tk8.0/generic/tkSelect.h
include/tk8.0/generic/tkText.h
man/man1/wish.1.gz
man/man3/FontId.3.gz
man/man3/GetFont.3.gz
@ -228,4 +249,6 @@ lib/libtk80.so.1.0
@dirrm lib/tk8.0/demos
@dirrm lib/tk8.0/images
@dirrm lib/tk8.0
@dirrm include/tk8.0/unix
@dirrm include/tk8.0/generic
@dirrm include/tk8.0

View File

@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.2 1997/08/25 16:40:13 jkh Exp $
# $Id: Makefile,v 1.3 1997/08/27 05:03:11 asami Exp $
#
DISTNAME= tk8.0
@ -14,7 +14,6 @@ MASTER_SITES= ftp://ftp.sunlabs.com/pub/tcl/
MAINTAINER= jkh@Freebsd.ORG
LIB_DEPENDS= tcl80\\.1\\.:${PORTSDIR}/lang/tcl80
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/lang/tcl80:configure
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
GNU_CONFIGURE= yes

View File

@ -1,11 +1,37 @@
--- configure.orig Wed Aug 20 03:40:08 1997
+++ configure Wed Aug 20 03:40:21 1997
@@ -662,7 +662,7 @@
--- configure.orig Fri Aug 15 22:17:52 1997
+++ configure Wed Oct 1 10:50:54 1997
@@ -662,14 +662,14 @@
if test -n "$withval"; then
TCL_BIN_DIR=$withval
else
- TCL_BIN_DIR=`cd ../../tcl8.0/unix; pwd`
+ TCL_BIN_DIR=`cd ../../../../../lang/tcl80/work/tcl8.0/unix; pwd`
+ TCL_BIN_DIR=${prefix}/lib/tcl8.0
fi
if test ! -d $TCL_BIN_DIR; then
{ echo "configure: error: Tcl directory $TCL_BIN_DIR doesn't exist" 1>&2; exit 1; }
fi
-if test ! -f $TCL_BIN_DIR/Makefile; then
- { echo "configure: error: There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
+ { echo "configure: error: There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
fi
#--------------------------------------------------------------------
@@ -688,6 +688,8 @@
DL_LIBS=$TCL_DL_LIBS
LD_FLAGS=$TCL_LD_FLAGS
+TCL_SRC_DIR=${prefix}/include/tcl${TCL_VERSION}
+
LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
# If Tcl and Tk are installed in different places, adjust the library
@@ -2271,6 +2273,7 @@
s%@SHLIB_VERSION@%$SHLIB_VERSION%g
s%@TCL_BIN_DIR@%$TCL_BIN_DIR%g
s%@TCL_BUILD_LIB_SPEC@%$TCL_BUILD_LIB_SPEC%g
+s%@TCL_LIB_SPEC@%$TCL_LIB_SPEC%g
s%@TCL_SRC_DIR@%$TCL_SRC_DIR%g
s%@TCL_VERSION@%$TCL_VERSION%g
s%@TK_BUILD_LIB_SPEC@%$TK_BUILD_LIB_SPEC%g

View File

@ -1,15 +1,17 @@
--- Makefile.in.orig Fri Aug 15 16:17:51 1997
+++ Makefile.in Sun Aug 31 21:36:30 1997
@@ -56,7 +56,7 @@
--- Makefile.in.orig Fri Aug 15 22:17:51 1997
+++ Makefile.in Wed Oct 1 10:07:16 1997
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include/tk$(VERSION)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -94,11 +94,11 @@
@@ -94,11 +96,11 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
@ -23,7 +25,7 @@
# To turn off the security checks that disallow incoming sends when
# the X server appears to be insecure, reverse the comments on the
@@ -134,7 +134,7 @@
@@ -134,7 +136,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -32,7 +34,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -290,6 +290,11 @@
@@ -290,6 +292,11 @@
@MAKE_LIB@
$(RANLIB) @TK_LIB_FILE@
@ -44,7 +46,7 @@
# Make target which outputs the list of the .o contained in the Tk lib
# usefull to build a single big shared library containing Tcl/Tk and other
# extensions. used for the Tcl Plugin. -- dl
@@ -340,7 +345,7 @@
@@ -340,7 +347,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -53,7 +55,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -354,10 +359,15 @@
@@ -354,13 +361,19 @@
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@ -70,7 +72,32 @@
install-libraries:
@for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
@@ -430,28 +440,28 @@
+ $(GENERIC_INCLUDE_INSTALL_DIR) $(UNIX_INCLUDE_INSTALL_DIR) \
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -370,8 +383,18 @@
else true; \
fi; \
done;
- @echo "Installing tk.h"
- @$(INSTALL_DATA) $(GENERIC_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @echo "Installing headers"
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
do \
echo "Installing $$i"; \
@@ -430,28 +453,28 @@
@cd $(SRC_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,5 +1,26 @@
bin/wish8.0
include/tk8.0/tk.h
include/tk8.0/unix/tkUnixDefault.h
include/tk8.0/unix/tkUnixInt.h
include/tk8.0/unix/tkUnixPort.h
include/tk8.0/generic/default.h
include/tk8.0/generic/ks_names.h
include/tk8.0/generic/tk.h
include/tk8.0/generic/tk3d.h
include/tk8.0/generic/tkButton.h
include/tk8.0/generic/tkCanvas.h
include/tk8.0/generic/tkColor.h
include/tk8.0/generic/tkFileFilter.h
include/tk8.0/generic/tkFont.h
include/tk8.0/generic/tkInitScript.h
include/tk8.0/generic/tkInt.h
include/tk8.0/generic/tkMenu.h
include/tk8.0/generic/tkMenubutton.h
include/tk8.0/generic/tkPort.h
include/tk8.0/generic/tkScale.h
include/tk8.0/generic/tkScrollbar.h
include/tk8.0/generic/tkSelect.h
include/tk8.0/generic/tkText.h
man/man1/wish.1.gz
man/man3/FontId.3.gz
man/man3/GetFont.3.gz
@ -228,4 +249,6 @@ lib/libtk80.so.1.0
@dirrm lib/tk8.0/demos
@dirrm lib/tk8.0/images
@dirrm lib/tk8.0
@dirrm include/tk8.0/unix
@dirrm include/tk8.0/generic
@dirrm include/tk8.0

View File

@ -3,7 +3,7 @@
# Date created: 19 August 1997
# Whom: jkh
#
# $Id: Makefile,v 1.2 1997/08/25 16:40:13 jkh Exp $
# $Id: Makefile,v 1.3 1997/08/27 05:03:11 asami Exp $
#
DISTNAME= tk8.0
@ -14,7 +14,6 @@ MASTER_SITES= ftp://ftp.sunlabs.com/pub/tcl/
MAINTAINER= jkh@Freebsd.ORG
LIB_DEPENDS= tcl80\\.1\\.:${PORTSDIR}/lang/tcl80
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/lang/tcl80:configure
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
GNU_CONFIGURE= yes

View File

@ -1,11 +1,37 @@
--- configure.orig Wed Aug 20 03:40:08 1997
+++ configure Wed Aug 20 03:40:21 1997
@@ -662,7 +662,7 @@
--- configure.orig Fri Aug 15 22:17:52 1997
+++ configure Wed Oct 1 10:50:54 1997
@@ -662,14 +662,14 @@
if test -n "$withval"; then
TCL_BIN_DIR=$withval
else
- TCL_BIN_DIR=`cd ../../tcl8.0/unix; pwd`
+ TCL_BIN_DIR=`cd ../../../../../lang/tcl80/work/tcl8.0/unix; pwd`
+ TCL_BIN_DIR=${prefix}/lib/tcl8.0
fi
if test ! -d $TCL_BIN_DIR; then
{ echo "configure: error: Tcl directory $TCL_BIN_DIR doesn't exist" 1>&2; exit 1; }
fi
-if test ! -f $TCL_BIN_DIR/Makefile; then
- { echo "configure: error: There's no Makefile in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
+ { echo "configure: error: There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?" 1>&2; exit 1; }
fi
#--------------------------------------------------------------------
@@ -688,6 +688,8 @@
DL_LIBS=$TCL_DL_LIBS
LD_FLAGS=$TCL_LD_FLAGS
+TCL_SRC_DIR=${prefix}/include/tcl${TCL_VERSION}
+
LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
# If Tcl and Tk are installed in different places, adjust the library
@@ -2271,6 +2273,7 @@
s%@SHLIB_VERSION@%$SHLIB_VERSION%g
s%@TCL_BIN_DIR@%$TCL_BIN_DIR%g
s%@TCL_BUILD_LIB_SPEC@%$TCL_BUILD_LIB_SPEC%g
+s%@TCL_LIB_SPEC@%$TCL_LIB_SPEC%g
s%@TCL_SRC_DIR@%$TCL_SRC_DIR%g
s%@TCL_VERSION@%$TCL_VERSION%g
s%@TK_BUILD_LIB_SPEC@%$TK_BUILD_LIB_SPEC%g

View File

@ -1,15 +1,17 @@
--- Makefile.in.orig Fri Aug 15 16:17:51 1997
+++ Makefile.in Sun Aug 31 21:36:30 1997
@@ -56,7 +56,7 @@
--- Makefile.in.orig Fri Aug 15 22:17:51 1997
+++ Makefile.in Wed Oct 1 10:07:16 1997
@@ -56,7 +56,9 @@
BIN_DIR = $(exec_prefix)/bin
# Directory in which to install the include file tk.h:
-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include/tk$(VERSION)
+GENERIC_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/generic
+UNIX_INCLUDE_INSTALL_DIR = $(INCLUDE_INSTALL_DIR)/unix
# Top-level directory for manual entries:
MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
@@ -94,11 +94,11 @@
@@ -94,11 +96,11 @@
# Libraries to use when linking. This definition is determined by the
# configure script.
@ -23,7 +25,7 @@
# To turn off the security checks that disallow incoming sends when
# the X server appears to be insecure, reverse the comments on the
@@ -134,7 +134,7 @@
@@ -134,7 +136,7 @@
# "install" around; better to use the install-sh script that comes
# with the distribution, which is slower but guaranteed to work.
@ -32,7 +34,7 @@
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
@@ -290,6 +290,11 @@
@@ -290,6 +292,11 @@
@MAKE_LIB@
$(RANLIB) @TK_LIB_FILE@
@ -44,7 +46,7 @@
# Make target which outputs the list of the .o contained in the Tk lib
# usefull to build a single big shared library containing Tcl/Tk and other
# extensions. used for the Tcl Plugin. -- dl
@@ -340,7 +345,7 @@
@@ -340,7 +347,7 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
@ -53,7 +55,7 @@
@for i in $(LIB_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
do \
if [ ! -d $$i ] ; then \
@@ -354,10 +359,15 @@
@@ -354,13 +361,19 @@
@$(INSTALL_DATA) $(TK_LIB_FILE) $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@(cd $(LIB_INSTALL_DIR); $(RANLIB) $(TK_LIB_FILE))
@chmod 555 $(LIB_INSTALL_DIR)/$(TK_LIB_FILE)
@ -70,7 +72,32 @@
install-libraries:
@for i in $(INSTALL_ROOT)$(prefix)/lib $(INCLUDE_INSTALL_DIR) \
@@ -430,28 +440,28 @@
+ $(GENERIC_INCLUDE_INSTALL_DIR) $(UNIX_INCLUDE_INSTALL_DIR) \
$(SCRIPT_INSTALL_DIR) $(SCRIPT_INSTALL_DIR)/images; \
do \
if [ ! -d $$i ] ; then \
@@ -370,8 +383,18 @@
else true; \
fi; \
done;
- @echo "Installing tk.h"
- @$(INSTALL_DATA) $(GENERIC_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
+ @echo "Installing headers"
+ @for i in $(GENERIC_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(GENERIC_INCLUDE_INSTALL_DIR); \
+ done;
+ @for i in $(UNIX_DIR)/*.h ; \
+ do \
+ echo "Installing $$i"; \
+ $(INSTALL_DATA) $$i $(UNIX_INCLUDE_INSTALL_DIR); \
+ done;
+ @ln -sf $(GENERIC_INCLUDE_INSTALL_DIR)/tk.h $(INCLUDE_INSTALL_DIR)/tk.h
for i in $(SRC_DIR)/library/*.tcl $(SRC_DIR)/library/tclIndex $(SRC_DIR)/library/prolog.ps $(UNIX_DIR)/tkAppInit.c; \
do \
echo "Installing $$i"; \
@@ -430,28 +453,28 @@
@cd $(SRC_DIR)/doc; for i in *.1; \
do \
echo "Installing doc/$$i"; \

View File

@ -1,5 +1,26 @@
bin/wish8.0
include/tk8.0/tk.h
include/tk8.0/unix/tkUnixDefault.h
include/tk8.0/unix/tkUnixInt.h
include/tk8.0/unix/tkUnixPort.h
include/tk8.0/generic/default.h
include/tk8.0/generic/ks_names.h
include/tk8.0/generic/tk.h
include/tk8.0/generic/tk3d.h
include/tk8.0/generic/tkButton.h
include/tk8.0/generic/tkCanvas.h
include/tk8.0/generic/tkColor.h
include/tk8.0/generic/tkFileFilter.h
include/tk8.0/generic/tkFont.h
include/tk8.0/generic/tkInitScript.h
include/tk8.0/generic/tkInt.h
include/tk8.0/generic/tkMenu.h
include/tk8.0/generic/tkMenubutton.h
include/tk8.0/generic/tkPort.h
include/tk8.0/generic/tkScale.h
include/tk8.0/generic/tkScrollbar.h
include/tk8.0/generic/tkSelect.h
include/tk8.0/generic/tkText.h
man/man1/wish.1.gz
man/man3/FontId.3.gz
man/man3/GetFont.3.gz
@ -228,4 +249,6 @@ lib/libtk80.so.1.0
@dirrm lib/tk8.0/demos
@dirrm lib/tk8.0/images
@dirrm lib/tk8.0
@dirrm include/tk8.0/unix
@dirrm include/tk8.0/generic
@dirrm include/tk8.0