update to 0.7.2

switch to CLang
This commit is contained in:
Oliver Lehmann 2014-03-23 09:46:39 +00:00
parent 4619451ba9
commit 9443b344d2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348847
6 changed files with 536 additions and 495 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ember
PORTVERSION= 0.7.0
PORTREVISION= 4
PORTVERSION= 0.7.2
CATEGORIES= games
MASTER_SITES= SF/worldforge/Ember%20%28OGRE%20client%29/${PORTVERSION} \
http://amber.worldforge.org/ember/releases/stable/
@ -13,15 +12,17 @@ DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= oliver@FreeBSD.org
COMMENT= Ember is a WorldForge 3D client using the OGRE 3D library
BUILD_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.8.1:${PORTSDIR}/graphics/ogre3d
RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so.1.8.1:${PORTSDIR}/graphics/ogre3d
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d
RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d
LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
liberis-1.3.so:${PORTSDIR}/devel/eris \
libvarconf-1.0.so:${PORTSDIR}/devel/varconf \
libmercator-0.3.so:${PORTSDIR}/devel/mercator \
libwfut-0.2.so:${PORTSDIR}/devel/libwfut \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libCEGUIBase-0.7.9.so:${PORTSDIR}/graphics/cegui
libCEGUIBase-0.so:${PORTSDIR}/graphics/cegui
CONFIGURE_ARGS= --with-png-prefix=${LOCALBASE} --enable-binreloc \
--program-transform-name= --disable-cppunit --disable-debug \
@ -31,16 +32,12 @@ CONFIGURE_ENV+= LUA_LIBS="-L${LUA_LIBDIR} -llua" \
TOLUAXX="${TOLUAXX_CMD}"
USE_SDL= sdl
GNU_CONFIGURE= YES
USE_LDCONFIG= YES
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_LUA= 5.1
LUA_COMPS= toluaxx
USES= openal:al,alut pathfix pkgconfig
USES= openal:al,alut pathfix pkgconfig compiler:c++11-lib
USE_BZIP2= YES
CPPFLAGS+= -DBR_NO_MACROS -std=c++11
USE_GCC= yes
NO_STAGE= yes
OPTIONS_DEFINE= DOCS
@ -51,28 +48,23 @@ post-patch:
s|-lGL|-L${LOCALBASE}/lib -lGL|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| install-dist_docDATA | |g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|$$(sysconfdir)/ember/|$$(sysconfdir)/ember|g' \
${WRKSRC}/Makefile.in \
${WRKSRC}/src/components/ogre/Makefile.in
@${REINPLACE_CMD} -e 's|#plugindir=.*|plugindir="${LOCALBASE}/lib/OGRE"|; \
s|,Plugin_CgProgramManager||g' \
${WRKSRC}/ember.conf
@${REINPLACE_CMD} -e 's|/bash|/sh|g' ${WRKSRC}/ember.in
@${REINPLACE_CMD} -e 's|BOOST_THREAD_LIB =|& -L${_GCC_RUNTIME} -lstdc++ |g' \
${WRKSRC}/src/main/Makefile.in
@${REINPLACE_CMD} -e 's|reset(0)|reset()|g' \
${WRKSRC}/src/components/ogre/SceneManagers/EmberPagingSceneManager/src/OgrePagingLandScapeData2D.cpp
@${REINPLACE_CMD} -e 's|std::lround|lround|g' \
${WRKSRC}/src/components/ogre/terrain/TerrainPageGeometry.cpp \
${WRKSRC}/src/components/ogre/terrain/HeightMap.cpp
post-install:
(cd ${WRKDIR}/ember-media-${PORTVERSION}/media && ${FIND} . -type f -print | \
${CPIO} -pdmu -R${SHAREOWN}:${SHAREGRP} ${DATADIR}/media)
${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
${CPIO} -pdmu -R${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/media)
${FIND} ${STAGEDIR}${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
${FIND} ${STAGEDIR}${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for docfile in README COPYING AUTHORS ChangeLog TODO
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docfile in README.md COPYING AUTHORS ChangeLog
@${INSTALL_DATA} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}
.endfor
.endif

View File

@ -1,4 +1,4 @@
SHA256 (ember-0.7.0.tar.bz2) = 2ded4df8e3b0ef33e2789fc1cfa8da794c43b26ae929506f655cc6e59394f77b
SIZE (ember-0.7.0.tar.bz2) = 2195155
SHA256 (ember-media-0.7.0.tar.bz2) = 240b963c1562bcbd282f075ba4e72f81ef16e3777dac659769f05ec54a014e45
SIZE (ember-media-0.7.0.tar.bz2) = 281819258
SHA256 (ember-0.7.2.tar.bz2) = 10b8ca796a680abd9c2cca2360f7bff0b3eb7ce938fa64d3aa30f9609ba8b2d8
SIZE (ember-0.7.2.tar.bz2) = 2145050
SHA256 (ember-media-0.7.2.tar.bz2) = 97f1c58fef7da7fb2cff06f2930f1170c390f7dd8937121066b4d5b75f0cb181
SIZE (ember-media-0.7.2.tar.bz2) = 275810809

View File

@ -0,0 +1,11 @@
--- src/framework/bindings/lua/atlas/Atlas.cxx.orig 2014-03-11 07:55:38.000000000 +0100
+++ src/framework/bindings/lua/atlas/Atlas.cxx 2014-03-11 07:55:51.000000000 +0100
@@ -1908,7 +1908,7 @@
if (!self) tolua_error(tolua_S,"invalid 'self' in function 'operator=='", NULL);
#endif
{
- bool tolua_ret = (bool) self->operator==(*value);
+ bool tolua_ret = (*self==*value);
tolua_pushboolean(tolua_S,(bool)tolua_ret);
}
}

View File

@ -0,0 +1,20 @@
--- src/components/ogre/scripting/bindings/lua/EmberOgre.cxx.orig 2014-03-11 22:11:48.000000000 +0100
+++ src/components/ogre/scripting/bindings/lua/EmberOgre.cxx 2014-03-11 22:12:58.000000000 +0100
@@ -17592,7 +17592,7 @@
if (!self) tolua_error(tolua_S,"invalid 'self' in function 'operator=='", NULL);
#endif
{
- bool tolua_ret = (bool) self->operator==(*value);
+ bool tolua_ret = (*self==*value);
tolua_pushboolean(tolua_S,(bool)tolua_ret);
}
}
@@ -24412,7 +24412,7 @@
if (!self) tolua_error(tolua_S,"invalid 'self' in function 'operator=='", NULL);
#endif
{
- bool tolua_ret = (bool) self->operator==(*value);
+ bool tolua_ret = (*self)==(*value);
tolua_pushboolean(tolua_S,(bool)tolua_ret);
}
}

View File

@ -0,0 +1,10 @@
--- src/components/ogre/terrain/foliage/Vegetation.h.orig 2014-03-11 22:15:45.000000000 +0100
+++ src/components/ogre/terrain/foliage/Vegetation.h 2014-03-11 22:16:03.000000000 +0100
@@ -9,6 +9,7 @@
#define VEGETATION_H_
#include "components/ogre/terrain/Types.h"
+#include <cstdlib>
#include <map>
namespace Ember

File diff suppressed because it is too large Load Diff