dns/powerdns-recursor: upgrade 4.1.14 -> 4.2.0
PR: 239376 Submitted by: Ralf van der Enden <tremere@cainites.net> (maintainer) Relnotes: https://doc.powerdns.com/recursor/changelog/4.2.html https://blog.powerdns.com/2019/07/15/powerdns-recursor-4-2-0-released/
This commit is contained in:
parent
916bddad77
commit
9424edd54a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=511261
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= recursor
|
||||
DISTVERSION= 4.1.14
|
||||
PORTREVISION= 4
|
||||
DISTVERSION= 4.2.0
|
||||
CATEGORIES= dns ipv6
|
||||
MASTER_SITES= http://downloads.powerdns.com/releases/
|
||||
PKGNAMEPREFIX= powerdns-
|
||||
@ -14,7 +13,7 @@ COMMENT= Advanced DNS recursor
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BROKEN_armv6= fails to compile: use of overloaded operator << is ambiguous
|
||||
BROKEN_armv6= fails to compile: use of overloaded operator << is ambiguous
|
||||
BROKEN_armv7= fails to compile: use of overloaded operator << is ambiguous
|
||||
BROKEN_sparc64= fails to compile: json11.cpp: undefined reference to std::__throw_out_of_range_fmt
|
||||
|
||||
@ -37,26 +36,27 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
OPTIONS_DEFINE= LUAJIT OPTALGO SETUID
|
||||
OPTIONS_DEFINE= LUAJIT SETUID
|
||||
OPTIONS_DEFAULT= SETUID
|
||||
|
||||
LUAJIT_DESC= Use LuaJIT instead of Lua
|
||||
OPTALGO_DESC= Enable optional algorithms (12, 15 & 16)
|
||||
SETUID_DESC= Run as pdns_recursor user
|
||||
|
||||
LUAJIT_LIB_DEPENDS= libluajit-5.1.so.2:lang/luajit
|
||||
LUAJIT_USES_OFF= lua
|
||||
LUAJIT_CONFIGURE_WITH= luajit
|
||||
|
||||
OPTALGO_LIB_DEPENDS= libbotan-2.so:security/botan2 \
|
||||
libdecaf.so:security/libdecaf \
|
||||
libsodium.so:security/libsodium
|
||||
OPTALGO_CONFIGURE_ON= --enable-botan \
|
||||
--enable-libdecaf \
|
||||
--enable-libsodium
|
||||
LUAJIT_CONFIGURE_ON= --with-lua=luajit
|
||||
|
||||
SETUID_EXTRA_PATCHES= ${PATCHDIR}/extrapatch-setuid
|
||||
SETUID_VARS= GROUPS=pdns \
|
||||
USERS=pdns_recursor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} != openssl111
|
||||
CONFIGURE_ARGS+= --enable-libdecaf \
|
||||
--enable-libsodium
|
||||
LIB_DEPENDS+= libdecaf.so:security/libdecaf \
|
||||
libsodium.so:security/libsodium
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1560505728
|
||||
SHA256 (pdns-recursor-4.1.14.tar.bz2) = 7fceb8fa3bea693aad49d137c801bb3ecc15525cc5a7dc84380321546e87bf14
|
||||
SIZE (pdns-recursor-4.1.14.tar.bz2) = 1249908
|
||||
TIMESTAMP = 1563267791
|
||||
SHA256 (pdns-recursor-4.2.0.tar.bz2) = f03c72c1816fdcc645cc539d8c16721d2ec294feac9b5179e78c3db311b7c2c2
|
||||
SIZE (pdns-recursor-4.2.0.tar.bz2) = 1316156
|
||||
|
12
dns/powerdns-recursor/files/patch-pdns_dns__random.cc
Normal file
12
dns/powerdns-recursor/files/patch-pdns_dns__random.cc
Normal file
@ -0,0 +1,12 @@
|
||||
--- dns_random.cc.orig 2018-11-29 12:53:42 UTC
|
||||
+++ dns_random.cc
|
||||
@@ -40,7 +40,9 @@
|
||||
#include <openssl/rand.h>
|
||||
#endif
|
||||
#if defined(HAVE_GETRANDOM)
|
||||
+extern "C" {
|
||||
#include <sys/random.h>
|
||||
+}
|
||||
#endif
|
||||
|
||||
static enum DNS_RNG {
|
@ -1,27 +0,0 @@
|
||||
$OpenBSD: patch-rec_channel_cc,v 1.1.1.1 2018/12/29 14:29:08 sthen Exp $
|
||||
|
||||
Index: rec_channel.cc
|
||||
--- rec_channel.cc.orig 2019-01-31 19:43:44 UTC
|
||||
+++ rec_channel.cc
|
||||
@@ -54,6 +54,10 @@ int RecursorControlChannel::listen(const string& fname
|
||||
if(bind(d_fd, (sockaddr*)&d_local,sizeof(d_local))<0)
|
||||
throw PDNSException("Unable to bind to controlsocket '"+fname+"': "+stringerror());
|
||||
|
||||
+ int bufsz = 60*1024;
|
||||
+ setsockopt(d_fd, SOL_SOCKET, SO_SNDBUF, &bufsz, sizeof(bufsz));
|
||||
+ bufsz = 64*1024;
|
||||
+ setsockopt(d_fd, SOL_SOCKET, SO_RCVBUF, &bufsz, sizeof(bufsz));
|
||||
return d_fd;
|
||||
}
|
||||
|
||||
@@ -99,6 +103,10 @@ void RecursorControlChannel::connect(const string& pat
|
||||
unlink(d_local.sun_path);
|
||||
throw PDNSException("Unable to connect to remote '"+string(remote.sun_path)+"': "+stringerror());
|
||||
}
|
||||
+ int bufsz = 60*1024;
|
||||
+ setsockopt(d_fd, SOL_SOCKET, SO_SNDBUF, &bufsz, sizeof(bufsz));
|
||||
+ bufsz = 64*1024;
|
||||
+ setsockopt(d_fd, SOL_SOCKET, SO_RCVBUF, &bufsz, sizeof(bufsz));
|
||||
|
||||
} catch (...) {
|
||||
close(d_fd);
|
Loading…
Reference in New Issue
Block a user