Initial import of xdigger version 1.0.6.

Boulderdash-like KC85 Digger for X Window System.

PR:		7149
Submitted by:	Andrey Zakhvatov <andy@icc.surw.chel.su>
This commit is contained in:
Steve Price 1998-07-12 23:08:56 +00:00
parent b5278d0b4a
commit 93e071172d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11862
8 changed files with 179 additions and 0 deletions

38
games/xdigger/Makefile Normal file
View File

@ -0,0 +1,38 @@
# New ports collection makefile for: xdigger
# Version required: 1.0.6
# Date created: 29 June 1998
# Whom: Andrey Zakhvatov
#
# $Id$
#
DISTNAME= xdigger-1.0.6
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= games/arcade
EXTRACT_SUFX= .tgz
MAINTAINER= andy@icc.surw.chel.su
USE_IMAKE= yes
MAN6= xdigger.6
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/xdigger ${PREFIX}/bin
@ ${INSTALL_DATA} ${WRKSRC}/xdigger.man ${PREFIX}/man/man6/xdigger.6
@ ${MKDIR} ${PREFIX}/share/xdigger
@ ${INSTALL_DATA} ${WRKSRC}/xdigger.hiscore ${PREFIX}/share/xdigger
@ ${INSTALL_DATA} ${WRKSRC}/xdigger.level ${PREFIX}/share/xdigger
.for file in diamond.au step.au stone.au
@ ${INSTALL_DATA} ${WRKSRC}/audio/${file} ${PREFIX}/share/xdigger
.endfor
@ chmod a+rw ${PREFIX}/share/xdigger/xdigger.hiscore
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/xdigger
.for file in COPYING ChangeLog README
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/xdigger
.endfor
.endif
.include <bsd.port.mk>

1
games/xdigger/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (xdigger-1.0.6.tgz) = 18408b730bac4182dfef63cd3d056edf

View File

@ -0,0 +1,16 @@
--- configure.h Thu Jan 1 00:06:00 1998
+++ /home/andy/tmp/wrk/configure.h Sat Jun 29 23:18:58 1996
@@ -19,8 +19,13 @@
#define _CONFIGURE_H
/* Directories */
+#ifdef __FreeBSD__
+#define XDIGGER_LIB_DIR "/usr/X11R6/share/xdigger"
+#define XDIGGER_HISCORE_DIR "/usr/X11R6/share/xdigger"
+#else
#define XDIGGER_LIB_DIR "/usr/lib/X11/xdigger"
#define XDIGGER_HISCORE_DIR "/var/X11R6/scores"
+#endif
#define SOUND_DSP_AUDIO

View File

@ -0,0 +1,57 @@
--- sound.c Thu Jan 1 00:06:00 1998
+++ /home/andy/tmp/wrk/sound.c Sat Jun 29 23:19:09 1996
@@ -39,6 +39,9 @@
#ifdef linux
#include <linux/soundcard.h>
#endif
+#ifdef __FreeBSD__
+#include <machine/soundcard.h>
+#endif
#ifdef SOUND_RPLAY
#include <rplay.h>
#endif
@@ -147,7 +150,7 @@
{
ton_typ = msgp.mtext[0];
#endif
-#ifdef linux
+#if ( defined(linux) || defined(__FreeBSD__) )
if (sound_device == SD_DSP)
{
int rate = TON_DSP_RATE;
@@ -171,7 +174,7 @@
else
done = True;
}
-#ifdef linux
+#if ( defined(linux) || defined(__FreeBSD__) )
if(sound_device == SD_DSP)
ioctl(fd, SNDCTL_DSP_RESET, 0);
#endif
@@ -248,7 +251,7 @@
} /* Fill_TonBuffer(int ton_low, int ton_high, int korrektur, Bool sndheader)*/
-#ifdef linux
+#if ( defined(linux) || defined (__FreeBSD__) )
Bool Check_DSP(Bool msg)
{
int fd;
@@ -374,7 +377,7 @@
{
if (debug) fprintf(stderr, "%s: XDisplay is on localhost\n", progname);
#ifdef SOUND_DSP_AUDIO
-#ifdef linux
+#if ( defined(linux) || defined(__FreeBSD__) )
Check_DSP(False);
#endif
if (sound_device == SD_AUTO) Check_SUN_Audio(False);
@@ -400,7 +403,7 @@
else
{
#ifdef SOUND_DSP_AUDIO
-#ifdef linux
+#if ( defined(linux) || defined(__FreeBSD__) )
if (sound_device == SD_DSP)
{
if (!Check_DSP(True)) sound_device = SD_NONE;

View File

@ -0,0 +1,50 @@
--- xdigger.c Thu Jan 1 00:06:00 1998
+++ /home/andy/tmp/wrk/xdigger.c Sat Jun 29 23:19:18 1996
@@ -311,17 +315,29 @@
Fill_TonBuffer(TON_AUDIO_LOW, TON_AUDIO_HIGH, TON_AUDIO_RATE, True);
+#ifdef __FreeBSD__
+ fd = open("/usr/X11R6/share/xdigger/diamond.au", O_CREAT | O_WRONLY);
+#else
fd = open("audio/diamond.au", O_CREAT | O_WRONLY);
+#endif
fchmod(fd, 0644);
write(fd, &ton_buffer[TON_DIAMANT], ton_laenge[TON_DIAMANT]+24);
close(fd);
+#ifdef __FreeBSD__
+ fd = open("/usr/X11R6/share/xdigger/stone.au", O_CREAT | O_WRONLY);
+#else
fd = open("audio/stone.au", O_CREAT | O_WRONLY);
+#endif
fchmod(fd, 0644);
write(fd, &ton_buffer[TON_STEINE], ton_laenge[TON_STEINE]+24);
close(fd);
+#ifdef __FreeBSD__
+ fd = open("/usr/X11R6/share/xdigger/step.au", O_CREAT | O_WRONLY);
+#else
fd = open("audio/step.au", O_CREAT | O_WRONLY);
+#endif
fchmod(fd, 0644);
write(fd, &ton_buffer[TON_SCHRITT], ton_laenge[TON_SCHRITT]+24);
close(fd);
@@ -338,7 +354,7 @@
{
printf("Usage: xdigger [-display display] [-1|2|3|...] [-noblink] [-noiconmove] [-vert240] [-sound ");
#ifdef SOUND_DSP_AUDIO
-#ifdef linux
+#if ( defined(linux) || defined(__FreeBSD__) )
printf("dsp|");
#endif
printf("audio|");
@@ -390,7 +406,7 @@
}
#endif
#ifdef SOUND_DSP_AUDIO
-#ifdef linux
+#if ( defined(linux) || defined(__FreeBSD__) )
if(!strcmp(argv[i], "dsp")) sound_device = SD_DSP; else
#endif
if(!strcmp(argv[i], "audio")) sound_device = SD_AUDIO; else

View File

@ -0,0 +1 @@
Boulderdash-like KC85 Digger for X Window System.

2
games/xdigger/pkg-descr Normal file
View File

@ -0,0 +1,2 @@
XDigger is digger game for X Window System. Digger was
originally developed for the KC 85/3 and KC 85/4.

14
games/xdigger/pkg-plist Normal file
View File

@ -0,0 +1,14 @@
bin/xdigger
man/man6/xdigger.6.gz
share/doc/xdigger/COPYING
share/doc/xdigger/ChangeLog
share/doc/xdigger/README
share/xdigger/diamond.au
share/xdigger/step.au
share/xdigger/stone.au
@mode 666
share/xdigger/xdigger.hiscore
@mode
share/xdigger/xdigger.level
@dirrm share/doc/xdigger
@dirrm share/xdigger