Add p5-Geo-Distance 0.06, calculate Distances and Closest Locations.
PR: 68902 Submitted by: Rod Taylor <ports@rbt.ca> Approved by: erwin (implicit)
This commit is contained in:
parent
99a34eb395
commit
939f964014
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113427
@ -121,6 +121,7 @@
|
||||
SUBDIR += p5-Bit-Vector
|
||||
SUBDIR += p5-Chart-Math-Axis
|
||||
SUBDIR += p5-Date-Handler
|
||||
SUBDIR += p5-Geo-Distance
|
||||
SUBDIR += p5-Graph
|
||||
SUBDIR += p5-Math-Base85
|
||||
SUBDIR += p5-Math-BaseCalc
|
||||
|
22
math/p5-Geo-Distance/Makefile
Normal file
22
math/p5-Geo-Distance/Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
# New ports collection makefile for: p5-Geo-Distance
|
||||
# Date created: 10 July 2004
|
||||
# Whom: Rod Taylor <ports@rbt.ca>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= Geo-Distance
|
||||
PORTVERSION= 0.06
|
||||
CATEGORIES= math perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Geo
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= ports@rbt.ca
|
||||
COMMENT= Calculate Distances and Closest Locations
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= Geo::Distance.3
|
||||
|
||||
.include <bsd.port.mk>
|
2
math/p5-Geo-Distance/distinfo
Normal file
2
math/p5-Geo-Distance/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (Geo-Distance-0.06.tar.gz) = 6313eb1cdabca80d494d213db1aa94c0
|
||||
SIZE (Geo-Distance-0.06.tar.gz) = 9234
|
51
math/p5-Geo-Distance/files/patch-Distance.pm
Normal file
51
math/p5-Geo-Distance/files/patch-Distance.pm
Normal file
@ -0,0 +1,51 @@
|
||||
--- ../../../Geo-Distance-0.06/Distance.pm Wed Jun 30 02:12:10 2004
|
||||
+++ Distance.pm Sun Jul 11 21:46:44 2004
|
||||
@@ -1,21 +1,20 @@
|
||||
package Geo::Distance;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use warnings;
|
||||
use Carp;
|
||||
use Math::Trig qw( great_circle_distance deg2rad );
|
||||
|
||||
require Exporter;
|
||||
-our @ISA = qw(Exporter);
|
||||
-our %EXPORT_TAGS = ( 'all' => [ qw(
|
||||
+use vars qw(@ISA %EXPORT_TAGS @EXPORT_OK $VERSION);
|
||||
+@ISA = qw(Exporter);
|
||||
+%EXPORT_TAGS = ( 'all' => [ qw(
|
||||
&distance
|
||||
&distance_calc
|
||||
&find_closest
|
||||
®_unit
|
||||
&formula
|
||||
) ] );
|
||||
-our @EXPORT_OK = (
|
||||
+@EXPORT_OK = (
|
||||
@{ $EXPORT_TAGS{'all'} },
|
||||
'&distance',
|
||||
'&distance_calc',
|
||||
@@ -23,11 +22,11 @@
|
||||
'®_unit',
|
||||
'&formula'
|
||||
);
|
||||
-our $VERSION = '0.06';
|
||||
+$VERSION = '0.06';
|
||||
|
||||
|
||||
# See Math::Trig for what $rho is.
|
||||
-our(%rho,$formula);
|
||||
+use vars qw(%rho $formula);
|
||||
$rho{kilometer} = 6378; # Derived from the Math::Trig POD on the 'great_circle_distance'.
|
||||
$rho{meter} = $rho{kilometer}*1000; # 1000 meters in one kilometer.
|
||||
$rho{centimeter} = $rho{meter}*100; # 100 centimeters in one meter.
|
||||
@@ -41,7 +40,7 @@
|
||||
# Number of units in a single degree (lat or lon) at the equator.
|
||||
# Derived from doing dirty_distance('kilometer',10,0,11,0) = 111.317099692185
|
||||
# Then dividing that by $unit{kilometer} = 6378
|
||||
-our $deg_ratio = 0.01745329252;
|
||||
+use vars qw($deg_ratio); $deg_ratio = 0.01745329252;
|
||||
|
||||
|
||||
# New Object Constructor
|
7
math/p5-Geo-Distance/pkg-descr
Normal file
7
math/p5-Geo-Distance/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
This perl library aims to provide as many tools to make it as simple as possible
|
||||
to calculate distances between geographic points, and anything that can be
|
||||
derived from that. Currently there is support for finding the closest locations
|
||||
within a specified distance, to find the closest number of points to a specified
|
||||
point, and to do basic point-to-point distance calculations.
|
||||
|
||||
WWW: http://search.cpan.org/~bluefeet/Geo-Distance/
|
5
math/p5-Geo-Distance/pkg-plist
Normal file
5
math/p5-Geo-Distance/pkg-plist
Normal file
@ -0,0 +1,5 @@
|
||||
%%SITE_PERL%%/mach/auto/Geo/Distance/.packlist
|
||||
%%SITE_PERL%%/Geo/Distance.pm
|
||||
@dirrm %%SITE_PERL%%/mach/auto/Geo/Distance
|
||||
@unexec rmdir %D/%%%SITE_PERL%%/mach/auto/Geo 2>/dev/null || true
|
||||
@unexec rmdir %D/%%%SITE_PERL%%/Geo 2>/dev/null || true
|
Loading…
Reference in New Issue
Block a user