audio/cava: Unbreak build on powerpc (or with gcc 4.2)
- Remove command line options that gcc 4.2 does not recognize - Allow build on powerpc64 again as it most likely will work now too - Move post-patch to a patch file while here
This commit is contained in:
parent
c037e2194d
commit
9389f029b6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=479389
@ -10,8 +10,6 @@ COMMENT= Console-based Audio Visualizer for MPD, PulseAudio, and sndio
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option -Wno-unused-result
|
||||
|
||||
LIB_DEPENDS= libfftw3.so:math/fftw3 \
|
||||
libiniparser.so:devel/iniparser
|
||||
|
||||
@ -38,9 +36,6 @@ PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio \
|
||||
SNDIO_CONFIGURE_ENV_OFF= ac_cv_lib_sndio_sio_open=no
|
||||
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '/^cava_font/d' ${WRKSRC}/Makefile.am
|
||||
|
||||
pre-configure:
|
||||
@${ECHO_CMD} ${DISTVERSION} > ${WRKSRC}/version
|
||||
|
||||
|
18
audio/cava/files/patch-Makefile.am
Normal file
18
audio/cava/files/patch-Makefile.am
Normal file
@ -0,0 +1,18 @@
|
||||
- Remove some flags that gcc 4.2 (on tier 2 archs like powerpc)
|
||||
does not recognize
|
||||
- Do not install the Linux-only font
|
||||
|
||||
--- Makefile.am.orig 2018-09-10 08:31:56 UTC
|
||||
+++ Makefile.am
|
||||
@@ -14,10 +14,8 @@ cava_LDADD = -liniparser
|
||||
cava_LDFLAGS = -L/usr/local/lib -Wl,-rpath /usr/local/lib
|
||||
cava_CPPFLAGS = -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\" \
|
||||
-D_POSIX_SOURCE -D _POSIX_C_SOURCE=200809L
|
||||
-cava_CFLAGS = -std=c99 -Wall -Wextra -Wno-unused-result -Wno-maybe-uninitialized
|
||||
+cava_CFLAGS = -std=c99 -Wall -Wextra
|
||||
|
||||
-cava_font_dir = @FONT_DIR@
|
||||
-cava_font__DATA = cava.psf
|
||||
|
||||
if !SYSTEM_LIBINIPARSER
|
||||
cava_SOURCES += iniparser/libiniparser.la
|
Loading…
Reference in New Issue
Block a user