- Fix LICENSE

- Add LICENSE_FILE
- Switch to USES=localbase
- Switch to options helpers
- Regenerate patches
This commit is contained in:
Dmitry Marakasov 2017-01-17 09:03:56 +00:00
parent 2a70903361
commit 93735b6324
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431725
3 changed files with 12 additions and 12 deletions

View File

@ -11,30 +11,30 @@ MASTER_SITES= http://mirror.symnds.com/software/misc/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ frontend for mkisofs and cdrecord
LICENSE= GPLv2
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= cdlabelgen:print/cdlabelgen \
cdrecord:sysutils/cdrtools
USES= gettext perl5
USES= gettext localbase perl5
USE_PERL5= build
USE_GNOME= gtk12
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--without-included-gettext --datadir=${PREFIX}/share
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --without-included-gettext \
--datadir=${PREFIX}/share
OPTIONS_DEFINE= DOCS
pre-patch:
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
${WRKSRC}/configure
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|==|=|g' ${WRKSRC}/po/Makefile.in.in
post-configure:
cd ${WRKSRC}/po && ${MAKE} update-po
post-install:
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}

View File

@ -1,5 +1,5 @@
--- src/optimize_usage.h 1999-12-20 15:23:18.000000000 -0500
+++ src/optimize_usage.h 2007-08-05 15:47:54.000000000 -0400
--- src/optimize_usage.h.orig 1999-12-20 20:23:18 UTC
+++ src/optimize_usage.h
@@ -16,7 +16,6 @@
** Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
*/

View File

@ -1,6 +1,6 @@
--- src/rip_audio.h 2000-12-11 13:26:41.000000000 -0500
+++ src/rip_audio.h 2007-08-05 15:48:02.000000000 -0400
@@ -20,4 +20,3 @@
--- src/rip_audio.h.orig 2000-12-11 18:26:41 UTC
+++ src/rip_audio.h
@@ -20,4 +20,3 @@ void open_rip_audio_req(void);
extern char *cdda2wav_path, *cdda_device_path, *cdparanoia_path;
extern char *def_rip_path;