. Update to 0.0.7E7F3.
. Take maintainership. [1] Approved by: clive@darkarts.co.za (previous maintainer)
This commit is contained in:
parent
a9c74f1ce3
commit
934d2728a5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=197903
@ -6,38 +6,39 @@
|
||||
#
|
||||
|
||||
PORTNAME= slashem
|
||||
PORTVERSION= 0.0.6E.4F.8
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.0.7E.7F.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMESUFFIX= -tty
|
||||
DISTNAME= se${PORTVERSION:S/.//g:L}
|
||||
|
||||
MAINTAINER= clive@darkarts.co.za
|
||||
MAINTAINER= glewis@FreeBSD.org
|
||||
COMMENT= A dungeon explorin', slashin', hackin' game
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 slashem-tty.6 recover.6
|
||||
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
|
||||
SUB_FILES+= pkg-deinstall
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e \
|
||||
"s@/usr/local@${PREFIX}@g" ${WRKSRC}/include/config.h
|
||||
"s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/include/config.h
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
|
||||
|
||||
post-install:
|
||||
@cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
|
||||
@cp ${WRKSRC}/doc/slashem.6 ${WRKSRC}/doc/slashem${PKGNAMESUFFIX}.6
|
||||
@cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
|
||||
@(cd ${WRKSRC}/doc; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
|
||||
${MAKEFILE} ${MAKE_ARGS} manpages)
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${INSTALL_MAN} ${WRKSRC}/slamfaq.txt ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${INSTALL_MAN} ${FILESDIR}/sample.slashemrc ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/slamfaq.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${FILESDIR}/sample.slashemrc ${DOCSDIR}
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (se006e4f8.tar.gz) = 2abd847d4f5fc426d6c7ed5a97b0de99
|
||||
SHA256 (se006e4f8.tar.gz) = ec165936b0d7d4e3f4067d81e08b59d02f1b6a7a774f96ba9f756ffe1eeff268
|
||||
SIZE (se006e4f8.tar.gz) = 4331015
|
||||
MD5 (se007e7f3.tar.gz) = 54b4534fe85f08722e8b6b38d52c2e9a
|
||||
SHA256 (se007e7f3.tar.gz) = 3b55b7fa6f4a8b703382cdcfb0af6dd25e65fb55a723298b02624af566e36df9
|
||||
SIZE (se007e7f3.tar.gz) = 5288791
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- include/config.h.good Wed Nov 22 23:18:52 2000
|
||||
+++ include/config.h Wed Nov 22 23:29:22 2000
|
||||
@@ -176,12 +176,12 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- include/config.h.orig Sat Dec 30 05:08:31 2006
|
||||
+++ include/config.h Fri Aug 17 23:09:31 2007
|
||||
@@ -230,12 +230,12 @@
|
||||
|
||||
#ifdef UNIX
|
||||
/* path and file name extension for compression program */
|
||||
@ -17,7 +19,7 @@
|
||||
|
||||
/* # define COMPRESS "/usr/bin/bzip2" *//* bzip2 compression */
|
||||
/* # define COMPRESS_EXTENSION ".bz2" *//* bzip2 extension */
|
||||
@@ -195,7 +195,7 @@
|
||||
@@ -249,7 +249,7 @@
|
||||
* a tar-like file, thus making a neater installation. See *conf.h
|
||||
* for detailed configuration.
|
||||
*/
|
||||
@ -26,12 +28,12 @@
|
||||
|
||||
/*
|
||||
* Defining INSURANCE slows down level changes, but allows games that
|
||||
@@ -214,7 +214,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
-# define HACKDIR "." /* nethack directory */
|
||||
+# define HACKDIR "/usr/local/share/slashem-tty" /* nethack directory */
|
||||
@@ -271,7 +271,7 @@
|
||||
# ifdef __APPLE__
|
||||
# define HACKDIR "nethackdir" /* nethack directory */
|
||||
# else
|
||||
-# define HACKDIR "."
|
||||
+# define HACKDIR "%%PREFIX%%/share/slashem" /* nethack directory */
|
||||
# endif
|
||||
# endif
|
||||
|
||||
/*
|
||||
|
@ -1,33 +1,35 @@
|
||||
--- sys/unix/Makefile.doc.good Thu Nov 23 01:01:16 2000
|
||||
+++ sys/unix/Makefile.doc Thu Nov 23 01:04:09 2000
|
||||
@@ -52,10 +52,10 @@
|
||||
# Guidebook.dvi: Guidebook.mn
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.doc.orig Sat Dec 30 05:08:31 2006
|
||||
+++ sys/unix/Makefile.doc Fri Aug 17 23:19:06 2007
|
||||
@@ -53,16 +53,16 @@
|
||||
# tbl tmac.n Guidebook.mn | groff -Wall -Tdvi > Guidebook.dvi
|
||||
|
||||
-GAME = slashem
|
||||
+GAME = slashem-tty
|
||||
#GAME = nethack
|
||||
-MANDIR = /games/slash/doc
|
||||
-MANEXT = 1n
|
||||
+MANDIR = ${PREFIX}/man/man
|
||||
+MANEXT = 6
|
||||
GAME = slashem
|
||||
-MANDIR = /usr/man/man6
|
||||
+MANDIR = ${MANPREFIX}/man/man6
|
||||
MANEXT = 6
|
||||
FRMANDIR= $(MANDIR:man6=fr/man6)
|
||||
|
||||
# manual installation for most BSD-style systems
|
||||
GAMEMANCREATE = cp $(GAME).6
|
||||
@@ -72,11 +72,11 @@
|
||||
# DLBMANCREATE = groff -Wall -mtty-char -Tascii -man dlb.6 >
|
||||
|
||||
manpages:
|
||||
- -$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
|
||||
- -$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
|
||||
- -$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
||||
- -$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
||||
- -$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
||||
+ -$(GAMEMANCREATE) $(MANDIR)${MANEXT}/$(GAME).$(MANEXT)
|
||||
+ -$(LEVMANCREATE) $(MANDIR)${MANEXT}/lev_comp.$(MANEXT)
|
||||
+ -$(DGNMANCREATE) $(MANDIR)${MANEXT}/dgn_comp.$(MANEXT)
|
||||
+ -$(RCVRMANCREATE) $(MANDIR)${MANEXT}/recover.$(MANEXT)
|
||||
+ -$(DLBMANCREATE) $(MANDIR)${MANEXT}/dlb.$(MANEXT)
|
||||
-GAMEMANCREATE = cp $(GAME).6
|
||||
-LEVMANCREATE = cp lev_comp.6
|
||||
-DGNMANCREATE = cp dgn_comp.6
|
||||
-RCVRMANCREATE = cp recover.6
|
||||
-DLBMANCREATE = cp dlb.6
|
||||
+GAMEMANCREATE = ${BSD_INSTALL_MAN} $(GAME).6
|
||||
+LEVMANCREATE = ${BSD_INSTALL_MAN} lev_comp.6
|
||||
+DGNMANCREATE = ${BSD_INSTALL_MAN} dgn_comp.6
|
||||
+RCVRMANCREATE = ${BSD_INSTALL_MAN} recover.6
|
||||
+DLBMANCREATE = ${BSD_INSTALL_MAN} dlb.6
|
||||
FRGAMEMANCREATE = cp fr/$(GAME).6
|
||||
# manual installation for most SYSV-style systems
|
||||
# and for man files readable in less (eg dos DJGPP+GNU)
|
||||
@@ -79,7 +79,6 @@
|
||||
-$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
||||
-$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
||||
-$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
||||
- -$(FRGAMEMANCREATE) $(FRMANDIR)/$(GAME).$(MANEXT)
|
||||
|
||||
# manual creation for distribution
|
||||
DISTRIB = Guidebook.txt $(GAME).txt lev_comp.txt dgn_comp.txt recover.txt dlb.txt
|
||||
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.src.good Thu Nov 23 00:24:58 2000
|
||||
+++ sys/unix/Makefile.src Thu Nov 23 00:26:13 2000
|
||||
@@ -144,8 +144,8 @@
|
||||
@ -11,12 +13,3 @@
|
||||
|
||||
# QT windowing system
|
||||
# SuSE 6.1
|
||||
@@ -322,7 +322,7 @@
|
||||
LIBS =
|
||||
|
||||
# make NetHack
|
||||
-GAME = slashem
|
||||
+GAME = slashem-tty
|
||||
# GAME = slashem.prg
|
||||
|
||||
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
|
||||
|
@ -1,12 +1,13 @@
|
||||
--- sys/unix/Makefile.top.good Wed Nov 22 23:48:33 2000
|
||||
+++ sys/unix/Makefile.top Wed Nov 22 23:54:33 2000
|
||||
@@ -14,18 +14,17 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.top.orig Sat Dec 30 05:08:31 2006
|
||||
+++ sys/unix/Makefile.top Sun Aug 19 01:18:58 2007
|
||||
@@ -14,20 +14,19 @@
|
||||
# MAKE = make
|
||||
|
||||
# make NetHack
|
||||
-PREFIX = /usr
|
||||
-GAME = slashem
|
||||
+GAME = slashem-tty
|
||||
GAME = slashem
|
||||
# GAME = slashem.prg
|
||||
GAMEUID = games
|
||||
-GAMEGRP = bin
|
||||
@ -14,17 +15,19 @@
|
||||
|
||||
# Permissions - some places use setgid instead of setuid, for instance
|
||||
# See also the option "SECURE" in include/config.h
|
||||
-GAMEPERM = 04755
|
||||
GAMEPERM = 04755
|
||||
-FILEPERM = 0644
|
||||
+GAMEPERM = 02755
|
||||
+FILEPERM = 0664
|
||||
EXEPERM = 0755
|
||||
-DIRPERM = 0755
|
||||
+DIRPERM = 0775
|
||||
DIRPERM = 0755
|
||||
-VARFILEPERM = 0644
|
||||
-VARDIRPERM = 0755
|
||||
+VARFILEPERM = 0664
|
||||
+VARDIRPERM = 0775
|
||||
|
||||
# GAMEDIR also appears in config.h as "HACKDIR".
|
||||
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
|
||||
@@ -38,7 +37,7 @@
|
||||
@@ -40,7 +39,7 @@
|
||||
# These must agree with the definitions in unixconf.h
|
||||
|
||||
# Defs. for non file areas support.
|
||||
@ -33,7 +36,7 @@
|
||||
VARDIR = $(GAMEDIR)
|
||||
FILE_AREA_VAR = $(VARDIR)
|
||||
FILE_AREA_SAVE = $(VARDIR)/save
|
||||
@@ -47,7 +46,7 @@
|
||||
@@ -49,7 +48,7 @@
|
||||
FILE_AREA_DOC = $(GAMEDIR)
|
||||
FILE_AREA_BONES = $(FILE_AREA_VAR)
|
||||
FILE_AREA_LEVL = $(FILE_AREA_VAR)
|
||||
@ -42,12 +45,12 @@
|
||||
|
||||
# Defs. compatible with Linux's FSSTND 1.2
|
||||
# FILE_AREA_VAR = /var/lib/games/slashem
|
||||
@@ -239,7 +238,7 @@
|
||||
-e '$$s/.*/nodlb/p' < dat/options` ; \
|
||||
@@ -290,7 +289,7 @@
|
||||
$(MAKE) dofiles-$${target-nodlb}
|
||||
cp src/$(GAME) $(FILE_AREA_UNSHARE)
|
||||
- cp license doc/Guidebook.txt $(FILE_AREA_DOC)
|
||||
+ cp license $(FILE_AREA_DOC)
|
||||
cp util/recover $(FILE_AREA_UNSHARE)
|
||||
- cp dat/license doc/Guidebook.txt $(FILE_AREA_DOC)
|
||||
+ cp dat/license $(FILE_AREA_DOC)
|
||||
# cp win/Qt/KDE/kslashem.kdelnk $(KDEDIR)/share/applnk/Games
|
||||
-rm -f $(SHELLDIR)/$(GAME)
|
||||
sed -e 's;/usr/games/lib/nethackdir;$(FILE_AREA_UNSHARE);' \
|
||||
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.utl.good Thu Nov 23 13:55:38 2000
|
||||
+++ sys/unix/Makefile.utl Thu Nov 23 13:56:54 2000
|
||||
@@ -89,8 +89,8 @@
|
||||
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- include/system.h.good Wed Nov 22 23:38:44 2000
|
||||
+++ include/system.h Wed Nov 22 23:41:03 2000
|
||||
@@ -522,7 +522,7 @@
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- win/tty/termcap.c.orig Thu Sep 2 23:20:27 2004
|
||||
+++ win/tty/termcap.c Thu Sep 2 23:20:46 2004
|
||||
@@ -835,10 +835,6 @@
|
||||
|
||||
#include <curses.h>
|
||||
|
||||
-#ifndef LINUX
|
||||
-extern char *tparm();
|
||||
-#endif
|
||||
-
|
||||
# ifdef COLOR_BLACK /* trust include file */
|
||||
#undef COLOR_BLACK
|
||||
# else
|
@ -1,42 +0,0 @@
|
||||
--- src/read.c.orig Sat Jul 22 18:04:06 2000
|
||||
+++ src/read.c Thu Jan 25 18:46:03 2001
|
||||
@@ -62,6 +62,24 @@
|
||||
return(1);
|
||||
#ifdef TOURIST
|
||||
} else if (scroll->otyp == T_SHIRT) {
|
||||
+ static const char *shirt_msgs[] = {
|
||||
+ "I explored the Dungeons of Doom and all I got was this lousy T-shirt!",
|
||||
+ "Is that Mjollnir in your pocket or are you just happy to see me?",
|
||||
+ "It's not the size of your sword, it's how #enhance'd you are with it.",
|
||||
+ "Madame Elvira's House O' Succubi Lifetime Customer",
|
||||
+ "Madame Elvira's House O' Succubi Employee of the Month",
|
||||
+ "Ludios Vault Guards Do It In Small, Dark Rooms",
|
||||
+ "Yendor Military Soldiers Do It In Large Groups",
|
||||
+ "I survived Yendor Military Boot Camp",
|
||||
+ "Ludios Accounting School Intra-Mural Lacrosse Team",
|
||||
+ "Oracle(TM) Fountains 10th Annual Wet T-Shirt Contest",
|
||||
+ "Hey, black dragon! Disintegrate THIS!",
|
||||
+ "I'm With Stupid -->",
|
||||
+ "Don't blame me, I voted for Izchak!",
|
||||
+ "Don't Panic", // HHGTTG
|
||||
+ "Furinkan High School Athletic Dept.", // Ranma 1/2
|
||||
+ "Hel-LOOO, Nurse!", // Animaniacs"
|
||||
+ };
|
||||
char buf[BUFSZ];
|
||||
int erosion;
|
||||
|
||||
@@ -72,13 +90,7 @@
|
||||
u.uconduct.literate++;
|
||||
if(flags.verbose)
|
||||
pline("It reads:");
|
||||
- Sprintf(buf, "I explored the Dungeons of Doom, %s.",
|
||||
- Hallucination ?
|
||||
- (scroll == uarmu ?
|
||||
- /* (force these two to have identical length) */
|
||||
- "and never did any laundry..." :
|
||||
- "and couldn't find my way out") :
|
||||
- "but all I got was this lousy T-shirt");
|
||||
+ strcpy(buf, shirt_msgs[scroll->o_id % SIZE(shirt_msgs)]);
|
||||
erosion = greatest_erosion(scroll);
|
||||
if (erosion)
|
||||
wipeout_text(buf,
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- include/unixconf.h.good Wed Nov 22 23:42:39 2000
|
||||
+++ include/unixconf.h Wed Nov 22 23:43:42 2000
|
||||
@@ -206,7 +206,7 @@
|
||||
|
10
games/slashem-tty/files/pkg-deinstall.in
Normal file
10
games/slashem-tty/files/pkg-deinstall.in
Normal file
@ -0,0 +1,10 @@
|
||||
#!/bin/sh
|
||||
# $FreeBSD$
|
||||
|
||||
if [ "$2" = "POST-DEINSTALL" -a -d "%%DATADIR%%" ]; then
|
||||
echo ""
|
||||
echo " If slashem is being removed permanently, please remove"
|
||||
echo ""
|
||||
echo " %%DATADIR%%"
|
||||
echo ""
|
||||
fi
|
@ -1,8 +1,8 @@
|
||||
====================================================
|
||||
A sample .slashemrc file has been copied to
|
||||
${PREFIX}/share/doc/slashem-tty as sample.slashemrc.
|
||||
${PREFIX}/share/doc/slashem as sample.slashemrc.
|
||||
Copy it to your home directory as .slashemrc and
|
||||
edit it to taste.
|
||||
The options for it are described in
|
||||
${PREFIX}/share/doc/slashem-tty/Guidebook.txt.
|
||||
${PREFIX}/share/doc/slashem/Guidebook.txt.
|
||||
====================================================
|
||||
|
@ -1,19 +1,19 @@
|
||||
bin/slashem-tty
|
||||
share/slashem-tty/slashem-tty
|
||||
@exec mkdir %D/share/slashem-tty/save
|
||||
@exec chmod -R 775 %D/share/slashem-tty
|
||||
@exec chmod 2755 %D/share/slashem-tty/save
|
||||
@exec chown games:games %D/share/slashem-tty/save
|
||||
@unexec rm -rf %D/share/slashem-tty/save
|
||||
%%PORTDOCS%%share/doc/slashem-tty/Guidebook.txt
|
||||
%%PORTDOCS%%share/doc/slashem-tty/slamfaq.txt
|
||||
%%PORTDOCS%%share/doc/slashem-tty/sample.slashemrc
|
||||
share/slashem-tty/license
|
||||
share/slashem-tty/nhshare
|
||||
share/slashem-tty/nhushare
|
||||
@mode 664
|
||||
share/slashem-tty/logfile
|
||||
share/slashem-tty/record
|
||||
share/slashem-tty/perm
|
||||
@dirrm share/slashem-tty
|
||||
%%PORTDOCS%%@dirrm share/doc/slashem-tty
|
||||
bin/slashem
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Guidebook.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sample.slashemrc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/slamfaq.txt
|
||||
%%DATADIR%%/license
|
||||
%%DATADIR%%/logfile
|
||||
%%DATADIR%%/nhshare
|
||||
%%DATADIR%%/nhushare
|
||||
%%DATADIR%%/perm
|
||||
%%DATADIR%%/record
|
||||
%%DATADIR%%/recover
|
||||
%%DATADIR%%/slashem
|
||||
@exec mkdir %D/%%DATADIR%%/save
|
||||
@exec chmod -R 775 %D/%%DATADIR%%
|
||||
@exec chmod 2755 %D/%%DATADIR%%/save
|
||||
@exec chown games:games %D/%%DATADIR%%/save
|
||||
@dirrmtry %%DATADIR%%/save
|
||||
@dirrmtry %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
@ -6,38 +6,39 @@
|
||||
#
|
||||
|
||||
PORTNAME= slashem
|
||||
PORTVERSION= 0.0.6E.4F.8
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.0.7E.7F.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMESUFFIX= -tty
|
||||
DISTNAME= se${PORTVERSION:S/.//g:L}
|
||||
|
||||
MAINTAINER= clive@darkarts.co.za
|
||||
MAINTAINER= glewis@FreeBSD.org
|
||||
COMMENT= A dungeon explorin', slashin', hackin' game
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 slashem-tty.6 recover.6
|
||||
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
|
||||
SUB_FILES+= pkg-deinstall
|
||||
MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e \
|
||||
"s@/usr/local@${PREFIX}@g" ${WRKSRC}/include/config.h
|
||||
"s@%%PREFIX%%@${PREFIX}@g" ${WRKSRC}/include/config.h
|
||||
|
||||
pre-configure:
|
||||
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
|
||||
|
||||
post-install:
|
||||
@cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
|
||||
@cp ${WRKSRC}/doc/slashem.6 ${WRKSRC}/doc/slashem${PKGNAMESUFFIX}.6
|
||||
@cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
|
||||
@(cd ${WRKSRC}/doc; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
|
||||
${MAKEFILE} ${MAKE_ARGS} manpages)
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${INSTALL_MAN} ${WRKSRC}/slamfaq.txt ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${INSTALL_MAN} ${FILESDIR}/sample.slashemrc ${DOCSDIR}${PKGNAMESUFFIX}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/slamfaq.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${FILESDIR}/sample.slashemrc ${DOCSDIR}
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (se006e4f8.tar.gz) = 2abd847d4f5fc426d6c7ed5a97b0de99
|
||||
SHA256 (se006e4f8.tar.gz) = ec165936b0d7d4e3f4067d81e08b59d02f1b6a7a774f96ba9f756ffe1eeff268
|
||||
SIZE (se006e4f8.tar.gz) = 4331015
|
||||
MD5 (se007e7f3.tar.gz) = 54b4534fe85f08722e8b6b38d52c2e9a
|
||||
SHA256 (se007e7f3.tar.gz) = 3b55b7fa6f4a8b703382cdcfb0af6dd25e65fb55a723298b02624af566e36df9
|
||||
SIZE (se007e7f3.tar.gz) = 5288791
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- include/config.h.good Wed Nov 22 23:18:52 2000
|
||||
+++ include/config.h Wed Nov 22 23:29:22 2000
|
||||
@@ -176,12 +176,12 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- include/config.h.orig Sat Dec 30 05:08:31 2006
|
||||
+++ include/config.h Fri Aug 17 23:09:31 2007
|
||||
@@ -230,12 +230,12 @@
|
||||
|
||||
#ifdef UNIX
|
||||
/* path and file name extension for compression program */
|
||||
@ -17,7 +19,7 @@
|
||||
|
||||
/* # define COMPRESS "/usr/bin/bzip2" *//* bzip2 compression */
|
||||
/* # define COMPRESS_EXTENSION ".bz2" *//* bzip2 extension */
|
||||
@@ -195,7 +195,7 @@
|
||||
@@ -249,7 +249,7 @@
|
||||
* a tar-like file, thus making a neater installation. See *conf.h
|
||||
* for detailed configuration.
|
||||
*/
|
||||
@ -26,12 +28,12 @@
|
||||
|
||||
/*
|
||||
* Defining INSURANCE slows down level changes, but allows games that
|
||||
@@ -214,7 +214,7 @@
|
||||
* otherwise it will be the current directory.
|
||||
*/
|
||||
# ifndef HACKDIR
|
||||
-# define HACKDIR "." /* nethack directory */
|
||||
+# define HACKDIR "/usr/local/share/slashem-tty" /* nethack directory */
|
||||
@@ -271,7 +271,7 @@
|
||||
# ifdef __APPLE__
|
||||
# define HACKDIR "nethackdir" /* nethack directory */
|
||||
# else
|
||||
-# define HACKDIR "."
|
||||
+# define HACKDIR "%%PREFIX%%/share/slashem" /* nethack directory */
|
||||
# endif
|
||||
# endif
|
||||
|
||||
/*
|
||||
|
@ -1,33 +1,35 @@
|
||||
--- sys/unix/Makefile.doc.good Thu Nov 23 01:01:16 2000
|
||||
+++ sys/unix/Makefile.doc Thu Nov 23 01:04:09 2000
|
||||
@@ -52,10 +52,10 @@
|
||||
# Guidebook.dvi: Guidebook.mn
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.doc.orig Sat Dec 30 05:08:31 2006
|
||||
+++ sys/unix/Makefile.doc Fri Aug 17 23:19:06 2007
|
||||
@@ -53,16 +53,16 @@
|
||||
# tbl tmac.n Guidebook.mn | groff -Wall -Tdvi > Guidebook.dvi
|
||||
|
||||
-GAME = slashem
|
||||
+GAME = slashem-tty
|
||||
#GAME = nethack
|
||||
-MANDIR = /games/slash/doc
|
||||
-MANEXT = 1n
|
||||
+MANDIR = ${PREFIX}/man/man
|
||||
+MANEXT = 6
|
||||
GAME = slashem
|
||||
-MANDIR = /usr/man/man6
|
||||
+MANDIR = ${MANPREFIX}/man/man6
|
||||
MANEXT = 6
|
||||
FRMANDIR= $(MANDIR:man6=fr/man6)
|
||||
|
||||
# manual installation for most BSD-style systems
|
||||
GAMEMANCREATE = cp $(GAME).6
|
||||
@@ -72,11 +72,11 @@
|
||||
# DLBMANCREATE = groff -Wall -mtty-char -Tascii -man dlb.6 >
|
||||
|
||||
manpages:
|
||||
- -$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
|
||||
- -$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
|
||||
- -$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
||||
- -$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
||||
- -$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
||||
+ -$(GAMEMANCREATE) $(MANDIR)${MANEXT}/$(GAME).$(MANEXT)
|
||||
+ -$(LEVMANCREATE) $(MANDIR)${MANEXT}/lev_comp.$(MANEXT)
|
||||
+ -$(DGNMANCREATE) $(MANDIR)${MANEXT}/dgn_comp.$(MANEXT)
|
||||
+ -$(RCVRMANCREATE) $(MANDIR)${MANEXT}/recover.$(MANEXT)
|
||||
+ -$(DLBMANCREATE) $(MANDIR)${MANEXT}/dlb.$(MANEXT)
|
||||
-GAMEMANCREATE = cp $(GAME).6
|
||||
-LEVMANCREATE = cp lev_comp.6
|
||||
-DGNMANCREATE = cp dgn_comp.6
|
||||
-RCVRMANCREATE = cp recover.6
|
||||
-DLBMANCREATE = cp dlb.6
|
||||
+GAMEMANCREATE = ${BSD_INSTALL_MAN} $(GAME).6
|
||||
+LEVMANCREATE = ${BSD_INSTALL_MAN} lev_comp.6
|
||||
+DGNMANCREATE = ${BSD_INSTALL_MAN} dgn_comp.6
|
||||
+RCVRMANCREATE = ${BSD_INSTALL_MAN} recover.6
|
||||
+DLBMANCREATE = ${BSD_INSTALL_MAN} dlb.6
|
||||
FRGAMEMANCREATE = cp fr/$(GAME).6
|
||||
# manual installation for most SYSV-style systems
|
||||
# and for man files readable in less (eg dos DJGPP+GNU)
|
||||
@@ -79,7 +79,6 @@
|
||||
-$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
||||
-$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
||||
-$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
||||
- -$(FRGAMEMANCREATE) $(FRMANDIR)/$(GAME).$(MANEXT)
|
||||
|
||||
# manual creation for distribution
|
||||
DISTRIB = Guidebook.txt $(GAME).txt lev_comp.txt dgn_comp.txt recover.txt dlb.txt
|
||||
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.src.good Thu Nov 23 00:24:58 2000
|
||||
+++ sys/unix/Makefile.src Thu Nov 23 00:26:13 2000
|
||||
@@ -144,8 +144,8 @@
|
||||
@ -11,12 +13,3 @@
|
||||
|
||||
# QT windowing system
|
||||
# SuSE 6.1
|
||||
@@ -322,7 +322,7 @@
|
||||
LIBS =
|
||||
|
||||
# make NetHack
|
||||
-GAME = slashem
|
||||
+GAME = slashem-tty
|
||||
# GAME = slashem.prg
|
||||
|
||||
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
|
||||
|
@ -1,12 +1,13 @@
|
||||
--- sys/unix/Makefile.top.good Wed Nov 22 23:48:33 2000
|
||||
+++ sys/unix/Makefile.top Wed Nov 22 23:54:33 2000
|
||||
@@ -14,18 +14,17 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.top.orig Sat Dec 30 05:08:31 2006
|
||||
+++ sys/unix/Makefile.top Sun Aug 19 01:18:58 2007
|
||||
@@ -14,20 +14,19 @@
|
||||
# MAKE = make
|
||||
|
||||
# make NetHack
|
||||
-PREFIX = /usr
|
||||
-GAME = slashem
|
||||
+GAME = slashem-tty
|
||||
GAME = slashem
|
||||
# GAME = slashem.prg
|
||||
GAMEUID = games
|
||||
-GAMEGRP = bin
|
||||
@ -14,17 +15,19 @@
|
||||
|
||||
# Permissions - some places use setgid instead of setuid, for instance
|
||||
# See also the option "SECURE" in include/config.h
|
||||
-GAMEPERM = 04755
|
||||
GAMEPERM = 04755
|
||||
-FILEPERM = 0644
|
||||
+GAMEPERM = 02755
|
||||
+FILEPERM = 0664
|
||||
EXEPERM = 0755
|
||||
-DIRPERM = 0755
|
||||
+DIRPERM = 0775
|
||||
DIRPERM = 0755
|
||||
-VARFILEPERM = 0644
|
||||
-VARDIRPERM = 0755
|
||||
+VARFILEPERM = 0664
|
||||
+VARDIRPERM = 0775
|
||||
|
||||
# GAMEDIR also appears in config.h as "HACKDIR".
|
||||
# VARDIR may also appear in unixconf.h as "VAR_PLAYGROUND" else GAMEDIR
|
||||
@@ -38,7 +37,7 @@
|
||||
@@ -40,7 +39,7 @@
|
||||
# These must agree with the definitions in unixconf.h
|
||||
|
||||
# Defs. for non file areas support.
|
||||
@ -33,7 +36,7 @@
|
||||
VARDIR = $(GAMEDIR)
|
||||
FILE_AREA_VAR = $(VARDIR)
|
||||
FILE_AREA_SAVE = $(VARDIR)/save
|
||||
@@ -47,7 +46,7 @@
|
||||
@@ -49,7 +48,7 @@
|
||||
FILE_AREA_DOC = $(GAMEDIR)
|
||||
FILE_AREA_BONES = $(FILE_AREA_VAR)
|
||||
FILE_AREA_LEVL = $(FILE_AREA_VAR)
|
||||
@ -42,12 +45,12 @@
|
||||
|
||||
# Defs. compatible with Linux's FSSTND 1.2
|
||||
# FILE_AREA_VAR = /var/lib/games/slashem
|
||||
@@ -239,7 +238,7 @@
|
||||
-e '$$s/.*/nodlb/p' < dat/options` ; \
|
||||
@@ -290,7 +289,7 @@
|
||||
$(MAKE) dofiles-$${target-nodlb}
|
||||
cp src/$(GAME) $(FILE_AREA_UNSHARE)
|
||||
- cp license doc/Guidebook.txt $(FILE_AREA_DOC)
|
||||
+ cp license $(FILE_AREA_DOC)
|
||||
cp util/recover $(FILE_AREA_UNSHARE)
|
||||
- cp dat/license doc/Guidebook.txt $(FILE_AREA_DOC)
|
||||
+ cp dat/license $(FILE_AREA_DOC)
|
||||
# cp win/Qt/KDE/kslashem.kdelnk $(KDEDIR)/share/applnk/Games
|
||||
-rm -f $(SHELLDIR)/$(GAME)
|
||||
sed -e 's;/usr/games/lib/nethackdir;$(FILE_AREA_UNSHARE);' \
|
||||
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- sys/unix/Makefile.utl.good Thu Nov 23 13:55:38 2000
|
||||
+++ sys/unix/Makefile.utl Thu Nov 23 13:56:54 2000
|
||||
@@ -89,8 +89,8 @@
|
||||
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- include/system.h.good Wed Nov 22 23:38:44 2000
|
||||
+++ include/system.h Wed Nov 22 23:41:03 2000
|
||||
@@ -522,7 +522,7 @@
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- win/tty/termcap.c.orig Thu Sep 2 23:20:27 2004
|
||||
+++ win/tty/termcap.c Thu Sep 2 23:20:46 2004
|
||||
@@ -835,10 +835,6 @@
|
||||
|
||||
#include <curses.h>
|
||||
|
||||
-#ifndef LINUX
|
||||
-extern char *tparm();
|
||||
-#endif
|
||||
-
|
||||
# ifdef COLOR_BLACK /* trust include file */
|
||||
#undef COLOR_BLACK
|
||||
# else
|
@ -1,42 +0,0 @@
|
||||
--- src/read.c.orig Sat Jul 22 18:04:06 2000
|
||||
+++ src/read.c Thu Jan 25 18:46:03 2001
|
||||
@@ -62,6 +62,24 @@
|
||||
return(1);
|
||||
#ifdef TOURIST
|
||||
} else if (scroll->otyp == T_SHIRT) {
|
||||
+ static const char *shirt_msgs[] = {
|
||||
+ "I explored the Dungeons of Doom and all I got was this lousy T-shirt!",
|
||||
+ "Is that Mjollnir in your pocket or are you just happy to see me?",
|
||||
+ "It's not the size of your sword, it's how #enhance'd you are with it.",
|
||||
+ "Madame Elvira's House O' Succubi Lifetime Customer",
|
||||
+ "Madame Elvira's House O' Succubi Employee of the Month",
|
||||
+ "Ludios Vault Guards Do It In Small, Dark Rooms",
|
||||
+ "Yendor Military Soldiers Do It In Large Groups",
|
||||
+ "I survived Yendor Military Boot Camp",
|
||||
+ "Ludios Accounting School Intra-Mural Lacrosse Team",
|
||||
+ "Oracle(TM) Fountains 10th Annual Wet T-Shirt Contest",
|
||||
+ "Hey, black dragon! Disintegrate THIS!",
|
||||
+ "I'm With Stupid -->",
|
||||
+ "Don't blame me, I voted for Izchak!",
|
||||
+ "Don't Panic", // HHGTTG
|
||||
+ "Furinkan High School Athletic Dept.", // Ranma 1/2
|
||||
+ "Hel-LOOO, Nurse!", // Animaniacs"
|
||||
+ };
|
||||
char buf[BUFSZ];
|
||||
int erosion;
|
||||
|
||||
@@ -72,13 +90,7 @@
|
||||
u.uconduct.literate++;
|
||||
if(flags.verbose)
|
||||
pline("It reads:");
|
||||
- Sprintf(buf, "I explored the Dungeons of Doom, %s.",
|
||||
- Hallucination ?
|
||||
- (scroll == uarmu ?
|
||||
- /* (force these two to have identical length) */
|
||||
- "and never did any laundry..." :
|
||||
- "and couldn't find my way out") :
|
||||
- "but all I got was this lousy T-shirt");
|
||||
+ strcpy(buf, shirt_msgs[scroll->o_id % SIZE(shirt_msgs)]);
|
||||
erosion = greatest_erosion(scroll);
|
||||
if (erosion)
|
||||
wipeout_text(buf,
|
@ -1,3 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- include/unixconf.h.good Wed Nov 22 23:42:39 2000
|
||||
+++ include/unixconf.h Wed Nov 22 23:43:42 2000
|
||||
@@ -206,7 +206,7 @@
|
||||
|
10
games/unnethack/files/pkg-deinstall.in
Normal file
10
games/unnethack/files/pkg-deinstall.in
Normal file
@ -0,0 +1,10 @@
|
||||
#!/bin/sh
|
||||
# $FreeBSD$
|
||||
|
||||
if [ "$2" = "POST-DEINSTALL" -a -d "%%DATADIR%%" ]; then
|
||||
echo ""
|
||||
echo " If slashem is being removed permanently, please remove"
|
||||
echo ""
|
||||
echo " %%DATADIR%%"
|
||||
echo ""
|
||||
fi
|
@ -1,8 +1,8 @@
|
||||
====================================================
|
||||
A sample .slashemrc file has been copied to
|
||||
${PREFIX}/share/doc/slashem-tty as sample.slashemrc.
|
||||
${PREFIX}/share/doc/slashem as sample.slashemrc.
|
||||
Copy it to your home directory as .slashemrc and
|
||||
edit it to taste.
|
||||
The options for it are described in
|
||||
${PREFIX}/share/doc/slashem-tty/Guidebook.txt.
|
||||
${PREFIX}/share/doc/slashem/Guidebook.txt.
|
||||
====================================================
|
||||
|
@ -1,19 +1,19 @@
|
||||
bin/slashem-tty
|
||||
share/slashem-tty/slashem-tty
|
||||
@exec mkdir %D/share/slashem-tty/save
|
||||
@exec chmod -R 775 %D/share/slashem-tty
|
||||
@exec chmod 2755 %D/share/slashem-tty/save
|
||||
@exec chown games:games %D/share/slashem-tty/save
|
||||
@unexec rm -rf %D/share/slashem-tty/save
|
||||
%%PORTDOCS%%share/doc/slashem-tty/Guidebook.txt
|
||||
%%PORTDOCS%%share/doc/slashem-tty/slamfaq.txt
|
||||
%%PORTDOCS%%share/doc/slashem-tty/sample.slashemrc
|
||||
share/slashem-tty/license
|
||||
share/slashem-tty/nhshare
|
||||
share/slashem-tty/nhushare
|
||||
@mode 664
|
||||
share/slashem-tty/logfile
|
||||
share/slashem-tty/record
|
||||
share/slashem-tty/perm
|
||||
@dirrm share/slashem-tty
|
||||
%%PORTDOCS%%@dirrm share/doc/slashem-tty
|
||||
bin/slashem
|
||||
%%PORTDOCS%%%%DOCSDIR%%/Guidebook.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sample.slashemrc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/slamfaq.txt
|
||||
%%DATADIR%%/license
|
||||
%%DATADIR%%/logfile
|
||||
%%DATADIR%%/nhshare
|
||||
%%DATADIR%%/nhushare
|
||||
%%DATADIR%%/perm
|
||||
%%DATADIR%%/record
|
||||
%%DATADIR%%/recover
|
||||
%%DATADIR%%/slashem
|
||||
@exec mkdir %D/%%DATADIR%%/save
|
||||
@exec chmod -R 775 %D/%%DATADIR%%
|
||||
@exec chmod 2755 %D/%%DATADIR%%/save
|
||||
@exec chown games:games %D/%%DATADIR%%/save
|
||||
@dirrmtry %%DATADIR%%/save
|
||||
@dirrmtry %%DATADIR%%
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user